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Chapter 1 Getting Started Guide
This guide helps you go through the initial configuration and the basic set-up of your device. The
intended reader is your company's network administrator.
This guide is used when you have finished mounting your device. After following the steps in this guide,
your private network will be able to access the Internet. To set up security functions, you will need to
read the User Guide (WebUI User Guide or CLI User Guide).
You may configure your firewall in the following sequence:
1.

"Initial Visit to Web Interface"

2.

"Preparing the FSOS System" including:


"Installing Licenses"



"Creating a System Administrator"



"Adding Trust Hosts"



"Upgrading FSOS Firmware"



"Updating Signature Database"

3.

"Connecting to Internet Under Routing Mode"

4.

"Restoring Factory Settings"

Initial Visit to Web Interface
Interface eth0/0 is configured with IP address 192.168.1.1/24 by default and it is open to SSH、PING、
SNMP、HTTP connection types(except for some custom versions). For the initial visit, use this
interface.
To visit the web interface for the first time, take the following steps:
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1.

Go to your computer's Ethernet properties and set the IPv4 protocol as below.

2.

Connect an RJ-45 Ethernet cable from your computer to the eth0/0 of the device.

3.

In your browser's address bar, type "http://192.168.1.1" and press Enter.

4.

In the login interface, type the default username and password: admin/admin.

5.

Click Login, and the device's system will initiate.

Preparing the FSOS System
Installing Licenses
Licenses control features and performance.
Before installing any license, you must purchase a license code.
www.fs.com
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To install a license, take the following steps:
1.

Go to System > License.

2.

Choose one of the three ways to import a license:



Upload License File: Select the radio button, click Browse, and select the license
file (a .txt file).



Manual Input: Select the radio button, and paste the license code into the text
box.



3.
4.

Online Installation:Select the Online Installation radio button and click the
Online Installation button, your purchased licenses will be automatically installed. It
should be noted that the licenses must be in an activated status in the Online
Registration Platform . (To activate the license, you need to log into the platform using
your username and password. The username is the same as your email which was
provided when placing the order. FS will send the password by email. Then, activate
the licenses that need to be installed. If you purchased the device from a FS agent,
please contact the agent to activate the licenses.)

Click OK.
To make the license take effect, reboot the system. Go to System > Device
Management > Options, and click Reboot.

Creating a System Administrator
System administrator has the authority to read, write and execute all the features in system.
To create a system administrator, take the following steps:
1.
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2.

Click New.

In the Admin Configuration dialog box, enter values

3.

Option

Value

Name

Admin

Role

Administrator

Password

123456

Confirm
Password

123456

Login Type

Select Telnet, SSH, HTTPand HTTPS.

Click OK.

Notes: The system has a default administrator "admin”, which cannot be deleted or renamed.

Adding Trust Hosts
The trust host is administrator's host. Only computers included in the trust hosts can manage system.
To add a trust host, take the following steps:
1.

Go to System > Device Management.

2.

Select Trust Host tab, and click New.

In the Trust Host Configuration dialog box, enter value

www.fs.com

Option

Value

Type

Select IP/Netmask
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3.

Option

Value

IP

192.168.1.2/24

Login Type

Select all: Telnet, SSH, HTTP and HTTPS

Click OK.

Upgrading FSOS Firmware
Notes: Back up your configuration files before upgrading your system.
To upgrade your system firmware, take the following steps:
1.

Go to System > Upgrade Management.

2.

Select Browse and choose the new image from your local computer.

3.

Click Reboot to make new firmware take effect, then click Apply.

4.

System will automatically reboot when it finishes installing the new firmware.

Updating Signature Database
Features that require constant updates of signature are license controlled. You must purchase the license
in order to be able to update the signature libraries. By default, the system will automatically update the
databases daily.
To update a database, take the following steps:
1.

Go to System > Upgrade Management, and click the <Signature Database Update> tab.

2.

Find your intended database, and choose one of the following two ways to upgrade.



Remote Update: Click Update, and system will automatically update the database.
Local Update: Select Browse to open the file explorer, and select your local
signature file to import it into system.

Connecting to Internet Under Routing Mode
In routing mode, the device is working as a gateway and router between two networks. This section
shows how to connect and configure a new device in routing mode to securely connect the private
network to the Internet.

www.fs.com
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To get your private network access to Internet through a FS device, take the following steps:
Step 1: Connecting to the device
1.

Connect one port (e.g. eth0/1) of FS device to your ISP network. In this way, "eth0/1"
is in the untrust zone.

2.

Connect your internal network to another Ethernet interfaces (e.g. eth0/0) of the device.
This means "eth0/0" is connected to the trust zone.

3.
4.

5.

Power on the device and your PCs.
If one of the internal interfaces already has been configured with an IP address, use a
browser to visit that address from one of your internal PCs.
If it is a new device, use the methods in "Initial Visit to Web Interface" to visit.
Enter "admin" for both the username and the password.

Step 2: Configuring interfaces
1.

www.fs.com

Go to Network > Interface.
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2.

Double click eth0/1.

In the Ethernet Interface dialog box, enter values
Option
Binding Zone
Zone

L3-zone
untrust

Type

Static IP

IP Address

202.10.1.2 (public IP address provided by your ISP)

Netmask

255.255.255.0

Management
3.

Value

Select protocols that you want to use to access the device.

Click OK.

Step 3: Creating a NAT rule to translate internal IP to public IP
1.

www.fs.com

Go to Policy > NAT > SNAT.
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2.

Select New

In the SNAT Configuration dialog box, enter values
Option

Value

Source Address Address Entry, Any

3.

Destination
Address

Address Entry, Any

Egress

Egress interface, ethernet 0/1

Translated

Egress IP

Sticky

Enable

Click OK.

Step 4: Creating a security policy to allow internal users access Internet.
1.

www.fs.com

Go to Policy > Security Policy.
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2.

Click New.

In the Policy Configuration dialog box, enter values.
Source Information
Zone

trust

Address

Any

Destination Information
Zone

untrust

Address

Any

Other Information
Service/Service Any
Group

3.

APP/APP
Group

-----

Action

Permit

Click OK.

Step 5: Configuring a default route
1.

www.fs.com

Go to Network >Routing > Destination Route.
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2.

Click New.

In the Destination Route Configuration dialog box, enter values.
Option

Value

Destination

0.0.0.0 (means all network)

Subnet Mask

0.0.0.0 (means all subnets)

Gateway
3.

202.10.1.1 (gateway provided by your ISP)

Click OK.

Restoring Factory Settings
Notes: Resetting your device will erase all configurations, including the settings that have been saved.
Please be cautious!
To restore factory's default settings, you may use one of the following two ways:


"Restoring using a pin"



"Restoring via WebUI"

Restoring using a pin
To restore factory default settings using a Web interface, take the following steps:
1.

www.fs.com

Power off the device.

2.

Use a pin to press the CLR pinhole on the front panel; keep pressing and power on the
devcie.

3.

Keep pressing until the STA and ALM indicators on the front panel turn a constant red;
release the pin. System will start to reset itself.
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4.

When restoring is complete, system will reboot automatically.

Restoring via WebUI
To restore factory default settings using a Web interface, take the following steps:

www.fs.com

1.

Go to System > Configuration File Management.

2.

Click Backup Restore.

3.

In the prompt, click Restore.

4.

Click OK to confirm.

5.

The device will automatically reboot and be back to factory settings.

11

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

Chapter 2 Deploying Your Device
This chapter introduces how a firewall works and its most commonly used scenarios. Understanding the
system structure, basic elements and flow chart will help you in better organizing your network and
making the most of the firewall product.


"How a Firewall Works"

A firewall has more than one deployment scenario. Each scenario applies to one environment
requirement. The usual deployment modes are:


"Deploying Transparent Mode"
Transparent mode is a situation when the IT administrator does not wish to change his/her
existing network settings. In transparent mode, the firewall is invisible to the network. Because
no IP address configuration is needed, the firewall only provides security features.



"Deploying Routing Mode"
Routing mode applies when the firewall offers both routing and NAT functions. In routing
mode, the firewall connects two networks typically, an internal network and the Internet, and the
firewall interfaces are configured with IP addresses.



"Deploying Mix Mode"
If a firewall has Layer-2 interfaces and Layer-3 interfaces, it is in mix mode.



"Deploying Tap Mode"
When an IT administrator only wants the monitor, IPS or statistic function of a firewall, while
not a gateway device, using tap mode is the right choice. In tap mode, the firewall is not directly
connected within the network.

How a Firewall Works
A firewall is a network security device. It protects a network by controlling the traffic that comes in and
out of that network. The basic mechanism of how a firewall works is that allowing or denying the data
packet by identifying whether it matches the policy rules or not. Besides security functions, a firewall can
also works as a bridging device to connect a trust zone (internal network) and untrust zone (external
network).

FSOS System Architecture
The elements that constitute system architecture are:

www.fs.com
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Zone: Zones divide network into multiple segments, for example, trust (usually refers to
the trusted segments such as the Intranet), untrust (usually refers to the untrusted segments
where security treats exist).



Interface: Interface is the inlet and outlet for traffic going through security zones. An
interface must be bound to a security zone so that traffic can flow into and from the security
zone. Furthermore, for the Layer 3 security zone, an IP address should be configured for the
interface and the corresponding policy rules should also be configured to allow traffic
transmission between different security zones. Multiple interfaces can be bound to one security
zone, but one interface cannot be bound to multiple security zones.



VSwitch: VSwitch is short for Virtual Switch. A VSwitch functions as a switch in Layer 2.
After binding a Layer 2 zone to a VSwitch, all the interfaces in the zone are also bound to the
VSwitch. There is a default VSwitch named VSwitch1. By default, all Layer 2 zones will be
bound to VSwitch1. You can create new VSwitches and bind Layer 2 zones to VSwitches. Each
VSwitch is a Layer 2 forwarding zone with its own MAC address table which supports the Layer
2 traffic transmission for the device. Furthermore, the VSwitchIF helps the traffic to flow
between Layer 2 and Layer 3.



VRouter: VRouter is Virtual Router and also abbreviated as VR. A VRouter functions as
a router with its own routing table. There is a default VR named trust-vr. By default, all the Layer
3 zones will be bound to trust-vr automatically. The system supports the multi-VR function and
the max VR number varies from different platforms. Multiple VRs make the device work as
multiple virtual routers, and each virtual router uses and maintains its own routing table.The
multi-VR function allows a device to achieve the effects of the address isolating in different
route zones and the address overlapping in different VRs, as well as avoiding leakage of route to
some extent and enhancing route security of network.



Policy: Policy is used to control the traffic flow in security zones/segments. By default
FS devices will deny all traffic in security zones/segments, while the policy can identify which
flow in security zones or segments will be permitted, and which will be denied, which is
specifically based on policy rules.

For the relationships among interface, security zone, VSwitch and VRouter, see the following diagram:

www.fs.com
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As shown above, the binding relationships among them are:


Interfaces are bound to security zones. Interfaces bound to Layer 2 security zones and
Layer 3 security zones are known as Layer 2 interfaces and Layer 3 interfaces respectively. One
interface can be only bound to one security zone; interface and its sub interface can belong to
different security zones.



Security zones are bound to a VSwitch or VRouter. Layer 2 security zones are bound to a
VSwitch (by default the predefined Layer 2 security zone is bound to the default VSwitch1), and
Layer 3 security zones are bound to a VRouter (by default the predefined Layer 3 security zone is
bound to the default trust-vr), thus realizing the binding between the interfaces and VSwitch or
VR. One security zone can be only bound to one VSwtich or VR.

General Rules of Security Policy
By default, all interfaces, even in the same zone, cannot communicate. Traffic in different zones are not
allowed to be transferred either. In order to change the rule, you need to set up new policy rules to allow
traffic forwarding.
Notes: To allow bidirectional traffic, you need to set up two policies: one is from source to
destination, the other is from destination to source. If there is only one-direction initiative access, the
responsive direction only need to respond to that visit, you will need to create only one-way policy
(from source to destination).
This part explains what policy is needed to allow interfaces in different zones, VSwitches, or VRouters
to communicate. The rules are:


Interfaces in the same zone
To allow interfaces in the same zone to communicate, you need to create a policy whose source
and destination are both the zone which the interfaces belong to.
For example, to allow eth0/0 and eth0/1 to communicate, you need to create an "allowing"
policy with source L3-zone and destination L3-zone.

www.fs.com
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Zones of two interfaces are under the same VSwtich
To allow communication of interfaces in different zones under the same VSwitch, you need to
create two policies: one policy is to allow traffic from a zone to another; the other policy is to
allow traffic in the opposite direction.
For example, to allow eth0/2 and eth0/3 to communicate, you should create a policy whose
source is L2-zone1 and destination is L2-zone2, then create another policy to allow traffic from
L2-zone2 to L2-zone1.



Zones of two interfaces are under different VSwitches
Each VSwtich has its VSwtich interface (VSwitchIF) which is bound to a Layer-3 zone. To allow
interfaces in different zones under different VSwitches to communicate, you need to create an
"allowing" policy where the source is the zone of one VSwitchIF and the destination is the zone
of the other VSwitchIF. After that, create another policy of the opposite direction.



Zones of two L3 interfaces are under the same VRouter
To allow two L3 interfaces to communicate, you need to create a policy allowing one zone to the
other zone.
For example, to allow communication between eth0/0 and eth0/5, you should create a policy
from L3-zone1 to L3-zone2, and then create an opposite direction policy.



Zones of two L3 interfaces are under different VRouters
To allow two L3 interfaces in two different zones of different VRouters, you need to create a
policy with the source being one VRouter and the destination being the other VRouter. Then
you create a policy of the opposite direction.



An L2 interface and an L3 interface under the same VRouter
To allow communication between an L2 interface and an L3 interface under the same VRouter,
you will need to create a policy whose source is the zone which binds the VSwithIF of L2
interface and the destination is the zone of L3 interface. After that, create a policy of the
opposite direction.
For example, to allow eth0/0 and eth0/2 to communicate, create a policy from L3-zone1 to L2zone1, and its opposite direction policy.

Packet Processing Rule
Forwarding Rule in Layer 2
Forwarding within Layer 2 means it is in one VSwitch. FSOS system creates a MAC address table for a
VSwitch by source address learning. Each VSwitch has its own MAC address table. The packets are
forwarded according to the types of the packets, including IP packets, ARP packets, and non-IP-nonARP packets.
The forwarding rules for IP packets are:

www.fs.com
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1.

Receive a packet.

2.

Learn the source address and update the MAC address table.

3.

If the destination MAC address is a unicast address, the system will look up the egress
interface according to the destination MAC address. And in this case, two situations may
occur:


If the destination MAC address is the MAC address of the VSwitchIF with an IP
configured, system will forward the packet according to the related routes; if the
destination MAC address is the MAC address of the VSwitchIF with no IP configured,
system will drop the packet.



Figure out the egress interface according to the destination MAC address. If the
egress interface is the source interface of the packet, system will drop the packet.
Otherwise, system will forward the packet from the egress interface.

If no egress interfaces (unknown unicast) is found in the MAC address table, jump to Step 6 directly.
4.

Figure out the source zone and destination zone according to the ingress and egress
interfaces.

5.

Look up the policy rules and forward or drop the packet according to the matched policy
rules.

6.

If no egress interface (unknown unicast) is found in the MAC address table, system will
send the packet to all the other L2 interfaces. The sending procedure is: take each L2 interface
as the egress interface and each L2 zone as the destination zone to look up the policy rules,
and then forward or drop the packet according to the matched policy rule. In a word,
forwarding of unknown unicast is the policy-controlled broadcasting. Process of broadcasting
packets and multicasting packets is similar to the unknown unicast packets, and the only
difference is the broadcast packets and multicast packets will be copied and handled in Layer 3
at the same time.

For the ARP packets, the broadcast packet and unknown unicast packet are forwarded to all the other
interfaces in the VSwitch, and at the same time, system sends a copy of the broadcast packet and
unknown unicast packet to the ARP module to handle.

www.fs.com
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Forwarding Rule in Layer 3

www.fs.com

0.

Identify the logical ingress interface of the packet to determine the source zone of the
packet. The logical ingress interface may be a common interface or a sub-interface.

1.

System performs sanity check to the packet. If the attack defense function is enabled on
the source zone, system will perform AD check simultaneously.

2.

Session lookup. If the packet belongs to an existing session, system will perform Step 11
directly.

3.

DNAT operation. If a DNAT rule is matched, system will mark the packet. The DNAT
translated address is needed in the step of route lookup.
*Note: If the system has static 1-to-1 BNAT rule, BNAT rule is checked before other NAT
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rules. If a packet matches BNAT, it will be processed in accordance with this rule's
configuration. It will skip the regular DNAT rule checking.
4.

Route lookup. The route lookup order from high to low is: PBR > SIBR > SBR >
DBR > ISP route.
Until now, the system has known the logical egress and destination zone of the packet.

5.

SNAT operation. If a SNAT rule is matched, system will mark the packet.
*Note: If the system has static 1-to-1 BNAT rule, BNAT rule is checked before other NAT
rules. If a packet matches BNAT, it will be processed in accordance with this rule's
configuration. It will skip the regular SNAT rule checking.

6.

VR next hop check. If the next hop is a VR, system will check whether it is beyond the
maximum VR number (current version allows the packet traverse up to three VRs). If it is
beyond the maximum number, system will drop the packet; if it is within the maximum
number range, return to Step 4. If the next hop is not a VR, go on with policy lookup.

7.

Policy lookup. System looks up the policy rules according to the packet’s
source/destination zones, source/destination IP and port, and protocol. If no policy rule is
matched, system will drop the packet; if any policy rule is matched, the system will deal with
the packet as the rule specified. And the actions can be one of the followings:



Permit: Forward the packet.


Deny: Drop the packet.



Tunnel: Forward the packet to the specified tunnel.




Fromtunnel: Check whether the packet originates from the specified tunnel.
System will forward the packet from the specified tunnel and drop other packets.
WebAuth: Perform WebAuth on the specified user.

First time application identification. System tries to identify the type of the application
according to the port number and service specified in the policy rule.
9.

Establish the session.

10.

If necessary, system will perform the second time application identification. It is a
precise identification based on the packet contents and traffic action.

11.

Application behavior control. After knowing the type of the application, system will deal
with the packet according to the configured profiles and ALG.

12.

Perform operations according to the records in the session, for example, the NAT mark.

13.

Forward the packet to the egress interface.

www.fs.com
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Deploying Transparent Mode
Transparent mode is also known as bridge mode or transparent bridging mode. Transparent mode is
used when the IT administrator does not wish to change the existing network layout. Normally, the
existing network has already set up routers and switches. The firewall will be used as a security device.
Transparent mode has the following advantages:


No need to change IP addresses



No need to set up NAT rule

Under normal circumstances, the firewall in transparent mode is deployed between the router and the
switch of the protected network, or it is installed between the Internet and a company's router. The
internal network uses its old router to access the Internet, and the firewall only provides security control
features.
This section introduces a configuration example of a firewall deployed between a router and a switch. In
this example, the administrator uses eth0/0 to manage firewall. The firewall's eth0/1 is connected to
router (which is connecting to the Internet) and eth0/2 is connected to a switch (which is connecting to
internal network).

Step 1: Initial log in the firewall

www.fs.com
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1.

In the administrator's Ethernet properties, set the IPv4 protocol as below.

2.

Connect an RJ-45 Ethernet cable from the computer to the eth0/0 of the device.

3.

In the browser's address bar, type "http://192.168.1.1" and press Enter.

4.

In the login interface, type the default username and password: admin/admin.

5.

Click Login, and the device's system will initiate.

Step 2: Configure interface and zone




Configure eth0/1 as an Internet connected interface.
1.

Select Network > Interface.

2.

Double click ethernet0/1, and configure in the prompt.

3.

Click OK.

Configure eth0/2 as a private network connected interface.
1.

www.fs.com

Select Network > Interface.
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2.

Double click ethernet0/2, and configure in the prompt.

3.

Click OK.

Step 3: Configuring policies




www.fs.com

Create a policy to allow visiting the Internet.
1.

Select Policy > Security Policy.

2.

Click New.

3.

Click OK.

Create a policy to allow the Internet to visit a private network.
1.

Select Policy > Security Policy.

2.

Click New.

3.

Click OK.
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The two policies above ensure communication between a private network and the
Internet. If you want to set up more details, e.g. to limit P2P download, you can add more
policies and overlap the new policies with the old ones. The match sequence of policies is
determined by their position in the policy list, not their ID numbers.

(Optional) Step 4: Configuring VSwitch Interface for managing the firewall.
If you want any PC in the private network to visit and configure the firewall, you can configure a
VSwitch interface as a management interface.
1.

Select Network > Interface.

2.

Double click vswtichif1.

3.

Click OK.

4.

With any PC in the private network, enter the IP address of vswitchif1, and you will visit
the firewall web user interface.

Deploying Routing Mode
Routing mode deployment often uses the NAT function, so it is also called NAT mode. In routing
mode, each interface has its IP address which means interfaces are in the layer 3 zone. A firewall in
routing mode can work as a router and a security devcie.
Routing mode is mostly used when the firewall is installed between an internal network and the Internet.
The example which is based on the below topology shows you how to connect and configure a new
device in routing mode. The device connects a private network to the Internet.

www.fs.com
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Step 1: Connecting to the device
1.

Connect one port (e.g. eth0/1) of the FS device to your ISP network. In this way,
"eth0/1" is in the untrust zone.

2.

Connect your internal network to another Ethernet interface (e.g. eth0/0) of the device.
This means "eth0/0" is connected to the trust zone.

3.
4.

5.

Power on the device and your PCs.
If one of the internal interfaces already has been configured with an IP address, use a
browser to visit that address from one of your internal PCs.
If it is a new device, use the methods in "Initial Visit to Web Interface" to visit.
Enter "admin" for both the username and the password.

Step 2: Configuring interfaces

www.fs.com

1.

Go to Network > Interface.

2.

Double click eth0/1.
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In the Ethernet Interface dialog box, enter values
Option
Binding Zone
Zone

L3-zone
untrust

Type

Static IP

IP Address

202.10.1.1 (public IP address provided by your ISP)

Netmask

255.255.255.0

Management
3.

Value

Select the protocols that you want to use to access the device.

Click OK.

Step 3: Creating a NAT rule to translate internal IP to public IP
1.

Go to Policy > NAT > SNAT.

2.

Select New

In the SNAT Configuration dialog box, enter values
Option

Value

Source Address Address Entry, Any

www.fs.com

Destination
Address

Address Entry, Any

Egress

Egress interface, ethernet 0/1

Translated

Egress IP

Sticky

Enable
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3.

Click OK.

Step 4: Creating a security policy to allow internal users to access the Internet.
1.

Go to Policy > Security Policy.

2.

Click New.

In the Policy Configuration dialog box, enter values.
Source Information
Zone

trust

Address

Any

Destination Information
Zone

untrust

Address

Any

Other Information
Service/Service Any
Group

3.

APP/APP
Group

-----

Action

Permit

Click OK.

Step 5: Configuring a default route
1.

www.fs.com

Go to Network >Routing > Destination Route.
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2.

Click New.

In the Destination Route Configuration dialog box, enter values.
Option

Value

Destination

0.0.0.0 (means all network)

Subnet Mask

0.0.0.0 (means all subnets)

Gateway

202.10.1.1 (gateway provided by your ISP)

Deploying Mix Mode
If the firewall has both L2 interfaces (transparent mode) and L3 interfaces (routing mode), the firewall is
in mix mode.

To configure a mix mode, you need to combine the routing mode of the deployment methods with the
transparent mode. Please refer to these two modes.

www.fs.com
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Deploying Tap Mode
In most cases, the security device is deployed within the network as a serial node. However, in some
other scenarios, an IT administrator would just want the auditing and statistical functions like IPS,
antivirus, and Internet behavior control. For these features, you just need to connect the device to a
mirrored interface of a core network. The traffic is mirrored to the security device for auditing and
monitoring.

The bypass mode is created by binding a physical interface to a tap zone. Then, the interface becomes a
bypass interface.

Use an Ethernet cable to connect e0 of the Switch with e1 of the device. The interface e1 is the bypass
interface and e2 is the bypass control interface. The interface e0 is the mirror interface of the switch.The
switch mirrors the traffic to e1 and the FS device will monitor, scan, and log the traffic received from e1.
After configuring IPS, AV, or network behavior control on the FS device, if the device detects network
intrusions, viruses, or illegal network behaviors, it will send a TCP RST packet from e2 to the switch to
tell it to reset the connections.
Notes: Before configuring tap mode in the device, you need to set up an interface mirroring your
primary switch. Mirror the traffic of the switch from e0 to e1, and the device can scan, monitor and
count the mirrored traffic.
Here provides an example of monitoring IPS in tap mode.
Step 1: Creating tap mode by binding an interface

www.fs.com
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1.

2.

Select Network > Zone, and click New.

Option

Value

Zone

enter a name, e.g. "tap-zone" .

Type

TAP

Binding
Interface

Select the bypass interface (only a physical interface, aggregate
interface or redundant interface can apply, sub-interface is not
allowed).

Click OK.

Step 2: Creating an IPS rule
1.

Select Object > Intrusion Prevention System.

2.

Click New.

3.

Enter the rule name.

4.

Configure the signatures settings.

5.

Configure the protocol settings.

6.

Click OK to complete IPS rule configuration.

Step 3: Add IPS rule into Tap zone
1.

Select Network > Zone, and double-click the tap zone created in step 1.

2.

In the Treat Prevention tab, enable IPS and select the IPS rule created.

3.

Click OK.

(Optional) Block traffic in switch
A bypass control interface is used to send control packets (TCP RST packet is supported in current
version). After configuring IPS, AV, or network behavior control on the FS device, if the device detects

www.fs.com
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network intrusions, viruses, or illegal network behaviors, it will send a TCP RST packet from e2 to the
switch to tell it to reset the connections.
By default, the bypass interface itself is the control interface. However, you may also change the control
interface.
To change a bypass control interface, you can only use the command line interface:
tap control-interface interface-name


www.fs.com

interface-name - Specifies which interface is used as the bypass control interface.
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Chapter 3 Dashboard
This feature may vary slightly on different platforms. If there is a conflict between this guide and the
actual page, the latter shall prevail.
The dashboard shows the system and threat information. The layout of the dashboard is shown below:

Customize
You can customize the dashboard display function or modify the function area location as needed.




To customize the dashboard display function:
1.

Click Customize at the top-right corner.

2.

Select the function check box from the expanded list.

To modify the function area location:
1.
2.

www.fs.com

Hover your mouse over the title part in the ribbon.
When appears, press and hold the mouse functional area , the regional location to
be displayed .
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Threats
Display the top 10 threats information within the specified period.



Click
Threat Name.

to specify the type of display: Destination IP, Source IP or

Threatscape
The threat information statistic chart is displayed within the specified period.



Click the column to jump to the iCenter page, and the list will display the corresponding
threat level.

User
Display the top 10 user traffic information within the specified period.



Specify the type of display: by Traffic or by Concurrent Sessions from the drop-down
menu.


www.fs.com

Click

and

, switch between the table and the bar chart.
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Hover your mouse over a bar, to view users' upstream traffic, downstream traffic, total
traffic or concurrent sessions.

Application
Display the top 10 application traffic information within the specified period.



Specify the type of display: by Traffic or by New Sessions from the drop-down menu.



Click



Hover your mouse over a bar, to view users' total traffic or new sessions.

and

, switch between the table and the bar chart.

Total Traffic
Show the Total Traffic within the specified period .

Physical Interface
Display the statistical information of interfaces, including the interface name, IP address, upstream speed,
downstream speed, and total speed.

www.fs.com
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System Information
System information include.


Serial number: The serial number of the device.



Host name: The host name of the device.



Platform: The platform type of the device.



System Time: The time of system.



System Uptime: The running time of system.



HA State: The HA State of device:


Standalone: Non-HA mode which represents HA is disabled.



Init: Initial state.



Hello: Negotiation state which represents the device is negotiating the
relationship between master and backup.



Master: Master state which represents current device is master.



Backup: Backup state which represents current device is backup.



Failed: Fault state which represents the device is failed.



Firmware:The version number and version time of the firmware running on the device.



Boot File: The boot file name.



AntiVirus Signature: The version number and time of the anti virus signature database.



IPS Signature: The version number and time of the IPS signature database.



URL Category Database: The version number and time of the URL category database.

www.fs.com
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Application Identification Signature: The version number and time of the application
signature database.



IP Reputation Database: The version number and time of the IP reputation database.

License
Display the detailed information of installed licenses.



Customer: Displays the name of the customer who applied for the license.



Type: Displays the type of license.



Valid Time: Displays the valid time of license.



Others: Displays additional notes for the license.

Specified Period
System supports the predefined time cycle and the custom time cycle. Click (
on the top right corner of each tab to set the time cycle.


Realtime: Display the statistical information within 5 minutes of the current time.



Last Hour: Display the statistical information within the latest 1 hour.



Last Day: Display the statistical information within the latest 1 day.



Last Week: Display the statistical information within the latest 1 week.



Last Month: Display the statistical information within the latest 1 month.



)

Custom: Customize the time cycle. Select Custom and the Custom Date and Time dialog.
Select the start time and the end time as needed.

In the top-right corner, you can set the refresh interface of the displayed data.
Notes: The specified period may vary slightly on different platforms and different statistical objects.
Please see the actual page for the feature that your device delivers.

www.fs.com
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Chapter 4 iCenter
This feature may not be available on all platforms. Please check actual page in system to see whether
your device delivers this feature.
The multi-dimensional features show threats to the whole network in depth. threats of the whole
network.
If IPv6 function is enabled, you can view the threat information of IPv6 address through iCenter page.
Click iCenter.

Click a threat name link in the list to view the detailed information , source/destination, knowledge base
and history about the threat.


Threat Analysis: Depending on the threats of the different detection engine , the content
of Threat Analysis tab is also different.


Anti Virus/IPS: Display the detailed threat information .
For the Anti Virus/IPS function introduction, see "Anti Virus" /" Intrusion Prevention
System" .



Attack Defense/Perimeter Traffic Filtering: Display the threat detailed
information.
For the Attack Defense/Perimeter Traffic Filtering function introduction, see "AttackDefense" /"Perimeter Traffic Filtering".



Knowledge Base: Display the specified threat description, solution, etc. of the threats
detected by IPS .
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Threat History: Display the selected threat historical information of the whole network.
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Chapter 5 Network
This chapter describes factors and configurations related to network connection, including:


Security Zone: The security zone divides the network into different section, such as the
trust zone and the untrust zone. The device can control the traffic flow from and to security
zones once the configured policy rules have been applied.



Interface: The interface allows inbound and outbound traffic flow to security zones. An
interface must be bound to a security zone so that traffic can flow into and from the security
zone.



DNS: Domain Name System.



DHCP: Dynamic Host Configuration Protocol.



DDNS: Dynamic Domain Name Server.



PPPoE: Point-to-Point Protocol over Ethernet.



Virtual-Wire: The virtual wire allows direct Layer 2 communications between sub
networks.



Virtual Router: Virtual Route (Virtual Router for short) acts as a router. Different
Virtual Routers have their own independent routing tables.



Virtual Switch: Running on Layer 2, VSwitch acts as a switch. Once a Layer 2 security
zone is bound to a VSwitch, all the interfaces bound to that zone will also be bound to the
VSwitch.



Port Mirroring: Allow users to mirror the traffic of one interface to another interface
(analytic interface) for analysis and monitoring.



Link Load Balancing: It takes advantage of dynamic link detection technique to assign
traffic to different links appropriately, thus making full use of all available link resources.



Application Layer Gate: ALG can assure the data transmission for the applications that
use multiple channels and assure the proper operation of VoIP applications in the strictest NAT
mode.



Global Network Parameters: These parameters mainly include the IP packet's processing
options, like IP fragmentation, TCP MSS value, etc.

www.fs.com
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Security Zone
Security zone is a logical entity. One or more interfaces can be bound to one zone. A zone applied with a
policy is known as a security zone, while a zone created for a specific function is known as a functional
zone. Zones have the following features:


An interface should be bound to a zone. A Layer 2 zone will be bound to a VSwitch,
while a Layer 3 zone will be bound to a VRouter. Therefore, the VSwitch to which a Layer 2
zone is bound decides which VSwitch the interfaces belong to in that Layer 2 zone, and the
VRouter to which a Layer 3 zone is bound decides which VRouter the interfaces belong to in
that Layer 3 zone.



Interfaces in Layer 2 and Layer 3 are working in Layer 2 mode and Layer 3 mode
respectively.



System supports internal zone policies, like trust-to-trust policy rule.

There are 8 pre-defined security zones in FSOS, which are trust, untrust, dmz, L2-trust, L2-untrust, L2dmz, vpnhub (VPN functional zone) and ha (HA functional zone). You can also customize security
zones. Pre-defined security zones and user-defined security zones have no difference in functions, so
you can make your choice freely.

Configuring a Security Zone
To create a security zone, take the following steps：
1.
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Select Network > Zone.

37

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

2.

Click New.

3.

In the Zone Configuration text box, type the name of the zone into the Zone box.

4.

Type the descriptions of the zone in the Description text box.

5.

Specify a type for the security zone. For a Layer 2 zone, select a VSwitch for the zone
from the VSwitch drop-down list below; for a Layer-3 zone, select a VRouter from the Virtual
Router drop-down list. If TAP is selected, the zone created is a tap zone, which is used in
Bypass mode.

6.

Bind interfaces to the zone. Select an interface from the Binding Interface drop-down
list.

7.

If needed, select the Enable check box to enable APP identification for the zone.

8.

If needed, select the Enable check box to set the zone to a WAN zone, assuring the
accuracy of the statistic analysis sets that are based on IP data.

9.

If needed, select the Enable check box to enable NetBIOS host query for the zone. For
detailed instructions, see "DNS"

10.

If needed, select Threat Protection tab and configure the parameters for Threat
Protection function. For detailed instructions, see "Chapter 11 Threat Prevention".

11.

If needed, select Data Security tab and configure the parameters for Data Security
function. For detailed instructions, see "Data Security"

www.fs.com

38

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

12.

Click OK.

Notes:



Pre-defined zones cannot be deleted.
When changing the VSwitch to which a zone belong, make sure there is no binding
interface in the zone.

Interface
Interfaces allow inbound and outbound traffic to flow to security zones. An interface must be bound to
a security zone so that traffic can flow into and from the security zone. Furthermore, for the Layer 3
security zone, an IP address should be configured for the interface, and the corresponding policy rules
should also be configured to allow traffic transmission between different security zones. Multiple
interfaces can be bound to one security zone, but one interface cannot be bound to multiple security
zones.
The security devices support various types of interfaces which are basically divided into physical and
logical interfaces based on the nature.


Physical Interface: Each Ethernet interface on devices represents a physical interface.
The name of a physical interface, consisting of media type, slot number and location parameter,
is pre-defined, like ethernet2/1 or ethernet0/2.



Logical Interface: Include sub-interface, VSwitch interface, VLAN interface, loopback
interface, tunnel interface, aggregate interface, redundant interface, PPPoE interface and Virtual
Forward interface.

Interfaces can also be divided into Layer 2 interface and Layer 3 interface based on their security zones.



Layer 2 Interface: Any interface in Layer 2 zone or VLAN.
Layer 3 Interface: Any interface in Layer 3 zone. Only Layer 3 interfaces can operate in
NAT/routing mode.

Different types of interfaces provide different functions, as described in the table below.
Type

Description

Sub-interface

The name of an sub-interface is an extension to the name of its
original interface, like ethernet0/2.1. System supports the
following types of sub-interfaces: Ethernet sub-interface,
aggregate sub-interface and redundant sub-interface. An interface

www.fs.com
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Type

Description
and its sub-interfaces can be bound to one single security zone,
or to different zones.

VSwitch
interface

A Layer 3 interface that represents the collection of all the
interfaces of a VSwitch. The VSwtich interface is virtually the
upstream interface of a switch that implements packet forwarding
between Layer 2 and Layer 3.

VLAN
interface

A Layer 3 interface that represents the collection of all the
Ethernet interfaces within a VLAN. If only one Ethernet
interface is in UP state, the VLAN interface will be UP as well.
The VLAN interface is the outbound communication interface
for all the devices within a VLAN. Typically its IP address is the
gateway's address of the network device within the VLAN.

Loopback
interface

A logical interface. If only the security device with loopback
interface configured is in the working state, the interface will be
in the working state as well. Therefore, the loopback interface is
featured with stability.

Tunnel
interface

Only a Layer 3 interface, the tunnel interface acts as an ingress
for VPN communications. Traffic flows into VPN tunnel
through this interface.

Aggregate
interface

Collection of physical interfaces that include 1 to 16 physical
interfaces. These interfaces averagely share the traffic load to the
IP address of the aggregate interface, in an attempt to increase
the available bandwidth for a single IP address. If one of the
physical interfaces within an aggregate interface fails, other
physical interfaces can still process the traffic normally. The only
effect is the available bandwidth will decrease.

Redundant
interface

The redundant interface allows backup between two physical
interfaces. One physical interface, acting as the primary interface,
processes the inbound traffic, and another interface, acting as the
alternative interface, will take over the processing if the primary
interface fails.

PPPoE
interface

A logical interface based on Ethernet interface that allows
connection to PPPoE servers over PPPoE protocol.

Virtual
Forward
interface

In HA environment, the Virtual Forward interface is HA group's
interface designed for traffic transmission.

www.fs.com
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Configuring an Interface
The configuration options for different types of interfaces may vary. For more information, see the
following instructions.
Both IPv4 and IPv6 address can be configured for the interface, but IPv6 address is not supported for
the PPPoE interface.

Creating a PPPoE Interface
To create a PPPoE interface, take the following steps:
1.

Select Network > Interface.

2.

Click New > PPPoE Interface.

In the Basic tab, configure the following.
Option

Description

Interface Name Specifies a name for the PPPoE interface.
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Description

Enter descriptions for the PPPoE interface.

Binding Zone

If Layer 3 zone is selected, you should also select a security zone
from the Zone drop-down list, and the interface will bind to a
Layer 3 zone. If TAP is selected, the interface will bind to a tap
zone. If No Binding is selected, the interface will not bind to any
zone.

Zone

Select a security zone from the Zone drop-down list.

HA sync

Select this check box to enable the HA Sync function, which
disables Local property and uses the virtual MAC, and the
primary device will synchronize its information with the backup
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Option

Description
device; not selecting this check box disables the HA Sync
function, which enables Local property and uses the original
MAC, and the primary device will not synchronize its
information with the backup device.

NetFlow
Select a configured NetFlow profile from the drop-down list
Configuration below.
User

Specifies a username for PPPoE.

Password

Specifies PPPoE user's password.

Confirm
Password

Enter the password again to confirm.

Idle interval

If the PPPoE interface has been idle (no traffic) for a certain
period, i.e. the specified idle interval, system will disconnect the
Internet connections; if the interface requires Internet access, the
system will connect to the Internet automatically. The value
range is 0 to 10000 minutes. The default value is 30.

Re-connect
interval

Specifies a re-connect interval (i.e., system will try to re-connect
automatically after being disconnected for the interval). The
value range is 0 to 10000 seconds. The default value is 0, which
means the function is disabled.

Set gateway
With this selected checkbox, system will set the gateway
information
information provided by PPPoE server as the default gateway
from PPPoE route.
server as the
default gateway
route
Advanced

In the Advanced dialog, configure advanced options for PPPoE,
including:

Access Concentrator - Specifies a name for the
concentrator.

Authentication - The devices will have to pass
PPPoE authentication when trying to connect to a
PPPoE server. The supported authentication methods
include CHAP, PAP and Any (the default, anyone
between CHAP and PAP).

www.fs.com
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Option

Description

Netmask - Specifies a netmask for the IP address
obtained via PPPoE.

Static IP - You can specify a static IP address
and negotiate about using this address to avoid IP
change. To specify a static IP address, type it into the
box.

Distance - Specifies a route distance. The value
range is 1 to 255. The default value is 1.

Weight - Specifies a route weight. The value range
is 1 to 255. The default value is 1.

Service - Specifies allowed service. The specified
service must be the same with that provided by the
PPPoE server. If no service is specified, system will
accept any service returned from the server automatically.

DDNS

In the DDNS Configuration dialog, configure DDNS options
for the interface. For detailed instructions, see "DDNS" .
Tip: This function is available only when you edit the interface.

Management

Select one or more management method check boxes to
configure the interface management method.

Reverse Route

Enable or Disable reverse route as needed:

Enable: Force to use a reverse route. If the
reverse route is not available, packets will be dropped.
This option is enabled by default.

Close: Reverse route will not be used. When
reaching the interface, the reverse data stream will be
returned to its original route without any reverse route
check. That is to say, reverse packets will be sent from
the ingress interface that initializes the packets.

Auto: Reverse route will be prioritized. If
available, the reverse route will be used to send packets;
otherwise the ingress interface that initializes the packets
will be used as the egress interface that sends reverse

www.fs.com
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Option

Description
packets.

Auth Service

Click the Enable，Close or Global Default radio button as
needed.

Enable：Enable the WebAuth function of the
specified interface.

Close：Disable the WebAuth function of the
specified interface.

Global Default：Specify that the interface uses
the global default configuration of WebAuth. For the
global default configuration of WebAuth function, see
"Web Authentication" .

Proactive
WebAuth

Select the Enable check box to enable proactive webauth
function and Specify the AAA server.
After enabling, you can access the Web authentication address
initiate authentication request, and then fill in the correct user
name and password in the authentication login page. The Web
authentication address consists of the IP address of the interface
and the port number of the HTTP/HTTPS of the authentication
server. For example the IP address of the interface is 192.168.3.1,
authentication server HTTP/HTTPS port numbe is respectively
configured as 8182/44434. When the authentication server is
configured for HTTP authentication mode, Web address is:
http:// 192.168.3.1:8182; when the authentication server is
configured for HTTPS mode, the Web address for the https://
192.168.3.1:44434 certification.

In the Properties tab, configure properties for the interface.
Option
MTU

Description
Specifies a MTU for the interface. The value range is 1280 to
1500/1800 bytes. The default value is 1500. The max MTU may
vary on different platforms.

ARP Learning Select the Enable checkbox to enable ARP learning.
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Option

Description

ARP Timeout Specifies an ARP timeout for the interface. The value range is 5
to 65535 seconds. The default value is 1200.
Keep-alive IP

Specifies an IP address that receives the interface's keep-alive
packets.

MAC clone

Select the MAC clone check box to enable the MAC clone
function. System clones a MAC address in the Ethernet subinterface. If the user click "Restore Default MAC", the Ethernet
sub-interface will restore the default MAC address.

Mirror

Enable port mirroring on an Ethernet interface, and select the
traffic type to be mirrored.

In the Advanced tab, configure advanced options for the interface.
Option
Shutdown

Description
System supports interface shutdown. You can not only force a
specific interface to shut down, but also control the time it shuts
down by schedule or according to the link status of tracked
objects. Configure the options as below:
1.
Select the Shut down check box to enable
interface shutdown.
2.
To control the shutdown by schedule or tracked
objects, select the appropriate check box, and then
select an appropriate schedule or tracked object from
the drop-down list.

Monitor and
Backup

Configure the options as below:
1.
Select the appropriate check box, and then select
an appropriate schedule or tracked object from the
drop-down list.
2.

Select an action:

Shut down the interface: During the time
specified in the schedule, or when the tracked
object fails, the interface will be shut down and
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Option

Description
its related route will fail;

Migrate traffic to backup interface:
During the time specified in the schedule, or
when the tracked object fails, traffic flowing to
the interface will be migrated to the backup
interface. In such a case you need to select a
backup interface from the Backup interface
drop-down list and type the time into the
Migrating time box. (Migrating time, 0 to 60
minutes, is the period during which traffic is
migrated to the backup interface before the
primary interface is switched to the backup
interface. During the migrating time, traffic is
migrated from the primary interface to the
backup interface smoothly. By default the
migrating time is set to 0, i.e., all the traffic will
be migrated to the backup interface
immediately.)

In the RIP tab, configure RIP for the interface.
Option

Description

Authentication Specifies a packet authentication mode for the system, including
mode
plain text (the default) and MD5. The plain text authentication,
during which unencrypted string is transmitted together with the
RIP packet, cannot assure security, so it cannot be applied to the
scenarios that require high security.
Authentication Specifies a RIP authentication string for the interface.
string
Transmit
version

Specifies a RIP information version number transmitted by the
interface. By default V1&V2 RIP information will be transmitted.

Receive version Specifies a RIP information version number transmitted by the
interface. By default V1&V2 RIP information will be transmitted.
Split horizon
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Select the Enable checkbox to enable split horizon. With this
function enabled, routes learned from an interface will not be
sent from the same interface, in order to avoid routing loop and
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Option

Description
assure correct broadcasting to some extent.

In the OSPF tab, configure OSPF for the interface.
Option

Description

Interface Timer There are four interface timers: the interval for sending Hello
packets, the dead interval of adjacent routers, the interval for
retransmitting LSA, and the transmit delay for updating packets.

Hello Transmission Interval: Specifies the interval
for sending Hello packets for an interface. The value
range is 1 to 65535 seconds. The default value is 10.

Dead Time: Specifies the dead interval of
adjacent routes for an interface. The value range is 1 to
65535 seconds. The default value is 40 (4 times of
sending the Hello packets). If a router has not received
the Hello packet from its peer for a certain period, it will
determine the peering router is dead. This period is
known as the dead interval between the two adjacent
routers.

LSA Transmit Interval: Specifies the LSA
retransmit interval for an interface. The value range is 3
to 65535 seconds. The default value is 5.

LSU Transmit Delay Time: Specifies the transmit
delay for updating packet for an interface. The value
range is 1 to 65535 seconds. The default value is 1.
Priority
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Specifies the router priority. The value range is 0 to 255. The
default value is 1. The router with priority set to 0 will not be
selected as the designated router (The designated router will
receive the link information of all the other routers in the
network, and broadcast the received link information). If two
routers within a network can both be selected as the designated
router, the router with higher priority will be selected; if the
priority level is the same, the one with higher Router ID will be
selected.
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Option

Description

Network Type Specifies the network type of an interface. The network types of
an interface have the following options: broadcast, point-topoint, and point-to-multipoint. By default, the network type of
an interface is broadcast.
Link Cost

3.

Select the Enable check box to enable the link cost function. The
value range is 1 to 65535. By default, the HA synchronization
function is enabled, and the link cost will be synchronized to the
backup device. Clear the check box to disable the
synchronization function, and the system will stop synchronizing.

Click OK.

Creating a Tunnel Interface
To create a tunnel interface:
1.

Select Network > Interface.

2.

Select New > Tunnel Interface.

In the Basic tab, configure the following.
Option

Description

Interface Name Specifies a name for the tunnel interface.
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Description

Enter descriptions for the tunnel interface.

Binding Zone

If Layer 3 zone is selected, you should also select a security zone
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Option

Description
from the Zone drop-down list, and the interface will bind to a
Layer 3 zone. If TAP is selected, the interface will bind to a tap
zone. If No Binding is selected, the interface will not bind to any
zone.

Zone

Select a security zone from the Zone drop-down list.

HA sync

Select this check box to enable the HA Sync function, which
disables Local property and uses the virtual MAC, and the
primary device will synchronize its information with the backup
device; not selecting this check box disables the HA Sync
function, which enables Local property and uses the original
MAC, and the primary device will not synchronize its
information with the backup device.

NetFlow
configuration

Select a configured NetFlow profile from the drop-down list
below.

IP Configuration
Static IP

IP address: Specifies an IP address for the interface.
Netmask: Specifies a netmask for the interface.
Set as Local IP: In an HA environment, if this option is specified,
the interface IP will not synchronize to the HA peer.
Advanced:

Management IP: Specifies a management IP for
the interface. Type the IP address into the box.

Secondary IP: Specifies secondary IPs for the
interface. You can specify up to 6 secondary IP
addresses.
DHCP: In the DHCP Configuration dialog, configure DHCP
options for the interface. For detailed instructions, see "DHCP" .
DDNS: In the DDNS Configuration dialog, configure DDNS
options for the interface. For detailed instructions, see "DDNS" .
Tip: This function is available only when you edit the interface.

Auto-obtain
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Set gateway information from DHCP server as the default
gateway route: With this check box selected, system will set the
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Option

Description
gateway information provided by the DHCP server as the default
gateway route.
Advanced:

Distance: Specifies a route distance. The value
range is 1 to 255. The default value is 1.

Weight: Specifies a route weight. The value range
is 1 to 255. The default value is 1.

Management Priority: Specifies a priority for the
DNS server. Except for static DNS servers, system can
also learn DNS servers dynamically via DHCP or
PPPoE. Therefore, you need to configure priorities for
the DNS servers, so that system can choose a DNS
server according to its priority during DNS resolution.
The priority is represented in numbers from 1 to 255.
The larger the number is, the higher the priority is. The
priority of static DNS servers is 20.

Classless Static Routes: Enable the classless static
routing function via the DHCP options. When it is
enabled, the DHCP client will send a request message
with the Option121 (i.e., classless static routing option) to
the server, and then the server will return the classless
static route information. Finally, the client will add the
classless static routing information to the routing table.
DDNS: In the DDNS Configuration dialog, configure DDNS
options for the interface. For detailed instructions, see "DDNS" .
Tip: This function is available only when you edit the interface.

Management
Reverse Route

Select one or more management method check boxes to
configure the interface management method.
Enable or Disable reverse route as needed:

Enable: Enforces to use a reverse route. If the
reverse route is not available, packets will be dropped.
This option is enabled by default.
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Option

Description

Close: Reverse route will not be used. When
reaching the interface, the reverse data stream will be
returned to its original route without any reverse route
check. That is, reverse packets will be sent from the
ingress interface that initializes the packets.

Auto: Reverse route will be prioritized. If
available, the reverse route will be used to send packets;
otherwise the ingress interface that initializes the packets
will be used as the egress interface that sends reverse
packets.

Tunnel Binding

Bind the interface to a IPSec VPN tunnel or a SSL VPN tunnel.
One tunnel interface can be bound to multiple IPSec VPN
tunnels, while only to one SSL VPN tunnel.

IPSec VPN: Select IPSec VPN radio button.
Specifies a name for the IPSec VPN tunnel that is bound
to the interface. Then select a next-hop address for the
tunnel, which can either be the IP address or the egress
IP address of the peering tunnel interface. This
parameter, which is 0.0.0.0 by default, will only be valid
when multiple IPSec VPN tunnels is bound to the tunnel
interface.

SSL VPN: Select SSL VPN radio button.
Specifies a name for the SSL VPN tunnel that is bound
to the interface.

3.

Upstream
Brandwidth

Specifies the maximum value of the upstream rate of the
interface.

Downstream
Brandwidth

Specifies the maximum value of the downstream rate of the
interface.

In the IPv6 Configuration tab, configure the following.
Option
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Description

Enable

Enable IPv6 in the interface.

IPv6 Address

Specifies the IPv6 address prefix.
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Option
Prefix Length
Autoconfig

Description
Specifies the prefix length.
Select the checkbox to enable Auto-config function.
In the address auto-config mode, the interface
receives the address prefix in RA packets first, and
then combines it with the interface identifier to
generate a global address.


Enable DNS Proxy
DHCP
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Set Default Route - If the interface is
configured with a default router, this option
will generate a default route to the default
router.

Select this check box to enable DNS proxy for the
interface.
System supports DHCPv6 client, DHCPv6 server
and DHCPv6 relay proxy.


Select DHCP check box to enable
DHCP client for the interface. After enabling,
system will act as a DHCPv6 client and
obtain IPv6 addresses from the DHCP
server. Selecting Rapid-commit option can
help fast get IPv6 addresses from the server.
You need to enable both of the DHCP client
and the server's Rapid-commit function.



Select DHCPv6 Server from DHCP
drop-down list and configure options as
Configuring DHCPv6 Server, system will act
as a DHCPv6 server to appropriate IPv6
addresses for DHCP client.



Select DHCPv6 Relay Proxy from
DHCP drop-down list and configure options
as Configuring DHCPv6 Relay Proxy, system
will act as a DHCPv6 relay proxy to receive
requests from a DHCPv6 client and send
requests to the DHCPv6 server
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Option

Description

AdvancedEnable DNS Proxy: Select this check box to enable DNS proxy for the
interface.
Static

Dynamic
Link-local

MTU
DAD Attempts

Click Add button to add several IPv6 address, at
most 5 IPv6 addresses.. Click Delete button to delete
IPv6 address.
Shows IPv6 address which is dynamic.
Specifies link-local address. Link-local address is used
for communication between adjacent nodes of a
single link. For example, communication between
hosts when there are no routers on the link. By
default system will generate a link-local address for
the interface automatically if the interface is enabled
with IPv6 (in the interface configuration mode, use
the command ipv6 enable). You can also specify a
link-local address for the interface as needed, and the
specified link-local address will replace the
automatically generated one.
Specifies an IPv6 MTU for an interface.
Specifies NS packet attempt times. The value range is
0 to 20. Value 0 indicates DAD is not enabled on the
interface. If system does not receive any NA
response packets after sending NS packets for the
attempt times, it will verify that the IPv6 address is
an unique available address.
DAD (Duplicate Address Detection) is designed to
verify the uniqueness of IPv6 addresses. This
function is implemented by sending NS (Neighbor
Solicitation) requests. After receiving a NS packet, if
any other host on the link finds that the address of
the NS requester is duplicated, it will send a NA
(Neighbor Advertisement) packet advertising that the
address is already in use, and then the NS requester
will mark the address as duplicate, indicating that the
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Description
address is an invalid IPv6 address.

ND Interval

Specifies an interval for sending NS packets.

ND Reachable Time

Specifies reachable time. After sending an NS packet,
if the interface receives acknowledgment from a
neighbor within the specified time, it will consider
the neighbor as reachable. This time is known as
reachable time.

Hop Limit

ND RA Suppress

Specifies the hop limit. Hop limit refers to the
maximum number of hops for IPv6 or RA packets
sent by the interface.
Select the checkbox to disable RA suppress on LAN
interfaces.
By default, FDDI interface configured with IPv6
unicast route will send RA packets automatically, and
interfaces of other types will not send RA packets.

Manage IP/MASK

Specifies the manage IP/MASK.

4.

"In the Properties tab, configure properties for the interface."

5.

"In the Advanced tab, configure advanced options for the interface."

6.

"In the RIP tab, configure RIP for the interface."

7.

In the OSPF tab, configure OSPF for the interface.

8.

Click OK.

Creating a Virtual Forward Interface
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
To create a virtual forward interface, take the following steps:
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1.

Select Network > Interface.

2.

Select New > Virtual Forward Interface.
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In the Basic tab, configure the following.
Option

Description

Interface Name Specifies a name for the virtual forward interface.
Description

Enter descriptions for the virtual forward interface.

Binding Zone

If Layer 3 zone is selected, you should also select a security zone
from the Zone drop-down list, and the interface will bind to a
Layer 3 zone. If TAP is selected, the interface will bind to a tap
zone. If No Binding is selected, the interface will not bind to any
zone.

Zone

Select a security zone from the Zone drop-down list.

NetFlow
configuration

Select a configured NetFlow profile from the drop-down list
below.

IP Configuration
Static IP

IP address: Specifies an IP address for the interface.
Netmask: Specifies a netmask for the interface.
Set as Local IP: In an HA environment, if this option is specified,
the interface IP will not synchronize to the HA peer.
Advanced:

Management IP: Specifies a management IP for
the interface. Type the IP address into the box.

Secondary IP: Specifies secondary IPs for the
interface. You can specify up to 6 secondary IP
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Description
addresses.
DHCP: In the DHCP Configuration dialog, configure DHCP
options for the interface. For detailed instructions, see "DHCP" .
DDNS: In the DDNS Configuration dialog, configure DDNS
options for the interface. For detailed instructions, see "DDNS" .
Tip: This function is available only when you edit the interface.

Auto-obtain

Set gateway information from DHCP server as the default
gateway route: With this check box selected, system will set the
gateway information provided by the DHCP server as the default
gateway route.
Advanced:

Distance: Specifies a route distance. The value
range is 1 to 255. The default value is 1.

Weight: Specifies a route weight. The value range
is 1 to 255. The default value is 1.

Management Priority: Specifies a priority for the
DNS server. Except for static DNS servers, system can
also learn DNS servers dynamically via DHCP or
PPPoE. Therefore, you need to configure priorities for
the DNS servers, so that system can choose a DNS
server according to its priority during DNS resolution.
The priority is represented in numbers from 1 to 255.
The larger the number is, the higher the priority is. The
priority of static DNS servers is 20.

Classless Static Routes: Enable the classless static
routing function via the DHCP options. When it is
enabled, the DHCP client will send a request message
with the Option121 (i.e., classless static routing option) to
the server, and then the server will return the classless
static route information. Finally, the client will add the
classless static routing information to the routing table.
DDNS: In the DDNS Configuration dialog, configure DDNS
options for the interface. For detailed instructions, see "DDNS" .
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Option

Description
Tip: This function is available only when you edit the interface.

Management
Reverse Route

Select one or more management method check boxes to
configure the interface management method.
Enable or Disable reverse route as needed:

Enable: Enforces to use a reverse route. If the
reverse route is not available, packets will be dropped.
This option is enabled by default.

Close: Reverse route will not be used. When
reaching the interface, the reverse data stream will be
returned to its original route without any reverse route
check. That is, reverse packets will be sent from the
ingress interface that initializes the packets.

Auto: Reverse route will be prioritized. If
available, the reverse route will be used to send packets;
otherwise the ingress interface that initializes the packets
will be used as the egress interface that sends reverse
packets.

Upstream
Brandwidth

Specifies the maximum value of the upstream rate of the
interface.

Downstream
Brandwidth

Specifies the maximum value of the downstream rate of the
interface.

Proactive
WebAuth

Select the Enable check box to enable proactive webauth
function and Specify the AAA server.
After enabling, you can access the Web authentication address
initiate authentication request, and then fill in the correct user
name and password in the authentication login page. The Web
authentication address consists of the IP address of the interface
and the port number of the HTTP/HTTPS of the authentication
server. For example the IP address of the interface is 192.168.3.1,
authentication server HTTP/HTTPS port numbe is respectively
configured as 8182/44434. When the authentication server is
configured for HTTP authentication mode, Web address is:
http:// 192.168.3.1:8182; when the authentication server is
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Description
configured for HTTPS mode, the Web address for the https://
192.168.3.1:44434 certification.

3.

"In the IPv6 Configuration tab, configure the following."

4.

"In the Properties tab, configure properties for the interface."

5.

"In the Advanced tab, configure advanced options for the interface."

6.

"In the RIP tab, configure RIP for the interface."

7.

In the OSPF tab, configure OSPF for the interface.

8.

Click OK.

Creating a Loopback Interface
To create a loopback interface, take the following steps:
1.

Select Network > Interface.

2.

Click New > Loopback Interface.

In the Basic tab, configure the following.
Option

Description

Interface Name Specifies a name for the loopback interface.
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Description

Enter descriptions for the loopback interface.

Binding Zone

If Layer 3 zone is selected, you should also select a security zone
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Option

Description
from the Zone drop-down list, and the interface will bind to a
Layer 3 zone. If TAP is selected, the interface will bind to a tap
zone. If No Binding is selected, the interface will not bind to any
zone.

Zone

Select a security zone from the Zone drop-down list.

HA sync

Select this check box to enable the HA Sync function, which
disables Local property and uses the virtual MAC, and the
primary device will synchronize its information with the backup
device; not selecting this check box disables the HA Sync
function, which enables Local property and uses the original
MAC, and the primary device will not synchronize its
information with the backup device.

NetFlow
configuration

Select a configured NetFlow profile from the drop-down list
below.

IP Configuration
Static IP

IP address: Specifies an IP address for the interface.
Netmask: Specifies a netmask for the interface.
Set as Local IP:In an HA environment, if this option is specified,
the interface IP will not synchronize to the HA peer.
Advanced:

Management IP: Specifies a management IP for
the interface. Type the IP address into the box.

Secondary IP: Specifies secondary IPs for the
interface. You can specify up to 6 secondary IP
addresses.
DHCP: In the DHCP Configuration dialog, configure DHCP
options for the interface. For detailed instructions, see "DHCP" .
DDNS: In the DDNS Configuration dialog, configure DDNS
options for the interface. For detailed instructions, see "DDNS" .
Tip: This function is available only when you edit the interface.

Auto-obtain
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Set gateway information from DHCP server as the default
gateway route: With this check box selected, system will set the
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Option

Description
gateway information provided by the DHCP server as the default
gateway route.
Advanced:

Distance: Specifies a route distance. The value
range is 1 to 255. The default value is 1.

Weight: Specifies a route weight. The value range
is 1 to 255. The default value is 1.

Management Priority: Specifies a priority for the
DNS server. Except for static DNS servers, system can
also learn DNS servers dynamically via DHCP or
PPPoE. Therefore, you need to configure priorities for
the DNS servers, so that system can choose a DNS
server according to its priority during DNS resolution.
The priority is represented in numbers from 1 to 255.
The larger the number is, the higher the priority is. The
priority of static DNS servers is 20.

Classless Static Routes: Enable the classless static
routing function via the DHCP options. When it is
enabled, the DHCP client will send a request message
with the Option121 (i.e., classless static routing option) to
the server, and then the server will return the classless
static route information. Finally, the client will add the
classless static routing information to the routing table.
DDNS: In the DDNS Configuration dialog, configure DDNS
options for the interface. For detailed instructions, see "DDNS"
Tip: This function is available only when you edit the interface.

Management
Reverse Route

Select one or more management method check boxes to
configure the interface management method.
Enable or Disable reverse route as needed:

Enable: Enforces to use a reverse route. If the
reverse route is not available, packets will be dropped.
This option is enabled by default.
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Option

Description

Close: Reverse route will not be used. When
reaching the interface, the reverse data stream will be
returned to its original route without any reverse route
check. That is, reverse packets will be sent from the
ingress interface that initializes the packets.

Auto: Reverse route will be prioritized. If
available, the reverse route will be used to send packets;
otherwise the ingress interface that initializes the packets
will be used as the egress interface that sends reverse
packets.

Upstream
Brandwidth

Specifies the maximum value of the upstream rate of the
interface.

Downstream
Brandwidth

Specifies the maximum value of the downstream rate of the
interface.

3.

"In the IPv6 Configuration tab, configure the following."

4.

"In the Properties tab, configure properties for the interface."

5.

"In the Advanced tab, configure advanced options for the interface."

6.

"In the RIP tab, configure RIP for the interface."

7.

In the OSPF tab, configure OSPF for the interface.

8.

Click OK.

Creating an Aggregate Interface
To create an aggregate interface, take the following steps：
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1.

Select Network > Interface.

2.

Click New > Aggregate Interface.

61

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

3.

In the Basic tab, configure the following.
Option

Description

Interface Name Specifies a name for the aggregate interface.
Description
Binding Zone

Enter descriptions for the aggregate interface.
Specifies the zone type.
If Layer 3 or Layer 2 zone is selected, you should also select a
security zone from the Zone drop-down list, and the interface
will bind to a Layer 3 or Layer 2 zone.
If TAP is selected, the interface will bind to a tap zone.
If No Binding is selected, you should also select a
VLAN/aggregate interface/redundant interface:
Belong to
VLAN
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Description
Acess
The interface in Access mode is
mode(one designed for terminal users and only
VLAN) allows packets from one VLAN to pass
through.
Trunk
The interface in Trunk mode is typically
mode(mul used for inter-connections between
tiple
devices, and allows packets from multiple
VLANs) VLANs to pass through. When Native
VLAN is configured, the interface will
delete the tag of the Native VLAN
packets being transmitted, and add a
Native VLAN tag to the received packets
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Option

Description
with no tag set.
Aggregate The interface you specified belongs to an aggregate
Interface interface. Choose an aggregate interface which the
aggregate interface belongs to from the Interface
Group drop-down list.
Redundant This interface belongs to a redundant interface.
Interface Select that redundant interface from the Interface
Group drop-down list.
None
This interface does not belong to any object.

Zone
LACP

Select a security zone from the Zone drop-down list.

Forced: Aggregates multiple physical interfaces to
form an aggregate interface. These physical interfaces will
share the traffic passing through the aggregate interface
equally.

Enables LACP on the interface to negotiate
aggregate interfaces dynamically. LACP options are:

System priority: Specifies the LACP
system priority. The value range is 1 to 32768, the
default value is 32768. This parameter is used to
assure the interfaces of two ends are consistent.
System will select interfaces based on the end
with higher LACP system priority. The smaller
the value is, the higher the priority will be. If the
LACP system priorities of the two ends are equal,
system will compare MACs of the two ends. The
smaller the MAC is, the higher the priority will
be.

Max bundle: Specifies the maximum
active interfaces. The value range is 1 to 16, the
default value is 16. When the active interfaces
reach the maximum number, the status of other
legal interfaces will change to Standby.

Min bundle: Specifies the minimum active
interfaces. The value range is 1 to 8, the default
value is 1. When the active interfaces reach the
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Description
minimum number, the status of all the legal
interfaces in the aggregation group will change to
Standby automatically and will not forward any
traffic.

HA sync

Select this check box to enable HA sync function. The primary
device will synchronize its information with the backup device.

NetFlow
configuration

Select a configured NetFlow profile from the drop-down list
below.

IP Configuration
Static IP

IP address: Specifies an IP address for the interface.
Netmask: Specifies a netmask for the interface.
Set as Local IP: In an HA environment, if this option is specified,
the interface IP will not synchronize to the HA peer.
Advanced:

Management IP: Specifies a management IP for
the interface. Type the IP address into the box.

Secondary IP: Specifies secondary IPs for the
interface. You can specify up to 6 secondary IP
addresses.
DHCP: In the DHCP Configuration dialog, configure DHCP
options for the interface. For detailed instructions, see "DHCP"
DDNS: In the DDNS Configuration dialog, configure DDNS
options for the interface. For detailed instructions, see "DDNS" .
Tip: This function is available only when you edit the interface.

Auto-obtain

Set gateway information from DHCP server as the default
gateway route: With this check box being selected, system will set
the gateway information provided by the DHCP server as the
default gateway route.
Advanced:


www.fs.com

Distance: Specifies a route distance. The value
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Option

Description
range is 1 to 255. The default value is 1.

Weight: Specifies a route weight. The value range
is 1 to 255. The default value is 1.

Management Priority: Specifies a priority for the
DNS server. Except for static DNS servers, system can
also learn DNS servers dynamically via DHCP or
PPPoE. Therefore, you need to configure priorities for
the DNS servers, so that system can choose a DNS
server according to its priority during DNS resolution.
The priority is represented in numbers from 1 to 255.
The larger the number is, the higher the priority is. The
priority of static DNS servers is 20.

Classless Static Routes: Enable the classless static
routing function via the DHCP options. When it is
enabled, the DHCP client will send a request message
with the Option121 (i.e., classless static routing option) to
the server, and then the server will return the classless
static route information. Finally, the client will add the
classless static routing information to the routing table.
DDNS: In the DDNS Configuration dialog, configure DDNS
options for the interface. For detailed instructions, see "DDNS" .
Tip: This function is available only when you edit the interface.

PPPoE

Obtain IP through PPPoE。Configure the following options：


User - Specifies a username for PPPoE.



Password - Specifies PPPoE user's password.


Confirm password - Enter the password again to
confirm.

Idle interval - If the PPPoE interface has been
idle (no traffic) for a certain period, i.e., the specified idle
interval, the system will disconnect the Internet
connection; if the interface requires Internet access, the
system will connect to the Internet automatically. The
value range is 0 to 10000 minutes. The default value is 30.
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Option

Description

Re-connect interval - Specifies a re-connect
interval (i.e., system will try to re-connect automatically
after being disconnected for the interval). The value
range is 0 to 10000 seconds. The default value is 0, which
means the function is disabled.

Set gateway information from PPPoE server as
the default gateway route - With this checkbox selected,
system will set the gateway information provided by
PPPoE server as the default gateway route.

Management
Reverse Route

Select one or more management method check boxes to
configure the interface management method.
Enable or Disable reverse route as needed:

Enable: Enforces to use a reverse route. If the
reverse route is not available, packets will be dropped.
This option is enabled by default.

Close: Reverse route will not be used. When
reaching the interface the reverse data stream will be
returned to its original route without any reverse route
check. That is, reverse packets will be sent from the
ingress interface that initializes the packets.

Auto: Reverse route will be prioritized. If
available, the reverse route will be used to send packets;
otherwise the ingress interface that initializes the packets
will be used as the egress interface that sends reverse
packets.

Upstream
Brandwidth

Specifies the maximum value of the upstream rate of the
interface.

Downstream
Brandwidth

Specifies the maximum value of the downstream rate of the
interface.

Auth Service

Click the Enable，Close or Global Default radio button as
needed.
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Enable：Enable the WebAuth function of the
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Option

Description
specified interface.

Close：Disable the WebAuth function of the
specified interface.

Global Default：Specify that the interface uses
the global default configuration of WebAuth. For the
global default configuration of WebAuth function, see
"Web Authentication".

Proactive
WebAuth

Select the Enable check box to enable proactive webauth
function and Specify the AAA server.
After enabling, you can access the Web authentication address
initiate authentication request, and then fill in the correct user
name and password in the authentication login page. The Web
authentication address consists of the IP address of the interface
and the port number of the HTTP/HTTPS of the authentication
server. For example the IP address of the interface is 192.168.3.1,
authentication server HTTP/HTTPS port numbe is respectively
configured as 8182/44434. When the authentication server is
configured for HTTP authentication mode, Web address is:
http:// 192.168.3.1:8182; when the authentication server is
configured for HTTPS mode, the Web address for the https://
192.168.3.1:44434 certification.

4.

"In the IPv6 Configuration tab, configure the following."

5.

"In the Properties tab, configure properties for the interface."

6.

"In the Advanced tab, configure advanced options for the interface."

7.

"In the RIP tab, configure RIP for the interface."

8.

In the OSPF tab, configure OSPF for the interface.

9.
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In the Load Balance tab, configure a load balance mode for the interface. "Flow-based"
means enabling automatic load balance based on the flow. This is the default mode. "Tuple"
means enabling load based on the source/destination IP, source/destination MAC,
source/destination interface or protocol type of packet, or the combination of the selected
items.
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10.

Click OK.

Creating a Redundant Interface
To create a redundant interface, take the following steps:
1.

Select Network > Interface.

2.

Click New > Redundant Interface.

3.

"In the Basic tab, configure the following."

4.

"In the IPv6 Configuration tab, configure the following."

5.

"In the Properties tab, configure properties for the interface."

6.

"In the Advanced tab, configure advanced options for the interface."

7.

"In the RIP tab, configure RIP for the interface."

8.

In the OSPF tab, configure OSPF for the interface.

9.

Click OK.

Creating an Ethernet Sub-interface/an Aggregate Sub-interface/a Redundant Subinterface
To create an ethernet sub-interface/an aggregate sub-interface/a redundant sub-interface, take the
following steps:
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1.

Select Network > Interface.

2.

Click New > Ethernet Sub-interface/Aggregate Sub-interface/Redundant Sub-interface.

3.

In the Basic tab, configure the following.
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Option

Description

Interface Name Specifies a name for the virtual forward interface.
Description

Enter descriptions for the virtual forward interface.

Binding Zone

If Layer 3 zone is selected, you should also select a security zone
from the Zone drop-down list, and the interface will bind to a
Layer 3 zone. If TAP is selected, the interface will bind to a tap
zone. If No Binding is selected, the interface will not bind to any
zone.

Zone

Select a security zone from the Zone drop-down list.

NetFlow
configuration

Select a configured NetFlow profile from the drop-down list
below.

IP Configuration
Static IP

IP address: Specifies an IP address for the interface.
Netmask: Specifies a netmask for the interface.
Set as Local IP: In an HA environment, if this option is specified,
the interface IP will not synchronize to the HA peer.
Advanced:

Management IP: Specifies a management IP for
the interface. Type the IP address into the box.

Secondary IP: Specifies secondary IPs for the
interface. You can specify up to 6 secondary IP
addresses.
DHCP: In the DHCP Configuration dialog, configure DHCP
options for the interface. For detailed instructions, see "DHCP" .
DDNS: In the DDNS Configuration dialog, configure DDNS
options for the interface. For detailed instructions, see "DDNS"
Tip: This function is available only when you edit the interface.

Auto-obtain

Set gateway information from DHCP server as the default
gateway route: With this check box selected, system will set the
gateway information provided by the DHCP server as the default
gateway route.
Advanced:
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Description

Distance: Specifies a route distance. The value
range is 1 to 255. The default value is 1.

Weight: Specifies a route weight. The value range
is 1 to 255. The default value is 1.

Management Priority: Specifies a priority for the
DNS server. Except for static DNS servers, system can
also learn DNS servers dynamically via DHCP or
PPPoE. Therefore, you need to configure priorities for
the DNS servers, so that the system can choose a DNS
server according to its priority during DNS resolution.
The priority is represented in numbers from 1 to 255.
The larger the number is, the higher the priority is. The
priority of static DNS servers is 20.

Classless Static Routes: Enable the classless static
routing function via the DHCP options. When it is
enabled, the DHCP client will send a request message
with the Option121 (i.e., classless static routing option) to
the server, and then the server will return the classless
static route information. Finally, the client will add the
classless static routing information to the routing table.
DDNS: In the DDNS Configuration dialog, configure DDNS
options for the interface. For detailed instructions, see "DDNS" .
Tip: This function is available only when you edit the interface.

PPPoE

Obtain IP through PPPoE。Configure the following options：
(Effective only when creating a aggregate sub-interface)


User - Specifies a username for PPPoE.



Password - Specifies PPPoE user's password.


Confirm password - Enter the password again to
confirm.

Idle interval -If the PPPoE interface has been idle
(no traffic) for a certain period, i.e., the specified idle
interval, system will disconnect the Internet connection;
if the interface requires Internet access, the system will
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Description
connect to the Internet automatically. The value range is
0 to 10000 minutes. The default value is 30.

Re-connect interval - Specifies a re-connect
interval (i.e., system will try to re-connect automatically
after being disconnected for the interval). The value
range is 0 to 10000 seconds. The default value is 0, which
means the function is disabled.

Set gateway information from PPPoE server as
the default gateway route - With this checkbox selected,
system will set the gateway information provided by
PPPoE server as the default gateway route.

Management
Reverse Route

Select one or more management method check boxes to
configure the interface management method.
Enable or Disable reverse route as needed:

Enable: Enforces to use a reverse route. If the
reverse route is not available, packets will be dropped.
This option is enabled by default.

Close: Reverse route will not be used. When
reaching the interface the reverse data stream will be
returned to its original route without any reverse route
check. That is, reverse packets will be sent from the
ingress interface that initializes the packets.

Auto: Reverse route will be prioritized. If
available, the reverse route will be used to send packets;
otherwise the ingress interface that initializes the packets
will be used as the egress interface that sends reverse
packets.

Upstream
Brandwidth

Specifies the maximum value of the upstream rate of the
interface.

Downstream
Brandwidth

Specifies the maximum value of the downstream rate of the
interface.

Auth Service
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Click the Enable，Close or Global Default radio button as
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Option

Description
needed.

Enable：Enable the WebAuth function of the
specified interface.

Close：Disable the WebAuth function of the
specified interface.

Global Default：Specify that the interface uses
the global default configuration of WebAuth. For the
global default configuration of WebAuth function, see
"Web Authentication" .

Proactive
WebAuth

Select the Enable check box to enable proactive webauth
function and Specify the AAA server.
After enabling, you can access the Web authentication address
initiate authentication request, and then fill in the correct user
name and password in the authentication login page. The Web
authentication address consists of the IP address of the interface
and the port number of the HTTP/HTTPS of the authentication
server. For example the IP address of the interface is 192.168.3.1,
authentication server HTTP/HTTPS port numbe is respectively
configured as 8182/44434. When the authentication server is
configured for HTTP authentication mode, Web address is:
http:// 192.168.3.1:8182; when the authentication server is
configured for HTTPS mode, the Web address for the https://
192.168.3.1:44434 certification.
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4.

"In the IPv6 Configuration tab, configure the following."

5.

"In the Properties tab, configure properties for the interface."

6.

"In the Advanced tab, configure advanced options for the interface."

7.

"In the RIP tab, configure RIP for the interface."

8.

In the OSPF tab, configure OSPF for the interface.

9.

Click OK.
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Creating a VSwitch Interface/a VLAN Interface
To create a VSwitch interface/a VLAN interface, take the following steps:
1.

Select Network > Interface.

2.

Click New > VSwitch Interface/VLAN Interface.

3.

"In the Basic tab, configure the following."

4.

"In the IPv6 Configuration tab, configure the following."

5.

"In the Properties tab, configure properties for the interface."

6.

"In the Advanced tab, configure advanced options for the interface."

7.

"In the RIP tab, configure RIP for the interface."

8.

In the OSPF tab, configure OSPF for the interface.

9.

Click OK.

Editing an Interface
To edit an interface, take the following steps:
1.

Select Network > Interface.

2.

Select the interface you want to edit from the interface list and click Edit.

3.

In the Basic tab, configure the following.
Option

Description

Interface Specifies a name for the interface.
Name
Descripti Enter descriptions for the interface.
on
Binding
Zone

Specifies the zone type.
If Layer 3 or Layer 2 zone is selected, you should also select a security
zone from the Zone drop-down list, and the interface will bind to a
Layer 3 or Layer 2 zone.
If TAP is selected, the interface will bind to a tap zone.
If No Binding is selected, you should also select a VLAN/aggregate
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Option

Description
interface/redundant interface:
Belong to
VLAN

Aggregate
Interface

Description
Acess
mode(one
VLAN)

The interface in Access mode is
designed for terminal users and only
allows packets from one VLAN to pass
through.
Trunk
The interface in Trunk mode is typically
mode(multiple used for inter-connections between
VLANs)
devices, and allows packets from multiple
VLANs to pass through. When Native
VLAN is configured, the interface will
delete the tag of the Native VLAN
packets being transmitted, and add a
Native VLAN tag to the received packets
with no tag set.
The interface you specified belongs to a aggregate
interface.

Interface Group:Choose an aggregate
interface which the aggregate interface belongs
to from Interface Group drop-down list.

Port LACP priority：Port LACP
priority determines the sequence of becoming
the Selected status for the members in the
aggregate group. The smaller the number is, the
higher the priority will be. Link in the aggregate
group that will be aggregated is determined by
the interface LACP priority and the LACP
system priority.

Port timeout mode：The LACP timeout
refers to the time interval for the members The
system supports Fast (1 second) and Slow (30
seconds, the default value).waiting to receive the
LACPDU packets. If the local member does not
receive the LACPDU packet from its peer in
three timeout values, the peer will be conclude
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Option

Description
as down, and the status of the local member will
change from Active to Selected, and stop traffic
forwarding.

Redundant
Interface
None
LACP
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This interface belongs to a redundant interface. Select
that redundant interface from the Interface Group
drop-down list.
This interface does not belong to any object.



Forced: Aggregates multiple physical interfaces to form
an aggregate interface. These physical interfaces will share the
traffic passing through the aggregate interface equally.



Enables LACP on the interface to negotiate aggregate
interfaces dynamically. LACP options are:


System priority: Specifies the LACP system
priority. The value range is 1 to 32768, the default
value is 32768. This parameter is used to assure the
interfaces of two ends are consistent. System will select
interfaces based on the end with higher LACP system
priority. The smaller the value is, the higher the priority
will be. If the LACP system priorities of the two ends
are equal, system will compare MACs of the two ends.
The smaller the MAC is, the higher the priority will be.



Max bundle: Specifies the maximum active
interfaces. The value range is 1 to 16, the default value
is 16. When the active interfaces reach the maximum
number, the status of other legal interfaces will change
to Standby.



Min bundle: Specifies the minimum active
interfaces. The value range is 1 to 8, the default value is
1. When the active interfaces reach the minimum
number, the status of all the legal interfaces in the
aggregation group will change to Standby automatically
and will not forward any traffic.
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Option
Zone

Description
Select a security zone from the Zone drop-down list.

NetFlow Select a configured NetFlow profile from the drop-down list below.
configurat
ion
IP Configuration
Static IP

IP address: Specifies an IP address for the interface.
Netmask: Specifies a netmask for the interface.
Set as Local IP: In an HA environment, if this option is specified, the
interface IP will not synchronize to the HA peer.
Advanced:


Management IP: Specifies a management IP for the
interface. Type the IP address into the box.



Secondary IP: Specifies secondary IPs for the interface.
You can specify up to 6 secondary IP addresses.

DHCP: In the DHCP Configuration dialog, configure DHCP options
for the interface. For detailed instructions, see "DHCP" .
DDNS: In the DDNS Configuration dialog, configure DDNS options
for the interface. For detailed instructions, see "DDNS" .
Tip: This function is available only when you edit the interface.
Autoobtain

Set gateway information from DHCP server as the default gateway
route: With this check box selected, system will set the gateway
information provided by the DHCP server as the default gateway
route.
Advanced:
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Distance: Specifies a route distance. The value range is
1 to 255. The default value is 1.



Weight: Specifies a route weight. The value range is 1
to 255. The default value is 1.



Management Priority: Specifies a priority for the DNS
server. Except for static DNS servers, system can also learn
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Option

Description
DNS servers dynamically via DHCP or PPPoE. Therefore,
you need to configure priorities for the DNS servers, so that
system can choose a DNS server according to its priority
during DNS resolution. The priority is represented in numbers
from 1 to 255. The larger the number is, the higher the priority
is. The priority of static DNS servers is 20.


Classless Static Routes: Enable the classless static
routing function via the DHCP options. When it is enabled,
the DHCP client will send a request message with the
Option121 (i.e., classless static routing option) to the server,
and then the server will return the classless static route
information. Finally, the client will add the classless static
routing information to the routing table.

DDNS: In the DDNS Configuration dialog, configure DDNS options
for the interface. For detailed instructions, see "DDNS" .
Tip: This function is available only when you edit the interface.
PPPoE
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User: Specifies a username for PPPoE.
Password: Specifies PPPoE user's password.
Confirm Password: Enter the password again to confirm.
Idle Interval: If the PPPoE interface has been idle (no traffic) for a
certain period, i.e. the specified idle interval, system will disconnect the
Internet connection; if the interface requires Internet access, system
will connect to the Internet automatically. The value range is 0 to
10000 minutes. The default value is 30.
Re-connect Interval: Specifies a re-connect interval (i.e., system will try
to re-connect automatically after being disconnected for the interval).
The value range is 0 to 10000 seconds. The default value is 0, which
means the function is disabled.
Set gateway information from PPPoE server as the default gateway
route: With this check box being selected, system will set the gateway
information provided by PPPoE server as the default gateway route.
Advanc Access concentrator: Specifies a name for the concentrator.
ed
Authentication: The devices will have to pass PPPoE
authentication when trying to connect to a PPPoE server. The
supported authentication methods include CHAP, PAP and
Any (the default, anyone between CHAP and PAP). Click an
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Option

Description
authentication method.
Netmask: Specifies a netmask for the IP address obtained via
PPPoE.
Static IP: You can specify a static IP address and negotiate to
use this address to avoid IP change. To specify a static IP
address, type it into the box.
Service: Specifies allowed service. The specified service must
be the same with that provided by the PPPoE server. If no
service is specified, FS will accept any service returned from
the server automatically.
Distance: Specifies a route distance. The value range is 1 to
255. The default value is 1.
Weight: Specifies a route weight. The value range is 1 to 255.
The default value is 1.
DDNS: In the DDNS Configuration dialog, configure DDNS options
for the interface. For detailed instructions, see "DDNS" .
Tip: This function is available only when you edit the interface.

Managem Select one or more management method check boxes to configure the
ent
interface management method.
Reverse
Route
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Enable or Disable reverse route as needed:


Enable: Enforces to use a reverse route. If the reverse
route is not available, packets will be dropped. This option is
enabled by default.



Close: Reverse route will not be used. When reaching
the interface, the reverse data stream will be returned to its
original route without any reverse route check. That is, reverse
packets will be sent from the ingress interface that initializes
the packets.



Auto: Reverse route will be prioritized. If available, the
reverse route will be used to send packets; otherwise the
ingress interface that initializes the packets will be used as the
egress interface that sends reverse packets.
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Option

Description

Upstream Specifies the maximum value of the upstream rate of the interface.
Brandwid
th
Downstre Specifies the maximum value of the downstream rate of the interface.
am
Brandwid
th
Auth
Service

Click the Enable，Close or Global Default radio button as needed.


Enable：Enable the WebAuth function of the
specified interface.



Close：Disable the WebAuth function of the specified
interface.



Global Default：Specify that the interface uses the
global default configuration of WebAuth. For the global
default configuration of WebAuth function, see "Web
Authentication" .

Proactive
Select the Enable check box to enable proactive webauth function and
WebAuth
Specify the AAA server.
After enabling, you can access the Web authentication address initiate
authentication request, and then fill in the correct user name and
password in the authentication login page. The Web authentication
address consists of the IP address of the interface and the port
number of the HTTP/HTTPS of the authentication server. For
example the IP address of the interface is 192.168.3.1, authentication
server HTTP/HTTPS port numbe is respectively configured as
8182/44434. When the authentication server is configured for HTTP
authentication mode, Web address is: http:// 192.168.3.1:8182; when
the authentication server is configured for HTTPS mode, the Web
address for the https:// 192.168.3.1:44434 certification.
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4.

"In the IPv6 Configuration tab, configure the following."

5.

In the Properties tab, configure properties for the interface.
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Property

Description

Duplex

Specifies a duplex working mode for the interface. Options
include auto, full duplex and half duplex. Auto is the default
working mode, in which system will select the most appropriate
duplex working mode automatically. 1000M half duplex is not
supported.

Rate

Specifies a working rate for the interface. Options include Auto,
10M, 100M and 1000M. Auto is the default working mode, in
which system will detect and select the most appropriate working
mode automatically. 1000M half duplex is not supported.

Combo type

This option is applicable to the Combo port of copper port +
fiber port. If both the copper port and the fiber port are plugged
with cable, the fiber port will be prioritized by default; if the
copper port is used at first, and the cable is plugged into the fiber
port, and the fiber port will be used for data transmission after
reboot. You can specify how to use a copper port or fiber port.
For detailed options, see the following instructions:


Auto: The above default scenario.



Copper forced: The copper port is enforced.



Copper preferred: The copper port is prioritized.



Fiber forced: The fiber port is enforced.


Fiber preferred: The fiber port is prioritized. With
this option configured, the device will migrate the traffic
on the copper port to the fiber port automatically
without reboot.
MTU

Specifies a MTU for the interface. The value range is 1280 to
1500/1800 bytes. The default value is 1500. The max MTU may
vary in different FS models.

ARP Learning Select the Enable checkbox to enable ARP learning.
ARP Timeout Specifies an ARP timeout for the interface. The value range is 5
to 65535 seconds. The default value is 1200.
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Keep-alive IP

Specifies an IP address that receives the interface's keep-alive
packets.

MAC clone

Select the MAC clone check box to enable the MAC clone
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Property

Description
funtion. System clones a MAC address to the Ethernet subinterface. If the user click "Restore Default MAC", the Ethernet
sub-interface will retore the default MAC address.

6.

"In the Advanced tab, configure advanced options for the interface."

7.

"In the RIP tab, configure RIP for the interface."

8.

In the OSPF tab, configure OSPF for the interface.

9.

Click OK.

Notes:


Before deleting an aggregate/redundant interface, you must cancel other interfaces'
bindings to it, aggregate/redundant sub-interface's configuration, its IP address configuration
and its binding to the security zone.



An Ethernet interface can only be edited but cannot be deleted.



When a VSwitch interface is deleted, the corresponding VSwitch will be deleted as well.

DNS
DNS, the abbreviation for Domain Name System, is a computer and network service naming system in
form of domain hierarchy. DNS is designed for TCP/IP network to query for Internet domain names
(e.g., www.xxxx.com) and translate them into IP addresses (e.g., 10.1.1.1) to locate related computers
and services.
The security device's DNS provides the following functions:



Server: Configures DNS servers and default domain names for the security device.
Proxy:As a DNS proxy, the device can filter the DNS request according to the DNS
proxy rules set by the user, and system will forwarded the qualified DNS request to the
designated DNS server.




Analysis: Sets retry times and timeout for device's DNS service.
Cache: DNS mappings to cache can speed up query. You can create, edit and delete
DNS mappings.
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NBT Cache: Displays NBT cache information.
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Configuring a DNS Server
You can configure a DNS server for system to implement DNS resolution. To create a DNS server, take
the following steps:
1.

Select Network > DNS > DNS Server.

2.

Click New in the DNS Server section.

3.

In the DNS Server Configuration dialog, type the IP address for the DNS server into the
Server IP box.

4.

Select a VRouter from the VR drop-down list. The default VRouter is trust-vr.

5.

Click OK.

Configuring a DNS Proxy
DNS Proxy function take effect by the DNS proxy rules.Generally a proxy rule consists of two parts:
filtering condition and action. You can set the filtering condition by specifying traffic's ingress interface ,
source address, destination address, and domain name. The action of the DNS proxy rules includes
proxy,bypass and block. When the action of the proxy rule is specified as proxy, you need to configure
the DNS proxy servers, so that the DNS request meeting the filtering condition will be resolved by these
DNS proxy servers.

Configuring a DNS Proxy Rule
To create a DNS proxy rule, take the following steps:
1.

Select Network > DNS > DNS Proxy.

2.

Click New in the DNS Proxy section.

3.

In the <DNS Proxy Rule Configuration> dialog, configure the following settings.
Option

Description

Description

Add the description.

Ingress
Interface

Specify the ingress interface of DNS request in the rule to filter
the DNS request message. It is permissible to specify numbers of
interfaces.

Source Address
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Specify the source address of DNS request to filter the DNS
request message. It is permissible to specify multiple source
address filtering conditions. Select the address entry type and
then type the address. Click Add to add the selected entry to the
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Option

Description
pane.
1.
Select an address type from the Address dropdown list.
2.
Select or type the source addresses based on the
selected type.
3.

Click

to add the addresses to the right pane.

4.
After adding the desired addresses, click the blank
area in this dialog box to complete the source address
configuration.
You can also perform other operations:

When selecting the Address Book type, you can
click Add to create a new address entry.

When selecting the IPv4 type, the default address
configuration is any. To restore the configuration to this
default one, select the any check box.

When selecting the IPv6 type, the default address
configuration is IPv6-any. To restore the configuration to
this default one, select the IPv6-any check box.
Destination
Address

Specify the destination address of DNS request to filter the DNS
request message. It is permissible to specify multiple destination
address filtering conditions. Select the address entry type and
then type the address. Click Add to add the selected entry to the
pane.
1.
Select an address type from the Address dropdown list.
2.
Select or type the destination addresses based on
the selected type.
3.

Click

to add the addresses to the right pane.

4.
After adding the desired addresses, click the blank
area in this dialog box to complete the destination
address configuration.

www.fs.com
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Option

Description
You can also perform other operations:

When selecting the Address Book type, you can
click Add to create a new address entry.

When selecting the IPv4 type, the default address
configuration is any. To restore the configuration to this
default one, select the any check box.

When selecting the IPv6 type, the default address
configuration is IPv6-any. To restore the configuration to
this default one, select the IPv6-any check box

Domain

Specify the domain name of DNS request to filter the DNS
request message. It is permissible to specify multiple domain
name filtering conditionsSelect the domain entry type and then
type the domain. Click Add to add the selected entry to the pane.
1.
Select an address type from the Domain dropdown list.
2.

Select or type the domain name.

3.

Click

to add the domain to the right pane.

4.
After adding the desired domain, click the blank
area in this dialog box to complete the domain
configuration.
You can also perform other operations:

When selecting the Host Book type, you can click
Add to create a new host book entry.

The default domain configuration is any. To
restore the configuration to this default one, select the
any check box.
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Action

Specify the action for a DNS proxy rule. For the DNS request
that meets the filtering conditions, system can proxy, bypass or
block the traffic.

DNS Proxy
Failed

Specify the action for DNS proxy failed. System can block or
bypass the DNS request and then forward it to the DNS server
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Option

Description
originally requested by the message.

DNS Server

Specify the DNS proxy server. When the action of the proxy rule
is specified as proxy, you need to configure the DNS proxy
servers. You can specify up to six DNS server and you can
configure the interface and preferred properties for the DNS
server as needed. When you configure multiple DNS servers, the
DNS server with preferred property will be selected for domain
name resolution. If no preferred server is specified, the system
will query whether there are DNS servers that have specified the
egress interface; If so, select these DNS server in a round robin.
Except for these two kinds of DNS servers, which means that
there are only regular DNS server, then system will select this
kind of DNS servers in a round robin.
At the bottom of the DNS server list, click the "+" button, and a
table entry will be added. Enter the IP address (IPv4 address or
IPv6 address) of server and other parameters ,such as the virtual
router.

4.

Click OK.

Enabling/Disabling a DNS Proxy Rule
DNS proxy rule is enabled by default. To disable or enable the function, take the following steps:
1.

Select Network > DNS > DNS Proxy.

2.

Select the rule that you want to enable/disable.

3.

Click Enable or Disable to enable or disable the rule.

Adjusting DNS Proxy Rule Position
To adjust the rule position, take the following steps:
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1.

Select Network > DNS > DNS Proxy.

2.

Select the check box of the security policy whose position will be adjusted.

3.

Click Priority.
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4.

In the pop-up menu, type the rule ID or name , and click Before ID , After ID , Before
Name or After Name. Then the rule will be moved before or after the specified ID or name.

DNS Proxy Global Configuration
To set the DNS proxy global configuration, take the following steps:
1.

Select Network > DNS > DNS Proxy.

2.

Click DNS Proxy Global Configuration in the DNS Proxy section.

3.

In the <DNS Proxy Global Configuration> dialog, configure the following settings.
Option
TTL

Server Track

UDP
Checksum

4.

Description
Enable and specifies the TTL for DNS-proxy’s response
packets. If the DNS-proxy requests are not responded after the
TTL, the DNS client will clear all DNS records. The value range
is 30 to 600 seconds. The default value is 60.
Enable the DNS proxy server track and configure the time
interval of tracking for DNS proxy server. System will
periodically detect the DNS proxy server at a specific time
interval. When the server cannot be tracked, the IP address of
server will be removed from the DNS resolution list untill the
link is restored. By default, the tracking for DNS proxy server is
enabled.
Click the checkbox to enable/disable calculating the checksum of
UDP packet for DNS proxy. The system will calculate the
checksum of UDP packet for DNS proxy when the DNS proxy
on interfaces is enabled. If you need to improve the performance
of the device, you can disable this function.

Click OK.

Configuring an Analysis
Analysis configuration includes DNS requests' retry times and timeout.


Retry: If there is no response from the DNS server after the timeout, system will send
the request again; if there is still no response from the DNS server after the specified retry times
(i.e. the number of times to repeat the DNS request), system will send the request to the next
DNS server.
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Timeout: System will wait for the DNS server's response after sending the DNS request
and will send the request again if no response returns after a specified time. The period of
waiting for a response is known as timeout.

To configure the retry times and timeout for DNS requests, take the following steps:
1.

Select Network > DNS > Analysis

2.

Select the retry times radio button.

3.

Select the timeout values radio button.

4.

Click Apply.

Configuring a DNS Cache
When using DNS, system might store the DNS mappings to its cache to speed up the query. There are
three ways to obtain DNS mappings:


Dynamic: Obtains from DNS response.



Static: Adds DNS mappings to cache manually.



Register: DNS hosts specified by some modules of security devices, such as NTP, AAA,
etc.

For convenient management , DNS static cache supports group function, which means users make the
multiple domain hosts with the same IP address and virtual router is a DNS static cache group.
To add a static DNS mapping to cache, take the following steps:
1.

Select Network > DNS > Cache

2.

Click New.

Option
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Description
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Option

Description

Hostname

Specify the hostname of a DNS cache group. You can click
to add or click
button to delete the specified hostname. The maximum number
of domain hosts is 128, and the maximum length of each
hostname is 255 characters.

IP

Specify the host IPv4 address of a DNS cache group. You can
click
to add or click
button to delete the specified IP. The maximum number of host
IP address is 8, and the earlier configured IP will be matched
first.

Virtual Router Select a VRouter.
3.

Click OK.

Notes:



Only DNS static cache group can support new, edit and delete operation , while dynamic
and register cache cannot .



The DNS dynamic cache can be deleted by command or the lifetime reset. For detailed
information , refer to FSOS CLI User Guide and download PDF on website.



User can clear the register cache only by deleting the defined hosts in function module.



DNS static cache is superior to dynamic and register cache, which means the static cache
will cover the same existed dynamic or register cache.

NBT Cache
System supports NetBIOS name resolution. With this function enabled, system can automatically obtain
all the NetBIOS host names registered by the hosts within the managed network, and store them in the
cache to provide IP address to NetBIOS host name query service for other modules.
Enabling a NetBIOS name resolver is the pre-requisition for displaying host names in NAT logs. For
more information on how to display host names in the NAT logs, see "Log Configuration" .
To enable NetBIOS for a zone, select the NBT cache check box when creating or editing the zone. For
more details, see "Security Zone" . The security zone with NetBIOS enabled should not be the zone that
is connected to WAN. After NetBIOS is enabled, the query process might last for a while, and the query

www.fs.com

88

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

result will be added to the NetBIOS cache table. System will perform the query again periodically and
update the result.
Notes: Only when PCs have NetBIOS enabled can their host names be queried. For more
information on how to enable NetBIOS, see the detailed instructions of your PC's Operating System.
To clear NBT cache, take the following steps:
1.

Select Network > DNS > NBT Cache.

2.

Select a VRouter from the VR drop-down list to display the NBT cache in that VRouter.

3.

Select a NBT cache entry from the list and click Delete.

DHCP
DHCP, the abbreviation for Dynamic Host Configuration Protocol, is designed to allocate appropriate
IP addresses and related network parameters for subnetworks automatically, thus reducing requirement
on network administration. Besides, DHCP can avoid address conflict to assure the re-allocation of idle
resources.
DHCP supports to allocate IPv4 and IPv6 addresses.
System supports DHCP client, DHCP server and DHCP relay proxy.


DHCP client: The interface can be configured as a DHCP client and obtain IP addresses
from the DHCP server. For more information on configuring a DHCP client, see "Configuring
an Interface".



DHCP server: The interface can be configured as a DHCP server and allocate IP
addresses chosen from the configured address pool for the connected hosts.



DHCP relay proxy: The interface can be configured as a DHCP relay proxy to obtain
DHCP information from the DHCP server and forward the information to connected hosts.

The security devices are designed with all the above three DHCP functions, but an individual interface
can be only configured with one of the above functions.

Configuring a DHCP Server
To create a DHCP server, take the following steps:
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1.

Select Network > DHCP.

2.

Select New > DHCP Server.
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3.

In the DHCP Configuration dialog, configure as following:
Option

Description

Interface

Configures a interface which enables the DHCP server.

Gateway

Configures a gateway IP for the client.

Netmask

Configures a netmask for the client.

DNS1

Configures a primary DNS server for the client. Type the server's
IP address into the box.

DNS2

Configures an alternative DNS server for the client. Type the
server's IP address into the box.

Address pool

Configures an IP range in the address pool. The IPs within this
range will be allocated. Take the following steps:
1.
Type the start IP and end IP into the Start IP
and End IP box respectively.
2.
Click Add to add an IP range which will be
displayed in the list below.
3.
Repeat the above steps to add more IP ranges.
To delete an IP range, select the IP range you want to
delete from the list and click Delete.

4.
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Configure Reserved Address ( IP addresses in the Reserved Address, within the IP range
of the address pool, are reserved for the DHCP server and will not be allocated).
To configure a reserved address, click the Reserved Address tab, type the start and end IP for
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an IP range into the Start IP and End IP box respectively, and then click Add. To delete an IP
range, select the IP range you want to delete from the list and then click Delete.
5.

6.

Configure IP-MAC Binding. If the IP is bound to a MAC address manually, the IP will
only be allocated to the specified MAC address.
To configure an IP-MAC Binding, click the IP-MAC Binding tab and type the IP and MAC
address into the IP address and MAC box respectively, type the description in the Description
text box if necessary, and then click Add. Repeat the above steps to add multiple entries. To
delete an IP-MAC Binding, select an entry from the list and click Delete.
In the Option tab, configure the options supported by DHCP server
Option
43

Description
Option 43 is used to exchange specific vendor specific
information (VSI) between DHCP client and DHCP server. The
DHCP server uses option 43 to assign Access Controller (AC)
addresses to wireless Access Point (AP), and the wireless AP use
DHCP to discover the AC to which it is to connect.
1.

Select 43 from the Option drop-down list.

2.
Select the type of the VSI, ASCII or HEX. When
selecting ASCII, the VSI matching string must be
enclosed in quotes if it contains spaces.
3.

Enter the VSI in the Sign text box.

4.

Click Add.

5.

Click OK to save the settings.

Notes: If the VCI matching string has been configured, first
of all, you need to verify the VCI carried by the option 60
field in client’s DHCP packets. When the VCI matches the
configured one, the IP address, option 43 and corresponding
information will be offered. If not, DHCP server will drop
client’s DHCP packets and will not reply to the client.
49

After you configure the option 49 settings, the DHCP client can
obtain the list of the IP addresses of systems that are running the
X window System Display Manager.
To configure the option 49 settings:
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Option

Description
1.

Select 49 from the Option drop-down list.

2.
Enter the IP address of the system that is running
the X window System Display Manager into the IP
address box.
3.

Click Add.

4.
Repeat the above steps to add multiple entries.
To delete an entry, select it from the list and click
Delete.
60

After configuring the VCI carried by option 60 for DHCP
server, the DHCP packets sent by the DHCP server will carry
this option and the corresponding VCI.
1.

Select 60 from the Option drop-down list.

2.
Select the type of the VCI, ASCII or HEX. When
selecting ASCII, the VCI matching string must be
enclosed in quotes if it contains spaces.

66

3.

Enter the VCI in the Sign text box.

4.

Click Add.

5.

Click OK to save the settings.

The option 66 is used to configure the TFTP server name
option. By configuring Option 66, the DHCP client get the
domain name or the IP address of the TFTP server. You can
download the startup file specified in the Option 67 from the
TFTP server.
1.

Select 66 from the Option drop-down list.

2.
Select the type of the TFTP server name, ASCII
or HEX. When selecting ASCII, the length of TFTP
server is 1 to 255 characters, but the maximum length
between the two periods (.) is only 63 characters.
3.
Enter the domain name or the IP address of the
TFTP server in the Sign text box.
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Option

67

Description
4.

Click Add.

5.

Click OK to save the settings.

The option 67 is used to configure the startup file name option
for the TFTP server. By configuring option 67, the DHCP client
can get the name of the startup file.
1.

Select 67 from the Option drop-down list.

2.
Select the type of the startup file name, ASCII or
HEX. When selecting ASCII, the length of startup file
name is 1 to 255 characters.

138

3.

Enter the startup file name in the Sign text box.

4.

Click Add.

5.

Click OK to save the settings.

The DHCP server uses option 138 to carry a list of 32-bit
(binary) IPv4 addresses indicating one or more CAPWAP ACs
available to the WTP. Then the WTP discovers and connects to
the AC according to the provided AC list.
1.

Select 138 from the Option drop-down list.

2.
Enter the AC IP address in the IP address text
box.
3.

Click Add.

You can add up to four AC IP addresses.
If you do not set the option 138 for the DHCP server or the
DHCP client does not request option 138, DHCP server will not
offer the option 138 settings.
150

The option 150 is used to configure the address options for the
TFTP server. By configuring option 150, the DHCP client can
get the address of the TFTP server.
1.
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Option

Description
2.
Enter the TFTP server IP address in the IP
address text box.
3.
Click Add. You can configure up to 8 TFTP
servers.

242

The option 242 is a private DHCP private option for IP phones.
By configuring option 242, the specific parameters information
of IP phone can be exchanged between DHCP server and
DHCP client, such as call server address (MCIPADD), call the
server port (MCPORT), the address of the TLS server
(TLSSRVR), HTTP (HTTPSRVR) HTTP server address and
server port (HTTPPORT) etc.
1.

Select 242 from the Option drop-down list.

2.
Select the type of the specific parameters of the
IP phone, ASCII or HEX. When selecting ASCII, the
length of startup file name is 1 to 255 characters.
3.
Enter the specific parameters of the IP phone in
the Sign text box.

7.

Click Add.

5.

Click OK to save the settings.

Click the Advanced tab to configure the DHCP server's advanced options.
Option

Description

Domain

The domain name configured by the DHCP client.

Lease

Specifies a lease time. The value range is 300 to 1048575 seconds.
The default value is 3600. Lease is the period during which a
client is allowed to use an IP address, starting from the time the
IP address is assigned. After the lease expires, the client will have
to request an IP address again from the DHCP server.

Auto Configure
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4.

Enables automatic configuration. Select an interface with DHCP
client enabled on the same gateway from the drop-down list. "---"indicates auto configure is not enabled.
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Option

Description
Auto configure will activate function in the following condition:
Another interface with DHCP configured on the device enables
DHCP client. When auto configure is enabled, if the DHCP
server does not have DNS, WINS or domain name configured,
the DHCP client (DHCP) will dispatch the DNS, WINS and
domain name information obtained from a connected DHCP
server to the host that obtains such information from the DHCP
server. However, the DNS, WINS and domain name that are
configured manually still have the priority.

WINS1

Configures a primary WINS server for the client. Type the
server's IP address into the box.

WINS2

Configures an alternative WINS server for the client. Type the
server's IP address into the box.

SMTP server

POP3 server

News server

Relay agent

Configures a SMTP server for the client. Type the server's IP
address into the box.
Configures a POP3 server for the client. Type the server's IP
address into the box.
Configures a news server for the client. Type the server's IP
address into the box.
When the device1 with DHCP server enabled is connected to
another device2 with DHCP relay enabled, and the PC obtains
device1's DHCP information from device2, then only when the
relay agent's IP address and netmask are configured on device1
can the DHCP information be transmitted to the PC
successfully.
Relay agent: Type relay agent's IP address and netmask, i.e., the
IP address and netmask for the interface with relay agent enabled
on device2.

VCI-matchstring
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The DHCP server can verify the VCI carried by option 60 in the
client’s DHCP packets.When the VCI in the client's DHCP
packet matches the VCI matching string you configured in the
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Option

Description
DHCP server, the DHCP server will offer the IP address and
other corresponding information. If not, the DHCP server will
drop the client's DHCP packets and will not reply to the client. If
you do not configure a VCI matching string for the DHCP
server, it will ignore the VCI carried by option 60.
1.
Select the type of the VCI matching string, ASCII
or HEX. When selecting ASCII, the VCI matching
string must be enclosed in quotes if it contains spaces.
2.

8.

Enter the VCI matching string in the text box.

Click OK.

Configuring a DHCP Relay Proxy
The device can act as a DHCP relay proxy to receive requests from a DHCP client and send requests to
the DHCP server, and then obtain DHCP information from the server and return it to the client.
To create a DHCP relay proxy, take the following steps:
1.

Select Network > DHCP.

2.

Click New > DHCP Relay Proxy.

3.

In the DHCP Relay Proxy dialog, select an interface to which the DHCP Relay Proxy
will be applied from the Interface drop-down list.

4.

Type the IP addresses of DHCP servers into the Server 1/Server 2/Server 3 boxes.

5.

Click OK.

Configuring a DHCPv6 Server
To create a DHCPv6 server to appropriate IPv6 addresses, take the following steps:
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1.

Select Network > DHCP.

2.

Select New > DHCPv6 Server.
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3.

In the DHCPv6 Configuration dialog, configure as following:
Option

Description

Interface

Configures a interface which enables the DHCPv6 server to
appropriate IPv6 addresses.

rapid-commit

Selecting this check box can help fast get IPv6 address from the
server. You need to enable both of the DHCP client and server's
Rapid-commit function.

Preference

Specifies the priority of the DHCPv6 server. The range should
be from 0 to 255. The bigger the value is, the higher the priority
is.

DNS1

Configures a primary DNS server for the client. Type the server's
IP address into the box.

DNS2

Configures an alternative DNS server for the client. Type the
server's IP address into the box.

Domain

Configures the domain name for the DHCP client.

Address Pool: System can act as a DHCPv6 server to allocate IPv6 addresses for
the DHCP clients in the subnets.
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IP

Specifies the IPv6 address prefix and prefix length.

Valid Lifetime

Specifies the lifetime of the address.
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Option
Preferred
Lifetime
4.

Description
Specifies the preferred lifetime for the IPv6 address. The
preferred lifetime should not be larger than the valid lifetime.

Click OK.

Configuring a DHCPv6 Relay Proxy
The device can act as a DHCPv6 relay proxy to receive requests from a DHCPv6 client and send
requests to the DHCPv6 server, and then obtain DHCP information from the server and return it to the
client.
To create a DHCPv6 relay proxy, take the following steps:
1.

Select Network > DHCP.

2.

Click New > DHCPv6 Relay Proxy.

3.

In the DHCP Relay Proxy dialog, select an interface to which the DHCPv6 Relay Proxy
will be applied from the Interface drop-down list.

4.

Type the IPv6 addresses of DHCPv6 servers into the Server 1/Server 2/Server 3 boxes.

5.

If the DHCPv6 server is specified as link-local address, you need to select the egress
interface name from Egress Interface 1/Egress Interface 2/Egress Interface 3 dropdown list.

6.

Click OK.

DDNS
DDNS (Dynamic Domain Name Server) is designed to resolve fixed domain names to dynamic IP
addresses. Generally you will be allocated with a dynamic IP address from ISP each time you connect to
the Internet, i.e., the allocated IP addresses for different Internet connections will vary. DDNS can bind
the domain name to your dynamic IP address, and the binding between them will be updated
automatically each time you connect to the Internet.
In order to enable DDNS, you will have to register in a DDNS provider to obtain a dynamic domain
name. FS devices support the following 5 DDNS providers, and you can visit one of the following
websites to complete the registration:


dyndns.org: http://dyndns.com/dns



3322.org: http://www.pubyun.com

www.fs.com
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no-ip.com: http://www.noip.com



Huagai.net: http://www.ddns.com.cn



ZoneEdit.com: http://www.zoneedit.com

Configuring a DDNS
To create a DDNS, take the following steps:
1.

Select Network > DDNS.

2.

Click New.

3.

In the DDNS Configuration dialog, configure as follows:
Option

Description

DDNS Name Specifies the name of DDNS.
Interface

Specifies the interface to which DDNS is applied.

Hostname

Specifies the domain name obtained from the DDNS provider.

Provider

Specifies a DDNS provider. Choose one from the drop-down
list.

Server Name

Specifies a server name for the configured DDNS.

Server Port

User Name
Password
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Specifies a server port number for the configured DDNS. The
value range is 1 to 65535.
Specifies the user name registered in the DDNS provider.
Specifies the corresponding password.
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Option
Confirm
Password
Minimum
Update
Interval

Maximum
Update
Interval

4.

Description
Enter the password again to confirm.
When the IP address of the interface with DDNS enabled
changes, system will send an update request to the DDNS server.
If the server does not respond to the request, system will send
the request again according to the configured min update interval.
For example, if the minimum update interval is set to 5 minutes,
then system will send the second request 5 minutes after the first
request failure; if it fails again, system will send the third request
10 (5x2) minutes later; if it fails again, and system will send the
forth request 20 (10*2) minutes later, and so forth. The value will
not increase anymore when reaching 120 minutes. That is, system
will send the request at a fixed interval of 120 minutes. The
default value is 5.
In case the IP address has not changed, system will send an
update request to the DDNS server at the maximum update
interval. Type the maximum update interval into the box. The
value range is 24 to 8760 hours. The default value is 24.

Click OK.

Notes: The Server name and Server port in the configuration options must be the corresponding
name and port of the DDNS server. Do not configure these options if the exact information is
unknown. The server will return the name and port information automatically after connection to the
DDNS server has been established successfully.

PPPoE
PPPoE, Point-to-Point Protocol over Ethernet, combines PPP protocol and Ethernet to implement
access control, authentication, and accounting on clients during an IP address allocation.
The implementation of PPPoE protocol consists of two stages: discovery stage and PPP session stage.


Discovery stage: The client discovers the access concentrator by identifying the Ethernet
MAC address of the access concentrator and establishing a PPPoE session ID.
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PPP session stage: The client and the access concentrator negotiate over PPP. The
negotiation procedure is the same with that of a standard PPP negotiation.

Interfaces can be configured as PPPoE clients to accept PPPoE connections.

Configuring PPPoE
To create a PPPoE instance, take the following steps:
1.

Select Network > PPPoE.

2.

Click New.

3.

In the PPPoE Configuration dialog, configure as follows.
Option

Description

PPPoE Name

Specifies a name for the PPPoE instance.

Interface

Select an interface from the drop-down list.

User Name

Specifies a username.

Password

Specifies the corresponding password.

Confirm Password Enter the password again to confirm.
Idle Interval
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Automatic connection. If the PPPoE interface has been idle
(no traffic) for a certain period, i.e., the specified idle
interval, system will disconnect the Internet connection; if
the interface requires Internet access, system will connect to
the Internet automatically. The value range is 0 to 10000
minutes. The default value is 30.
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Option

Description

Reconnect Interval If the PPPoE connection disconnects for any reason for a
certain period, i.e. the specified re-connect interval, system
will try to re-connect automatically. The value range is 0 to
10000 seconds. The default value is 0, which means the
function is disabled.

4.

Access
Concentrator

Specifies a name for the concentrator.

Authentication

The devices will have to pass PPPoE authentication when
trying to connect to a PPPoE server. The supported
authentication methods include CHAP, PAP and Any (the
default, anyone between CHAP and PAP). To configure a
PPPoE authentication method, click the authentication you
want to select. The configured authentication must be the
same with that configured in the PPPoE server.

Netmask

Specifies a netmask for the IP address obtained via PPPoE.

Distance

Specifies a route distance. The value range is 1 to 255. The
default value is 1.

Weight

Specifies a route weight. The value range is 1 to 255. The
default value is 1.

Service

Specifies allowed service. The specified service must be the
same with that provided by the PPPoE server. If no service
is specified, system will accept any service returned from the
server automatically.

Static IP

You can specify a static IP address and negotiate to use this
address to avoid IP change. To specify a static IP address,
type it into the Static IP box.

Click OK.

Virtual Wire
The system supports the VSwitch-based Virtual Wire. With this function enabled and the Virtual Wire
interface pair configured, the two Virtual Wire interfaces form a virtual wire that connects the two
subnetworks attached to the Virtual Wire interface pair together. The two connected subnetworks can
communicate directly on Layer 2, without any requirement on MAC address learning or other sub
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network's forwarding. Furthermore, controls of policy rules or other functions are still available when
Virtual Wire is used.
Virtual Wire operates in two modes, which are Strict and Non-Strict mode respectively, as detailed below:


Strict Virtual Wire mode: Packets can only be transmitted between Virtual Wire
interfaces, and the VSwitch cannot operate in Hybrid mode. Any PC connected to Virtual Wire
can neither manage devices nor access Internet over this interface.



Non-Strict Virtual Wire mode: Packets can be transmitted between Virtual Wire
interfaces, and the VSwitch also supports data forwarding in Hybrid mode. That is, this mode
only restricts Layer 2 packets' transmission between Virtual Wire interfaces, and does not affect
Layer 3 packets' forwarding.

The table below lists packet transmission conditions in Strict Virtual Wire and Non-Strict Virtual Wire
mode. You can choose an appropriate Virtual Wire mode according to the actual requirement.
Packet

Strict

Non-strict

Egress and ingress are interfaces of one Virtual Wire
interface pair

Allow

Allow

Ingress is not Virtual Wire's interface

Deny

Deny

Egress and ingress are interfaces of different Virtual
Wire interface pairs

Deny

Deny

Ingress of to-self packet is a Virtual Wire’s interface

Deny

Allow

Ingress is Virtual Wire's interface, and egress is a Layer 3 Deny
interface

Allow

Configuring a Virtual-Wire
To create a Virtual-Wire, take the following steps:

www.fs.com

1.

Select Network > Virtual-Wire.

2.

Click New.

3.

In the Virtual-Wire Configuration dialog, select a virtual switch from the VSwitch dropdown list.

4.

In the Interface 1 drop-down list, specify an interface for the virtual wire interface pair.
The two interfaces in a single virtual wire interface pair must be different, and one interface
cannot belong to two different virtual wire interface pairs simultaneously.
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5.

6.

In the Interface 2 drop-down list, specify an interface for the virtual wire interface pair.
The two interfaces in a single virtual wire interface pair must be different, and one interface
cannot belong to two different virtual wire interface pairs simultaneously.
Click OK.

Configuring the Virtual Wire Mode
To configure a virtual wire mode, take the following steps:
1.

Select Network > Virtual-Wire.

2.

Click Virtual-Wire Mode.

3.
4.

In the Virtual-Wire Mode Configuration dialog, select a virtual switch from the VSwitch
drop-down list.
Specify a virtual wire mode from one of the following options:


Strict - Packets can only be transmitted between virtual wire interfaces, and the
VSwitch cannot operate in Hybrid mode. Any PC connected to the virtual wire can
neither manage devices nor access Internet over this interface.



Non-strict - Packets can be transmitted between virtual wire interfaces, and the
VSwitch also supports data forwarding in Hybrid mode. That is, this mode only
restricts Layer 2 packets' transmission between virtual wire interfaces, and does not
affect Layer 3 packets' forwarding.


5.

Disabled - Disables the virtual wire.

Click OK.

Virtual Router
Virtual Router (VRouter) is known as VR in system. VR acts as a router, and different VRs have their
own independent routing tables. A VR named "trust-vr" is implemented with the system, and by default,
all of the Layer 3 security zones are bounded to the trust-vr automatically. FS devices support multiple
VRs, and the max amount of supported VRs may vary with different hardware platforms. Multiple VRs
divide a device into multiple virtual routers, and each router utilizes and maintains their independent
routing table. In such a case one device is acting as multiple routers. Multiple VRs allow a device to
achieve the effects of the address isolation between different route zones and address overlapping
between different VRs, as well as to avoid route leaking to some extent, enhancing route security of
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network. For more information about the relationship between interface, security zone, VSwitch and
VRouter, see the following diagram:

As shown above, the binding relationship between them are:


Interfaces are bound to security zones. Those that are bound to Layer 2 security zones
and Layer 3 security zones are known as Layer 2 interfaces and Layer 3 interfaces respectively.
One interface can be only bound to one security zone; the primary interface and sub interface
can belong to different security zones.



Security zones are bound to a VSwitch or VRouter. Layer 2 security zones are bound to
a VSwitch (by default the pre-defined Layer 2 security zone is bound to the default VSwitch1),
and Layer 3 security zones are bound to a VRouter (by default the pre-defined Layer 3 security
zone is bound to the default trust-vr), thus realizing the binding between the interfaces and
VSwitch or VR. One security zone can be only bound to one VSwtich or VR.

Creating a Virtual Router
To create a Virtual Router, take the following steps:
1.

Select Network > Virtual Router > Virtual Router.

2.

Click New.

3.

Type the name into the Virtual Router name box.

4.
5.

Select the Enable check box for Vsys Share to share the Virtual Router between different
virtual systems.
Click OK.

Global Configuration
Virtual Router's global configuration is the configuration for multiple Virtual Routers. To configure
Multi-Virtual Router, take the following steps:
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1.

Select Network > Virtual Router > Global Configuration.

2.

Select the Enable check box for Multi-Virtual Router.
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3.

Click Apply.

Notes:


After Multi-Virtual Router is enabled or disabled, system must reboot to make it take
effect. After rebooting, system's max concurrent sessions will decrease by 15% if the function
is enabled, or restore to normal if the function is disabled. When AV and Multi-Virtual Router
are enabled simultaneously, the max concurrent session will further decrease by 50% (with AV
enabled, the max concurrent session will decrease by half). The formula is: Actual max
concurrent sessions = original max concurrent sessions*(1-0.15)*(1-0.5).



If Multi-Virtual Router is enabled, traffic can traverse up to 3 Virtual Routers, and any
traffic that has to traverse more than 3 Virtual Routers will be dropped.

Virtual Switch
System might allow packets between some interfaces to be forwarded in Layer 2 (known as transparent
mode), and packets between some interfaces to be forwarded in Layer 3 (known as routing mode),
specifically depending on the actual requirement. To facilitate a flexible configuration of hybrid mode of
Layer 2 and Layer3, system introduces the concept of Virtual Switch (VSwitch). By default system uses a
VSwitch known as VSwitch1. Each time you create a VSwitch, system will create a corresponding
VSwitch interface (VSwitchIF) for the VSwitch automatically. You can bind an interface to a VSwitch by
binding that interface to a security zone, and then binding the security zone to the VSwitch.
A VSwitch acts as a Layer 2 forwarding zone, and each VSwitch has its own independent MAC address
table, so the packets of different interfaces in one VSwitch will be forwarded according to Layer 2
forwarding rules. You can configure policy rules conveniently in a VSwitch. A VSwitchIF virtually acts
as a switch uplink interface, allowing packets forwarding between Layer 2 and Layer 3.

Creating a VSwitch
To create a VSwitch, take the following steps:
1.

Select Network > VSwitch.

2.

Click New.
Options are described as follows.
Option

Description

VSwitch Name Specifies a name for the VSwitch.
Vsys Shared
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Select the Enable check box and then system will share the
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Option

Description
VSwitch with different VSYS.

Virtual-Wire
Mode

Specifies a Virtual-Wire mode for the VSwitch, including (for
specific information on Virtual Wire, see "Virtual Wire" )

Strict - Packets can only be transmitted between
Virtual Wire interfaces, and the VSwitch cannot operate
in Hybrid mode. Any PC connected to Virtual Wire can
neither manage devices nor access Internet over this
interface.

Non-strict - Packets can be transmitted between
Virtual Wire interfaces, and the VSwitch also supports
data forwarding in Hybrid mode. That is, this mode only
restricts Layer 2 packets' transmission between Virtual
Wire interfaces, and does not affect Layer 3 packets'
forwarding.


IGMP
Snooping

Disabled - Disables Virtual Wire.

Enables IGMP snooping on the VSwitch.

Forward
Enables VLAN transparent so that the device can transmit
Tagged Packets VLAN tagged packets transparently, i.e., packets tagged with
VLAN ID will still keep the original ID after passing through the
device.
Forward
Enables VLAN transparent so that the device can transmit
Double Tagged
VLAN double tagged packets transparently, i.e., packets tagged
Packets
with VLAN ID will still keep the original ID after passing
through the device.
Drop
Unknown
Multicast
Packets
3.
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Drops the packets sent to unknown multicast to save bandwidth.

Click OK.
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Outbound Link Load Balancing
For Outbound LLB, the system can intelligently oute and dynamically adjust the traffic load of each link
by monitoring the delay, jitter, packet loss rate and bandwidth utilization of each link in real-time.You
can configure a flexible LLB profile to bind to the route (the current system only supports DBR and
PBR), forming LLB rules to implement outbound dynamic link load balancing, and thus make efficient
use of network bandwidth.

Configuring LLB Profile
The LLB profile contains the parameters of the load balancing algorithm, such as bandwidth utilization
threshold, probe switch, probe mode, and equalization direction.
1.

Select Network > Outbound > Profile.

2.

Click New.

3.

In the LLB Profile Configurion, configure as follows:
Option
Profile Name

Specifies the Profile name whose length range is 1-96 characters.

Bandwidth
Utilization

Specifies the bandwidth utilization threshold of the interface.
When the rate does not exceed the threshold by the interface
bandwidth, the system will only analysis delay, jitter and packet
loss rate to dynamically adjust the routing link; when the rate
exceeds the threshold by the interface bandwidth, system will
analysis of each link bandwidth utilization rate of the parameters
at the same time to adjust the routing method. Value ranges
from 0 to 100 (0% to 100%) and defaults to 60.

Balance Mode

www.fs.com

Description

There are two equalization modes: High Performance and High
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Option

Description
Compatibility.

High Performance - In this mode, system adjusts
link to keep the link balance as fast as possible

High Compatibility - When the link load
changes, system does not switch the link frequently, but
ensures that the service is as far as possible on the
previous link. This mode is suitable for services that are
sensitive to link switching, such as banking services, only
when the previous link is overloaded.

Description
4.

Configure Additional details for the LLB profile.

Click OK.

Configuring LLB Rule
The LLB Profile and the route is bound by the formation of LLB rules that currently support binding
destination routing (DBR) and policy-based routing (PBR).
1.

Select Network > Outbound > Rule.

2.

Click New.

3.

In the LLB Rule Configuration, configure the following:
Option
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Description

Rule Name

Specifies the Rule name, length of 1-96 characters

LLB Profile

Specifies the bandwidth utilization threshold. It is in the range of
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Option

Description
0-100 (0% -100%) and defaults to 60.

Bind Route

4.

Specify the route to be bound in the rule: Destination Route or
Policy Based Route.


Destination Route - When this option is selected,
specify the virtual router and destination address of the
destination route.



Policy Based Routing - Select this option to
specify the name and id of the policy route.

Click OK.

Inbound Link Load Balancing
After enabling the LLB for inbound traffic, the system will resolve domains of different IPs based on the
sources of the DNS requests and return IPs for different ISPs to the corresponding users who initiate
the requests, which reduces access across ISPs. Such a resolution method is known as SmartDNS.
You can enable inbound LLB by the following steps:
1.
2.

Enable SmartDNS. This is the prerequisite for the implementation of inbound LLB.
Configure a SmartDNS rule table. The smart domain-to-IP resolution is implemented
based on the rule table.

Creating a Smart DNS Rule Table
To create a SmartDNS rule table, take the following steps:
1.

Select Network > Inbound.

2.

Click New > Domain Table.

3.

In the Domain Configuration dialog, type a domain table name into Domain Table text
box.

4.
5.
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Type a domain name into Domain text box. Separate multiple domain names with
comma. Each rule table supports up to 64 domain names (case insensitive).
Click OK.

110

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

6.

In the Inbound LLB page, click the domain table name you already created and then
click New > SmartDNS Rule.

In the New SmartDNS Rule, configure the following:
Option
ISP Static
Address
Return IP

ISP Link
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Description
Select a predefined or user-defined ISP from the drop-down list.
If the source address matches any address entry of the ISP,
system will return the specified IP.
Specifies the return IP for different request sources. Options
include:


IP - Specifies the return IP. You can configure up
to 64 IPs for a domain name.



Weight - Specifies the weight of the return IP.
The value range is 1 to 100. The default value is 1. In the
SmartDNS rule table, one domain name might
correspond to multiple IPs. System will sort the IPs based
on the weight and then return to the users.

Specifies the inbound interface for the return IP address. System
will judge whether the return IP address is valid according to the
track result or the protocol status of the inbound interface. Only
the valid IP address will be returned to the request source. When
there’s track object configured on the inbound interface, if the
track status is successful, the return IP address is valid. Otherwise
the IP address is invalid. When there’s no track object
configured on inbound interface, if the protocol state of the
interface is UP, the return IP address is valid. Otherwise the IP
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Option

Description
address is invalid. If you don’t specify the inbound interface for
the return IP address, the return IP address is always valid.

7.



Inbound Interface - Select the proximity address
to which the request source address will be matched from
the drop-down list.



Track Object - Select a track object of interface
type from the drop-down list. When the track object fails,
the return IP address is invalid.

Click OK.

Notes: The ISP route being referenced by the SmartDNS rule table cannot be deleted.

Application Layer Gateway (ALG)
Some applications use multi-channels for data transmission, such as the commonly used FTP. In such a
condition the control channel and data channel are separated. Devices under strict security policy control
may set strict limits on each data channel, like only allowing FTP data from the internal network to the
external network to transfer on the well-known port TCP 21. Once in the FTP active mode, if a FTP
server in the public network tries to initiate a connection to a random port of the host in the internal
network, devices will reject the connection and the FTP server will not work properly in such a
condition. This requires devices to be intelligent enough to properly handle the randomness of legitimate
applications under strict security policies. In FTP instances, by analyzing the transmission information of
the FTP control channel, devices will be aware that the server and the client reached an agreement, and
open up a temporary communication channel when the server takes the initiative to connect to a port of
the client, thus assuring the proper operation of FTP.
The system adopts the strictest NAT mode. Some VoIP applications may work improperly after NAT
due to the change of IP address and port number. The ALG mechanism can ensure the normal
communication of VoIP applications after the NAT. Therefore, the ALG supports the following
functions:


Ensures normal communication of multi-channel applications under strict security policy
rules.



Ensures the proper operation of VoIP applications such as SIP and H.323 in NAT mode,
and performs monitoring and filtering according to policies.
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Enabling ALG
The system allows you to enable or disable ALG for different applications. Devices support ALG for
the following applications: FTP, HTTP, MSRPC, PPTP, Q.931, RAS, RSH, RTSP, SIP, SQLNetV2,
SUNRPC, TFTP, DNS, Auto. You can not only enable ALG for applications, but also specify H323's
session timeout.
To enable the ALG for applications, take the following steps:
1.

Select Networl> Application Layer Gateway.

2.

In the Application Layer Gateway dialog, select the applications that require ALG.

3.
4.

To modify H323's session timeout, type the value into the H323 session timeout box.
The value range is 60 to 1800 seconds. The default value is 60.
Click OK to save your changes.

Global Network Parameters
Global network parameter configuration includes IP fragment, TCP packet processing methods and
other options.

Configuring Global Network Parameters
To configure global network parameters, take the following steps:
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1.

Select Network > Global Network Parameters > Global Network Parameters.

2.

Configure the following parameters.
Option

Description

IP Fragment
Maximum
Fragment
Number

Specifies a maximum fragment number for every IP packet.
The value range is 1 to 1024. The default value is 48. Any IP
packet that contains more fragments than this number will be
dropped.

Timeout

Specifies a timeout period of fragment reassembling. The value
range is 1 to 30. The default value is 2. If the FS device has not
received all the fragments after the timeout, the packet will be
dropped.

Long Duration
Session

Enables or disables long duration session. If this function is
enabled, specify long duration session's percentage in the
Percentage text box below. The default value is 10, i.e., 10% of
long duration session in the total sessions.

TCP
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TCP MSS

Specifies a MSS value for all the TCP SYN/ACK packets.
Select the Enable check box, and type the value into the
Maximum MSS text box below.

Maximum MSS

Type the max MSS value into the Maximum MSS text box
below. The value range is 64 to 65535. The default value is
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Option

Description
1448.

TCP MSS VPN

Specifies a MSS value for IPSec VPN's TCP SYN packets.
Select the Enable check box, and type the value into the
Maximum MSS text box below.

Maximum MSS

Type the max MSS value for IPSEC VPN into the Maximum
MSS text box below. The value range is 64 to 65535. The
default value is 1380.

TCP Sequence
Number Check

Configures if the TCP sequence number will be checked. When
this function is enabled, if the TCP sequence number exceeds
TCP window, that TCP packet will be dropped.

TCP Three-way Configures if the timeout of TCP three-way handshaking will
Handshaking
be checked. Select the Enable check box to enable this
function, and specify a timeout value in the Timeout text box
below. The value range is 1 to 1800 seconds. The default value
is 20. If the three-way handshaking has not been completed
after timeout, the connection will be dropped.
TCP SYN Packet
Select the Enable check box to enable this function and specify
Check
the action for TCP non-SYN packet. When the received packet
is a TCP SYN packet, the TCP connection will be established.
When the received packet is a TCP non-SYN packet, the
packet will be processed according to the specified action.


drop: When the received packet is a TCP nonSYN packet, the system will drop the packet.



reset：When the received packet is a TCP nonSYN packet, the system will drop the packet and send
RST packet to the peer device.

Others
Non-IP and
Specifies how to process packets that are neither IP nor ARP.
Non-ARP Packet
3.
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Chapter 6 Advanced Routing
Routing is the process of forwarding packets from one network to the destination address in another
network. Router, a packet forwarding device between two networks, is designed to transmit packets
based on the various routes stored in routing tables. Each route is known as a routing entry.
FS devices are designed with Layer 3 routing. This function allows you to configure routing options and
forward various packets via VRouter. System implements with a default VRouter trust-vr, and also
supports multiple VRouters (multi-VR).
FS devices support destination routing, ISP routing, Source-Based Routing (SBR), Source-InterfaceBased Routing (SIBR), Destination-Interface-Based Routing (DIBR), Policy-Based Routing (PBR),
dynamic routing (including RIP, OSPF and BGP) and Equal Cost MultiPath Routing (ECMP).


Destination Routing: A manually-configured route which determines the next routing
hop according to the destination IP address.



DIBR: A manually-configured route which determines the next routing hop according to
the destination IP address and ingress interface.



SBR: Source IP based route which selects routers and forwards data according to the
source IP address.



SIBR: Source IP and ingress interface based route.



ISP Profile: Add a subnet to an ISP.



ISP Routing: A kind of route which determines the next hop based on different ISPs.



PBR: A route which forwards data based on the source IP, destination IP address and
service type.



Dynamic Routing: Selects routers and forwards data according to the dynamic routing
table generated by dynamic routing protocols ("RIP" , "OSPF" or BGP).

When forwarding the inbound packets, the device will select a route in the following sequence: PBR >
SIBR > SBR > DIBR > Destination routing/ISP routing/Proximity routing/Dynamic routing.
Routing supports IPv4 and IPv6 address. If IPv6 is enabled, you can configure IPv6 address entry for
the routing rule.
Related Topics:


"Destination Route"



"Destination-Interface Route"
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"Source Route"



"Source-Interface Route"



"ISP Profile"



"ISP Route"



"Policy-based Route"



"RIP"

Destination Route
The destination route is a manually-configured route entry that determines the next routing hop based
on the destination IP address. Usually a network with comparatively a small number of outbound
connections or stable Intranet connections will use a destination route. You can add a default route entry
at your own choice as needed.

Creating a Destination Route
To create a destination route, take the follwing steps:
1.

Select Network > Routing > Destination Route.

2.

Click New.
In the Destination Route Configuration dialog box, enter values.

Option

Description

Virtual Router From the Virtual Router drop-down list, select the Virtual
Routerouter for the new route. The default value is "trust-vr".
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Destination

Type the IP address for the route into the text box.

Netmask

Type the corresponding subnet mask into the text box.
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Option
Next-hop

Description
To specify the type of next hop, click Gateway, Current
VRouter, Interface, or Other VRouter.

Gateway: Type the IP address into the Gateway
text box.

Current VRouter: Select a name from the dropdown list.

Interface: Select a name from the Interface dropdown list. Type the IP address into the Gateway text
box. For a tunnel interface, you need to type the gateway
address for the tunnel's peer in the optional box below.

Other VRouter: Select a name from the Vsys
drop-down list. Select a name from the Virtual Router
drop-down list.

Schedule

Specifies a schedule when the rule will take effect. Select a
desired schedule from the Schedule drop-down list. After
selecting the desired schedules, click the blank area in this dialog
to complete the schedule configuration.
To create a new schedule, click New Schedule.

3.
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Precedence

Type the route precedence into the text box. The smaller the
parameter is, the higher the precedence is. If multiple routes are
available, the route with higher precedence will be prioritized.
The value range is 1 to 255. The default value is 1. When the
value is set to 255, the route will be invalid.

Weight

Type the weight for the route into the text box. This parameter
is used to determine the weight of traffic forwarding in load
balance. The value range is 1 to 255. The default value is 1.

Description

Type the description information into the Description text box if
necessary.

Click OK.
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Destination-Interface Route
Destination interface route is designed to select a route and forward data based on the Destination IP
address and ingress interface of a packet.

Creating a Destination-Interface Route
To create a Destination-Interface route, take the following steps:
1.

Select Network > Routing > Destination Interface Route.

2.

Click New.
In the Destination Interface Route Configuration dialog box, enter values.

Option

Description

Virtual Router From the Virtual Router drop-down list, select the Virtual
Routerouter for the new route. The default value is "trust-vr".
Ingress
Interface

Select an interface for the route from the drop-down list.

Destination IP Type the Destination IP for the route into the textbox.
Netmask
Next-hop

Type the corresponding subnet mask into the textbox.
To specify the type of next hop, click Gateway, Virtual Router in
current Vsys, Interface, or Virtual Router in other Vsys.

Gateway: Type the IP address into the Gateway
text box.

Virtual Router in current Vsys: Select a name
from the Virtual Router drop-down list.
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Interface: Select a name from the Interface drop-
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Option

Description
down list. Type the IP address into the Gateway text
box. For a tunnel interface, you need to type the gateway
address for the tunnel's peer in the optional box below.

Virtual Router in other Vsys: Select a name from
the Vsys drop-down list. Select a name from the Virtual
Router drop-down list.

Schedule

Specifies a schedule when the rule will take effect. Select a
desired schedule from the Schedule drop-down list. After
selecting the desired schedules, click the blank area in this dialog
to complete the schedule configuration.
To create a new schedule, click New Schedule.

3.

Precedence

Type the route precedence into the textbox. The smaller the
parameter is, the higher the precedence is. If multiple routes are
available, the route with higher precedence will be prioritized.
The value range is 1 to 255. The default value is 1. When the
value is set to 255, the route will be invalid.

Weight

Type the weight for the DIBR into the textbox. This parameter
is used to determine the weight of traffic forwarding in load
balance. The value range is 1 to 255. The default value is 1.

Description

Type the description information into the Description text box if
necessary.

Click OK.

Source Route
Source route is designed to select a router and forward data based on the source IP address of a packet.

Creating a Source Route
To create a source route, take the following steps:
1.

Select Network > Routing > Source Route.

2.

Click New.
In the Source Route Configuration dialog box, enter values.
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Option

Description

Virtual Router

From the Virtual Router drop-down list, select the Virtual
Routerouter for the new route. The default value is "trust-vr".

Source IP

Type the source IP for the route into the box.

Netmask

Type the corresponding subnet mask into the box.

Next-hop

Schedule

To specify the type of next hop, click Gateway, Virtual Router
in current Vsys, Interface, or Virtual Router in other Vsys.


Gateway: Type the IP address into the Gateway
text box.



Virtual Router in current Vsys: Select a name
from the drop-down list.



Interface: Select a name from the Interface dropdown list. Type the IP address into the Gateway text
box. For a tunnel interface, you need to type the gateway
address for the tunnel's peer in the optional box below.



Virtual Router in other Vsys: Select a name from
the Vsys drop-down list. Select a name from the Virtual
Router drop-down list.

Specifies a schedule when the rule will take effect. Select a
desired schedule from the Schedule drop-down list. After
selecting the desired schedules, click the blank area in this dialog
to complete the schedule configuration.
To create a new schedule, click New Schedule.

Precedence
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Type the route precedence into the box. The smaller the
parameter is, the higher the precedence is. If multiple routes are
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Option

Description
available, the route with higher precedence will be prioritized.
The value range is 1 to 255. The default value is 1. When the
value is set to 255, the route will be invalid.

3.

Weight

Type the weight for the route into the box. This parameter is
used to determine the weight of traffic forwarding in load
balance. The value range is 1 to 255. The default value is 1.

Description

Type the description information into the Description text box
if necessary.

Click OK.

Source-Interface Route
Source interface route is designed to select a router and forward data based on the source IP address and
ingress interface of a packet.

Creating a Source-Interface Route
To create a Source-Interface route, take the following steps:
1.

Select Network > Routing > Source Interface Route.

2.

Click New.
In the Source Interface Route Configuration dialog box, enter values.

Option

Description

Virtual Router From the Virtual Router drop-down list, select the Virtual
Routerouter for the new route. The default value is "trust-vr".
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Option

Description

Ingress
Interface

Select an interface for the route from the drop-down list.

Source IP

Type the source IP for the route into the textbox.

Netmask

Type the corresponding subnet mask into the textbox.

Next-hop

To specify the type of next hop, click Gateway, Virtual Router in
current Vsys, Interface, or Virtual Router in other Vsys.

Gateway: Type the IP address into the Gateway
text box.

Virtual Router in current Vsys: Select a name
from the Virtual Router drop-down list.

Interface: Select a name from the Interface dropdown list. Type the IP address into the Gateway text
box. For a tunnel interface, you need to type the gateway
address for the tunnel's peer in the optional box below.

Virtual Router in other Vsys: Select a name from
the Vsys drop-down list. Select a name from the Virtual
Router drop-down list.

Schedule

Specifies a schedule when the rule will take effect. Select a
desired schedule from the Schedule drop-down list. After
selecting the desired schedules, click the blank area in this dialog
to complete the schedule configuration.
To create a new schedule, click New Schedule.
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Precedence

Type the route precedence into the textbox. The smaller the
parameter is, the higher the precedence is. If multiple routes are
available, the route with higher precedence will be prioritized.
The value range is 1 to 255. The default value is 1. When the
value is set to 255, the route will be invalid.

Weight

Type the weight for the ISP route into the textbox. This
parameter is used to determine the weight of traffic forwarding
in load balance. The value range is 1 to 255. The default value is
1.

Description

Type the description information into the Description text box if
necessary.
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3.

Click OK.

ISP Profile
To configure an ISP route, you need to first add a subnet to an ISP, and then configure the ISP route.
The destination of the route is determined by the name of the ISP. You can customize ISP information,
or upload profiles that contain different ISP information.

Creating an ISP Profile
To create an ISP Profile, take the following steps:
1.

Select Network > Routing > ISP Profile.

2.

Click New.
In the ISP Configuration dialog box, enter values.

Option

Description

ISP Profile

Type the name for the new ISP profile into the textbox.

Subnet Prefix

Type the IP address for the subnet into the textbox.

Netmask

3.

Type the subnet mask into the textbox.

Add

Add the subnet to the ISP profile. The subnet will be displayed in
the ISP subnet list below. If needed, repeat the steps to add
multiple subnets for the ISP profile.

Delete

Delete the selected ISP profiles.

Click OK.

Uploading an ISP Profile
To upload an ISP Profile, take the following steps:
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1.

Select Network > Routing > ISP Profile.

2.

Click Upload.
In the Upload ISP File dialog box, enter values.

Option

Description

Upload
To update the predefined IPS file:
Predefined ISP
1.
Select Upload Predefined IPS File.
File
2.
User-defined
ISP File

3.

Click Browse to select an ISP profile in your PC.

To update the user-defined IPS file:
1.

Select Upload Predefined IPS File.

2.

Click Browse to select an ISP profile in your PC.

Click Upload to upload the selected ISP profile to device.

Saving an ISP Profile
To save an ISP Profile, take the following steps:
1.

Select Network > Routing > ISP Profile.

2.

Click Save.

3.

In the Save User-defined ISP Configuration dialog box, select an ISP profile from the
ISP profile drop-down list.

4.

Click Save to save the profile to a specified location in PC.

ISP Route
Generally many users might apply for multiple lines for load balancing purpose. However, a typical
balance will not have the function based on the traffic's direction. For such a scenario, the device
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provides the ISP route, which allows traffic from different ISPs to take their proprietary routes, thus
accelerating network access.
To configure an ISP route, first you need to add a subnet to an ISP, and then configure the ISP route.
The destination of the route is determined by the name of the ISP. You can customize ISP information,
or upload profiles that contain different ISP information.

Creating an ISP Route
To create an ISP route, take the following steps:
1.

Select Network > Routing > ISP Route.

2.

Click New.
In the ISP Configuration dialog box, enter values.

Option

Description

ISP Profile

Select an ISP profile name from the drop-down list.

Virtual Router From the Virtual Router drop-down list, select the Virtual
Router for the new route. The default value is "trust-vr".
Next-hop

To specify the type of next hop, click Gateway, Current
VRouter, Interface, or Other VRouter.

Gateway: Type the IP address into the Gateway
text box.

Current VRouter: Select a name from the Virtual
Router drop-down list.

Interface: Select a name from the Interface dropdown list. Type the IP address into the Gateway text
box. For a tunnel interface, you need to type the gateway
address for the tunnel's peer in the optional box below.
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Option

Description

Other VRouter: Select a name from the Vsys
drop-down list. Select a name from the Virtual Router
drop-down list.

Schedule

Specifies a schedule when the rule will take effect. Select a
desired schedule from the Schedule drop-down list. After
selecting the desired schedules, click the blank area in this dialog
to complete the schedule configuration.
To create a new schedule, click New Schedule.

3.

Precedence

Type the route precedence into the textbox. The smaller the
parameter is, the higher the precedence is. If multiple routes are
available, the route with higher precedence will be prioritized.
The value range is 1 to 255. The default value is 10. When the
value is set to 255, the route will be invalid.

Weight

Type the weight for the ISP route into the textbox. This
parameter is used to determine the weight of traffic forwarding
in load balance. The value range is 1 to 255. The default value is
1.

Description

Type the description information into the Description text box if
necessary.

Click OK.

Policy-based Route
Policy-based Route (PBR) is designed to select a router and forward data based on the source IP address,
destination IP address and service type of a packet.

Creating a Policy-based Route
To create a Policy-based route, take the following steps:
1.

Select Network > Routing > Policy-based Routing.

2.

Click New. Select PBR from the drop-down list.
In the Policy-based Route Configuration dialog box, configure the following.
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Option

Description

PBR Name

Specifies a name for the policy-based route.

Virtual Router From the Virtual Router drop-down list, select the Virtual Router
for the new route. The default value is "trust-vr".
Type

Specifies the object type that the policy-based route binds to.
You can select Zone, Virtual Router, Interface or No Binding.

Zone: Click this option button and select a zone
from the Zone drop-down list.

Virtual Router: Click this option button and show
the virtual router that the policy-based route bind to.

Interface: Click this option button and select a
interface from the Interface drop-down list.

No Binding: This policy-based route is no
binding.

3.

Click OK.

Creating a Policy-based Route Rule
To create a Policy-based Route rule, take the following steps:
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1.

Select Network > Routing > Policy-based Routing.

2.

Click New. Select Rule from the drop-down list.
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In the Rule Condition tab, configure the following.
Option

Description

PBR Name

Specifies a name for the policy-based route.

Description
Type information about the PBR rule.
（Optional）
Source
Address

Specifies the source addresses of PBR rule.
1.

Select an address type from the Address dropdown list.

2.

Select or type the source addresses based on the
selected type.

3.
4.

Click

to add the addresses to the right pane.

After adding the desired addresses, click the blank
area in this dialog to complete the source address
configuration.

You can also perform other operations:

User



When selecting the Address Book type, you can
click Add to create a new address entry.



The default address configuration is any. To
restore the configuration to this default one, select the
any check box.

Specifies a role, user or user group for the PBR rule.
1.
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From the User drop-down menu, select the AAA
server which the users and user groups belongs to. To
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Option

Description
specify a role, select Role from the AAA Server dropdown list.
2.

Based on different types of AAA server, you can
execute one or more actions: search a user/user
group/role, expand the user/user group list, enter the
name of the user/user group.

3.

After selecting users/user groups/roles, click
to add them to the right panes.

4.

After adding the desired objects, click the blank
area in this dialog to complete the user configuration.

Destination
Address

Specifies the destination addresses of PBR rule.
1.

Select an address type from the Address dropdown list.

2.

Select or type the source addresses based on the
selected type.

3.
4.

Click

to add the addresses to the right panes.

After adding the desired addresses, click the blank
area in this dialog to complete the destination address
configuration.

You can also perform other operations:


When selecting the Address Book type, you can
click Add to create a new address entry.



The default address configuration is any. To
restore the configuration to this default one, select the
any check box.

Other
Host Book

Service
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Specifies the Host-book of PBR rule. Select an Host-book from
the Host Book drop-down list.
Specifies a service or service group.
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Option

Description
1.

From the Service drop-down menu, select a type:
Service, Service Group.

2.

You can search the desired service/service group,
expand the service/service group list.

3.

After selecting the desired services/service
groups, click to add them to the right panes.

4.

After adding the desired objects, click the blank
area in this dialog to complete the service
configuration.

You can also perform other operations:



Application

To add a new service or service group, click Add.
The default service configuration is any. To
restore the configuration to this default one, select the
any check box.

Specifies an application/application group/application filters.
1.

From the Application drop-down menu, you can
search the desired application/application
group/application filter, expand the list of
applications/application groups/application filters.

2.

After selecting the desired
applications/application groups/application filters,
click to add them to the right panes.

3.

After adding the desired objects, click the blank
area in this dialog to complete the application
configuration.

You can also perform other operations:
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To add a new application group, click New
AppGroup.



To add a new application filter, click New
AppFilter.

131

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

Option
Schedule

Description
Specifies a schedule when the PBR rule will take effect. Select a
desired schedule from the Schedule drop-down list. After
selecting the desired schedules, click the blank area in this dialog
to complete the schedule configuration.
To create a new schedule, click New Schedule.

Record log

Select the Enable check box to enable the logging function for
PBR rules.

In the Next-hop tab, configure the following.
Option
Set Next-hop
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Description
To specify the type of next hop, click IP Address, Virtual Router
in current Vsys, Interface, Virtual Router in other Vsys.


IP Address: Type IP address into the IP address
text box and specify the weight into the Weight text box.
When more than one next hops are available, the traffic
will be allocated to the different next hops according to
the weight value.



Virtual Router in current Vsys: Select a name
from the Next-Hop Virtual Router drop-down list and
specify the weight into the Weight text box. When more
than one next hops are available, the traffic will be
allocated to the different next hops according to the
weight value.



Interface: Select an interface from the Interface
drop-down list and specify the weight into the Weight
text box. When more than one next hops are available,
the traffic will be allocated to the different next hops
according to the weight value.



Virtual Router in other Vsys: Check the radio
button to specify a virtual router in the current VSYS as
the next hop. Select a virtual router from the Virtual
Router drop-down list and specify the weight into the
Weight text box. When more than one next hops are
available, the traffic will be allocated to the different next
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Option

Description
hops according to the weight value.

Track Object

Weight

Add
Delete

Select the track object from the drop-down list. See "Track
Object"
Specifies the weight for the next hop. The value range is 1 to
255. The default value is 1. If a PBR rule is configured with
multiple next hops, system will distribute the traffic in
proportion to the corresponding weight.
Click to add the specified next hop.
Select next-hop entries from the next hop table and click this
button to delete.

Adjusting Priority of a PBR Rule
To adjust priority of a Policy-based Route rule, take the following steps:
1.

Select Network > Routing > Policy-based Routing.

2.

From the Virtual Router drop-down list, select the Virtual Router for the new route.

3.

Select the rule you want to adjust priority from the list below, click Priority.

4.

In the Adjust Priority dialog box, enter values.

Option

Description

Top

Click this option button to move the PBR rule to the top.

Bottom

Click this option button to move the PBR rule to the bottom.

Before ID

www.fs.com

Click this option button and type the ID into the box to move
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Option

Description
the PBR rule to the position before the ID.

After ID

Click this option button and type the ID into the box to move
the PBR rule to the position after the ID.

Notes: Each PBR rule is labeled with a unique ID. When traffic flows into a FS device, the
device will query for PBR rules by turn, and process the traffic according to the first
matched rule. However, the PBR rule ID is not related to the matching sequence during
the query. You can move a PBR rule's location up or down at your own choice to adjust
the matching sequence accordingly.

Applying a Policy-based Route
You can apply a policy-based route by binding it to an interface, virtual router or zone.
To apply a policy-based route, take the following steps:
1.

Select Network > Routing > Policy-based Routing.

2.

From the Virtual Router drop-down list, select the Virtual Router for the new route.

3.

Click Bind to.
In the Policy-based Route Configuration dialog box, enter values.

Option

Description

PBR Name

Select a route from the PBR name drop-down list.

Virtual Router From the Virtual Router drop-down list, select the Virtual Router
for the new route. The default value is "trust-vr".
Type

Specifies the object type that the policy-based route binds to.
You can select Zone, Virtual Router, Interface or No Binding.

Zone: Click this option button and select a zone
from the Zone drop-down list.

Virtual Router: Click this option button and show
the virtual router that the policy-based route binds to.

www.fs.com
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Option

Description

Interface: Click this option button and select a
interface from the Interface drop-down list.

No Binding: This policy-based route is no
binding.

4.

Click OK.

DNS Redirect
System supports the DNS redirect funtion, which redirects the DNS requests to a specified DNS server.
For more information about specifying IP addresses of the DNS server, see Configuring a DNS Server.
Currently, the DNS redirect function is mainly used to redirect the video traffic for load balancing. With
the policy based route working together, system can redirect the Web video traffic to different links,
improving the user experience.
To enable the DNS redirect function, take the following steps:
1.

Select Network > Routing > Policy-based Routing.

2.

Click Enable DNS Redirect.

Configuring the Global Match Order
By default, if the PRB rule is bound to both an interface , VRouter and the security zone the interface
belongs to, the traffic matching sequence will be: Interface > Zone > VRouter. You can configure the
global match order of PBR.
To configure the global match order, take the following steps:
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1.

Select Network > Routing > Policy-based Routing.

2.

Click Configure Global Match Order.

3.

Select the items that need to be adjusted, and click

and

.
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4.

To restore the default matching sequence, click Restore Default.

5.

Click OK.

RIP
RIP, Routing Information Protocol, is an internal gateway routing protocol that is designed to exchange
routing information between routers. Currently, devices support both RIP versions, i.e., RIP-1 and RIP2.
RIP configuration includes basic options, redistribute, Passive IF, neighbor, network and distance. You
will also need to configure RIP parameters for different interfaces, including RIP version, split horizon,
and authentication mode.

Creating RIP
To create RIP, take the following steps:
1.

Select Network > Routing > RIP.

2.

From the Virtual Router drop-down list, select the Virtual Router for the new route.

3.

Click New.

In the Basic tab, configure the following.
Option

Description

Version

Specifies a RIP version. FS devices support RIP-1 and RIP-2.
RIP-1 transmits packets by broadcasting, while RIP-2 transmits
packet by multicasting. Select a version from the drop-down list.
The default version is RIP-2.

Metric
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Specifies a default metric. The value range is 1 to 15. If no value
is specified, the value of 1 will be used. RIP measures the
distance to the destination network by hops. This distance is
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Option

Description
known as metric. The metric from a router to a directly
connected network is 1, increment is 1 for every additional router
between them. The max metric is 15, and the network with
metric larger than 15 is not reachable. The default metric will
take effect when the route is redistributed.

Distance

Specifies a default distance. The value range is 1 to 255. If no
value is specified, the value of 120 will be used.

Information
originate

Specifies if the default route will be redistributed to other routers
with RIP enabled. By default RIP will not redistribute the default
route. Select the check box to redistribute the default route.

Update interval Specifies an interval in which all RIP routes will be sent to all the
neighbors. The value range is 0 to 16777215 seconds. The default
value is 30.
Invalid time

If a route has not been updated for the invalid time, its metric
will be set to 16, indicating an unreachable route. The value range
is 1 to 16777215 seconds. The default value is 180.

Holddown time If the metric becomes larger (e.g., from 2 to 4) after a route has
been updated, the route will be assigned with a holddown time.
During the holddown time, the route will not accept any update.
The value range is 1 to 16777215 seconds. The default value is
180.
Flush time

System will keep on sending the unreachable routes (metric set to
16) to other routers during the flush time. If the route still has
not been updated after the end of flush time, it will be deleted
from the RIP information database. The value range is 1 to
16777215 seconds. The default value is 240.

In the Redistribute tab, configure the following.
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Option

Description

Protocol

Select a protocol type for the route from the Protocol dropdown list. The type can be Connected, Static, OSPF or BGP.

Metric

Type the metric for the route into the Metric box. If no value is
specified, system will use the default metric value.

Add

Click Add to add the Redistribute route entry. All the entries that
have been added will be displayed in the Redistribute Route list
below.
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Option

Description

Delete

Repeat the above steps to add more Redistribute route entries.
To delete a Redistribute route entry, select the entry you want to
delete from the list, and click Delete.

In the Passive IF tab, configure the following.
Option

Description

Interface

Select a passive interface from the Interface drop-down list.

Add

Click Add to add the passive interface. All the interfaces that
have been added will be displayed in the list below.

Delete

Repeat the above steps to add more Passive IFs. To delete a
Passive IF, select the entry you want to delete from the list, and
click Delete.

In the Neighbor tab, configure the following.
Option

Description

Neighbor IP

Type the neighbor IP into the Neighbor IP box.

Add

Click Add to add the neighbor IP. All the neighbor IPs that have
been added will be displayed in the list below.

Delete

Repeat the above steps to add more neighbor IPs. To delete a
neighbor IP, select the entry you want to delete from the list, and
click Delete.

In the Network tab, configure the following.
Option

Description

Network(IP/ne Type the IP address and netmask into the Network(IP/netmask)
tmask)
box.
Add

Click Add to add the network. All the networks that have been
added will be displayed in the list below.

Delete

Repeat the above steps to add more networks. To delete a
network, select the entry you want to delete from the list, and
click Delete.

In the Distance tab, configure the following.
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Option

Description

Distance

Type the distance into the Distance box. The priority of the
specified distance is higher than than the default distance.
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Option

Description

Network(IP/ne Type the IP prefix and netmask into the Network(IP/netmask)
tmask)
box.
Add

Click Add to add the distance. All the distances that have been
added will be displayed in the list below.

Delete

Repeat the above steps to add more distances. To delete a
distance, select the entry you want to delete from the list, and
click Delete.

In the DB tab, view the database of the RIP route .
All the route entries that can reach target network are stored in the database.
4.

Click OK.

Notes: Configuration for RIP on device's interfaces includes: RIP version, split horizon and
authentication mode. For more information on how to configure RIP on an interface, see
"Configuring an Interface"

OSPF
OSPF, the abbreviation for Open Shortest Path First, is an internal gateway protocol based on link state
developed by IETF. The current version of OSPF is version 2 (RFC2328). OSPF is applicable to
networks of any size. Its quick convergence feature can send update message immediately after the
network topology has changed, and its algorithm assures it will not generate routing loops. OSFP also
have the following characteristics:


Area division: divides the network of autonomous system into areas to facilitate
management, thereby reducing the protocol's CPU and memory utilization, and improving
performance.



Classless routing: allows the use of variable length subnet mask.



ECMP: improves the utilization of multiple routes.



Multicasting: reduces the impact on non-OSPF devices.



Verification: interface-based packet verification ensures the security of the routing
calculation.

Note: Autonomous system is a router and network group under the control of a management
institution. All routers within an autonomous system must run the same routing protocol.

www.fs.com
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Creating OSPF
To create OSPF, take the following steps:
1.

Select Network > Routing > OSPF.

2.

From the Virtual Router drop-down list, select the Virtual Router for the new route.

3.

Click New.

In the Basic tab, configure the following.
Option
Process ID

Description
Enter the OSPF process ID. The default value is 1. The value
ranges from 1 to 65535. Each OSPF process is individual, and
has its own link state database and the related OSPF routing
table. Each VRouter supports up to 4 OSPF processes and
multiple OSPF processes maintain a routing table together.
When specifying the OSPF process ID, note the following
matters:
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When running multiple OSPF processes in a
VRouter, the network advertised in interfaces in each
OSPF process cannot be same.
When route entries with the same prefix exist in
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Option

Description
multiple OSPF processes, the system will compare the
administrative distance of each route entry and the
route entry with the lower administrative distance will
be added to the VRouter's routing table. If their AD is
the same, the route entry that was first discovered will
be added to the routing table.


Router ID

If the OSPF route entries are redistributed to
other routing protocols, the routing information of
process 1 will be redistributed by default. If this process
does not exist, the routing information of OSPF will
not be redistributed.

Enter the Router ID used by OSPF protocol. Each router
running OSPF protocol should be labeled with a Router ID.
The Router ID is the unique identifier of an individual router in
the whole OSPF domain, represented in the form of an IP
address.

HA
Select Enable check box to enable HA synchronization. The
Synchronization OSPF configuration of the master and backup will be
synchronized.
Network

Configure the network interface that enables OSPF and add the
network to the specified area.
Click
button, and enter the network address, network mask
and area ID.


Network Address: Enter the IP address of
network interface that enables OSPF protocol.




Network Mask: Enter the mask of IP address.
Area ID: Enter the area ID the network will be
added to, in form of a 32-bit digital number, or an IP
address.

In the Redistribute tab, configure the following.
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Option

Description

Static

Select the Enable check box to introduce the static route
protocol into the OSPF route and redistribute.

141

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

4.

Option

Description

Connected

Select the Enable check box to introduce the connected route
protocol into the OSPF route and redistribute.

RIP

Select the Enable check box to introduce the RIP route protocol
into the OSPF route and redistribute.

OSPF

Select the Enable check box to introduce the OSPF route
protocol into the OSPF route and redistribute.

ISIS

Select the Enable check box to introduce the ISIS route protocol
into the OSPF route and redistribute.

BGP

Select the Enable check box to introduce the BGP route
protocol into the OSPF route and redistribute.

VPN

Select the Enable check box to introduce the VPN route into the
OSPF route and redistribute.

Click OK.

Notes: Configuration for OSPF on device's interfaces includes: hello transmission interval, dead time,
LSA transmit interval and LSU transmit delay time. For more information on how to configure
OSPF on an interface, see "Configuring an Interface".

Viewing the Neighbor Information
To view the neighbor information, take the following steps:
1.
2.

Select Network > Routing > OSPF.
Select the process ID check box, and the neighbor information will be displayed in the
list below.
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Neighbor Router ID: Shows the router ID of OSPF neighbors.



Priority: Shows the router priority. The router priority is used to determine which
router will act as the designated router. The designated router will receive the link
information of all the other routers in the network, and broadcast the received link
information.



Neighbor State: Shows the OSPF neighbor state. The OSPF neighbor state
includes 8 types: Down, Attempt, Init, 2-Way, Exstart, Exchange, Loading and Full.
The Full state includes Full/DR and Full/BDR.
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Timeout: Shows the neighbor timeout, which is the difference between dead time
and hello transmission interval. The unit is second. If the OSPF doesn't receive the
Hello packets from neighbor, the neighbor ship cannot be established continually.
Neighbor IP: Shows the IP address of neighbor router.
Local Interface: Shows the interface sends the Hello packets to the neighbor
router.
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Chapter 7 Authentication
Authentication is one of the key features for a security product. When a security product enables
authentication, the users and hosts can be denied or allowed to access certain networks.
From a user's point of view, authentication is divided into the following categories:




If you are a user from an internal network who wants to access the Internet, you can use:


"Web Authentication"



"Single Sign-On"



"PKI"

If you are a user from the Internet who wants to visit an internal network (usually with
VPN), you can use:


"SSL VPN"



"IPSec VPN" (IPSec VPN (with radius server)+Xauth)



"L2TP VPN"(L2TP over IPsec VPN)

Authentication Process
A user uses his/her terminal to connect to the firewall. The firewall calls the user data from the AAA
server to check the user's identity.



User (authentication applicant): The applicant initiates an authentication request, and
enters his/her username and password to prove his/her identity.



Authentication system (i.e. the firewall in this case):The firewall receives the username
and password and sends the request to the AAA server. It is an agent between the applicant and
the AAA server.



"AAA Server": This server stores user information like the username and password, etc.
When the AAA server receives a legitimate request, it will check if the applicant has the right to
the user network services and send back the decision. For more information, refer to "AAA
Server" . AAA server has the following four types:
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Local server
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Radius server



LDAP server



AD server



TACACS+server

Web Authentication
After the Web authentication (WebAuth) is configured, when you open a browser to access the Internet,
the page will redirect to the WebAuth login page. According to different authentication modes, you need
to provide corresponded authentication information. With the successful Web authentication, system
will allocate the role for IP address according to the policy configuration, which provides a role-based
access control method.
Web authentication means you will be prompted to check the identity on the authentication page. It
includes the following four modes:


Password Authentication: Using username and password during the Web authentication.

Enabling the WebAuth
To enable the Web authentication, take the following steps:
1.

Click Network > WebAuth > WebAuth.

2.

Select the Enable check box of WebAuth to enable the WebAuth function.

Configuring Basic Parameters for WebAuth
The basic parameters are applicable to all WebAuth polices.
To configure WebAuth basic parameters, take the following steps:
1.
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Click Network > WebAuth > WebAuth.
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2.

In the Basic Configuration tab, configure the following options
Basic Configuration
HTTP

Select the HTTP authentication methods.
Port: Specifies the HTTP protocol transmission port number of
the authentication server. The range is 1 to 65535, and the default
value is 8181.

HTTPS

Select the HTTPS authentication methods. HTTPS is encrypted,
and can avoid information leakage.
Port: Specify the HTTPS protocol transmission port number of
the authentication server. The range is 1 to 65535, and the default
value is 44433.
Trust Domain: Specifies the HTTPS trust domain. This domain
is previously created in PKI and has imported international CA
certified certificate.

All Interface

Proxy Port

After the WebAuth function is enabled, the WebAuth function of
all interfaces is disabled by default. You can specify the Webauth
global default configuration of all interfaces, including Disable
authentication service by default and Enable authentication
service by default. For more information about configuring the
WebAuth of interface, see "Configuring an Interface"
Specifies the port number for HTTPS, HTTPS and SSO proxy
server. The port number applies to all. If it changes in any page,
the other mode will also use the new port. The range is 1 to
65535.

User Login
Address Type

Specifies IP address or MAC address as the address type of
authentication user. By default, the address type of authentication
user is IP address
Note: When the MAC is specified as the address type of
authentication user, the device needs to be deployed in the same
Layer 2 network environment with the client. Otherwise, system
will fail to get the MAC address of the client or get an incorrect
MAC address.

www.fs.com
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Basic Configuration
Multiple Login

If you disable the multiple login, one account cannot login if it
has already logged in elsewhere. You can click Replace to kick out
the registered user or you can click Refuse New Login to prevent
the same user from logging in again.
If you enable multiple login, more than one clients can login with
the same account. But you can still set up the maximum number
of clients using one account.

Authentication Mode
Password: Specifies the password authentication mode as the authentication
mode.
Idle Timeout

If there is no traffic during a specified time period after the
successful authentication, system will disconnect the connection.
By default, system will not disconnect the connection if there is
no traffic after the successful authentication.
Select the Idle Timeout check box to enable the idle timeout
function, and type the idle timeout value into the text box. Clear
the check box to disable the idle timeout function.

Force Timeout

If the forced re-login function is enabled, users must re-login
after the configured interval ends.
Select the Force Timeout check box to enable the forced timeout
function, and type the forced timeout value into the text box.
Clear the check box to disable the forced timeout function.

Heartbeat
Timeout

When authentication is successful, the system will automatically
refresh the login page before the configured timeout value ends
in order to maintain the login status. If configuring the idle time
at the same time, you will log off from the system at the smaller
value.
Select the Heartbeat Timeout check box to enable the heartbeat
timeout function, and type the heartbeat timeout value into the
text box. Clear the check box to disable the heartbeat timeout
function.

Re-Auth
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System can re-authenticate a user after a successful
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Basic Configuration
Interval

authentication. By default, the re-authentication function is
inactive.
Select the Re-Auth Interval check box to enable the re-auth
function, and type the re-auth interval into the text box. Clear the
check box to disable the re-auth function.

Redirect URL

The redirect URL function redirects the client to the specified
URL after successful authentication. You need to turn off the
pop-up blocker of your web browser to ensure this function can
work properly.
Notes:

3.



You can specify the username and password in
the URL address. When the specified redirect URL is
the application system page with the authentication
needed in the intranet, you do not need the repeat
authentication and can access the application system.
The corresponding keywords are $USER, $PWD, or
$HASHPWD. Generally, you can select one keyword
between $PWD and $HASHPWD. The formart of the
URL is "URL"
+"username=$USER&password=$PWD".



When entering the redirect URL in CLI, add
double quotations to the URL address if the URL
address contains question mark. For example,
"http://192.10.5.201/oa/login.do?username=$USER&
password=$HASHPWD"

Click Apply.

Notes:
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If the WebAuth success page is closed, you can log out not only by timeout, but also by
visiting the WebAuth status page (displaying online users, online times and logout button). You
can visit it through "http(https):// IP-Address: Port-Number". In the URL, IP-Address refers
to the IP address of the WebAuth interface, and Port-Number refers to HTTP/HTTPS port.
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By default, the HTTP port is 8181, the HTTPS port is 44433. The WebAuth status page will be
invalid if there are no online users on the client or the WebAuth is disabled.


After basic configurations, you should create two policy rules in "Security Policy" to
make WebAuth effective, and then adjust the priority of the two policies to the highest. The
WebAuth policies need to be configured according to the following policy template:



After WebAuth is configured, the users who matched the WebAuth policy are
recommended to input the correct username and password, and then the users can access the
network. System takes actions to avoid illegal users from getting usernames and passwords by
brute-force. If one fails to log in through the same host three times in two minutes, that host
will be blocked for 2 minutes.

Customizing WebAuth Page
The WebAuth page is the redirected page when an authenticated user opens the browser. By default, you
need to enter the username and password in the WebAuth page. You can also select the SMS
authentication mode or the WeChat authentication mode.
1.
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Click Network > WebAuth > WebAuth.

2.

Click Login Page Customization tab, and click Download Template to download the zip
file “webauth" of the default WebAuth login page, and then unzip the file.

3.

Open the source file and modify the content( including style, picture, etc.)according to
the requirements. For more detailed information, see the file of readme_cn.md or
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readme_en.md.

4.

Compress the modified file and click Upload to upload the zip file to system.

Notes:

www.fs.com



After upgrading the previous version to the 5.5 version, the WebAuth login page you
already specified will be invalid and restored to the default page. You should re-download the
template after the version upgrade and customize the login page.



After upgrading the system version, you should re-download the template, modify the
source file, and then upload the custom page compression package. If the uploaded package
version is not consistent with the current system version, the function of the custom login page
will not be used normally.



The zip file should comply with the following requirements: the file format should be
zip; the maximum number of the file in the zip file is 50; the upper limit of the zip file is 1M;
the zip file should contain “index.html”.



System can only save one file of the default template page and the customized page.
When you upload the new customized page file, the old file will be covered. You are suggested
to back up the old file.



If you want trigger WebAuth through HTTPS request, you need import the root
certificate (certificate of the device) to the browser firstly. Triggering WebAuth through HTTPS
requests depends on the feature of SSL proxy . If the devrice does not support the SSL proxy.
Triggering WebAuth through HTTPS requests will not work and you can then trigger WebAuth
through HTTP requests.
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Single Sign-On
When the user authenticates successfully for one time, system will obtain the user's authentication
information. Then the user can access the Internet without authentication later.
SSO can be realized through three methods, which are independent from each other, and they all can
achieve the "no-sign-on"(don't need to enter a user name and password) authentication.
Method

Installing Software or Description
Script

SSO Radius

---

After enabling SSO Radius
function, system can receive the
accounting packets that based on
Radius standard protocol. System
will obtain user authentication
information, update online user
information and manage user's
login and logout according to the
packets.

AD Scripting

Logonscript.exe

This method needs to install the
script "Logonscript.exe" on the
AD server. The triggered script
can also send user information to
FSOS. This method is
recommended if you have a higher
accuracy requirement for statistical
monitoring and don't mind to
change the AD server.

Using AD Scripting for SSO
Before using a script for SSO, make sure you have established your Active Directory server first. To use
a script for SSO, take the following steps:

Enabling SSO Radius for SSO
After enabling SSO Radius function, system can receive the accounting packets that based on Radius
standard protocol. System will obtain user authentication information, update online user information
and manage user's login and logout according to the packets.
To configure the SSO Radius function, take the following steps:

www.fs.com
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1.

2.

www.fs.com

Click Object >SSO Server >SSO Radius and enter SSO Radius page. By default, SSO
Radius is disabled.

Click the Enable check box to enable the SSO Radius function.

3.

Specify the Port to receive Radius packets for FSOS (Don't configure port in non-root
VSYS). The range is 1024 to 65535. The default port number is 1813.

4.

Specify the AAA Server that user belongs to. You can select the configured Local, AD or
LDAP server. After selecting the AAA server, system can query the corresponding user group
and role information of the online user on the referenced AAA server, so as to realize the
policy control based on the user group and role.

5.

Specify the IP Address, Shared Secret and Idle Interval of SSO Radius client which is
allowed to access system. You can configure up to 8 clients.


IP Address: Specify the IPv4 address of SSO Radius client. If the IPv4 address is
0.0.0.0, it means that system receives the packets sent from any Radius client.



Shared Key: Specify the shared secret key of SSO Radius client. The range is 1 to
31 characters. System will verify the packet by the shared secret key, and parse the
packet after verifying successfully. If system fails to verify the packet, the packet will
be dropped. The packet can be verified successfully only when SSO Radius client is
configured the same shared secret key with system or both of them aren't configured a
shared secret key.



User Timeout(minute): Configure the idle interval for the authentication
information of Radius packet in the device. If there’s no update or delete packet of
the user during the idle interval, the device will delete the user authentication
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information. The range is 0 to 1440 minutes. The default value is 30. 0 means the user
authentication information will never timeout.
6.

Click Apply button to save all the configurations.

Step 1: Configuring the Script for AD Server
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1.

Visit FS.COM or contact related sales staff to get the script "Logonscript.exe" , and save
it in a directory where all domain users can access.

2.

In the AD server, enter Start menu, and select Mangement Tools > Active Directory
User and Computer.

3.

In the pop-up <Active Directory User and Computer> dialog box, right-click the
domain which will apply SSO to select Properties, and then click <Group Policy> tab.

4.

In the Group Policy list, double-click the group policy which will apply SSO. In the popup <Group Policy Object Editor>dialog box, select User Configuration > Windows
Settings> Script (Logon/Logout).
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5.

Double-click Logon on the right window, and click Add in the pop-up <logon
properties> dialog box.

6.

In the <Add a Script> dialog box, click Browse to select the logon script (logonscript.exe)
for the Script Name; enter the authentication IP address of FSOS and the text "logon" for the
Script Parameters(the two parameters are separated by space). Then, click OK.

7.

Take the steps of 5-6 to configure the script for logging out, and enter the text "logoff"
in the step 6.

Notes: The directory of saving the script should be accessible to all domain users, otherwise, when a
user who does not have privilege will not trigger the script when logs in or out.

www.fs.com

154

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

Step 2: Configuring AD Scripting for FSOS
After the AD Scripting is enabled, the user can log in device simultaneously when logging in the AD
server successfully. System only supports AD Scripting of Active Directory server.
To configure the AD Scripting function, take the following steps:
1.

2.

Click Object> SSO Server > AD Scripting to enter the AD Scripting page. The AD
Scripting function is disabled by default.

Select the Enable check box of AD Scripting to enable the function.

3.

Specify the AAA Server that user belongs to. You can select the configured Local, AD
or LDAP server. After selecting the AAA server, system can query the corresponding user
group and role information of the online user on the referenced AAA server, so as to realize
the policy control based on the user group and role.

4.

Specify the Idle Interval, which specifies the longest time that the authentication user can
keep online without any traffic. After the interval timeout, FSOS will delete the user
authentication information. The value range is 0 to 1440 minutes. 0 means always online.

5.

6.

Allow or disable users with the same name to log in depends on needs.


Enable: Click to permit the user with the same name to log in from multiple
terminals simultaneously.



Refuse New Login: Click to permit only one user with the same name to log in,
and the user logged in will be kicked out by the user logging in.

Click Apply to save the changes.

After completing the above two steps, the script can send the user information to FSOS in real time.
When users log in or out, the script will be triggered and send the user behavior to FSOS.
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802.1x
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
802.1X is a standard defined by IEEE for Port-based Network Access Control. It uses Layer-2 based
authentication (protocol: EAPOL, Extensible Authentication Protocol over LAN) to verify the legality
of the users accessing the network through LAN. Before authentication, the security device only allows
the 802.1X message to pass through the port. After authentication, all of the normal traffic can pass
through.
The AAA servers for 802.1x are Local server and Radius server. Other types of AAA servers like AD or
LDAP server do not support 802.1x.
The authenticating process is the same with other authentication, please refer to "Chapter 7
Authentication"

Configuring 802.1x
A complete configuration for 802.1x authentication includes the following points:


Prerequisite: Before configuration, you should already have the AAA server you want
(only local or Radius server is supported for 802.1x). The AAA server has been added in the
firewall system (refer to AAA server), and the interface or VLAN for authentication has been
bound to a security zone (refer to interface or VLAN).





Configuration key steps:
1.

Creating a 802.1x profile.

2.

Creating a security policy to allow accessing.

In the user's PC, modify the network adapter's properties: If the computer is connected
to the 802.1x interface, this computer should enable its authentication function on its LAN port
(right click LAN and select Properties, in the prompt, under the <Authentication> tab, select
MD5-Challenge or Microsoft: Protected EAP (PEAP), and click OK to confirm.)

Notes: Early versions of Windows have enabled 802.1x by default, but Windows 7 and Window 8 do
not have this feature enabled. To enable 802.1x, please search online for a solution that suits your
system.

Creating 802.1x Profile
To create a 802.1x profile, take the following steps:
1.
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Select Network > 802.1X > 802.1X.
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2.

Click New and a prompt appears.

Under the Basic tab and Advanced tab, enter values
Basic Configuration
802.1x Name

Enter a name for the 802.1x profile

Interface

Select the interface for 802.1x authentication. It should be a
Layer-2 interface interface.

AAA Server

Select the AAA server for 802.1x authentication. It should be a
local server or a Radius server.

Access Mode

Select an access mode. If you select Port and one of the clients
connected to 802.1x interface has passed authentication, all
clients can access the Internet. If you select MAC, every client
must pass authentication before using Internet.

Advanced Configuration
Port authorized

If you select Auto, system will allow users who have successfully
passed authentication to connect to network;
If you select Force-unauthorized, system will disable the
authorization of the port; as a result, no client can connect to the
port, so there is no way to connect to the network.

Re-auth period Enter a time period as the re-authentication time. After a user
has successfully connected to the network, system will
automatically re-auth the user's credentials. The range is from 0
to 65535 seconds. If the value is set to 0, this function is
disabled.
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Quiet period

If the authentication fails, it will take a moment before system
can process the authenticating request from the same client
again. The range is 0 to 65535 seconds, and the default value is
60 seconds. If this value is set to 0, system will not wait, and will
immediately process the request from the same client.

Retries

Specifies a number for retry times. If the authentication system
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Basic Configuration
does not receive any response from the client, system will try to
require user's credentials again. When system has tried for the
specified times, it will stop trying. The range is 1 to 10 times, and
the default is 2 times.

3.

Sever timeout

Specifies a server timeout value. The authenticator transmits the
client's credentials to the authentication server. If the server does
not answer the authenticator within a specified time, the
authenticator will resend request to the authentication server.
The range is 1 to 65535 seconds, the default value is 30 seconds.

Client timeout

When the authenticator sends a request to ask the client to
submit his/her username, the client needs to respond within a
specified period. If the client does not respond before timeout,
system will resend the authentication request message. The range
is 1 to 65535 seconds, and the default value is 30 seconds.

Click OK.

802.1x Global Configuration
Global parameters apply to all 802.1x profiles.
To configure global parameters, take the following steps:
1.

Select Network > 802.1X > Global Configuration.

In the Global Configuration dialog box, specify the parameters that will be applicable for all
802.1x profiles.
Option

Description

Maximum
Users

The maximum user client number for a authentication port.

Multiple logins
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You may choose to allow or disable one account to login from
different clients.
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Option

Re-Auth time

2.

Description


Disable: If you select Disable, one account can
only login from one client simultaneously.
Then, when you want to kick off the old login user, you
should select Replace; if you want to disallow new login
user, select Refuse.



Enable: If you select Enable, different clients can
use one account to login.
If you do not limit the login client number, select
Unlimited; if you want to set up a maximum login
number, select Max attempts and enter a value for
maximum user client number.

Specify a time for authentication timeout value. If the client does
not respond within the timeout period, the client will be required
to re-enter its credentials. The range is 180 to 86400 seconds, the
default value is 300 seconds.

Click OK.

Viewing Online Users
To view which authenticated users are online:
1.
2.

Select Network > 802.1X > Online user.
The page will show all online users. You can set up filters to view results that match your
conditions.

PKI
PKI (Public Key Infrastructure) is a system that provides public key encryption and digital signature
service. PKI is designed to automate secret key and certificate management, and assure the
confidentiality, integrity and non-repudiation of data transmitted over the Internet. The certificate of
PKI is managed by a public key by binding the public key with a respective user identity by a trusted
third-party, thus authenticating the user over the Internet. A PKI system consists of Public Key
Cryptography, CA (Certificate Authority), RA (Certificate Authority), Digital Certificate and related PKI
storage library.
PKI terminology:
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Public Key Cryptography: A technology used to generate a key pair that consists of a
public key and a private key. The public key is widely distributed, while the private key is only
known to the recipient. The two keys in the key pair complement each other, and the data
encrypted by one key can only be decrypted by the other key of the key pair.



CA: A trusted entity that issues digital certificates to individuals, computers or any other
entities. CA accepts requests for certificates and verifies the information provided by the
applicants based on certificate management policy. If the information is legal, CA will sign the
certificates with its private key and issue them to the applicants.



RA: The extension to CA. RA forwards requests for a certificate to CA, and also
forwards the digital certificate and CRL issued by CA to directory servers in order to provide
directory browsing and query services.



CRL: Each certificate is designed with expiration. However, CA might revoke a
certificate before the date of expiration due to key leakage, business termination or other reasons.
Once a certificate is revoked, CA will issue a CRL to announce the certificate is invalid, and list
the series number of the invalid certificate.

PKI is used in the following two situations:



IKE VPN: PKI can be used by IKE VPN tunnel.
HTTPS/SSH: PKI applies to the situation where a user accesses a FS device over
HTTPS or SSH.

Creating a PKI Key
1.

Select System > PKI > Key.

2.

Click New.

In the PKI Key Configuration dialog, configure the following.
Option
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Option

Description

Label

Specifies the name of the PKI key. The name must be unique.

Key
configuration
mode

Specifies the generation mode of keys, which includes
Generate and Import.

Generate
Key Pair Type

Specifies the type of key pair, either RSA, DSA or SM2.

Key Modulus

Specifies the modulus of the key pair. The modulus of RSA
and DSA is 1024 (the default value), 2048, 512 or 768 bits, and
the modulus of SM2 is 256.

Import
Type

Import Key
3.

Specifies the type of key, including Encryption Key and Key
Pair.


Encryption Key - Protects the signing key pair
by digital envelope. If you select this option, you
should specify the signing key pair when importing key.



Key Pair - If you select this option, you should
specify the imported key pair type as RSA, DSA or
SM2.

Browse your local file system and import the key file.

Click OK.

Creating a Trust Domain
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1.

Select System > PKI > Trust Domain.

2.

Click New.
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In the Basic Configuration tab, configure values for basic properties.
Option

Description

Basic
Trust Domain
Enrollment Type

Key Pair

Enter the name of the new trust domain.
Use one of the two following methods:


Select Manual Input, and click Browse to
find the certificate and click Import to import it
into system.



Select Self-signed Certificate, and the
certificate will be generated by the device itself.

Select a key pair.

Subject
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Name

Enter a name of the subject.

Country (Region)

Enter the name of applicant's country or region. Only an
abbreviation of two letters are allowed, like CN.

Location

Optional. The location of the applicant.

State/Province

Optional. State or province name.

Organization

Optional. Organization name.

Organization Unit

Optional. Department name within applicant's
organization.
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3.

Click Apply Certificate, and a string of code will appear.

4.

Copy this code and send it to CA via email.

5.

When you receive the certificate sent from CA. Click Browse to import the certificate.

6.

(Optional) In the CRL tab, configure the following.
Certification Revocation List
Check

URL 1-3
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No Check - System does not check CRL. This is
the default option.



Optional - System accepts certificating from peer,
no matter if CRL is available or not.



Force - System only accepts certificating from
peer when CRL is available.

The URL address for receiving CRL. At most 3 URLs are
allowed, and their priority is from 1 to 3.


Select http:// if you want to get CRL via HTTP.



Select ldap:// if you want to get CRL via LDAP.



If you use LDAP to receive CRL, you need to
enter the login-DN of LDAP server and password. If no
login-DN or password is added, the transmission will be
anonymous.
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Certification Revocation List

7.

Auto Update

Update frequency of CRL list.

Manually
Update

Get the CRL immediately by clicking Obtain CRL.

Click OK.

Importing/Exporting Trust Domain
To simplify configurations, you can export certificates (CA or local) and private key (in the format of
PKSC12) to a computer and import them to another device.
To export a PKI trust domain, take the following steps:
1.

Select System > PKI > Trust Domain Certificate.

2.

Select a domain from drop-down menu.

3.
4.

Select the radio button of the item you want to export, and click Export.
If you choose PKCS, you need to set up password.
Click OK, and select a storage path to save the item.

To import the saved trust domain to another device, take the following steps:
1.

Log in the other device, select System > PKI > Trust Domain Certificate.

2.

Select a domain from drop-down menu.

3.

Select the radio button of the item you want to import, and click Import.
If you choose PKCS, you need to enter the password when it was exported.

4.

Click Browse and find the file to import.

5.

Click OK. The domain file is imported.

Importing Trust Certification
System will not detect the PE file whose certification is trusted. To import trust certification of PE files,
take the following steps:
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1.

Select System > PKI > Trusted Root Certificate.

2.

Click Import and choose a certificate file in your PC.

3.

Click OK and then the file will be imported.
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Online Users
To view the online authenticated users, take the following steps:
1.
2.

www.fs.com

Select Network >WebAuth > Online Users.
The page will show all online users. You can set up filters to views results that match
your conditions.



User Name: Displays the name of online users.



IP/MAC: Displays the IP or MAC address of online users.



Interface: Displays the authentication interface of online users.



Online Time: Displays the online time of online users.



Authentication Type: Displays the authentication type of online users.



Operation: Displays the executable operation of online users.
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Chapter 8 VPN
System supports the following VPN functions:


"IPSec VPN": IPSec is a security framework defined by the Internet Engineering Task
Force (IETF) for securing IP communications. It is a Layer 3 virtual private network (VPN)
technology that transmits data in a secure tunnel established between two endpoints.



"SSL VPN" : SSL provides secure connection services for TCP-based application layer
protocols by using data encryption, identity authentication, and integrity authentication
mechanisms.



"L2TP VPN" : L2TP is one protocol for VPDN tunneling. VPDN technology uses a
tunneling protocol to build secure VPNs for enterprises across public networks. Branch offices
and traveling staff can remotely access the headquarters’ Intranet resources through a virtual
tunnel over public networks.

IPSec VPN
IPSec is a widely used protocol suite for establishing a VPN tunnel. IPSec is not a single protocol, but a
suite of protocols for securing IP communications. It includes Authentication Headers (AH),
Encapsulating Security Payload (ESP), Internet Key Exchange (IKE) and some authentication methods
and encryption algorithms. IPSec protocol defines how to choose the security protocols and algorithms,
as well as the method for exchanging security keys among communicating peers, while offering the
upper layer protocols with network security services, including access control, data source authentication,
data encryption, etc.

Basic Concepts


Security association



Encapsulation modes



Establishing SA



Using IPSec VPN

Security Association (SA)
IPSec provides encrypted communication between two peers which are known as IPSec ISAKMP
gateways. Security Association (SA) is the basis and essence of IPSec. SA defines some factors of
communication peers like the protocols, operational modes, encryption algorithms (DES, 3DES, AES-

www.fs.com

166

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

128, AES-192 and AES-256), shared keys of data protection in particular flows and the life cycle of SA,
etc.
SA is used to process data flow in one direction. Therefore, in a bi-directional communication between
two peers, you need at least two security associations to protect the data flow in both of the directions.

Encapsulation Modes
IPSec supports the following IP packet encapsulation modes:


Tunnel mode - IPSec protects the entire IP packet, including both the IP header and the
payload. It uses the entire IP packet to calculate an AH or ESP header, and then encapsulates the
original IP packet and the AH or ESP header with a new IP header. If you use ESP, an ESP
trailer will also be encapsulated. Tunnel mode is typically used for protecting gateway-to-gateway
communications.



Transport mode - IPSec only protects the IP payload. It only uses the IP payload to
calculate the AH or ESP header, and inserts the calculated header between the original IP header
and payload. If you use ESP, an ESP trailer is also encapsulated. The transport mode is typically
used for protecting host-to-host or host-to-gateway communications.

Establishing SA
There are two ways to establish SA: manual and IKE auto negotiation (ISAKMP).


Manually configuring SA is complicated as all the information will be configured by
yourself and some advanced features of IPSec are not supported (e.g. timed refreshing), but the
advantage is that manually configured SA can independently fulfill IPSec features without relying
on IKE. This method applies to a situation with a small number of devices or an environment of
static IP addresses.



IKE auto negotiation method is comparatively simple. You only need to configure
information of IKE negotiation and leave the rest jobs of creating and maintaining SA to the
IKE auto negotiation function. This method is for medium and large dynamic networks.
Establishing SA by IKE auto negotiation consists of two phases. The Phase 1 negotiates and
creates a communication channel (ISAKMP SA) and authenticates the channel to provide
confidentiality, data integrity and data source authentication services for further IKE
communication; the Phase 2 creates IPSec SA using the established ISAKMP. Establishing SA in
two phases can speed up key exchanging.

Using IPSec VPN
To apply VPN tunnel feature in the device, you can use policy-based VPN or route-based VPN.
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Policy-based VPN - Applies the configured VPN tunnel to a policy so that the data flow
which conforms to the policy settings can pass through the VPN tunnel.



Route-based VPN - Binds the configured VPN tunnel to the tunnel interface and define
the next hop of static route as the tunnel interface.

Configuring an IKE VPN
IKE auto negotiation method is comparatively simple. You only need to configure information of IKE
negotiation and leave the rest jobs of creating and maintaining SA to the IKE auto negotiation function.
This method is for medium and large dynamic network. Establishing SA by IKE auto negotiation
consists of two phases. The Phase 1 negotiates and creates a communication channel (ISAKMP SA) and
authenticates the channel to provide confidentiality, data integrity and data source authentication services
for further IKE communication; the Phase 2 creates IPSec SA using the established ISAKMP.
Establishing SA in two phases can speed up key exchanging.
To configure an IKE VPN, you need to confirm the Phase 1 proposal, the Phase 2 proposal, and the
VPN peer. After confirming these three contents, you can proceed with the configuration of IKE VPN
settings.

Configuring a Phase 1 Proposal
The P1 proposal is used to negotiate the IKE SA. To configure a P1 proposal, take the following steps:
1.

Select Network > VPN > IPSec VPN.

2.

In the P1 Proposal tab, click New.

In the Phase1 Proposal Configuration dialog box, configure the corresponding options.
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Option

Description

Proposal Name

Specifies the name of the Phase1 proposal.

Authentication

Specifies the IKE identity authentication method. IKE
identity authentication is used to verify the identities of both
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Option

Description
communication parties. There are three methods for
authenticating identity: pre-shared key, RSA signature, DSA
signature and GM-DE. The default value is pre-shared key.
For pre-shared key method, the key is used to generate a
secret key and the keys of both parties must be the same so
that it can generate the same secret keys.

Hash

Encryption
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Specifies the authentication algorithm for Phase1. Select the
algorithm you want to use.


MD5 – Uses MD5 as the authentication
algorithm. Its hash value is 128-bit.



SHA – Uses SHA as the authentication
algorithm. Its hash value is 160-bit. This is the
default hash algorithm.



SHA-256 – Uses SHA-256 as the
authentication algorithm. Its hash value is 256-bit.



SHA-384 – Uses SHA-384 as the
authentication algorithm. Its hash value is 384-bit.



SHA-512 – Uses SHA-512 as the
authentication algorithm. Its hash value is 512-bit.



SM3 – Use the state password SM3 as the
authentication algorithm. Its hash value is 256-bit. It
is used for the digital signature and authentication,
the generation and authentication of message
authentication code, and the generation of random
digit, which can meet the security requirement of
multiple password applications.

Specifies the encryption algorithm for Phase1.


3DES - Uses 3DES as the encryption
algorithm. The key length is 192-bit. This is the
default encryption algorithm.



DES – Uses DES as the encryption
algorithm. The key length is 64-bit.
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Option

DH Group

Lifetime

www.fs.com

Description


AES – Uses AES as the encryption
algorithm. The key length is 128-bit.



AES-192 – Uses 192-bit AES as the
encryption algorithm. The key length is 192-bit.



AES-256 – Uses 256-bit AES as the
encryption algorithm. The key length is 256-bit.



SM1 – Uses the state password SM1 as the
encryption algorithm. The key length is 128-bit.
Only the state password device supports SM1.



SM4 – Uses the state password SM4 as the
encryption algorithm. The key length is 128-bit.

Specifies the DH group for Phase1 proposal.


Group1 – Uses Group1 as the DH group.
The key length is 768-bit.



Group2 – Uses Group2 as the DH group.
The key length is 1024-bit. Group2 is the default
value.



Group5 – Uses Group5 as the DH group.
The key length is 1536-bit.



Group14 – Uses Group14 as the DH
group. The key length is 2048-bit.



Group15 – Uses Group5 as the DH group.
The key length is 3072-bit.



Group16 – Uses Group5 as the DH group.
The key length is 4096-bit.

Specifies the lifetime of SA Phase1. The value range is 300
to 86400 seconds. The default value is 86400. Type the
lifetime value into the Lifetime box. When the SA lifetime
runs out, the device will send a SA P1 deleting message to
its peer, notifying that the P1 SA has expired and it requires
a new SA negotiation.
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3.

Click OK to save the settings.

Configuring a Phase 2 Proposal
The P2 proposal is used to negotiate the IPSec SA. To configure a P2 proposal, take the following steps:
1.

Select Network > VPN > IPSec VPN.

2.

In the P2 Proposal tab, click New.

In the Phase2 Proposal Configuration dialog box, configure the corresponding options.
Option

Description

Proposal Name

Specifies the name of the Phase2 proposal.

Protocol

Specifies the protocol type for Phase2. The options are ESP
and AH. The default value is ESP.

Hash
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Specifies the authentication algorithm for Phase2. Select the
algorithm you want to use.


MD5 – Uses MD5 as the authentication
algorithm. Its hash value is 128-bit.



SHA – Uses SHA as the authentication
algorithm. Its hash value is 160-bit. This is the default
hash algorithm.



SHA-256 – Uses SHA-256 as the
authentication algorithm. Its hash value is 256-bit.



SHA-384 – Uses SHA-384 as the
authentication algorithm. Its hash value is 384-bit.



SHA-512 – Uses SHA-512 as the
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Option

Description
authentication algorithm. Its hash value is 512-bit.



Encryption

PFS Group
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Null – No authentication.

Specifies the encryption algorithm for Phase2.


3DES - Uses 3DES as the encryption
algorithm. The key length is 192-bit. This is the default
encryption algorithm.



DES – Uses DES as the encryption
algorithm. The key length is 64-bit.



AES – Uses AES as the encryption
algorithm. The key length is 128-bit.



AES-192 – Uses 192-bit AES as the
encryption algorithm. The key length is 192-bit.



AES-256 – Uses 256-bit AES as the
encryption algorithm. The key length is 256-bit.



SM1 – Uses the state password SM1 as the
encryption algorithm. The key length is 128-bit. Only
the state password device supports SM1.



SM4 – Uses the state password SM4 as the
encryption algorithm. The key length is 128-bit.


Compression

SM3 – Uses the state password SM3 as the
authentication algorithm. Its hash value is 256-bit. It is
used for the digital signature and authentication, the
generation and authentication of message
authentication code, and the generation of random
digit, which can meet the security requirement of
multiple password applications.

Null – No authentication.

Specifies the compression algorithm for Phase2. By default, no
compression algorithm is used.
Specifies the PFS function for Phase2. PFS is used to protect
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Option

Description
DH algorithm.


No PFS - Disables PFS. This is the default
value.

3.



Group1 – Uses Group1 as the DH group.
The key length is 768-bit.



Group2 – Uses Group2 as the DH group.
The key length is 1024-bit.



Group5 – Uses Group5 as the DH group.
The key length is 1536-bit.



Group14 – Uses Group14 as the DH group.
The key length is 2048-bit.



Group15 – Uses Group5 as the DH group.
The key length is 3072-bit.



Group16 – Uses Group5 as the DH group.
The key length is 4096-bit.

Lifetime

You can evaluate the lifetime by two standards which are the
time length and the traffic volume. Type the lifetime length of
P2 proposal into the box. The value range is 180 to 86400
seconds. The default value is 28800.

Lifesize

Select Enable to enable the P2 proposal traffic-based lifetime.
By default, this function is disabled. After selecting Enable,
specifies the traffic volume of lifetime. The value range is 1800
to 4194303 KBs. The default value is 1800. Type the traffic
volume value into the box.

Click OK to save the settings.

Configuring a VPN Peer
To configure a VPN peer, take the following steps:
1.

www.fs.com

Select Network > VPN > IPSec VPN.
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2.

In the VPN Peer List tab, click New.

In the VPN Peer Configuration dialog box, configure the corresponding options.
Basic Configuration
Name

Specifies the name of the ISAKMP gateway.

Interface

Specifies interface bound to the ISAKMP gateway.

Interface Type

Select the interface type, including IPv4 or IPv6. Only
the IPv6 firmware supports to configure IPv6 type
interface.

Protocol Standard

Specifies the protocol standard, including IKEv1 and
GUOMI. The default protocol standard is IKEv1. If
you select GUOMI, specify the version:


v1.0: the version is 1.0.



v1.1: the version is 1.1.


Default: the initiator can negotiate with
the peer when the initiator version is v1.0 or
v1.1.
Note: If you specify the version as 1.0 or 1.1, the
version of the two peers which negotiate with each
other should be the same, or system will fail to
negotiate.
Mode
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Specifies the mode of IKE negotiation. There are two
IKE negotiation modes: Main and Aggressive. The
main mode is the default mode. The aggressive mode
cannot protect identity. You have no choice but use the
aggressive mode in the situation where the IP address
of the center device is static and the IP address of client
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Basic Configuration
device is dynamic.
Type

Local ID

Peer ID

Proposal1/2/3/4

3.
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Specifies the type of the peer IP. If the peer IP is static,
type the IP address into the Peer IP box; if the peer IP
type is user group, select the AAA server you need
from the AAA Server drop-down list.
Specifies the local ID. System supports five types of
ID: FQDN, U-FQDN, Asn1dn (only for license),
KEY-ID and IP. Select the ID type you want, and then
type the content for this ID into the Local ID box or
the Local IP box.
Specifies the peer ID. System supports five types of
ID: FQDN, U-FQDN, Asn1dn (only for license),
KEY-ID and IP. Select the ID type you want, and then
type the content for this ID into the Peer ID box or
the Peer IP box.
Specifies a P1 proposal for ISAKMP gateway. Select
the suitable P1 proposal from the Proposal1 dropdown list. You can define up to four P1 proposals for
an ISAKMP gateway.

Pre-shared Key

If you choose to use pre-shared key to authenticate,
type the key into the box.

Self-signed Trust
Domain

If you choose to use RSA signature or DSA signature,
select a trust domain.

Peer Trust Domain

Configure the trust domain of peer certification. The
peer certification is used for data encryption and
authentication in the negotiation. The initiator should
import the peer certification first. Only GUOMI v1.0
supports this option.

Encryption Trust
Domain

Configure the trust domain of encryption certification.
The encryption certification is used for data encryption
in the negotiation. Only GUOMI v1.1 supports this
option.

If necessary, click the Advanced Configuration tab to configure some advanced options.
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In the Advanced Configuration tab, configure the corresponding options.
Advanced Configuration
Connection
Type

Specifies the connection type for ISAKMP gateway.


Bidirectional - Specifies that the ISAKMP
gateway serves as both the initiator and responder. This
is the default value.



Initiator - Specifies that the ISAKMP gateway
serves as the only initiator.



Responder - Specifies that the ISAKMP gateway
serves as the only responder.

NAT Traversal This option must be enabled when there is a NAT device in the
IPSec or IKE tunnel and the device implements NAT. By
default, this function is disabled.
Any Peer ID

Makes the ISAKMP gateway accept any peer ID and not check
the peer IDs.

Generate Route Select the Enable check box to enable the auto routing function.
By default, this function is disabled. This function allows the
device to automatically add routing entries which are from the
center device to the branch, avoiding the problems caused by
manual configured routing.
DPD
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Select the Enable check box to enable the DPD (Delegated Path
Discovery) function. By default, this function is disabled. When
the responder does not receive the peer's packets for a long
period, it can enable DPD and initiate a DPD request to the
peer so that it can test if the ISAKMP gateway exists.


DPD Interval - The interval of sending DPD
request to the peer. The value range is 1 to 10 seconds.
The default value is 10 seconds.



DPS Retries - The times of sending DPD
request to the peer. The device will keep sending
discovery requests to the peer until it reaches the
specified times of DPD reties. If the device does not
receive response from the peer after the retry times, it
will determine that the peer ISAKMP gateway is down.
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Advanced Configuration
The value range is 1 to 10 times. The default value is 3.
Description
XAUTH Server

4.

Type the description for the ISAKMP gateway.
Select Enable to enable the XAUTH server in the device. Then
select an address pool from the drop-down list. After enabling
the XAUTH server, the device can verify the users that try to
access the IPSec VPN network by integrating the configured
AAA server.

Click OK to save the settings.

Configuring an IKE VPN
Use IKE to negotiate IPSec SA automatically. To configure IKE VPN, take the following steps:
1.

Select Network > VPN > IPSec VPN.

2.

In the IKE VPN List tab, click New.

In the Basic Configuration tab, configure the corresponding options.
Peer
Peer Name

Specifies the name of the ISAKMP gateway. To edit an
ISAKMP gateway, click Edit.

Information

Shows the information of the selected peer.

Tunnel
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Name

Type a name for the tunnel.

Mode

Specifies the mode, including tunnel mode and transport mode.

P2 Proposal

Specifies the P2 proposal for tunnel.
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Peer
Proxy ID

Specifies ID of Phase 2 for the tunnel which can be Auto or
Manual.


Auto - The Phase 2 ID is automatically
designated.



Manual - The Phase 2 ID is manually designated.
Manual configuration of P2 ID includes the following
options:


Local IP/Netmask - Specifies the local
ID of Phase 2.



Remote IP/Netmask - Specifies the
Phase 2 ID of the peer device.


3.

Service - Specifies the service.

If necessary, click the Advanced Configuration tab to configure some advanced options.
In the Advanced Configuration tab, configure the corresponding options.
Advanced
DNS1/2/3/4

Specifies the IP address of the DNS server allocated to the
client by the PnPVPN server. You can define one primary
DNS server and three backup DNS servers.

WINS1/2

Specifies the IP address of WINS server allocated to the
client by the PnPVPN server. You can define one primary
WINS server and a backup WINS server.

Enable Idle Time

Select the Enable check box to enable the idle time function.
By default, this function is disabled. This time length is the
longest time the tunnel can exist without traffic passing
through. When the time is over, SA will be cleared.

DF-Bit
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Select the check box to allow the forwarding device to
execute IP packet fragmentation. The options are:


Copy - Copies the IP packet DF options
from the sender directly. This is the default value.



Clear - Allows the device to execute packet
fragmentation.
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Advanced

Anti-Replay

Set - Disallows the device to execute packet
fragmentation.

Anti-replay is used to prevent hackers from attacking the
device by resending the sniffed packets, i.e., the receiver
rejects the obsolete or repeated packets. By default, this
function is disabled.


Disable - Disables this function.



32 -Specifies the anti-replay window as 32.



64 - Specifies the anti-replay window as 64.



128 - Specifies the anti-replay window as 128.



256 - Specifies the anti-replay window as 256.



512 - Specifies the anti-replay window as 512.

Commit Bit

Select the Enable check box to make the corresponding party
configure the commit bit function, which can avoid packet
loss and time difference. However, commit bit may slow the
responding speed.

Accept-all-proxyID

This function is disabled by default. With this function
enabled, the device which is working as the initiator will use
the peer's ID as its Phase 2 ID in the IKE negotiation, and
return the ID to its peer.

Auto Connect

Select the Enable check box to enable the auto connection
function. By default, this function is disabled. The device has
two methods of establishing SA: auto and intrigued traffic
mode. When it is auto mode, the device will check SA status
every 60 seconds and initiate negotiation request when SA is
not established; when it is in intrigued traffic mode, the
tunnel will send negotiation request only when there is traffic
passing through the tunnel. By default, the intrigued traffic
mode is enabled.
Note: Auto connection works only when the peer IP is static
and the local device is the initiator.
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Advanced
Tunnel Route

This item can be modified only after this IKE VPN is
created. Click Choose to add one or more tunnel routes in
the appearing Tunnel Route Configuration dialog box. You
can add up to 128 tunnel routes.

Description

Type the description for the tunnel.

VPN Track

4.
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Select the Enable check box to enable the VPN track
function. The device can monitor the connectivity status of
the specified VPN tunnel, and also allows backup or load
sharing between two or more VPN tunnels. This function is
applicable to both route-based and policy-based VPNs. The
options are:


Track Interval - Specifies the interval of
sending Ping packets. The unit is second.



Threshold - Specifies the threshold for
determining the track failure. If system did not
receive the specified number of continuous response
packets, it will identify a track as failure, i.e., the
target tunnel is disconnected.



Src Address - Specifies the source IP address
that sends Ping packets.



Dst Address - Specifies the IP address of the
tracked object.



Notify Track Event - Select the Enable check
box to enable the VPN tunnel status notification
function. With this function enabled, for route-based
VPN, system will inform the routing module about
the information of the disconnected VPN tunnel and
update the tunnel route once any VPN tunnel
disconnection is detected; for policy-based VPN,
system will inform the policy module about the
information of the disconnected VPN tunnel and
update the tunnel policy once any VPN tunnel
disconnection is detected.

Click OK to save the settings.
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Configuring a Manual Key VPN
Manually configuring SA is complicated as all the information will be configured by yourself and some
advanced features of IPSec are not supported (e.g. timed refreshing), but the advantage is that manually
configured SA can independently fulfill IPSec features without relying on IKE. This method applies to a
situation with a small number of devices or an environment of static IP addresses.
To create a manual key VPN, take the following steps:
1.

Select Network > VPN > IPSec VPN.

2.

In the Manual Key VPN Configuration section, click New.

In the Manual Key VPN Configuration dialog box, configure the corresponding options.
Basic Configuration
Tunnel Name

Specifies the name of manually created key VPN.

Mode

Specifies the mode, including Tunnel and Transport. The
tunnel mode is the default mode.

Peer IP

Specifies the IP address of the peer.

Local SPI

Remote SPI

Type the local SPI value. SPI is a 32-bit value transmitted in
AH and ESP header, which uniquely identifies a security
association. SPI is used to seek corresponding VPN tunnel for
decryption.
Type the remote SPI value.
Note: When configuring an SA, you should configure the
parameters of both the inbound and outbound direction.
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Basic Configuration
Furthermore, SA parameters of the two ends of the tunnel
should be totally matched. The local inbound SPI should be
the same with the outbound SPI of the other end; the local
outbound SPI should be the same with the inbound SPI of the
other end.
Interface

Specifies the egress interface for the manual key VPN. Select
the interface you want from the Interface drop-down list.

Interface Type

Select the interface type, including IPv4 or IPv6. Only the
IPv6 firmware supports to configure IPv6 type interface.

Encryption
Protocol
Encryption

Specifies the protocol type. The options are ESP and AH. The
default value is ESP.
Specifies the encryption algorithm.
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None – No authentication.



3DES – Uses 3DES as the encryption
algorithm. The key length is 192-bit. This is the default
encryption algorithm.



DES – Uses DES as the encryption
algorithm. The key length is 64-bit.



AES – Uses AES as the encryption
algorithm. The key length is 128-bit.



AES-192 – Uses 192-bit AES as the
encryption algorithm. The key length is 192-bit.



AES-256 – Uses 256-bit AES as the
encryption algorithm. The key length is 256-bit.

Inbound
Encryption Key

Type the encryption key of the inbound direction. You should
configure the keys of both ends of the tunnel. The local
inbound encryption key should be the same with the peer's
outbound encryption key, and the local outbound encryption
key should be the same with the peer's inbound encryption
key.

Outbound

Type the encryption key of the outbound direction.
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Basic Configuration
Encryption Key
Hash

Specifies the authentication algorithm. Select the algorithm
you want to use.


None – No authentication.



MD5 – Uses MD5 as the authentication
algorithm. Its hash value is 128-bit.



SHA-1 – Uses SHA as the authentication
algorithm. Its hash value is 160-bit. This is the default
hash algorithm.



SHA-256 – Uses SHA-256 as the
authentication algorithm. Its hash value is 256-bit.



SHA-384 – Uses SHA-384 as the
authentication algorithm. Its hash value is 384-bit.



SHA-512 – Uses SHA-512 as the
authentication algorithm. Its hash value is 512-bit.

Inbound Hash
Key

Type the hash key of the inbound direction. You should
configure the keys of both ends of the tunnel. The local
inbound hash key should be the same with the peer's
outbound hash key, and the local outbound hash key should
be the same with the peer's inbound hash key.

Outbound Hash
Key

Type the hash key of the outbound direction.

Compression

Select a compression algorithm. By default, no compression
algorithm is used.

Description
Description
3.

Type the description for the manual key VPN.

Click OK to save the settings.

Viewing IPSec VPN Monitoring Information
By using the ISAKMP SA table, IPSec SA table, and Dial-up User table, IPSec VPN monitoring
function can show the SA negotiation results of IPSec VPN Phase1 and Phase2 as well as information of
dial-up users.
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To view the VPN monitoring information, take the following steps:
1.

Select Network > VPN > IPSec VPN.

2.

In the IKE VPN Configuration section, click IPSec VPN Monitor.

Options in these tabs are described as follows:
ISAKMP SA
Option

Description

Cookie

Displays the negotiation cookies which are used to match SA
Phase 1.

Status

Displays the status of SA Phase1.

Peer

Displays the IP address of the peer.

Port

The port number used by the SA Phase1. 500 indicates that no
NAT has been found during the SA Phase 1; 4500 indicates that
NAT has been detected.

Algorithm

Displays the algorithm of the SA Phase1, including
authentication method, encryption algorithm and verification
algorithm.

Lifetime

Displays the lifetime of SA Phase1. The unit is second.

IPSec SA
Option

Description

ID

Displays the tunnel ID number which is auto assigned by the
system.

VPN Name

Displays the name of VPN.

Direction

Displays the direction of VPN.

Peer

Displays the IP address of the peer.

Port

The port number used by the SA Phase2.

Algorithm

The algorithm used by the tunnel, including protocol type,
encryption algorithm, verification algorithm and depression
algorithm.

SPI

Displays the local SPI and the peer SPI. The direction of
inbound is local SPI, while outbound is peer SPI.

CPI

Displays the compression parameter index (CPI) used by SA
Phase2.
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Option

Description

Lifetime (s)

Displays the lifetime of SA Phase2 in seconds, i.e. SA Phase2 will
restart negotiations after X seconds.

Lifetime (KB) Displays the lifetime of SA Phase2 in KB, i.e. SA Phase2 will
restart negotiations after X kilobytes of data flow.
Status

Displays the status of SA Phase2.

Dial-up User
Option

Description

Peer

Displays the statistical information of the peer user. Select
the peer you want from the Peer drop-down list.

User ID

Displays the IKE ID of the user selected.

IP

Displays the corresponding IP address.

Encrypted Packets Displays the number of encrypted packets transferred
through the tunnel.
Encrypted Bytes

Displays the number of encrypted bytes transferred through
the tunnel.

Decrypted Packets Displays the number of decrypted packets transferred
through the tunnel.
Decrypted Bytes

Displays the number of decrypted bytes transferred through
the tunnel.

Configuring PnPVPN
IPSec VPN requires sophisticated operational skills and high maintenance cost. To relieve network
administrators from the intricate work, system provides an easy-to-use VPN technology - PnPVPN
(Plug-and-Play VPN). PnPVPN consists of two parts: PnPVPN Server and PnPVPN Client.


PnPVPN Server: Normally deployed in the headquarters and maintained by an IT
engineer, the PnPVPN Server sends most of the configuration commands to the clients. The
device usually works as a PnPVPN Server and one device can serve as multiple servers.



PnPVPN Client: Normally deployed in the branch offices and controlled remotely by a
headquarters engineer, the PnPVPN Client can obtain configuration commands (e.g. DNS,
WINS, DHCP address pool, etc.) from the PnPVPN Server with simple configurations, such as
client ID, password, and server IP settings.
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The device can serve as both a PnPVPN Server and a PnPVPN Client. When working as a PnPVPN
Server, the maximum number of VPN instance and the supported client number of each device may
vary according to the platform series.

PnPVPN Workflow
The workflow for PnPVPN is as follows:
1.

The client initiates a connection request and sends his/her own ID and password to the
server.

2.

The server verifies the ID and password when it receives the request. If the verification
succeeds, the server will send the configuration information, including DHCP address pool,
DHCP mask, DHCP gateway, WINS, DNS and tunnel routes, etc,. to the client.

3.

The client distributes the received information to corresponding functional modules.

4.

The client PC automatically gains an IP address, IP mask, gateway address and other
network parameters and connects itself to the VPN.

PnPVPN Link Redundancy
The PnPVPN server supports dual VPN link dials for a PnPVPN client, and automatically generates the
routing to the client. Also, it can configure the VPN monitor for the client. Two ISAKMP gateways and
two tunnel interfaces need to be configured in the server. The two VPN tunnels need to refer different
ISAKMP gateways and be bound to different tunnel interfaces.
The client supports to configure dual VPN dials and redundant routing. When the two VPN tunnels are
negotiating with the server, the client generates routes with different priority according to the tunnel
routing configuration at the server side. The high priority tunnel acts as the master link and the tunnel
with low priority as the backup link, so as to realize redundant routing. The master VPN tunnel will be
in the active state first. When master tunnel is interrupted, the client will use the backup tunnel to
transfer the data. When the master tunnel restores to be normal, it will transfer the data again.

Configuring a PnPVPN Client
To configure a PnPVPN client, take the following steps:
1.
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Select Network > VPN > IPSec VPN.
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2.

In the IKE VPN Configuration section, click PnPVPN Client.

In the PnPVPN Configuration dialog box, configure the following options.

3.

Option

Description

Server
Address1

Type the IP address of PnPVPN Server into the box. PnPVPN
client supports dual link dials to the server side. This option is
required.

Server
Address2

Type the IP address of PnPVPN Server into the box. The server
address 1 and the server address 2 can be the same or different. It
is optional.

ID

Specifies the IKE ID assigned to the client by the server.

Password

Specifies the password assigned to the client by the server.

Confirm
Password

Enter the password again to confirm.

Auto Save

Select Enable to auto save the DHCP and WINS information
released by the PnPVPN Server.

Egress
Interface 1

Specifies the interface connecting to the Internet. This option is
required.

Egress
Interface 2

Specifies the interface connecting to the Internet. The IF1 and
the IF2 can be the same or different. It is optional.

Incoming IF

Specifies the interface on the PnPVPN Client accessed by the
Intranet PC or the application servers.

Click OK to save the settings.

Notes:
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Server Addresses1 and Egress IF1 both need to be configured. If you want to configure
a backup link, you need to configure both the Server Address2 and Egress IF2.
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If the server addresses or the Egress IFs are different, two separate VPN links will be
generated.



The configuration of the two servers can be configured on one device, and can also be
configured on two different devices. If you configure it on two devices, you need to configure
AAA user on the two devices. The DHCP configuration for the AAA user should be the same,
otherwise it might cause that the client and server negotiate successfully, but the traffic is
blocked.

Configuring IPSec-XAUTH Address Pool
XAUTH server assigns the IP addresses in the address pool to users. After the client has established a
connection to the XAUTH server successfully, the XAUTH server will choose an IP address along with
other related parameters (such as DNS server address, WINS server address, etc) from the address pool,
and will assign them to the client.
XAUTH server provides fixed IP addresses by creating and implementing IP binding rules that consist
of a static IP binding rule and an IP-role binding rule. The static IP binding rule binds the client user to a
fixed IP address in the address pool. Once the client has established a connection successfully, system
will assign the binding IP to the client. The IP-role binding rule binds the role to a specific IP range in
the address pool. Once the client has established a connection successfully, system will assign an IP
address within the IP range to the client.
When the XAUTH server is allocating IP addresses in the address pool, system will check the IP binding
rule and determine how to assign IP addresses to the client based on the specific checking order below:
1.

Check if the client is configured with any static IP binding rule. If so, assign the binding
IP address to the client; otherwise, check the other configuration. Note if the binding IP
address is in use, the user will be unable to log in.

2.

Check if the client is configured with any IP-role binding rule. If so, assign an IP address
within the binding IP range to the client; otherwise, the user will be unable to log in.

Notes: The IP addresses defined in the static IP binding rule and IP-role binding rule should not be
overlapped.
To configure the IPSec-XAUTH address pool, take the following steps:
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1.

Select Network > VPN > IPSec VPN.

2.

At the top-right corner, Select IPSec-XAUTH Address Pool..

3.

In the XAUTH Address Pool Configuration dialog box, click New.
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In the Basic Configuration tab, configure the corresponding options.
Option

Description

Address Pool
Name

Specifies the name of the address pool.

Start IP

Specifies the start IP of the address pool.

End IP

Specifies the end IP of the address pool.

Reserved Start
IP

Specifies the reserved start IP of the address pool.

Reserved End Specifies the reserved end IP of the address pool.
IP
Netmask

Specifies the netmask of the IP address.

DNS1/2

Specifies the DNS server IP address for the address pool. It is
optional. At most two DNS servers can be configured for one
address pool.

WINS1/2

Specifies the WIN server IP addresses for the address pool. It is
optional. Up to two WIN servers can be configured for one
address pool.

In the IP User Binding tab, configure the corresponding options.
www.fs.com
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Option

Description

User

Type the user name into the User box.

IP

Type the IP address into the IP box.

Add

Click Add to add the item that binds the specified user to the IP
address.

In the IP Role Binding tab, configure the corresponding options.
Option

Description

Role

Select a role from the Roledrop-down list.

Start IP

Type the start IP address into the Start IP
box.

End IP

Type the end IP address into the End IP
box.

Add

Click Add to add the item that binds the
specified role to the IP address range.

Up/Down/Top/Bottom

Move the selected IP-role binding rule . For
the user that is bound to multiple roles that
are also configured with their corresponding
IP-role binding rules, system will query the
IP-role binding rules in order, and assign an
IP address based on the first matched rule.

4.

Click OK to save the settings.

SSL VPN
The device provides an SSL based remote access solution. Remote users can access the intranet
resource safely through the provided SSL VPN.
SSL VPN consists of two parts: SSL VPN server and SSL VPN client. The device configured as the SSL
VPN server provides the following functions:


Accept client connections.



Allocate IP addresses, DNS server addresses, and WIN server addresses to SSL VPN
clients.



Authenticate and authorize clients.



Perform host checking to client.
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Encrypt and forward IPSec data.

By default, the concurrent online client number may vary on different platform series. You can expand
the supported number by purchasing the corresponding license.
After successfully connecting to the SSL VPN server, the SSL VPN client secures your communication
with the server. The following SSL VPN clients are available:


"SSL VPN Client for Windows"



"SSL VPN Client for Android"

Configuring an SSL VPN
To configure an SSL VPN, take the following steps:
1.

Select Network > VPN > SSL VPN.

2.

In the SSL VPN page, click New.

In the Name/Access User tab, configure the corresponding options.
Option

Description

SSL VPN
Name

Type the name of the SSL VPN instance

Assigned Users
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AAA Server

Select an AAA server from the AAA Server drop-down list. You
can click View AAA Server to view the detailed information of
this AAA server.

Domain

Type the domain name into the Domain box. The domain name
is used to distinguish the AAA server.

Verify User

After enabling this function, system will verify the username and
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Option

Description

Domain Name its domain name.
Add

Click Add to add the assigned users. You can repeat to add more
items.

In the Interface tab, configure the corresponding options.
Access Interface
Egress
Interface1

Select the interface from the drop-down list as the SSL VPN
server interface. This interface is used to listen to the request
from the SSL VPN client.

Egress
Interface2

Select the interface from the drop-down list. This interface is
needed when the optimal path detection function is enabled.

Service Port

Specifies the SSL VPN service port number.

Tunnel

Interface

Tunnel
Interface

Information

Specifies the tunnel interface used to bind to the SSL VPN
tunnel. Tunnel interface transmits traffic to/from SSL VPN
tunnel.


Select a tunnel interface from the drop-down list,
and then click Edit to edit the selected tunnel interface.



Click New in the drop-down list to create a new
interface.

Shows the zone, IP address, and netmask of the selected tunnel
interface.

Address Pool
Address Pool

Information

Specifies the SSL VPN address pool.


Select an address pool from the drop-down list,
and then click Edit to edit the selected address pool.



Click New in the drop-down list to create a new
address pool.

Shows the start IP address, end IP address, and mask of the
address pool.

In the Tunnel Route tab, configure the following options.
Tunnel Route
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Specify the destination network segment that you want to access through SCVPN
tunnel. The specified destination network segment will be distributed to the VPN
client, then the client uses it to generate the route to the specified destination.
IP

Type the destination IP address.

Mask

Type the netmask of the destination IP address.

Metric

Type the metric value.

Add

Click Add to add this route. You can repeat to add more items.

Delete

Click Delete to delete the selected route.

Enable Domain Route
Specify the destination domain name that you want to access through SCVPN
tunnel.
After selecting the Enable Domain Route check box, system will distribute the
specified domain names to the VPN client, and the client will generate the route
to the specified destination according to the resolving results from the DNS.
Domain

Specify the URL of the domain name. The URL cannot exceed
63 characters and it cannot end with a dot (.). Both wildcards and
a single top level domain, e.g. com and .com are not supported.

Add

Click Add to add the domain name to the list and you can add up
to 64 domain names.

Delete

Click Delete to delete the selected domain name.

Maximum

The maximum numbers of routes that can be generated after
obtaining the resolved IP addresses of the domain name. The
value ranges from 1 to 10000.

In the Binding Resource tab, configure the binding relationship between user groups and
resources.
Binding Resource
Resource List
User Group

Types or selects an existing resource name.
Specifies a user group name.
1.
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From the User Group drop-down menu, select
the AAA servers where user groups reside. Currently,
only the local authentication server and the RADIUS
server are available.
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2.

Based on different types of AAA server, you can
execute one or more actions: search a user group,
expand the user group list, and enter the name of the
user group.

3.

After selecting user groups, click
to the right pane.

4.

After adding the desired objects, click the blank
area in this dialog to complete the configuration.

to add them

Note:

3.



A user group can be bound with multiple
resources, and a resource can also be bound with
multiple user groups.



Only 32 binding entries can be configured in an
SSL VPN instance.

Add

Click Add to add binding entries for resources and user groups
to the list below. You can repeat to add more items.

Delete

Click Delete to delete the selected item.

If necessary, click Advanced Configuration to configure the advanced functions,
including parameters, client, host security, SMS authentication, and optimized path.
In the Parameters tab, configure the corresponding options.
Security Kit
SSL Version

Specifies the SSL protocol version. Any indicates one of SSLv2,
SSLv3, TLSv1, TLSv1.1, TLSv1.2 or GMSSLv1.0 protocol will
be used.
If tlsv1.2 or any is specified to the SSL protocol in SSL VPN
server, you need to convert the certificate that you are going to
import to the browser or certificate in the USB Key to make it
support the tlsv1.2 protocol before the digital certificate
authentication via SSL VPN client, so that the SSL VPN server
can be connected successfully when the Username/Password +
Digital Certificate or Digital Certificate Only authentication
method is selected. Prepare a PC with Windows or Linux system
which has been installed with OpenSSL 1.0.1 or later before
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processing the certificate. We will take the certificate file named
oldcert.pfx as an example, the procedure is as follows:
1.

In the OpenSSL software interface, enter the
following command to convert a certificate in .pfx
format to a certificate in .pem format.
openssl pkcs12 –in oldcert.pfx –out cert.pem

2.

Enter the following command to convert the
certificate in .pem format to a .pfx format certificate
that supports tlsv1.2 protocol.
openssl pkcs12 –export –in cert.pem –out
newcert.pfx –CSP “Microsoft Enhanced RSA and
AES Cryptographic Provider”

3.

Import the newly generated .pfx format
certificate into your browser or USB Key.

After the above operation, you have to log into SSL VPN server
with SSL VPN client whose version is 1.4.6.1239 or later.
Trust Domain Specifies the trust domain. When the GMSSLv1.0 protocol is
used, the specified PKI trust domain needs to include the SM2
signature certificate and its private key for the GMSSL
negotiation.
Encryption
When using the GMSSLv1.0 protocol, you must config this
Trust Domain option. The specified encryption PKI trust domain needs to
include the SM2 encryption certificate and its private key for the
GMSSL negotiation.
Encryption

Specifies the encryption algorithm of the SSL VPN tunnel. The
default value is 3DES. NULL indicates no encryption. When
using the GMSSLv1.0 protocol, you're recommended to select
SM4 for the encryption algorithm.

Hash

Specifies the hash algorithm of the SSL VPN tunnel. The default
value is SHA-1. NULL indicates no hash. When using the
GMSSLv1.0 protocol, you're recommended to select SM3 for the
hash algorithm.

Compression

Specifies the compression algorithm of the SSL VPN tunnel. By
default, no compression algorithm is used.

Client Connection

www.fs.com
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Idle Time

Specifies the time that a client stays online without any traffic
with the server. After waiting for the idle time, the server will
disconnect from the client. The value range is 15 to 1500
minutes. The default value is 30.

Multiple Login This function permits one client to sign in more than one place
simultaneously. Select the Enable check box to enable the
function.
Multiple Login Type the login time into the Multiple Login Times box. The
Times
value range is 0 to 99,999,999. The value of 0 indicates no login
time limitation.
Advanced Parameters
Anti-Replay
DF-Bit

The anti-replay function is used to prevent replay attacks. The
default value is 32.
Specifies whether to permit packet fragmentation on the device
forwarding the packets. The actions include:



Set - Permits packet fragmentation.
Copy - Copies the DF value from the destination
of the packet. It is the default value.


Port (UDP)

Clear - Forbids packet fragmentation.

Specifies the UDP port number for the SSL VPN connection.

In the Client tab, configure the corresponding options.
Client Configuration
Redirect URL

This function redirects the client to the specified redirected URL
after a successful authentication. Type the redirected URL into
the box. The value range is 1 to 255 characters. HTTP (http://)
and HTTPS (https://) URLs are supported. Based on the type of
the URL, the corresponding fixed format of URL is required.
Take the HTTP type as the example:
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For the UTF-8 encoding page - The format is
URL+username=$USER&password=$PWD, e.g.,
http://www.abc.com/oa/login.do?username=$USER&p
assword=$PWD
For the GB2312 page - The format is
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URL+username=$GBUSER&password=$PWD, e.g.,
http://www.abc.com/oa/login.do?username=$GBUSE
R&password=$PWD

Title

Other pages: - Type the URL directly, e.g.,
http://www.abc.com

Specifies the description for the redirect URL. The value range is
1 to 31 bytes. This title will appear as a client menu item.

Delete privacy Select Enable to delete the corresponding privacy data after the
data after
client's disconnection.
disconnection
Digital Certificate Authentication
Authentication

Select the Enable check box to enable this function. There are
two options available:


Username/Password + Digital Certificate - To
pass the authentication, you need to have the correct file
certificate, or the USB Key that stores the correct digital
certificate, and also type the correct username and
password. The USB Key certificate users also need to
type the USB Key password.



Digital Certificate only - To pass the
authentication, you need to have the correct file
certificate, or the USB Key that stores the correct digital
certificate. The USB Key certificater users also need to
type the USB Key password. No username or user's
password is required.

When Digital Certificate only is selected:
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System can map corresponding roles for the
authenticated users based on the CN or OU field of the
USB Key certificate. For more information about the role
mapping based on CN or OU, see "Role" .



System does not allow the local user to change
the password.



System does not support SMS authentication.



The client will not re-connect automatically if the
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USB Key is removed.
USB KEY
Download
URL

When USB Key authentication is enabled, you can download the
UKey driver from this URL.

Trust Domain To configure the trust domain and the subject & username
Subject&Usern checking function:
ame Checking

1.

From the Trust domain drop-down list, select the
PKI trust domain that contains the CA (Certification
Authority) certificate. If the client's certificate is the
only one that matches to any CA certificate of the trust
domain, then the authentication will succeed.

2.

If necessary, select the Subject&Username
Checking check box to enable the subject & username
check function. After enabling it, when the user is
authenticated by the USB Key certificate, system will
check whether the subject CommonName in the client
certificate is the same as the name of the login user.
You can also enter the strings in the CN Match box
and the OU box to determine whether matches them.

3.

Click Add. The configured settings will be
displayed in the list below. To delete an item, select the
item you want to delete from the list, and then click
Delete.

CN Matching
OU Matching

In the Host Compliance Check/Binding tab, configure the corresponding options.
Host Compliance Check
Creates a host compliance check rule to perform the host compliance check
function. Before creating a host compliance check rule, you must first configure
the host compliance check profile in "Configuring a Host Compliance Check
Profile" .
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Role

Specifies the role to which the host compliance check rule will be
applied. Select the role from the Role drop-down list. Default
indicates the rule will take effect to all the roles.

Host
Compliance

Specifies the compliance check profile. Select the profile from
the Host Compliance Check drop-down list.

198

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

Check
Guest Role

Select the guest role from the Guest Role drop-down list. The
user will get the access permission of the guest role when the
host checking fails. If Null is selected, system will disconnect the
connection when the host compliance check fails.

Periodic Check Specify the host compliance check period. System will check the
status of the host automatically according to the host compliance
check profile in each period.
Add

Delete

Click Add. The configured settings will be displayed in the table
below.
To delete an item, select the item you want to delete from the
list, and then click Delete.

Host Binding
Enable Host
Binding

Select the Enable Host Binding check box to enable the
function. By default, one user can only log in one host. You can
change the login status by configuring the following options.


Allow one user to login through multiple hosts.



Allow multiple users to login on one host.



Automatically add the user-host ID entry into the
binding list at the first login.

Note: To use the host binding function, you still have to
configure it in the host binding configuration page. For more
information about host binding, see "Host Binding" .
In the Optimized Path tab, configure the corresponding options.
Option

Description

Optimal path detection can automatically detect which ISP service is better, giving
remote users a better user experience.
No Check

Do not detect.

Client

The client selects the optimal path automatically by sending UDP
probe packets.

The device
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When the client connects to the server directly without any NAT
device, this is the detection process:
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1.

The server recognizes the ISP type of the client
according to the client's source address.

2.

The server sends all of the sorted IP addresses of
the egress interfaces to the client.

3.

The client selects the optimal path.

When the client connects to the server through a NAT device,
this is the detection process:
1.

The server recognizes the ISP type of the client
according to the client's source address.

2.

The server sends all of the sorted NAT IP
addresses of the external interfaces to the client.

3.

The client selects the optimal path.

NAT Mapping If necessary, in the NAT mapping address and port section,
Address and
specify the mapped public IPs and ports of the server referenced
Port
in the DNAT rules of the DNT device. When the client connects
to the server through the DNAT device, the NAT device will
translate the destination address of the client to the server's
egress interface address. Type the IP address of the NAT
device's external interface and the HTTPS port number (You are
not recommended to specify the HTTPS port as 443, because
443 is the default HTTPS port of WebUI management). You can
configure up to 4 IPs.
4.

Click Done to save the settings.

To view the SSL VPN online users, take the following steps:
1.

Select Configure > Network > SSL VPN.

2.

Select an SSL VPN instance.

3.

View the detailed information of the online users in the table.

Configuring Resource List
Resource list refers to resources configured in system that can be easily accessible by users. Each
resource contains multiple resource items. The resource item is presented in the form of a resource item
name followed by a URL in your default browser page. After the SSL VPN user is authenticated
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successfully, the authentication server will send the user group information of the user to the SSL VPN
server. Then, according to the binding relationship between the user group and resources in the SSL
VPN instance, the server will send a resource list in which the user can access to the client. After that,
the client will analyze and make the IE browser in system pop up a page to display the received resource
list information, so that the user can access the private network resource directly by clicking the URL
link. The resource list page pops up only after the authentication is passed. If a user does not belong to
any user group, the browser will not pop up the resource list page unless authentication is passed.
To configure resource list for SSL VPN:
1.

Select Network > VPN > SSL VPN.

2.

Click Resources List at the top-right corner.

3.

Click New.

In the Resources Configuration dialog box, configure the corresponding options.
Option

Description

Name

Enters a name for the new resource.

Resource Item
Name
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Enters a name for a new resource item. Names of resource
items in different resources can not be the same.
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URL

Enters a URL for a new resource item.

Add

Click Addto add this binding item to the list below.
Note: The number of resource items that can be added in a
resource ranges from 0 to 48. The total number of resource
items that can be added in all resources can not exceed 48.

Delete

To delete a rule, select the rule you want to delete from the list
and click Delete.

Up/Down/Top/ You can move the location for items at your own choice to
Bottom
adjust the presentation sequence accordingly.
4.

Click OK, the new resource will be displayed in the resource list.
At most 3 resource items can be displayed in the resource list for each resource, and the other
items will be displayed as "...". You can click Edit or Delete button to edit or delete the
selected resource.

Notes:


Less than 48 resources can be configured in a SSL VPN instance.



The resource list function is only available for Windows SSL VPN clients.

Configuring an SSL VPN Address Pool
The SSL VPN servers allocate the IPs in the SSL VPN address pools to the clients. After the client
connects to the server successfully, the server will fetch an IP address along with other related
parameters (e.g., DNS server address, and WIN server address) from the SSL VPN address pool and
then allocate the IP and parameters to the client.
You can create an IP binding rule to meet the fixed IP requirement. The IP binding rule includes the IPuser binding rule and the IP-role binding rule. The IP-user binding rule binds the client to a fixed IP in
the configured address pool. When the client connects to the server successfully, the server will allocate
the binding IP to the client. The IP-role binding rule binds the role to an IP range in the configured
address pool. When the client connects to the server successfully, the server will select an IP from the IP
range and allocate the IP to the client.
After the client successfully connects to the server, the server will check the binding rules in a certain
order to determine which IP to allocate. The order is shown as below:


Check whether the IP-user binding rule is configured for the client. If yes, allocate the
bound IP to the client; if no, the server will select an IP which is not bound or used from the
address pool, then allocate it to the client.
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Check whether the IP-role binding rule is configured for the client. If yes, get an IP from
the IP range and allocate to the client; if no, the server will select an IP which is not bound or
used from the address pool, then allocate it to the client.

Notes: IP addresses in the IP-user binding rule and the IP address in the IP-role binding rules should
not overlap.
To configure an address pool, take the following steps:
1.

Select Network > VPN > SSL VPN.

2.

Click Address Pool at the top-right corner.

3.

Click New.

In the Basic tab, configure the following options.
Option

Description

Address Pool
Name

Specifies the name of the address pool.

Start IP

Specifies the start IP of the address pool.

End IP

Specifies the end IP of the address pool.

Reserved Start Specifies the reserved start IP of the address pool.
IP
Reserved End Specifies the reserved end IP of the address pool.
IP
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Netmask

Specifies the netmask in the dotted decimal format.

DNS1/2/3/4

Specifies the DNS server IP address for the address pool. It is
optional. 4 DNS servers can be configured for one address pool
at most.
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WINS1/2

Specifies the WIN server IP addresses for the address pool. It is
optional. Up to 2 WIN servers can be configured for one address
pool.

In the IP User Binding tab, configure the corresponding options.
Option

Description

User

Type the user name into the User box.

IP

Type the IP address into the IP box.

Add

Click Add to add this IP user binding rule.

Delete

To delete a rule, select the rule you want to delete from the list
and click Delete.

In the IP Role Binding tab, configure the corresponding options.
Option

Description

Role

Type the role name into the Role box.

Start IP

Type the start IP address into the Start IP box.

End IP

Type the end IP address into the End IP box.

Add
Delete

Click Addto add this IP role binding rule.
To delete a rule, select the rule you want to delete from the list
and click Delete.

Up/Down/Top/ System will query IP role binding rules by turn, and allocate
Bottom
the IP address according to the first matched rule. You can
move the location up or down at your own choice to adjust the
matching sequence accordingly.
4.

Click OK to save the settings.

Configuring SSL VPN Login Page
You can customize the title and background of the SSL VPN login page. The default title is Login and
the login page is shown as below:
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To customize the SSL VPN login page, take the following steps:
1.

Select Network > VPN > SSL VPN.

2.

At the top-right corner, click Login Page Configuration.

3.

Click Browse to select the background picture. The selected pictures must be zipped, and
the file name must be Login_box_bg_en.gif for English pages. The picture size must be
624px*376px.

4.

Click Upload to upload the background picture to system. After uploading successfully,
you will have completed the background picture modification.

5.

Enter the title in the Authentication Page Title box to customize the title of the login
page.

6.

Click OK to save the settings. Clicking Cancel will only affect the authentication page
title modification.

If you want to use the default authentication title Login, click Clear Page Title. Then click OK. If you
want to restore the default picture, click Restore Default Background and select English in the pop-up
dialog. Then click OK.

Host Binding
The host binding function verifies that the hosts are running the SSL VPN clients according to their
host IDs and user information. The verification process is:
1.

When an SSL VPN user logs in via the SSL VPN client, the client will collect the host
information of main board serial number, hard disk serial number, CUP ID, and BIOS serial
number.

2.

Based on the above information, the client performs the MD5 calculation to generate a
32-digit character, which is named host ID.

3.
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The client sends the host ID and user/password to the SSL VPN server.
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4.

The SSL VPN server verifies the host according to the entries in the host unbinding list
and host binding list, and deals with the verified host according to the host binding
configuration.

The host unbinding list and host binding list are described as follows:


Host unbinding list: The host unbinding list contains the user-host ID entries for the
first-login users.



Host binding list: The host binding list contains the user-host ID entries for the users
who can pass the verification. The entries in the host unbinding list can be moved to the host
binding list manually or automatically for the first login. When a user logs in, the SSL VPN
server will check whether the host binding list contains the user-host ID entry of the login user.
If there is a matched entry in the host binding list, the user will pass the verification and the sever
will go on checking the user/password. If there is no matched entry for the login user, the
connection will be disconnected.

Configuring Host Binding
Configuring host binding includes host binding/unbinding configurations, super user configurations,
shared host configurations, and user-host binding list importing/exporting.

Configuring Host Binding and Unbinding
To add a binding entry to the host binding list, take the following steps:
1.
2.
2.
3.
4.

Select Network > VPN > SSL VPN.
At the top right corner, click Host Compliance Check/Binding to visit the Host
Compliance Check/Binding page.
Click Host Binding.
With the Binding and Unbinding tab active, select the entries you want to add to the
Host Unbinding List.
Click Add to add the selected entries to the Host Binding List.

To delete a binding entry from the host binding list, take the following steps:
1.
2.
3.
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Select Network > VPN > SSL VPN.
At the top right corner, click Host Compliance Check/Binding to visit the Host
Compliance Check/Binding page.
Click Host Binding.
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4.
5.

With the Binding and Unbinding tab active, select the entries you want to delete from the
Host binding List.
Click Unbinding to remove the selected entries from this list.

Configuring a Super User
The super user won't be controlled by the host checking function, and can log into any host. To
configure a super user, take the following steps:
1.
2.

Select Network > VPN > SSL VPN.
At the top right corner, click Host Compliance Check/Binding to visit the Host
Checking/Binding page.

3.

Click Host Binding.

4.

With the User Privilege tab active, click New.

In the New dialog box, configure the corresponding options.

5.
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Option

Description

User

Specifies the name of the user.

Privilege

Select the Enable check box to make it a super user.

Preapproved
Number

If system allows one user to login from multiple hosts, and the
option of automatically adding the user-host ID entry into the
host binding list at the first login is enabled, then by default
system only records the user and first login host ID entry to the
host binding list. For example, if the user logs in from other
hosts, the user and host ID will be added to the host unbinding
list. This pre-approved number specifies the maximum number
of user-host ID entries for one user in the host binding list.

Click OK

to save the settings.
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Configuring a Shared Host
Clients that log in from the shared host won't be controlled by the host binding list. To configure a
shared host, take the following steps:
1.
2.

Select Network > VPN > SSL VPN.
At the top right corner, click Host Compliance Check/Binding to visit the Host
Checking/Binding page.

3.

Click Host Binding.

4.

With the Host ID Privilege tab active, click New.

In the New dialog box, configure the corresponding options.

5.

Option

Description

Host ID

Type the host ID into the Host ID box.

Shared Host

Select the Enable check to make it a shared host. By default, this
check box is selected.

Click OK to save the settings.

Importing/Exporting Host Binding List
To import the host binding list, take the following steps:
1.
2.
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Select Network > VPN > SSL VPN.
At the top right corner, click Host Compliance Check/Binding to visit the Host
Checking/Binding page.

3.

Click Host Binding.

4.

With the Binding and Unbinding tab active, click Import.

5.

Click Browse to find the binding list file and click Upload.
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To export the host binding list, take the following steps:
1.
2.

Select Network > VPN > SSL VPN.
At the top right corner, click Host Compliance Check/Binding to visit the Host
Checking/Binding page.

3.

Click Host Binding.

4.

With the Binding and Unbinding tab active, click Export.

5.

Select a path to save the host binding list.

Host Compliance Check
The host compliance check function checks the security status of the hosts running SSL VPN clients,
and according to the check result, the SSL VPN server will determine the security level for each host and
assign corresponding resource access right based on their security level. It a way to assure the security of
SSL VPN connection. The checked factors include the operating system, IE version, and the installation
of some specific software.
The factors to be checked by the SSL VPN server are displayed in the list below:
Factor
Operating
system

Description


Operating system, e.g., Windows 2000, Windows
2003, Windows XP, Windows Vista, Windows 7m
Windows 8, etc.



Service pack version, e.g., Service Pack 1



Windows patch, e.g., KB958215, etc.



Whether the Windows Security Center and
Automatic Updates are enabled.



Whether the installation of AV software is
compulsory, and whether the real-time monitor and the
auto update of the signature database are enabled.



Whether the installation of anti-spyware is
compulsory, and whether the real-time monitor and the
online update of the signature database are enabled.
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Whether the personal firewall is installed, and
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Factor

Description
whether the real-time protection is enabled.
Whether the IE version and security level reach the specified
requirements.

Other
Whether the specified processes are running.
configurations Whether the specified services are installed.
Whether the specified services are running.
Whether the specified registry key values exist.
Whether the specified files exist in the system.

Role Based Access Control and Host Compliance Check Procedure
Role Based Access Control (RBAC) means that the permission of the user is not determined by his user
name, but his role. The resources can be accessed by a user after the login is determined by his
corresponding role. So role is the bridge connecting the user and permission.
The SSL VPN host checking function supports RBAC. And the concepts of primary role and guest role
are introduced in the host checking procedure. The primary role determines which host compliance
check profile (contains the host checking contents and the security level) will be applied to the user and
what access permission can the user have if he passes the host checking. The guest role determines the
access permissions for the users who fail the host checking.
The host compliance check procedure is shown as below
1.

The SSL VPN client sends request for connection and passes the authentication.

2.

The SSL VPN server sends the host checking profile to the client.

3.
4.
5.

The client checks the host security status according to the items in the host checking
profile. If it fails the host compliance check, system will be notified of the checking result.
The client sends the checking result back to the server.
The server disconnects the connection to the failed client or gives the guest role's access
permission to the failed client.

The host compliance check function also supports dynamic access permission control. On one side,
when the client's security status changes, the server will send a new host checking profile to the client to
make him re-check; on the other side, the client can perform security checks periodically. For example, if
the AV software is disabled and is detected by the host checking function, the role assigned to the client
may change as will the access permissions.
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Configuring a Host Compliance Check Profile
To configuring host compliance check profile, take the following steps:
1.
2.
3.

Select Network > VPN > SSL VPN.
At the top right corner, click Host Compliance Check/Binding to visit the Host
Compliance Check/Binding page.
In the Host Compliance Check tab, click New to create a new host checking rule.

In the Basic Configuration tab, configure the corresponding options.
Option

Description

Name

Specifies the name of the host checking profile.

OS Version

Specifies whether to check the OS version on the client
host. Click one of the following options:


No Check: Do not check the OS version.


Must Match: The OS version running on
the client host must be the same as the version
specified here. Select the OS version and service
pack version from the drop-down lists
respectively.

At Least: The OS version running on the
client host should not be lower than the version
specified here. Select the OS version and service
pack version from the drop-down lists
respectively.
Patch1/2/3/4/5
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Specifies the patch that must be installed on the client
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host. Type the patch name into the box. Up to 5 patches
can be specified.
Lowest IE Version

Specifies the lowest IE version in the Internet zone on
the client host. The IE version running on the client host
should not be lower than the version specified here.

Lowest IE Security
Level

Specifies the lowest IE security level on the client host.
The IE security level on the host should not be lower
than the level specified here.

In the Advanced Configuration tab, configure the corresponding options.
Option

Description

Security Center

Checks whether the security center is enabled on the
client host.

Auto Update

Checks whether the Windows auto update function
is enabled.

Anti-Virus Software

Checks the status and configurations of the anti-virus
software:

Installed: The client host must have
the AV software installed.

Monitor: The client host must enable
the real-time monitor of the AV software.

Virus Signature DB Update: The
client host must enable the signature database
online update function.

Anti-Spyware Software

Checks the status and configurations of the antispyware software:

Installed: The client host must have
the anti-spyware installed.

Monitor: The client host must enable
the real-time monitor of the anti-spyware.

Signature DB Update: The client host
must enable the signature database online
update function.
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Firewall

Checks the status and configurations of the firewall:

Installed: The client host must have
the personal firewall installed.

Monitor: The client host must enable
the real-time monitor function of the
personal firewall.

Registry Key Value
Key1/2/3/4/5

Checks whether the key value exists. Up to 5 key
values can be configured. The check types are:

No Check: Do not check the key
value.

Exist: The client host must have the
key value. Type the value into the box.

Do not Exist: The client cannot have
the key value. Type the value into the box.

File Path Name
File1/2/3/4/5

Checks whether the file exists. Up to 5 files can be
configured. The check types are:


No Check: Do not check file.


Exist: The client host must have the
file. Type the value into the box.

Do not Exist: The client cannot have
the file. Type the value into the box.
Name of Running Process
Process1/2/3/4/5

Checks whether the process is running. Up to 5
processes can be configured. The check types are:


No Check: Do not check the process.


Exist: The client host must have the
process run. Type the process name into the
box.
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Do not Exist: The client cannot have
the process run. Type the process name into
the box.
Name of Installed Service
Service1/2/3/4/5

Checks whether the service is installed. Up to 5
services can be configured. The check types are:


No Check: Do not check the service.


Exist: The client host must have the
service installed. Type the service name into
the box.

Do not Exist: The client host cannot
have the service installed. Type the service
name into the box.
Name of Running Service
Service1/2/3/4/5

Checks whether the service is running. Up to 5
services can be configured. The check types are:


No Check: Do not check the service.


Exist: The client host must have the
service run. Type the service name into the
box.

Do not Exist: The client host cannot
have the service run. Type the service name
into the box.
4.

Click OK to save the settings.

SSL VPN Client for Windows
SSL VPN client for Windows is named FS Secure Connect. FS Secure Connect can be run with the
following operating systems: Windows 2000/2003/XP/Vista/Windows 7/Windows 8/Windows
2008/Windows 10/Windows 2012. The encrypted data can be transmitted between the SSL VPN client
and SSL VPN server after a connection has been established successfully. The functions of the client are:
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Get the interface and the route information of the PC on which the client is running.
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Show the connecting status, statistics, interface information, and route information.



Show SSL VPN log messages.



Upgrade the client software.



Resolve the resource list information received from the server.

This section mainly describes how to download, install, start, uninstall the SSL VPN client, and its GUI
and menu. The method for downloading, installing and starting the client may vary from the
authentication methods configured on the server. The SSL VPN server supports the following
authentication methods:


Username/Password



Username/Password + Digital Certificate



Digital Certificate only

Downloading and Installing Secure Connect
When using the SSL VPN client for the first time, you need to download and install the client software
FS Secure Connect. This section describes three methods for downloading and installing the client
software based on three available authentication methods. For the Username/Password + Digital
Certificate authentication, the digital certificate can either be the USB Key certificate provided by the
vendor, or the file certificate provided by the administrator.

Using Username/Password Authentication
When the Username/Password authentication is configured on the server, take the following steps to
download and install the SSL VPN client software - FS Secure Connect:
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1.

Visit the following URL with a web browser: https://IP-Address:Port-Number. In the
URL, IP-Address and Port-Number refer to the IP address and HTTPS port number of the
egress interface specified in the SSL VPN instance.

2.

In the SSL VPN login page (shown in Figure 1), type the username and password into
the Username and Password boxes respectively, and then click Login.


If the local authentication server is configured on the device, the username and
password should already be configured on the device.



If "Radius authentication + RSA SecurID Token authentication by RSA Server"
is configured on the device, and the user logs in for the first time, the username should
be the username configured on the Radius server, and the password should be the
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dynamic Token password bound to the user. Click Login, and in the PIN Setting page
(shown in Figure 2), set a PIN (4 to 8 digits). After the PIN has been set successfully,
you will be prompted to login again with the new password (shown in Figure 3). Click
Login again to return to the login page, type the correct username and new password,
and click Login. The new password is PIN + dynamic Token password. For example,
if the PIN is set to 54321, and the dynamic Token password is 808771, then the new
password is 54321808771.


3.

If "Radius authentication + RSA SecurID Token authentication by RSA Server"
is configured on the device, but the user is not logging in for the first time, the
username should be the username configured on the Radius server, and the password
should be PIN + dynamic Token password.

After logging in, IE will download the client software automatically, and you can install it
by following the prompts; for other web browsers, e.g., Firefox, you should click Download to
download the client software scvpn.exe first, and then double click it to install.

A virtual network adapter will be installed on your PC together with Secure Connect. It is used to
transmit encrypted data between the SSL VPN server and client.

Using Username/Password + Digital Certificate Authentication
When the Username/Password + Digital Certificate authentication is configured on the server, take the
following steps to download and install the SSL VPN client software - FS Secure Connect:
1.
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Insert the USB Key to the USB port of the PC, or import the file certificate provided by
the administrator manually.
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2.

Visit the following URL with a web browser: https://IP-Address:Port-Number. In the
URL, IP-Address and Port-Number refer to the IP address and HTTPS port number of the
egress interface specified in the SSL VPN instance.

3.

In the Select Digital Certificate dialog box, select the certificate you want and click OK.
If USB Key certificate is selected, in the pop-up dialog box, provide the UKey PIN code
(1111 by default) and click OK.

4.

In the SSL VPN login page shown below, type the username and password into the
Username and Password boxes respectively, and then click Login. The login user should be
configured before in the device.

5.

After logging in, IE will download the client software automatically, and you can install it
by following the prompts; for other web browsers, e.g., Firefox, you should click Download to
download the client software scvpn.exe first, and then double click it to install.

A virtual network adapter will be installed on your PC together with Secure Connect. It is used to
transmit encrypted data between the SSL VPN server and client.

Using Digital Certificate Only
When only the Digital Certificate authentication is configured on the server, take the following steps to
download and install the SSL VPN client software - FS Secure Connect:
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1.

Insert the USB Key to the USB port of the PC, or import the file certificate provided by
the administrator manually.

2.

Visit the following URL with a web browser: https://IP-Address:Port-Number. In the
URL, IP-Address and Port-Number refer to the IP address and HTTPS port number of the
egress interface specified in the SSL VPN instance.
217

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

3.

In the Select Digital Certificate dialog box, select the certificate you want and click OK.
If USB Key certificate is selected, in the Enter Password dialog box, provide the UKey user
password (1111 by default) and click OK.

4.

After logging in, IE will download the client software automatically, and you can install
it by following the prompts; for other web browsers, e.g., Firefox, you should click Download
to download the client software scvpn.exe first, and then double click it to install.

A virtual network adapter will be installed on your PC together with Secure Connect. It is used to
transmit encrypted data between the SSL VPN server and client.

Starting Secure Connect
After installing Secure Connect on your PC, you can start it in two ways:


Starting via Web



Starting directly

Starting via Web
This section describes how to start Secure Connect via Web based on the three authentication methods
configured on the server. For the Username/Password + Digital Certificate authentication, the digital
certificate can either be the USB Key certificate provided by the vendor, or the file certificate provided
by the administrator.

Using Username/Password Authentication
When the Username/Password authentication is configured on the server, take the following steps to
start Secure Connect via web:
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1.

Type the URL https://IP-Address:Port-Number into the address bar of your web
browser.

2.

In the login page (shown in Figure 4), type the username and password into the
Username and Password boxes respectively, and then click Login.


If local authentication server is configured on the device, the username and
password should be configured before on the device;



If "Radius authentication + RSA SecurID Token authentication by RSA Server"
is configured on the device, and the user logs in for the first time, the username should
be the username configured on the Radius server, and the password should be the
dynamic Token password bound to the user. Click Login, and in the PIN Setting page
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(shown in Figure 5), set a PIN (4 to 8 digits). After the PIN has been set successfully,
you will be prompted to login again with the new password (shown in Figure 6). Click
Login again to return to the login page, type the correct username and new password,
and click Login. The new password is PIN + dynamic Token password. For example,
if the PIN is set to 54321, and the dynamic Token password is 808771, then the new
password is 54321808771.


If "Radius authentication + RSA SecurID Token authentication by RSA Server"
is configured on the device, but the user is not logging in for the first time, the
username should be the username configured on the Radius server, and the password
should be PIN + dynamic Token password.

Tips: If the password control function and the change password function are enabled on
the device, the system will remind the user to change the password before and after the
password expires, and verify the historical password to ensure that the new password is
different from the previous password. For more information about password control
function, refer to Configuring a Local AAA Server.

After the above steps being finished, the client will connect to the server automatically. After the
connection has been established successfully, the icon ( ) will be displayed in the notification area.
The encrypted communication between the client and server can be implemented now.

Using Username/Password + USB Key Certificate Authentication
When the Username/Password + Digital Certificate authentication for the USB Key certificate is
configured on the server, to start Secure Connect via web, take the following steps:
www.fs.com
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1.

Insert the USB Key to the USB port of the PC.

2.

Type the URL https://IP-Address:Port-Number into the address bar of your web
browser.

3.

In the Select Digital Certificate dialog box, select the digital certificate you want and click
OK. In the Enter Password dialog box, provide the UKey user password (1111 by default)
and click OK.

4.

In the SSL VPN login page shown below, type the username and password into the
Username and Password boxes respectively, and then click Login. The login user should
already be configured on the device.

5.

In the USB Key PIN dialog box shown below, type the UKey PIN (1111 by default), and
click OK.

After the above steps being finished, the client will connect to the server automatically. After the
connection has been established successfully, the icon ( ) will be displayed in the notification area.
The encrypted communication between the client and server can be implemented now.

www.fs.com
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Using Username/Password + File Certificate Authentication
When the Username/Password + Digital Certificate authentication for the file certificate is configured
on the server, to start the Secure Connect via web, take the following steps:
1.
2.

Import the file certificate provided by the administrator manually.
Type the URL https://IP-Address:Port-Number into the address bar of your web
browser.

3.

In the Select Digital Certificate dialog box, select the digital certificate you want and click
OK.

4.

In the SSL VPN login page shown below, type the username and password into the
Username and Password boxes respectively, and then click Login. The login user should
already be configured on the device.

After the above steps being finished, the client will connect to the server automatically. After the
connection has been established successfully, the icon ( ) will be displayed in the notification area.
The encrypted communication between the client and server can be implemented now.

Using USB Key Certificate Only Authentication
When the Digital Certificate only authentication for the USB Key certificate is configured on the server,
to start the Secure Connect via web, take the following steps:
1.
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Insert the USB Key to the USB port of the PC.
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2.

Type the URL https://IP-Address:Port-Number into the address bar of your web
browser.

3.

In the Select Digital Certificate dialog box, select the digital certificate you want and click
OK. In the Enter Password dialog box, provide the UKey user password (1111 by default)
and click OK.

4.

In the USB Key PIN dialog box shown below, type the UKey PIN (1111 by default), and
click OK.

After the above steps being finished, the client will connect to the server automatically. After the
connection has been established successfully, the icon ( ) will be displayed in the notification area.
The encrypted communication between the client and server can be implemented now.

Using File Certificate Only Authentication
When the Digital Certificate only authentication for the file certificate is configured on the server, to
start the Secure Connect via web, take the following steps:
1.
2.

Import the file certificate provided by the administrator manually.
Type the URL https://IP-Address:Port-Number into the address bar of your web
browser.

3.

In the Select Digital Certificate dialog box, select the digital certificate you want and click
OK.

After the above steps being finished, the client will connect to the server automatically. After the
connection has been established successfully, the icon ( ) will be displayed in the notification area.
The encrypted communication between the client and server can be implemented now.

Starting Directly
This section describes how to start Secure Connect directly based on the three authentication methods
configured on the server.

www.fs.com
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Starting the Software Based on TLS/SSL Protocol
For the Username/Password + Digital Certificate authentication, the digital certificate can either be the
USB Key certificate provided by the vendor, or the file certificate provided by the administrator.
The starting mode based on TLS/SSL protocol are as follows:


Username/Password



Username/Password + USB Key Certificate



Username/Password + File Certificate



USB Key Certificate Only



File Certificate Only

Using Username/Password Authentication
When the Username/Password authentication is configured on the server, to start the Secure Connect
directly, take the following steps:
1.
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On your PC, double click the shortcut of FS Secure Connect on your desktop.

2.

In the Login dialog box, click Mode. In the Login Mode dialog shown below, in
TLS/SSL section, click Username/Password, and then click OK.

3.

In the Login dialog box of the Username/Password authentication mode (shown in
Figure 7), configure the options to login.
Option

Description

Saved
Connection

Provides the connection information you have filled before.
Select a connection from the drop-down list.
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Option

Description

Server

Enter the IP address of SSL VPN server.

Port

Enter the HTTPS port number of SSL VPN server.

Username

Enter the name of the login user.

Password

Enter the password of the login user.



If the local authentication server is configured on the device, the username and
password should already be configured on the device.



If "Radius authentication + RSA SecurID Token authentication by RSA Server"
is configured on the device, and the user logs in for the first time, the username should
be the username configured on the Radius server, and the password should be the
dynamic Token password bound to the user. Click Login, and in the PIN Setting page
(shown in Figure 8), set a PIN (4 to 8 digits). After the PIN has been set successfully,
you will be prompted to login again with the new password (shown in Figure 9). Click
Login again to return to the login page, type the correct username and new password,
and click Login. The new password is PIN + dynamic Token password. For example,
if the PIN is set to 54321, and the dynamic Token password is 808771, then the new
password is 54321808771.



If "Radius authentication + RSA SecurID Token authentication by RSA Server"
is configured on the device, but the user is not logging in for the first time, the
username should be the username configured on the Radius server, and the password
should be PIN + dynamic Token password.

Tips: If the password control function and the change password function are
enabled on the device, the system will remind the user to change the password
before and after the password expires, and verify the historical password to ensure
that the new password is different from the previous password. For more
information about password control function, refer to Configuring a Local AAA
Server.

www.fs.com
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Finishing the above steps, the client will connect to the server automatically. After the connection has
been established successfully, the icon ( ) will be displayed in the notification area. And the encrypted
communication between the client and server can be implemented now.

Using Username/Password + USB Key Certificate Authentication
When the Username/Password + Digital Certificate authentication is configured on the server, for the
USB Key certificate, to start Secure Connect directly, take the following steps:
1.

Insert the USB Key to the USB port of the PC.

2.

In your PC, double click the shortcut to FS Secure Connect on your desktop.

3.
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In the Login dialog box, click Mode. In the Login Mode dialog box, first click
Username/Password + Digital Certificate in TLS/SSL section, and if necessary, click Select
Cert. In the Select Certificate dialog box shown below, select a USB Key certificate. If the
USB Key certificate is not listed, click Update. The client will send the selected certificate to
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the server for authentication. Finally click OK.

4.

In the Login dialog of the Username/Password + Digital Certificate authentication mode
(as shown below), configure the options to login.

After the above steps being finished, the client will connect to the server automatically. After the
connection has been established successfully, the icon ( ) will be displayed in the notification area.
The encrypted communication between the client and server can be implemented now.

Using Username/Password + File Certificate Authentication
When the Username/Password + Digital Certificate authentication for the USB Key certificate is
configured on the server, to start the Secure Connect directly, take the following steps:
1.
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Import the file certificate provided by the administrator manually.
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2.

On your PC, double click the shortcut to FS Secure Connect on your desktop.

3.

In the Login dialog box, click Mode. In the Login Mode dialog, first click
Username/Password + Digital Certificatein TLS/SSL section, and if necessary, click Select
Certificate. In the Select Certificate dialog box shown below, select a file certificate. If the file
certificate is not listed, click Update. The client will send the selected certificate to the server
for authentication. Finally click OK.

4.

In the Login dialog box of the Username/Password + Digital Certificate authentication
mode (as shown below), configure the options to login.

After the above steps being finished, the client will connect to the server automatically. After the
connection has been established successfully, the icon ( ) will be displayed in the notification area.
The encrypted communication between the client and server can be implemented now.

www.fs.com
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Using USB Key Certificate Only
When the Username/Password + Digital Certificate authentication for the file certificate is configured
on the server, to start the Secure Connect directly, take the following steps:
1.

Insert the USB Key to the USB port of the PC.

2.

On your PC, double click the shortcut to FS Secure Connect on your desktop.

3.

In the Login dialog box, click Mode. In the Login Mode dialog box, first click
Username/Password + Digital Certificate in TLS/SSL section, and if necessary, click Select
Certificate. In the Select Certificate dialog box shown below, select a USB Key certificate. If
the USB Key certificate is not listed, click Update. The client will send the selected certificate
to the server for authentication. Finally click OK.

4.

In the Login dialog box of the Username/Password + Digital Certificate authentication
mode (as shown below), configure the options to login.

5.
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Finishing the above configuration, click Login.
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After the above steps being finished, the client will connect to the server automatically. After the
connection has been established successfully, the icon ( ) will be displayed in the notification area.
The encrypted communication between the client and server can be implemented now.

Using File Certificate Only
When the Digital Certificate Only authentication for the USB Key certificate is configured on the server,
to start the Secure Connect directly, take the following steps:
1.

Import the file certificate provided by the administrator manually.

2.

On your PC, double click the shortcut to FS Secure Connect on your desktop.

3.
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In the Login dialog box, click Mode. In the Login Mode dialog box, first click
Username/Password + Digital Certificate in TLS/SSL section, and if necessary, click Select
Certificate. In the Select Certificate dialog box shown below, select a file certificate. If the file
certificate is not listed, click Update. The client will send the selected certificate to the server
for authentication. Finally click OK.
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4.

5.

In the Login dialog box of the Digital Certificate Only authentication mode (as shown
below), configure the options to login.

Finishing the above configuration, click Login.

After the above steps being finished, the client will connect to the server automatically. After the
connection has been established successfully, the icon ( ) will be displayed in the notification area.
The encrypted communication between the client and server can be implemented now.

Starting the Software Based on GMSSL Protocol
The starting mode based on GMSSL protocol are as follows:


Username/Password



Username/Password + Digital Certificate



Digital Certificate Only

Using Username/Password Authentication
To start the Secure Connect client software, take the following steps:
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1.

On your PC, double click the shortcut of FS Secure Connect on your desktop.

2.

In the Login dialog box, click Mode. In the Login Mode dialog shown below, click
Username/Password in GMSSL section,, and then click OK.

3.

In the Login dialog box of the Username/Password authentication mode, configure the
options to login.
Option

Description

Saved

Provides the connection information you have filled before.
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Option

Description

Connection

Select a connection from the drop-down list.

Server

Enter the IP address of SSL VPN server.

Port

Enter the HTTPS port number of SSL VPN server.

Username

Enter the name of the login user.

Password

Enter the password of the login user.

Finishing the above steps, the client will connect to the server automatically. After the connection has
been established successfully, the icon ( ) will be displayed in the notification area. And the encrypted
communication between the client and server can be implemented now.

Using Username/Password + Digital Certificate Authentication
When the Username/Password + Digital Certificate authentication is configured on the server, for the
USB Key certificate, to start the Secure Connect software directly, take the following steps:
1.

Insert the USB Token to the USB port of the PC.

2.

In your PC, double click the shortcut to FS Secure Connect on your desktop.

3.

4.
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In the Login dialog, click Mode. In the Login Mode dialog, first click
Username/Password + Digital Certificate in GMSSL section, and if necessary, click Select
GuoMi Cert. In the Select Certificate dialog as shown below, select a GM certificate. Finally
click OK.
In the Select Certificate dialog box, configure the options to login.
Option

Description

Device

Select the current USB Token device name in the drop-down list.

Application

The application is a structure that contains a container, a device
authentication key, and a file. Select the specified application
name in the drop-down list.

Container

The container is the unique storage space in the USB Token
device to save the key. It is used to store the encryption key pair,
the encryption certificate corresponding to the encryption key
pair, the signature key pair, and the signature certificate
corresponding to the signature key pair. Select the name of the
specified container in the drop-down list.

Signature
Certificate

Display the name of the SM2 signature certificate in the specified
container.
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5.

Option

Description

Encryption
Certificate

Display the name of the SM2 encryption certificate in the
specified container.

In the Login dialog of the Username/Password + Digital Certificate authentication mode
as shown below, configure the options to login.
Option

Description

Saved
Connection

Provides the connection information you have filled before.
Select a connection from the drop-down list.

Server

Enter the IP address of SSL VPN server.

Port

Enter the HTTPS port number of SSL VPN server.

Username

Enter the name of the login user.

Password

Enter the password of the login user.

USB Key PIN Enter the PIN code of the USB Key (1111 by default). One USB
Key only corresponds to one password.
Finishing the above steps, the client will connect to the server automatically. After the connection has
been established successfully, the icon ( ) will be displayed in the notification area. And the encrypted
communication between the client and server can be implemented now.

Using Digital Certificate Only Authentication
When the Digital Certificate Only authentication is configured on the server, for the file certificate, to
start the Secure Connect software directly, take the following steps:
1.

Insert the USB Token to the USB port of the PC.

2.

In your PC, double click the shortcut to FS Secure Connect on your desktop.

3.

4.
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In the Login dialog, click Mode. In the Login Mode dialog, first click Digital Certificate
only in GMSSL section, and if necessary, click Select GuoMi Cert. In the Select Certificate
dialog as shown below, select a GM certificate. Finally click OK.
In the Select Certificate dialog box, configure the options to login.
Option

Description

Device

Select the current USB Token device name in the drop-down list.

Application

The application is a structure that contains a container, a device
authentication key, and a file. Select the specified application
name in the drop-down list.
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5.

Option

Description

Container

The container is the unique storage space in the USB Token
device to save the key. It is used to store the encryption key pair,
the encryption certificate corresponding to the encryption key
pair, the signature key pair, and the signature certificate
corresponding to the signature key pair. Select the name of the
specified container in the drop-down list.

Signature
Certificate

Display the name of the SM2 signature certificate in the specified
container.

Encryption
Certificate

Display the name of the SM2 encryption certificate in the
specified container.

In the Login dialog of the Digital Certificate Only authentication mode as shown below,
configure the options to login.
Option

Description

Saved
Connection

Provides the connection information you have filled before.
Select a connection from the drop-down list.

Server

Enter the IP address of SSL VPN server.

Port

Enter the HTTPS port number of SSL VPN server.

USB Key PIN Enter the PIN code of the USB Key (1111 by default). One USB
Key only corresponds to one password.
6.

Finish the above configuration, click Login.

Finishing the above steps, the client will connect to the server automatically. After the connection has
been established successfully, the icon ( ) will be displayed in the notification area. And the encrypted
communication between the client and server can be implemented now.

Viewing Secure Connect GUI
Double click the Secure Connect icon ( ) in the notification area, and the Network Information dialog
box appears. This dialog box shows information about statistics, interfaces, and routes.

General
Descriptions of the options on the General tab:
Address Information
Server
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The IP address of the connected SSL VPN server.
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Address Information
Client

The IP address of the client.

Crypto Suite
Cipher

The encryption algorithm and authentication algorithm used by
SSL VPN.

Version

The SSL version used by SSL VPN.

Connection Status
Status

The current connecting status between the client and server.
The possible statuses are: connecting, connected, disconnecting,
and disconnected.

IPCompress
Algorithm

Shows the compression algorithm used by SSL VPN.

Tunnel Packets
Sent

The number of sent packets through the SSL VPN tunnel.

Received

The number of received packets through the SSL VPN tunnel.

Tunnel Bytes
Sent

The number of sent bytes through the SSL VPN tunnel.

Received

The number of received bytes through the SSL VPN tunnel.

Connected Time
Duration

Shows the time period during which the client is online.

Compress Ratio
Sent

Shows the length ratio of sent data after compression.

Received

Shows the length ratio of received data after compression.

Interface
Descriptions of the options on the Interface tab:
Option

Description

Adapter Name The name of the adapter used to send SSL VPN encrypted data.
Adapter Type

The type of the adapter used to send SSL VPN encrypted data.

Adapter Status The status of the adapter used to send SSL VPN encrypted data.
Physical
Address

The MAC address of the interface used to send SSL VPN
encrypted data.

IP Address

The type of the interface address used to send SSL VPN

www.fs.com
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Option

Description

Type

encrypted data.

Network
Address

The IP address (allocated by SSL VPN server) of the interface
used to send SSL VPN encrypted data.

Subnet Mask

The subnet mask of the interface used to send SSL VPN
encrypted data.

Default
Gateway

The gateway address of the interface used to send SSL VPN
encrypted data.

DNS Server
Address

The DNS server addresses used by the client.

WINS Address The WINS server addresses used by the client.

Route
Description of the option on the Route tab:
Option
Local LAN
Routes

Description
The routes used by the virtual network adapter.

Viewing Secure Connect Menu
Right-click the Secure Connect icon (

) in the notification area and the menu appears.

Descriptions of the menu items are as follows:
Option

Description

Network Information

Displays the related information in the Network
Information dialog box.

Log

Shows Secure Connect log messages in the Log
dialog box.
This dialog box shows the main log messages. To
view the detailed log messages, click Detail. Click
Clear to remove the messages in the dialog box.
Click OK to close the Log dialog box.

Debug
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Configures Secure Connect's debug function in the
Debug dialog box.
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Option

Description

About

Shows Secure Connect related information in the
About dialog box.

Connect

When Secure Connect is disconnected, click this
menu item to connect.

Disconnect

When Secure Connect is connected, click this
menu item to disconnect.

Option

Configures Secure Connect options, including
login information, auto start, auto login, and so on.
For more information, see "Configuring Secure
Connect" .

Exit

Click Exit to exit the client. If the client is
connected to the server, the connection will be
disconnected.

Configuring Secure Connect
You can configure Secure Connect in the Secure Connect Options dialog box(click Option from the
client menu). The configurations include:


Configuring General Options



Configuring a Login Entry

Configuring General Options
In the Secure Connect Options dialog box, select General from the navigation pane and the general
options will be displayed.
Descriptions of the options:
Option

Description

Auto Start

Select this check box to autorun the SSL VPN client when the
PC is started.

Auto Login

Select this check box to allow the specified user to login
automatically when the PC is started. Select the auto login user
from the Default Connection drop-down list.

Auto
Reconnect

Select this check box to allow the client to reconnect to the SSL
VPN server automatically after an unexpected disconnection.

Select Cert

Click the button to select a USB Key certificate in the Select
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Option

Description
Certificate dialog box. This option is available when the USB
KEY authentication is enabled.

Configuring a Login Entry
Login entry contains the login information for clients. The configured login entries will be displayed in
the Saved Connection drop-down list in the Login dialog box. You can login by simply choosing the
preferred connection instead of filling up the options in the Login dialog box.
To add a login entry, take the following steps:
1.

In the Secure Connect Options dialog box, select Saved Connection from the navigation
pane and the login options will be displayed.
In the dialog box, configure the corresponding options.
Option

Description

Connection
Name

Specifies the name for the connection to identify it. System will
assign a name to the connection based on its server, port, and
user automatically if this option is kept blank

Server

Specifies the IP address of the SSL VPN server.

Port

Specifies the HTTPS port number of the SSL VPN server.

Username

Specifies the login user.

Login Mode

Specifies the login mode. It can be one of the following options:


Password (the username/password authentication
method). If Password is selected, select Remember
Password to make system remember the password and
type the password into the Password box.



Password + UKey (the USB KEY authentication
method). If Password + UKey is selected, select
Remember PIN to make system remember the PIN
number and type PIN number into the UKey PIN box.

Proximity Auto Select the option to enable the optimal path detection function.
Detection
For more information about optimal path detection, see
"Configuring an SSL VPN" .
2.
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Click Apply.
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SSL VPN Client for Android
The SSL VPN client for Android is FS Secure Connect. It can run on Android 4.0 and above. The
functions of FS Secure Connect contains the following items:



Obtain the interface information of the Android OS.
Display the connection status with the device, traffic statistics, interface information, and
routing information.



Display the log information of the application.

Downloading and Installing the Client
To download and install the client, take the following steps:
1.

Visit //客户端下载地址 to download the installation file of the client.

2.

After downloading successfully, find this file in your mobile phone.

3.

Click it and the installation starts.

4.

Read the permission requirements.

5.

Click Install.

After the client being installed successfully, the icon of FS Secure Connect appears in the desktop as
shown below:

Starting and Logging into the Client
To start and log into the client, take the following steps:

www.fs.com

1.

Click the icon of FS Secure Connect. The login page appears.

2.

Provide the following information and then click Login.
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Please Choose: Select a login entry. A login entry stores the login information and
it facilities your next login. For more information on login entry, see the Configuration
Management section below.



Server: Enters the IP address or the server name of the device that acts as the
VPN server.



Port: Enters the HTTPs port number of the device.



Username: Enters the username for logging into the VPN.



Password: Enters the corresponding password.

After the client connecting to the SSL VPN server, the key icon (
area of your Android system.

) will appear at the notification

GUI
After the client connects to the SSL VPN server, you can view the following pages: Connection Status
page, Configuration Management page, Connection Log page, System Configuration page, and About
Us page.

Connection Status
Click Status at the bottom of the page to enter into the Connection Status page and it displays the
statistics and routing information:


The Connection Time: Time period during which the client is online.



Received Bytes: Shows the received bytes through the SSL VPN tunnel.



Sent Bytes: Shows the sent bytes through the SSL VPN tunnel.



Server: Shows the IP address or the server name of the device that client connects to.



Port: Shows the HTTPs port number of the device.



Account: Shows the username that logs into the VPN instance.



Private Server Address: Shows the interface’s IP address of the device that the client
connects to.



Client Private Address: Shows the IP address of the interface. This interface transmits
the encrypted traffic and this IP address is assigned by the SSL VPN server.



Address Mask: Shows the netmask of the IP address of the interface. This interface
transmits the encrypted traffic.
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DNS Address: Shows the DNS Address used by the client.



Routing Information: Shows the routing information for transmitting encrypted data.



Disconnection Connection: Click this button to disconnect the current connection with
the server.

Configuration Management
Click VPN at the bottom of the page to enter into the Configuration Management page. In this page,
you can perform the following operations:


Add/Edit/Delete a login entry



Modify the login password



Disconnect the connection with SSL VPN server



Connect to the SSL VPN server

Adding a Login Entry
To facilitate the login process, you can add a login entry that stores the login information. The added
login entry will display in the drop-down list of Please Choose in the login page. You can select a login
entry and the login information will be filled in automatically.
To add a login entry, take the following steps:
1.

In the Configuration Management page, click the

2.

In the pop-up window, enter the following information:
a.
b.

3.

icon at the top-right corner.

Connection Name: Enter a name as an identifier for this login entry
Server: Enter the IP address or the server name of the device that acts as the
VPN server.

c.

Port: Enter the HTTPs port number of the device.

d.

Username: Enter the username for logging into the VPN.

Click Confirm to save this login entry.

Editing a Login Entry
To edit a login entry, take the following steps:
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1.

In the login entry list, click the one that you want to edit and several buttons will appear.

2.

Click Edit to make the Edit Configuration dialog box appear.

3.

In the dialog box, edit the login entry.

4.

Click Confirm to save the modifications.

Deleting a Login Entry
To delete a login entry, take the following steps:
1.

In the login entry list, click the one that you want to delete and several buttons will
appear.

2.

Click Delete.

3.

Click Yes in the pop-up dialog box to delete this login entry.

Modifying the Login Password
To modify the login password, take the following steps:
1.

In the login entry list, click the one that you want to modify the password and several
buttons will appear.

2.

Click Modify Password.

3.

Enter the current password and new password in the pop-up dialog box.

4.

Click Confirm to save the settings.

Disconnecting the Connection or Logging into the Client
To disconnect the connection or log into the client, take the following steps:
1.
2.

3.
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In the login entry list, click a login entry and several buttons will appear.
If the connection status to this server is disconnected, you can click Login to log into the
client; if the connection status is connected, you can click Disconnect Connection to
disconnect the connection.
In the pop-up dialog box, confirm your operation.
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Connection Log
Click Log at the bottom of the page to enter into the Configuration Log page. In this page, you can view
the logs.

System Configuration
Click Config at the bottom of the page to enter into the System Configuration page. In this page, you
can configure the following options:


Auto Reconnect: After turning on this switch, the client wil automatically reconnect to
the server if the connection is disconnected unexpectedly.



Show Notify: After turning on this switch, the client icon will display in the notification
area.



Allow To Sleep: After turning on this switch, the client can stay connected while the
Android system is in the sleep status. With this switch turned off, the client might disconnect the
connection and cannot stay connected for a very long time while the Android system is in the
sleep status.



Auto Login: After turning on this switch, the client will automatically connect to the
server when it starts. The server is the one that the client connects to the last time.



Remember The Password: After turning on this switch, the client wil remember the
password and automatically fill in the login entry.



Exit: Click Exit to exit this application.

About Us
Click About at the bottom of the page to enter the About US page. This page displays the version
information, contact information, copyright information, etc.

L2TP VPN
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
L2TP (Layer Two Tunneling Protocol) is a VPDN technique that allows dial-up users to launch VPN
connection from L2TP clients or L2TP access concentrators (LAC), and connect to a L2TP network
server (LNS) via PPP. After the connection has been established successfully, LNS will assign IP
addresses to legal users and permit them to access the private network.
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The device acts as a LNS in the L2TP tunnel network. The device accepts connections from L2TP
clients or LACs, implements authentication and authorization, and assigns IP addresses, DNS server
addresses and WINS server addresses to legal users.
L2TP does not encrypt the data transmitted through the tunnel, so it cannot assure security during the
transmission. You can use L2TP in combination with IPsec, and encrypt data by IPSec, thus assuring the
security during the data transmitted through the L2TP tunnel.

Configuring an L2TP VPN
To create an L2TP VPN instance, take the following steps:
1.

Select Network > VPN > L2TP VPN.

2.

In the L2TP VPN page, click New.

In the Name/Access User tab, configure the corresponding options.
Option

Description

L2TP VPN
Name

Type the name of the L2TP VPN instance

Assigned Users
AAA Server
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Select an AAA server from the AAA Server drop-down list. You
can click View AAA Server to view the detailed information of
this AAA server.
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Option

Description

Domain

Type the domain name into the Domain box. The domain name
is used to distinguish the AAA server.

Verify User
After this function is enable, system will verify the username and
Domain Name its domain name.
Add

Click Add to add the assigned users. You can repeat to add more
items.

In the Interface/Address Pool/IPSec Tunnel tab, configure the corresponding options.
Access Interface
Egress
Interface
Tunnel

Select the interface from the drop-down list as the L2TP VPN
server interface. This interface is used to listen to the request
from L2TP clients.
Interface

Tunnel
Interface

Information

Specifies the tunnel interface used to bind to the L2TP VPN
tunnel. Tunnel interface transmits traffic to/from L2TP VPN
tunnel.


Select a tunnel interface from the drop-down list,
and then click Edit to edit the selected tunnel interface.



Click New in the drop-down list to create a new
interface.

Shows the zone, IP address, and netmask of the selected tunnel
interface.

Address Pool
Address Pool

Specifies the L2TP VPN address pool.


Select an address pool from the drop-down list,
and then click Edit to edit the selected address pool.



Click New in the drop-down list to create a new
address pool.

For more information about creating/editing address pools, see
"Configuring an L2TP VPN Address Pool" .
Information
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Shows the start IP address, end IP address, and mask of the
address pool.
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L2TP over IPSec
L2TP over
IPSec

3.

Select a referenced IPSec tunnel from the drop-down list. L2TP
does not encrypt the data transmitted through the tunnel, so it
cannot assure security during the transmission. You can use
L2TP in combination with IPSec, and encrypt data by IPSec,
thus assuring the security for the data transmitted through the
L2TP tunnel..

If necessary, click Advanced Configuration to configure the advanced functions.
In the Parameters tab, configure the corresponding options.
Security
Tunnel
Click Enable to enable tunnel authentication to assure the security of
Authenticat the connection. The tunnel authentication can be launched by either
ion
LNS or LAC. The tunnel cannot be established unless the both ends
are authenticated, i.e., the secret strings of the two ends are
consistent.
AVP
Hidden

Click Enable to enable AVP hidden. L2TP uses AVP (attribute value
pair) to transfer and negotiate several L2TP parameters and
attributes. By default AVP is transferred in plain text. For data
security consideration, you can encrypt the data by the secret string
to hide the AVP during the transmission.

Secret

Specifies the secret string that is used for LNS tunnel authentication.

Peer

Specifies the host name of LAC. If multiple LACs are connected to
LNS, you can specify different secret strings for different LACs by
this parameter.

Add

Click Add to add the configured secret and peer name pair to the
list.

Client Connection
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Accept
Client IP

Click Enable to allow the accepting of IP address specified by the
client. By default the client IP is selected from the address pool, and
allocated by LNS automatically. If this function is enabled, you can
specify an IP address. However, this IP address must belong to the
specified address pool, and be consistent with the username and role.
If the specified IP is already in use, system will not allow the user to
log on.

Multiple
Login

Click Enable to allow a user to log on and be authenticated on
different hosts simultaneously.
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Hello
Interval

Specifies the interval at which Hello packets are sent. LNS sends
Hello packets to the L2TP client or LAC regularly, and will drop the
connection to the tunnel if no response is returned after the specified
period.

LNS Name Specifies the local name of LNS.
Tunnel
Windows

Specifies the window size for the data transmitted through the
tunnel.

Control
Packet
Transmit
Retry

Specifies the retry times of control packets. If no response is received
from the peer after the specified retry times, system will determine
the tunnel connection is disconnected.

PPP Configuration
LCP
Interval
Transmit
Retries

Specifies parameters for LCP Echo packets used for PPP
negotiation. The options are:


Interval: Specifies the interval at which LCP Echo
packets are sent.



Transmit Retry: Specifies the retry times for sending
LCP Echo packets. If LNS has not received any response
after the specified retry times, it will determine the
connection is disconnected.

PPP
Specifies a PPP authentication protocol. The options are:
Authenticat

PAP: Uses PAP for PPP authentication.
ion

4.



CHAP: Uses CHAP for PPP authentication. This is
the default option.



Any: Uses CHAP for PPP authentication by default.
If CHAP is not supported, then uses PAP.

Click Done to save the settings.

Configuring an L2TP VPN Address Pool
LNS assigns the IP addresses in the address pool to users. After the client has established a connection
to LNS successfully, LNS will choose an IP address along with other related parameters (such as DNS
server address, WINS server address, etc) from the address pool, and assign them to the client.
L2TP provides fixed IP addresses by creating and implementing IP binding rules.
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The static IP binding rule binds the client user to a fixed IP address in the address pool.
Once the client has established a connection successfully, system will assign the binding IP to the
client.



The IP-role binding rule binds the role to a specific IP range in the address pool. Once
the client has established a connection successfully, system will assign an IP address within the
IP range to the client.

When LNS is allocating IP addresses in the address pool, system will check the IP binding rule and
determine how to assign IP addresses for the client based on the specific checking order below:
Notes: The IP addresses defined in the static IP binding rule and IP-role binding rule should not be
overlapped.
To create an address pool, take the following steps:
1.

Select Network > VPN > L2TP VPN.

2.

At the top-right corner, click Address Pool.

3.

In the pop-up window, click New.
In the Basic Configuration tab, configure the corresponding options.
Option

Description

Address Pool
Name

Specifies the name of the address pool.

Start IP

Specifies the start IP of the address pool.

End IP

Specifies the end IP of the address pool.

Reserved Start Specifies the reserved start IP of the address pool.
IP
Reserved End Specifies the reserved end IP of the address pool.
IP
DNS1/2

Specifies the DNS server IP address for the address pool. It is
optional. Up to 2 DNS servers can be configured for one address
pool.

WINS1/2

Specifies the WIN server IP addresses for the address pool. It is
optional. Up to 2 WIN servers can be configured for one address
pool.

In the IP User Binding tab, configure the corresponding options.
Option
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User

Type the user name into the User box.

IP

Type the IP address into the IP box.

Add

Click Add to add this IP user binding rule.

Delete

To delete a rule, select the rule you want to delete from the list
and click Delete.

In the IP Role Binding tab, configure the corresponding options.
Option

Description

Role

Type the role name into the Role box.

Start IP

Type the start IP address into the Start IP box.

End IP

Type the end IP address into the End IP box.

Add
Delete

Click Addto add this IP role binding rule.
To delete a rule, select the rule you want to delete from the list
and click Delete.

Up/Down/Top/ System will query for IP role binding rules by turn, and allocate
Bottom
the IP address according to the first matched rule. You can
move the location up or down at your own choice to adjust the
matching sequence accordingly.
4.

Click OK to save the settings.

Viewing L2TP VPN Online Users
To view the L2TP VPN online users, take the following steps:
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1.

Select Network > VPN > L2TP VPN.

2.

Select an L2TP VPN instance.

3.

View the detailed information of the online users in the table.
Option

Description

Name

Displays the name of L2TP VPN.

Login Time

Displays the login time of the L2TP VPN online user.

Public IP

Displays the public IP of the L2TP VPN online user.

Private IP

Displays the private IP of the L2TP VPN online user.

Operation

Displays the executable operation of the L2TP VPN online user.
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Chapter 9 Object
This chapter describes the concept and configuration of objects that will be referenced by other modules
in system, including:


"Address" : Contains address information, and can be used by multiple modules, such as
policy rules, NAT rules, QoS, session limit rules, etc.



"Host Book" : A collection of one domain name or several domain names.



"Service Book" : Contains service information, and can be used by multiple modules,
such as policy rules, NAT rules, QoS, etc.



"Application Book" : Contains application information, and it can be used by multiple
modules, such as policy rules, NAT rules, QoS, etc.




"SLB Server Pool ": Describes SLB server configurations.
"Schedule" : Specifies a time range or period. The functions (such as policy rules, QoS
rules, host blacklist, connections between the PPPoE interface and Internet) that use the
schedule will take effect in the time range or period specified by the schedule.



"AAA Server" : Describes how to configure an AAA server.



"User" : Contains information about the functions and services provided by a device, and
users authenticated and managed by the device.



"Role" : Contains role information that associates users to privileges. In function
configurations, different roles are assigned with different services. Therefore, the mapped users
can gain the corresponding services as well.



"Track Object" : Tracks if the specified object (IP address or host) is reachable or if the
specified interface is connected. This function is designed to track HA and interfaces.



"URL Filtering": URL filter controls the access to some certain websites and records log
messages for the access actions.



"NetFlow" : Collect the user's incoming traffic information according to the NetFlow
profile, and send it to the server with NetFlow data analysis tool.
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Address
IP address is an important element for the configurations of multiple modules, such as policy rules,
NAT rules and session limit rules. Therefore, system uses an address book to facilitate IP address
reference and flexible configuration. You can specify a name for an IP range, and only the name is
referenced during configuration. The address book is the database in system that is used to store the
mappings between IP ranges and the corresponding names. The mapping entry between an IP address
and its name in the address book is known as an address entry.
System provides a global address book. You need to specify an address entry for the global address book.
When specifying the address entry, you can replace the IP range with a DNS name. Interfaces of the
configured IPs will be used as address entries and added to the address book automatically. You can use
them for NAT conveniently. Furthermore, an address entry also has the following features:


All address books contain two default address entries named Any and private_network.
The IP address of Any is 0.0.0.0/0, which is any IP address. Any can neither be edited nor
deleted. The IP addresses of private_network are 10.0.0.0/8, 172.16.0.0/12, 192.168.0.0/16, that
all private network address. The private_network can be edited and deleted.



One address entry can contain another address entry in the address book.



If the IP range of an address entry changes, FSOS will update other modules that
reference the address entry automatically.

Address book supports IPv4 and IPv6 address. If IPv6 is enabled, you can configure IPv6 address entry.

Creating an Address Book
To create an address book, take the following steps:
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1.

Click Object>Address Book.

2.

Click New.
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In Address Book Configuration dialog box, enter the address entry configuration.
Basic
Name

Type the address entry name into the Name box.

Type

Select the IP type, including IPv4 or IPv6. Only the IPv6
firmware supports to configure IPv6 type IP. If IPv6 is
selected, all the IP/ netmask, IP range, address entry
configured should be in the IPv6 format.

Member
Member

Select an address entry member from the drop-down list, and
configure IP/netmask, IP range, Host name， Address entry，
or Country/Region as needed.


The Country/Region member is supported in the
address entry of the IPv4 type.



Only the security policy and the policy-based
route support the address entry with the Country/Region
member added.



The address entry with the Country/Region
member added does not support the Excluded Member
settings.

Add

Click Add to add the configured member to the list below. If it is
needed, repeat the above steps to add more members.

Delete

Delete the selected address entry from the list.

Excluded Member
Member
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Specify the excluded member. Select an address entry member
from the drop-down list, and configure IP/netmask, IP range,
Host name or Address entry as needed.
Note: Excluded members' address range need to be in the
address range of the members, otherwise the configuration
cannot be completed.

Add

Click Add to add the configured excluded member to the list
below. If needed, repeat the above steps to add more excluded
members.

Delete

Delete the selected excluded member entry from the list.
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3.

Click OK.

Viewing Details
To view the details of an address entry, take the following steps, including the name, member,
description and reference:
1.
2.

Click Object>Address Book.
In the Address Book dialog box, select an address entry from the member list, and view
the details under the list.

Host Book
You can specify a name to be a collection of one domain name or several domain names, and reference
this host book when configuring. Host book is the database to store the relationships of domain
integrations and the specified names in system.
The entry of the relationship of domain integrations and the specified name is called host entry.
Notes:


The maximum number of host entries is one fourth of the maximum number of address
entries.



Up to one host entry can be configured for each PBR rule.

Creating a Host Book
To create a host book, take the following steps:
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1.

Select Object > Host Book.

2.

Click New.
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Configure the following options.

3.

Option

Description

Name

Type a name for the host book.

Member

Specifies the host entry member. Enter IP address or domain
name in the Member text box and then click Add. If needed, you
can add multiple host entries in the host book. Select the host
entry you want to delete and click Delete, then the selected entry
will be removed.

Description

Type the description of host book.

Click OK.

Service Book
Service is an information stream designed with protocol standards. Service has some specific
distinguishing features, like corresponding protocol, port number, etc. For example, the FTP service
uses TCP protocol, and its port number is 21. Service is an essential element for the configuration of
multiple FSOS modules including policy rules, NAT rules, QoS rules, etc.
System ships with multiple predefined services/service groups. Besides, you can also customize userdefined services/service groups as needed. All these service/service groups are stored in and managed
by FSOS service book.

Predefined Service/Service Group
System ships with multiple predefined services, and identifies the corresponding application types based
on the service ports. The supported predefined services may vary from different device models.
Predefined service groups contain related predefined services to facilitate user configuration.

User-defined Service
Except for the above predefined services, you can also create your own user-defined services easily. The
parameters that will be specified for the user-defined service entries include:


Name



Protocol type



The source and destination port for TCP or UDP service, and the type and code value
for ICMP service.
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User-defined Service Group
You can organize some services together to form a service group, and apply the service group to FSOS
policies directly to facilitate management. The service group has the following features:


Each service of the service book can be used by one or more service groups.



A service group can contain both predefined services and user-defined services.



A service group can contain another service group. The service group of FSOS supports
up to 8 layers of nests.

The service group also has the following limitations:


The name of a service and service group should not be identical.



A service group being used by any policy cannot be deleted. To delete such a service
group, you must first end its relationship with the other modules.



If a user-defined service is deleted from a service group, the service will also be deleted
from all of the service groups using it.

Configuring a Service Book
This section describes how to configure a user-defined service and service group.

Configuring a User-defined Service
1.

Select Object > Service Book > Service.

2.

Click New.

Configure the following options.

www.fs.com

254

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

Service Configuration
Service
Member

Type the name for the user-defined service into the textbox.
Specify a protocol type for the user-defined service. The available
options include TCP, UDP, ICMP and Others. If needed, you
can add multiple service items.
Click New and the parameters for the protocol types are
described as follows:
TCP/UDP

Destination port:


Min - Specifies the minimum
port number of the specified service
entry.



Max - Specifies the maximum
port number of the specified service
entry. The value range is 0 to 65535.

Source port:


Min - Specifies the minimum
port number of the specified service
entry.



Max - Specifies the maximum
port number of the specified service
entry. The value range is 0 to 65535.

Notes: The minimum port number cannot
exceed the maximum port number.
ICMP

Type: Specifies an ICMP type for the service
entry. The value range is 3 (DestinationUnreachable), 4 (Source Quench), 5 (Redirect),
8 (Echo), 11 (Time Exceeded), 12 (Parameter
Problem), 13 (Timestamp) and 15
(Information).
Min Code: Specifies a minimum value for
ICMP code. The value range is 0 to 5.
Max Code: Specifies a maximum value for
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Service Configuration
ICMP code. The value range is 0 to 5.
Notes: The minimum port number cannot
exceed the maximum port number.
Others
Description

3.

Protocol: Specifies a protocol number for the
service entry. The value range is 1 to 255.

If it's needed, type the description for the service into the text
box.

Click OK.

Configuring a User-defined Service Group
1.

Select Object > Service Book > Service Group.

2.

Click New.

Configure the following options.
Service Group Configuration
Name

Type the name for the user-defined service group into the text
box.

Description

If needed, type the description for the service into the text box.

Member Type

Add services or service groups to the service group. System
supports at most 8-layer nested service group.
Expand Pre-defined Service or User-defined Service from the
left pane, select services or service groups, and then click Add to
add them to the right pane. To remove a selected service, select
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Service Group Configuration
it from the right pane, and then click Remove.
3.

Click OK.

Viewing Details
To view the details of a service entry, take the following steps, including the name, protocol, destination
port and reference:
1.
2.

Click Object>Service Book > Service.
In the service dialog box, select an address entry from the member list, and view the
details under the list.

Application Book
Application has some specific features, like corresponding protocol, port number, application type, etc.
Application is an essential element for the configuration of multiple device modules including policy
rules, NAT rules, application QoS management, etc.
System ships with multiple predefined applications and predefined application groups. Besides, you can
also customize user-defined application and application groups as needed. All of these applications and
applications groups are stored in and managed by FSOS application book.
If IPv6 is enabled, IPv6 applications will be recognized by FSOS..

Editing a Predefined Application
You can view and use all the supported predefined applications and edit TCP timeout, but cannot delete
any of them. To edit a predefined application, take the following steps:
1.

Select Object > APP Book > Application.

2.

Select the application you want to edit from the application list, and click Edit.

3.

In the Application Configuration dialog box, edit TCP timeout for the application.

Creating a User-defined Application
You can create your own user-defined applications. By configuring the customized application signature
rules, system can identify and manage the traffic that crosses into the device, thus identifying the type of
the traffic.
To create a user-defined application, take the following steps:
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1.

Select Object > APP Book > Application.

2.

Click New.

Configure the following options.
Option

Description

Name

Specify the name of the user-defined application.

Description

Specify the description of the user-defined application.

Timeout

Configure the application timeout value. If not, system will use
the default value of the protocol.

Signature

Select the signature of the application and then click Add.
To create a new signature, see "Creating a Signature Rule" .

3.

Click OK.

Creating a User-defined Application Group
To create a user-defined application group, take the following steps:
1.

Select Object > APP Book > Application Groups

2.

Click New.
Configure the following options.
Option

Description

Name

Specifies a name for the new application group.

Description

Specifies the description for the application group.

Member

www.fs.com

Add applications or application groups to the application group.
System supports at most 8-layer nested application group.
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Option

Description
Expand Application or Application Group from the left pane,
select applications or application groups, and then click Add to
add them to the right pane. To remove a selected application or
application group, select it from the right pane, and then click
Remove.

3.

Click OK.

Creating an Application Filter Group
Application Filter Group allows you to create a group to filter applications according to application
category, sub-category, technology, risk, and attributes.
To create an application filter group, take the following steps:
1.

Select Object > APP Book > Application Filters.

2.

Click New.

3.

Type an application filter group name in the Name text box.

4.

5.

Specifies the filter condition. Choose the category, subcategory, technology, risk and
characteristic by sequence in the drop-down list. You can click Clear Filter to clear all the
selected filter conditions according to your need.
Click OK.

Creating a Signature Rule
By configuring the customized application signature rules, system can identify and manage the traffic
that crosses into the device. When the traffic matches all of the conditions defined in the signature rule,
it hits this signature rule. Then system identifies the application type.
If IPv6 is enabled, traffic of IPv6 address will be recognized by FSOS..
To create a new signature rule, take the following steps:
1.

Select Object > APP Book > Static Signature Rule.

2.

Click New.
Configure the following options.

www.fs.com

Option

Description

Type

Select the IP address type, including IPv4 or IPv6.
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Option

Description
Only the IPv6 firmware supports to configure IPv6 type IP. If
IPv6 is selected, traffic of IPv6 address will be recognized by
FSOS.

Source
Zone

Specify the source security zone of the signature rule.

Address

Specify the source address. You can use the Address Book type
or the IP/Netmask type.

Destination
Address

Specify the source address. You can use the Address Book type
or the IP/Netmask type.

Protocol
Enable
Type

Select the Enable check box to configure the protocol of the
signature rule.
When selecting TCP or UDP,

Destination Port: Specify the destination port
number of the user-defined application signature. If the
destination port number is within a range, system will
identify the value of min-port as the minimum port
number and identify the value of max-port as the
maximum port number. The range of destination port
number is 0 to 66535. The port number cannot be 0. For
example, the destination port number is in the range of 0
to 20, but it cannot be 0.

Source Port: Specify the source port number of
the user-defined application signature. If the source port
number is within a range, system will identify the value of
min-port as the minimum port number and identify the
value of max-port as the maximum port number. The
range of source port number is 0 to 66535.
When selecting ICMP:

Type: Specify the value of the ICMP type of the
application signature. The options are as follows: 3
(Destination-Unreachable), 4 (Source Quench)， 5

www.fs.com
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Option

Description
(Redirect), 8 (Echo), 11 (Time Exceeded), 12 (Parameter
Problem), 13 (Timestamp), 15 (Information), and any
(any represents all of the above values).

Min Code: Specify the value of the ICMP code of
the application signature. The ICMP code is in the range
of 0 to 5. The default value is 0-5.
When selecting Others:

Protocol: Specifies the protocol number of the
application signature. The protocol number is in the
range of 1 to 255.

Action
App-Signature Select Enable to make this signature rule take effect after the
Rule
configurations. Otherwise, it will not take effect.
Continue
Dynamic
Identification

3.

Without selecting this check box, if the traffic satisfies the userdefined signature rule and system has identified the application
type, system will not continue identifying the application. To be
more accurate, you can select this check box to set the system to
continue dynamically identification.

Click OK.

Viewing Details
To view the details of an application entry, including the name, category, risk and reference, take the
following steps:
1.
2.

Click Object>APP Book > Application.
In the application dialog box, select an address entry from the member list, and view the
details under the list.

SLB Server Pool
The SLB function uses the load balancing algorithm to distribute the traffic and this utilizes the
resources of the intranet servers. You can use the following methods to balance the server load:

www.fs.com
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Distribute the traffic to the specified port of each intranet server. This is applicable to the
scenario that different intranet servers provide the same service via specified port at the same
time.



Distribute the traffic to different ports of an intranet server. This is applicable to the
scenario that an intranet server provides the same service by running the same process at
different ports.



Combine the above two methods.

Configuring SLB Server Pool and Track Rule
To configure an SLB server pool and track rule, take the following steps:
1.

Select Object > SLB Server Pool.

2.

Click New. The SLB Server Pool Configuration dialog box appears.

In the SLB Server Pool Configuration dialog box, configure the following options.
Option

Description

Name

Specifies the name of the SLB server pool

Algorithm

Select an algorithm for load balancing.

Member
Member

Port
Maximum
Sessions

Weight

www.fs.com

Specifies the member of the pool. You can type the IP range or
the IP address and the netmask.
Specifies the port number of the server.
Specifies the allowed maximum sessions of the server. The value
ranges from 0 to 1,000,000,000. The default value is 0, which
represents no limitation.
Specifies the traffic forwarding weight during the load balancing.
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Option

Description
The value ranges from 1 to 255.

Add

Add the SLB address pool member to the SLB server pool. You
can add up to 256 members.

Track
Track Type
Port

Selects a track type.
Specifies the port number that will be tracked. The value ranges
from 0 to 65535.

When the members in the SLB server pool have
the same IP address and different ports, you don’t
need to specify the port when configuring the track rule.
System will track each IP address and its port in the SLB
server pool.

When there is a member whose port is not
configured exists in the SLB sever pool, you must specify
the port when configuring the track rule. System will
track the specified port of the IP addresses in the SLB
server pool.

When the members in the SLB server pool are all
configured with IP addresses and ports and these
configured IP addresses are different from each other,
you can select whether to specify the port when
configuring the track rule. If specified, system will track
the specified port of these IP addresses. If not, system
will track the configured ports of the IP addresses of the
members.

Interval

Retries
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Specifies the interval between each Ping/TCP/UDP packet. The
unit is second. The value ranges from 3 to 255.
Specifies a retry threshold. If no response packet is received after
the specified times of retries, System will determine this track
entry fails, i.e., the track entry is unreachable. The value range is
1 to 255.
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Option
Weight

Add
Threshold

Description
3.

Description
Specifies a weight for the overall failure of the whole track rule if
this track entry fails. The value range is 1 to 255.
Click Add to add the configured track rule to the list.
Types the threshold for the track rule into the Threshold box.
The value range is 1 to 255. If the sum of weights for failed
entries in the track rule exceeds the threshold, system will
conclude that the track rule fails.
Types

the description for this track rule.

Click OK to save the settings.

Viewing Details of SLB Pool Entries
To view the details of the servers in the SLB pool, take the following steps:
1.

Click Object > SLB Server Pool.

2.

Select an SLB pool entry.

3.

In the Server List tab at the bottom of this page, view the information of the servers that
are in this SLB pool.

4.

In the Monitoring tab, view the information of the track rules.

5.

In the Referenced tab, view the DNAT rules that use the SLB pool.

Schedule
System supports a schedule. This function allows a policy rule to take effect in a specified time and
controls the duration of the connection between a PPPoE interface and the Internet. The schedule
consists of a periodic schedule and an absolute schedule. The periodic schedule specifies a time point or
time range for periodic schedule entries, while the absolute schedule decides a time range in which the
periodic schedule will take effect.

Periodic Schedule
Periodic schedule is the collection of periods specified by all of the schedule entries within the schedule.
You can add up to 16 schedule entries to a periodic schedule. These entries can be divided into 3 types:


www.fs.com

Daily: The specified time of every day, such as Everyday 09:00 to 18:00.
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Days: The specified time of a specified day during a week, such as Monday Tuesday
Saturday 09:00 to 13:30.



Period: A continuous period during a week, such as from Monday 09:30 to Wednesday
15:00.

Absolute Schedule
An absolute schedule is a time range in which a periodic schedule will take effect. If no absolute
schedule is specified, the periodic schedule will take effect as soon as it is used by some module.

Creating a Schedule
To create a schedule, take the following steps:
1.

Select Object > Schedule.

2.

Click New.

Configure the following options.
Schedule Configuration Dialog Box
Name
Add

Specifies a name for the new schedule.
Specifies a type for the periodic schedule in Add Periodic
Schedules section.
Type
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Daily - The specified time of every
day. Click this radio button, and then, in the
Time section, select a start time and end
time from the Start time and End time dropdown list respectively.
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Schedule Configuration Dialog Box

Preview

3.



Days - The specified time of a
specified day during a week. Click this radio
button, and then select a day/days in the
Days and Time section, and finally select a
start time and end time from the Start time
and End time drop-down list respectively.



Duration - A continuous period
during a week. Click this radio button, and
then in the Duration section select a start
day/time and end day/time from the Start
time and End time drop-down list
respectively.

Preview the detail of the configured periodic
schedule in the Preview section.

Delete

Select the entry you want to delete from the period schedule list
below, and click Delete.

Absolute
Schedule

The absolute schedule decides a time range in which the periodic
schedule will take effect. Without configuring an absolute
schedule, the periodic schedule will take effect as soon as it is
used by some module.

Click OK.

AAA Server
An AAA server is a server program that handles user requests to access computer resources, and for an
enterprise, this server provides authentication, authorization, and accounting (AAA) services. The AAA
server typically interacts with network access and gateway servers and with databases and directories
containing user information.
Here in system, authentication supports the following five types of AAA server:


Local server: a local server is the firewall itself. The firewall stores user identity
information and handles requests. A local server authentication is fast and cheap, but its storage
space is limited by the firewall hardware size.
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External servers:
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Radius Server



LDAP Server



Active-Directory Server



TACACS+ Server

According to the type of authentication, you need to choose different AAA servers:


"802.1x" and "Configuring IPSec-XAUTH Address Pool" : Only local and Radius
servers support these two types of authentication.



Other authentication methods mentioned in this guide: all four servers can support the
other authentication methods.

Configuring a Local AAA Server
1.

Select Object > AAA Server.

2.

Click New > Local Server, the Local Server Configuration dialog box prompts.
In the prompt, configure the following.
Option

Description

Name

Type the name for the new server into the text box.

Role mapping Specifies a role mapping rule for the server. With this option
rule
selected, system will allocate a role for the users who have been
authenticated to the server according to the specified role
mapping rule.
Change
Password

If needed, select the Enable checkbox. With this function
enabled, system allows users to change their own passwords after
the successful WebAuth or SCVPN authentication.

Backup
To configure a backup authentication server, select a server
Authentication from the drop-down list. After configuring a backup
Server
authentication server for the local server, the backup
authentication server will take over the authentication task when
the primary server malfunctions or authentication fails on the
primary server. The backup authentication server can be any
existing local, Active-Directory, RADIUS or LDAP server
defined in system.
Password
Control

www.fs.com

To prevent account security problem caused by not changing
password for a long time, you can enable the password control
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Option

Description
function to set the password validity check, the password expiry
warning and the history password check.

Select the History Password Check check box to
enable the history password check function. With the
function, system will verify the new password with the
historical passwords when you change the password,
ensuring the new password is different from the
passwords set in the specified times.

Select the Validity Check check box to enable the
password validity check function and configure the valid
period of password.

Select the Password Expiry Warning check box
to enable the password expiry warning function and
configure the days how long users will be reminded of
password expiry before it expities.

3.

Click OK.

Configuring Radius Server
1.

Select Object > AAA Server, and select New > Radius Server.

2.

The Radius Sever dialog box opens.

In the prompt, configure the following.

www.fs.com
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Basic Configuration
Name

Specifies a name for the Radius server.

Server Address Specifies an IP address or domain name for the Radius server.
Virtual Router Specifies a VR for the Radius server.
Port

Specifies a port number for the Radius server. The value range is
1024 to 65535. The default value is 1812.

Secret

Specifies a secret for the Radius server. You can specify at most
31 characters.

Optional
Role mapping Specifies a role mapping rule for the server. With this option
rule
selected, system will allocate a role for the users who have been
authenticated to the server according to the specified role
mapping rule.
Backup server Specifies an IP address or domain name for backup server 1 or
1/ Backup
backup server 2.
server 2
Virtual
Router1/
Virtual
Router2

Specifies a VR for the backup server.

Retries

Specifies a retry time for the authentication packets sent to the
AAA server. The value range is 1 to 10. The default value is 3.

Timeout

Specifies a timeout for the server response. The value range is 1
to 30 seconds. The default value is 3.

Backup
Specifies a backup authentication server. After configuring a
Authentication backup authentication server for the Radius server, the backup
Server
authentication server will take over the authentication task when
the primary server malfunctions or authentication fails on the
primary server. The backup authentication server can be any
existing local, Active-Directory, RADIUS or LDAP server
defined in system.
Enable
Accounting

Select the Enable checkbox to enable accounting for the Radius
server, and then configure options in the sliding out area.
Server
Address

www.fs.com

Specifies an IP address or domain name for the
accounting server.
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Basic Configuration
Virtual
Router

Specifies a VR for the accounting server.

Port

Specifies a port number for the accounting server.
The value range is 1024 to 65535. The default value
is 1813.

Password

Specifies a password for the accounting server.

Backup
server
1/Backup
server 2

Specifies an IP address or domain name for backup
server 1 or backup server 2.

Virtual
Specifies a VR for the backup server.
Router1/Vi
rtual
Router2
3.

Click OK.

Configuring Active Directory Server
1.

Select Object > AAA Server, and then select New > Active Directory Server.

2.

The Active Directory Server dialog box opens.

In the prompt, configure the following.
Basic Configuration
Name

www.fs.com

Specifies a name for the Active Directory server.
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Basic Configuration
Server
Address

Specifies an IP address or domain name for the Active Directory
server.

Virtual
Router

Specifies a VR for the Active Directory server.

Port

Specifies a port number for the Active Directory server. The value
range is 1 to 65535. The default value is 389.

Base-dn

Specifies a Base-dn for the AD server. The Base-dn is the starting
point at which your search will begin when the AD server receives
an authentication request.
For the example of abc.xyz.com as described above, the format for
the Base-dn is "dc=abc,dc=xyz,dc=com".

Login-dn

Specifies authentication characteristics for the Login-dn (typically a
user account with query privilege pre-defined by the AD server).
When the authentication mode is plain, the Login-dn should be
configured. DN (Distinguished name) is a username of the AD
server who has a privilege to read user information. The format of
the DN is"cn=xxx, DC=xxx,...". For example, the server domain is
abc.xyz.com, and the AD server admin name is administrator who
locates in Users directory. Then the login-dn should be
"cn=administrator,cn=users,dc=abc,dc=xyz,dc=com".

sAMAccount
When the authentication mode is MD5, the sAMAccountName
Name
should be configured. sAMAccountName is a username of the AD
server who has a privilege to read user information. The format of
sAMAccountName is "xxx". For example, the AD server admin
name is administrator , and then the sAMAccountName should be
"administrator".
Authenticatio
Specifies an authentication or synchronization method (either plain
n Mode
text or MD5). The default method is MD5.
If the sAMAccountName is not configured after you specify the
MD5 method, the plain method will be used in the process of
synchronizing user from the server, and the MD5 method will be
used in the process of authenticating the user.

www.fs.com

271

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

Basic Configuration
Password

Specifies a password for the AD server.

Optional
Role
Mapping
Rule

Specifies a role mapping rule for the server. With this option
selected, system will allocate a role for users who have been
authenticated to the server according to the specified role mapping
rule.

Backup
server
1/Backup
server 2

Specifies an IP address or domain name for backup server 1 or
backup server 2.

Virtual
Specifies a VR for the backup server.
Router1/Virt
ual Router2
Authenticatio Specifies an authentication Base-dn for the AD server. All users in
n Base-DN the Base-DN (including those directly under the user group) will be
allowed to pass the authentication. The format of the DN
is"OU=xxx, DC=xxx,...".
Synchronizati Specifies a Synchronization Base-dn for the AD server. All users
on Base-DN and user groups in the Base-DN will be synchronized to the local.
The format of the DN is"OU=xxx, DC=xxx,...".
Synchronizati Check the checkbox to enable the synchronization function; clear
on
the checkbox to disable the synchronization function, and the
system will stop synchronizing and clear the existing user
information. By default, system will synchronize the user
information on the configured Active-Directory server with the
local server every 30 minutes.
Automatic
Click the radio button to specify the automatic synchronization.
Synchronizati Interval
Specifies the time interval for automatic
on
Synchronization synchronization. The value range is 30 to 1440
minutes. The default value is 30.
Daily
Specifies the time when the user information is
Synchronization synchronized everyday. The format is HH:MM,
HH and MM indicates hour and minute
respectively.
Once
If this parameter is specified, system will
Synchronization
synchronize automatically when the
www.fs.com
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Basic Configuration
configuration of Active-Directory server is
modified. After executing this command ,
system will synchronize the user information
immediately.
Synchronous Specifies user synchronization mode, including Group
Operation
Synchronization and OU Synchronization. By default, the user
Mode
information will be synchronized with the local server based on the
group.
OU
maximum
depth

User Filter

Security
Agent
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Specifies the maximum depth of OU to be synchronized. The
value range is 1 to 12, and the default value is 12.
OU structure that exceeds the maximum depth will not be
synchronized, but users that exceed the maximum depth will be
synchronized to the specified deepest OU where they belong to. If
the total characters of the OU name for each level(including the
“OU=” string and punctuation) is more than 128, OU
information that exceeds the length will not be synchronized with
the local server.
Specifies the user-filter conditions. System can only synchronize
and authenticate users that are in accordance with the filtering
condition on the authentication server. The length is 0 to 120
characters. For example, if the condition is configured to
“memberOf=CN=Admin,DC=test,DC=com”, system only can
synchronize or authenticate user whose DN is
“memberOf=CN=Admin,DC=test,DC=com”. The commonly
used operators are: =(equals a value)、&(and）、|(or)、!(not)、
*(Wildcard: when matching zero or more characters)、～=( fuzzy
query.)、>=Be greater than or equal to a specified value in
lexicographical order.)、<=( Be less than or equal to a specified
value in lexicographical order.).
Select the Enable check box to enable the Security Agent. With
this function enabled, system will be able to obtain the mappings
between the usernames of the domain users and IP addresses from
the AD server, so that the domain users can gain access to network
resources. In this way "Single Sign-On" is implemented. Besides,
by making use of the obtained mappings, system can also
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implement other user-based functions, like security statistics,
logging, behavior auditing, etc. To enable the Security Agent on the
AD server, you first need to install and run the Security Agent on
the server. Afterwards, when a domain user is logging in or logging
off, the Security Agent will log the user's username, IP address,
current time, and other information, and it will add the mapping
between the username and the IP address to system. In this way
the system can obtain every online user's IP address.
Agent Port Specify the monitoring port. FSOS communicates
with the AD Agent through this port. The range is
1025 to 65535. The default value is 6666. This port
must be matched with the configured port of AD
Agent, or system will fail to communicate with the
AD Agent.
Specifies the disconnection timeout. The value range
Disconnecti is 0 to 1800 seconds. The default value is 300. The
on Timeout value of 0 indicates never timeout.
Backup
Specifies a backup authentication server. After configuring a
Authenticatio backup authentication server for the Radius server, the backup
n Server
authentication server will take over the authentication task when
the primary server malfunctions or authentication fails on the
primary server. The backup authentication server can be any
existing local, Active-Directory, RADIUS or LDAP server defined
in system.
3.

Click OK.

Configuring LDAP Server
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1.

Select Object > AAA Server, and then select New > LDAP Server.

2.

The LDAP Server dialog box opens.
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In the prompt, configure the following.
Basic Configuration
Server Name

Specifies a name for the LDAP server.

Server Address Specifies an IP address or domain name for the LDAP server.
Virtual Router Specifies a VR for the LDAP server.
Port

Specifies a port number for the LDAP server. The value range is
1 to 65535. The default value is 389.

Base-dn

Specifies the details for the Base-dn. The Base-dn is the starting
point at which your search will begin when the LDAP server
receives an authentication request.

Login-dn

Specifies authentication characteristics for the Login-dn
(typically a user account with query privileges pre-defined by the
LDAP server).

Authid

Specifies the Authid, which is a string of 1 to 63 characters and is
case sensitive.

Authentication
Specifies an authentication or synchronization method (either
Mode
plain text or MD5). The default method is MD5.
If the Authid is not configured after you specify the MD5
method, the plain method will be used in the process of
synchronizing user from the server, and the MD5 method will be
used in the process of authenticating user.
Password
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Specifies a password for the LDAP server. This should
correspond to the password for Admin DN.
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Optional
Role Mapping Specifies a role mapping rule for the server. With this option
Rule
selected, system will allocate a role for the users who have been
authenticated to the server according to the specified role
mapping rule.
Backup server Specifies an IP address or domain name for backup server 1 or
1/Backup
backup server 2.
server 2
Virtual
Specifies a VR for the backup server.
Router1/Virtua
l Router2
Authentication Specifies an authentication Base-dn for the AD server. All users
Base-DN
in the Base-DN (including those directly under the user group)
will be allowed to pass the authentication. The format of the DN
is"OU=xxx, DC=xxx,...".
Synchronizatio Specifies a Synchronization Base-dn for the AD server. All users
n Base-DN
and user groups in the Base-DN will be synchronized to the
local. The format of the DN is"OU=xxx, DC=xxx,...".
Synchronizatio Check the checkbox to enable the synchronization function; clear
n
the checkbox to disable the synchronization function, and system
will stop synchronizing and clear the existing user information.
By default, system will synchronize the user information on the
configured LDAP server with the local every 30 minutes.
Automatic
Click the radio button to specify the automatic synchronization.
Synchronizatio Interval
Specifies the time interval for automatic
n
Synchronization synchronization. The value range is 30 to
1440 minutes. The default value is 30.
Daily
Specifies the time when the user information
Synchronization is synchronized everyday. The format is
HH:MM, HH and MM indicates hour and
minute respectively.
Once
If this parameter is specified, system will
Synchronization
synchronize automatically when the
configuration of LDAP server is modified.
After executing this command , system will
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Basic Configuration
synchronize user information immediately.
Synchronous
Operation
Mode

Specifies the user synchronization mode, including Group
Synchronization and OU Synchronization. By default, the user
information will be synchronized with the local server based on
the group.

OU maximum
Specifies the maximum depth of OU to be synchronized. The
depth
value range is 1 to 12, and the default value is 12.
OU structure that exceeds the maximum depth will not be
synchronized, but users that exceed the maximum depth will be
synchronized to the specified deepest OU where they belong to.
If the total characters of the OU name for each level(including
the “OU=” string and punctuation) is more than 128, OU
information that exceeds the length will not be synchronized
with the local server.
User Filter

Specifies the user filters. System can only synchronize and
authenticate users that match the filters on the authentication
server. The length is 0 to 120 characters. For example, if the
condition is configured to
“(|(objectclass=inetOrgperson)(objectclass=person))”, system
only can synchronize or authenticate users which are defined as
inetOrgperson or person. The commonly used operators are as
follows: =(equals a value)、&(and）、|(or)、!(not)、
*(Wildcard: when matching zero or more characters)、～
=( fuzzy query.)、>=(Be greater than or equal to a specified
value in lexicographical order.)、<=( Be less than or equal to a
specified value in lexicographical order.).

Naming
Attribute

Specifies a naming attribute for the LDAP server. The default
naming attribute is uid.

Group Naming Specifies a naming attribute of group for the LDAP server. The
Attribute
default naming attribute is uid.

www.fs.com

Member
Attribute

Specifies a member attribute for the LDAP server. The default
member attribute is uniqueMember.

Group Class

Specifies a group class for the LDAP server. The default class is
groupofuniquenames.

Backup

Specifies a backup authentication server. After configuring a
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Basic Configuration
Authentication backup authentication server for the LDAP server, the backup
Server
authentication server will take over the authentication task when
the primary server malfunctions or authentication fails on the
primary server. The backup authentication server can be any
existing local, Active-Directory, RADIUS or LDAP server
defined in system.
3.

Click OK.

Configuring TACACS+ Server
1.
2.

Select Object > AAA Server.
Click New > TACACS+ Server, and the TACACS+ Server Configuration dialog box
will appear.

Configure values in the TACACS+ Server Configuration dialog box.
Basic Configuration
Server Name

Enter a name for the TACACS+ server.

Server Address Specify the IP address or host name for the TACACS+ server.
Virtual Router Specify the VRouter of TACACS+ server.
Port

Enter port number for the TACACS+ server. The default value
is 49. The value range is 1 to 65535.

Secret

Enter the shared secret to connect the TACACS+ server.

Optional
Role mapping Select a role mapping rule for the server. With this option
rule
selected, system will allocate a role for the users who have been
authenticated to the server according to the specified role

www.fs.com
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Basic Configuration
mapping rule.
Backup Server Enter the domain name or IP address for the backup TACACS+
1 (2)
server.
Virtual Router Select the VRouter for the backup server.
1 (2)

Connectivity Test
When AAA server parameters are configured, you can test if they are correct by testing server
connectivity.
To test server connectivity, take the following steps:
1.
2.
3.

Select Object > AAA Server, and click New.
Select your AAA server type, which can be Radius, AD, LDAP or TACACS+. The local
server does not need the connectivity test.
After filling out the fields, click Test Connectivity.

4.

For Radius or TACACS+ server, enter a username and password in the popped <Test
Connectivity> dialog box. If the server is AD or LDAP, the login-dn and secret is used to test
connectivity.

5.

Click Test Connectivity. If "Test connectivity success" message appears, the AAA server
settings are correct.

If there is an error message, here are the causes:


Connect AAA server timeout: Wrong server address, port or virtual router.



AAA server configuration error: Secret is wrong.



Wrong name or password: Username or password for testing is wrong.

User
User refers to the user who uses the functions and services provided by the device, or who is
authenticated or managed by the device. The authenticated users consist of local user and external user.
The local users are created by administrators. They belong to different local authentication servers, and
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are stored in system's configuration files. The external users are stored in external servers, such as AD
server or LDAP server. System supports User Group to facilitate user management. Users belonging to
one local authentication server can be allocated to different user groups, while one single user can belong
to different user groups simultaneously; similarly, user groups belonging to one local authentication
server can be allocated to different user groups, while one single user group can belong to different user
groups simultaneously. The following diagram uses the default AAA server, Local, as an example and
shows the relationship between users and user groups:

As shown above, User1, User2 and User3 belong to UserGroup1, while User3 also belongs to
UserGroup2, and UserGroup2 also contains User4, User5 and UserGroup1.

Configuring a Local User
This section describes how to configure a local user and user group.


Click the "Local server" drop-down box in the upper left corner of the page to switch
the local user's server.



Red
, orange
and yellow
colors are
used to mark the expired users , expired within a week, expired within a month in the list.

Creating a Local User
To create a local user, take the following steps:
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1.

Select Object > User > Local User.

2.

Click New > User.

280

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

In the Basic Configuration tab in User Configuration dialog box, configure the following.
Option

Description

Name

Specifies a name for the user.

Password

Specifies a password for the user.

Confirm
password

Type the password again to confirm.

Mobile+cou Specifies the user's mobile number. When users log into the SCVPN
ntry code
client, system will send the verification code to the mobile number.
Description If needed, type the description of the user.
Group

Add the user to a selected usergroup. Click Choose, and in the
Choose User Group dialog box, select the usergroup you want and
click Add.

Expiration

Select the Enable check box to enable expiration for the user, and
then specify a date and time. After expiration, the user cannot be
authenticated, therefore cannot be used in system. By default
expiration is not enabled.

In the VPN Options tab, configure network parameters for the PnPVPN client.
Option

Description

IKE ID

Specifies a IKE ID type for dial-up VPN users. If FQDN or ASN1
is selected, type the ID's content in the text box below.

DHCP Start Specifies a start IP for the DHCP address pool.
IP
DHCP End Specifies an end IP for the DHCP address pool.
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Option

Description

IP
DHCP
Netmask

Specifies a netmask for the DHCP address pool.

DHCP
Gateway

Specifies a gateway for the DHCP address pool. The IP address of
the gateway corresponds to the IP address of PnPVPN client's
Intranet interface and PC's gateway address. The PC's IP address is
determined by the segment and netmask configured in the above
DHCP address pool. Therefore, the gateway's address and DHCP
address pool should be in the same segment.

DNS1

Specifies an IP address for the DNS server. You can specify one
primary DNS server (DNS1) and up to three alternative DNS
servers.

DNS2
DNS3
DNS4
WINS1
WINS2

Specifies an IP address for the WINS server. You can specify one
primary WINS server (WINS1)and one alternative WINS server.

Tunnel IP 1 Specifies an IP address for the master PnPVPN client's tunnel
interface. Select the Enable SNAT check box to enable SNAT.
Tunnel IP 2 Specifies an IP address for the backup PnPVPN client's tunnel
interface.
3.

Click OK.

Creating a User Group
To create a user group, take the following steps:
1.

Select Object > User > Local User.

2.

Click New > User Group.

3.

Type the name of the user group into the Name box.

4.
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Specify members for the user group. Expand User or User Group in the Available list,
select a user or user group and click Add to add it to the Selected list on the right. To delete a
selected user or user group, select it in the Selected list and then click Remove. One user
group can contain multiple users or user groups, but system only supports up to 5 layers of
nested user groups and does not support the loopback nest. Therefore, a user group should
not nest the upper-layer user group it belongs to.
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5.

Click OK.

Import User Password List
Import user binding list to system, take the following steps:
1.

Select Object>User> Local User.

2.

Click Import User Password List, and the Import User Password List dialog box pops up.

3.

Click Browse to select the file name needed to be imported.

4.

Click OK to finish import.

Export User Password List
Export user binding list from system to local, take the following steps:
1.
2.

Select Object > User > Local User.
Click Export User Password List, and the Export User Password List dialog box pops up,
and select the saved position in local.

3.

Click OK to finish export.



The user password in the import/export file is in encrypted text;.



Please try to keep the import file format consistent with the export file.

Notes:



When importing, if the same user name exists under the same server, the original user
password will be overwritten.

Configuring a LDAP User
This section describes how to configure a LDAP user.

Synchronizing Users
To synchronize users in a LDAP server, firstly, you need to configure a LDAP server, refer to
"Configuring LDAP Server" . To synchronize users:
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1.

Select Object > User > LDAP User.

2.

Select a server from the LDAP Server drop-down list, and click Sync Users.
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Notes: By default, after creating a LDAP server, system will synchronize the users of the LDAP
server automatically, and then continue to synchronize every 30 minutes.

Configuring an Active Directory User
This section describes how to configure an active directory (AD) user.

Synchronizing Users
To synchronize users in an AD server to the device, first you need to configure an AD server ,refer to
"Configuring Active Directory Server" . To synchronize users, take the following steps:
1.
2.

Select Object > User >AD User.
Select an AD server from the Active Directory Server drop-down list, and click Sync
Users.

Notes: By default, after creating an AD server, system will synchronize the users of the AD server
automatically, and then continue to synchronize every 30 minutes.

Configuring a IP-User Binding
Adding User Binding
To bind an IP or MAC address to a user, take the following steps:
1.

Select Object > User > IP-User Binding .

2.

Click Add User Binding.

Configure the following options.
User

www.fs.com

AAA Server

Select an AAA server from the drop-down list.

User

Select a user for the binding from the drop-down list.
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User
Binding Type
Binding Type

By specifying the binding type, you can bind the user to a IP
address or MAC address.

IP - If IP is selected, type the IP address into the
IP text box. And select a VR from the Virtual Router
drop-down list. Select the Check WebAuth IP-User
Mapping Relationship check box to apply the IP-User
mapping only to the check for IP-user mapping during
Web authentication if needed.

MAC - If MAC is selected, type the MAC address
into the MAC text box. And select a VR from the Virtual
Router drop-down list.

3.

Click OK.

Import Binding
Import user binding list to system, take the following steps:
1.

Select Object>User> IP-User Binding.

2.

Click Import , and the Import User Binding List dialog box pops up.

3.

Click Browse to select the file name needed to be imported.

4.

Click OK to finish import.

Export Binding
Export user binding list from system to local, take the following steps:
1.
2.
3.
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Select Object>User> IP-User Binding.
Select the exported user category(include local, LDAP, AD and all users) in the Export
drop-down list to pop up the export dialog box, and select the saved position in local.
Click OK to finish export.
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Role
Roles are designed with certain privileges. For example, a specific role can gain access to some specified
network resources, or make exclusive use of some bandwidth. In FSOS, users and privileges are not
directly associated. Instead, they are associated by roles.
The mappings between roles and users are defined by role mapping rules. In function configurations,
different roles are assigned with different services. Therefore, the mapped users can gain the
corresponding services as well.
System supports role combination, i.e., the AND, NOT or OR operation on roles. If a role is used by
different modules, the user will be mapped to the result role generated by the specified operation.
System supports the following role-based functions:


Role-based policy rules: Implements access control for users of different types.



Role-based QoS: Implements QoS for users of different types.



Role-based statistics: Collects statistics on bandwidth, sessions and new sessions for
users of different types.




Role-based session limits: Implements session limits for specific users.
SCVPN role-based host security detection: Implements control over accesses to specific
resources for users of different types.



Role-based PBR: Implements routing for users of different types.

Configuring a Role
Creating a Role
To create a role, take the following steps:
1.

Select Object > Role > Role.

2.

Click New.

Configure the following options.
Option
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3.

Option

Description

Role Name

Type the role name into the Role Name box.

Description

Type the description for the role into the Description box.

Click OK.

Mapping to a Role Mapping Rule
You can map the role to user, user group, CN or OU through this function or Creating a Role Mapping
Rule. After Creating a Role Mapping Rule, you can click Mapping To to map the selected role again.
To map the selected role again, take the following steps:
1.

Select Object > Role > Role.

2.

Select the role need to be mapped, and click Mapping To.

3.

4.
5.
6.
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In the Mapping name section, select a created mapping rule name from the first dropdown list ( For detailed information of creating a role mapping role, see Creating a Role
Mapping Rule.), and then select a user, user group, certificate name (the CN field of USB Key
certificate), organization unit (the OU field of USB Key certificate) or any from the second
drop-down list. If User, User group, CN or OU is selected, also select or enter the
corresponding user name, user group name, CN or OU into the box behind.
Click Add to add to the role mapping list.
If needed, repeat Step 3 and Step 4 to add more mappings. To delete a role mapping,
select the role mapping you want to delete from the mapping list, and click Delete.
Click OK.
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Creating a Role Mapping Rule
To create a role mapping rule, take the following steps:
1.

Select Object > Role > Role Mapping .

2.

Click New.

3.

Type the name for the rule mapping rule into the Name box.

4.

5.
6.
7.

In the Member section, select a role name from the first drop-down list, and then select a
user, user group, certificate name (the CN field of USB Key certificate) or organization unit
(the OU field of USB Key certificate) from the second drop-down list. If User, User group,
CN or OU is selected, also select or enter the corresponding user name, user group name, CN
or OU into the box behind.
Click Add to add to the role mapping list.
If needed, repeat Step 4 and Step 5 to add more mappings. To delete a role mapping,
select the role mapping you want to delete from the mapping list, and click Delete.
Click OK.

Creating a Role Combination
To create a role combination, take the following steps:
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1.

Select Object > Role > Role Combination.

2.

Click New.
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Configure the following options.
Option

Description

First Prefix

Specifies a prefix for the first role in the role regular expression.

First Role

Select a role name from the First Role drop-down list to specify a
name for the first role in the role regular expression.

Operator

Specifies an operator for the role regular expression.

Second Prefix Specifies a prefix for the second role in the role regular
expression.

3.

Second Role

Select a role name from the Second Role drop-down list to
specify a name for the second role in the role regular expression.

Result Role

Select a role name from the Result Role drop-down list to specify
a name for the result role in the role regular expression.

Click OK.

Track Object
The devices provide the track object to track if the specified object (IP address or host) is reachable or if
the specified interface is connected. This function is designed to track HA and interfaces.

Creating a Track Object
To create a track object, take the following steps:
1.
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Select Object > Track Object.
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2.

Click New.

Configure the following options.
Option

Description

Name

Specifies a name for the new track object.

Threshold

Type the threshold for the track object into the text box. If the
sum of weights for failed entries in the track object exceeds the
threshold, system will conclude that the whole track object fails.

Track Type

Select a track object type. One track object can only be
configured with one type.
Select Interface radio button:


Click Add in Add Track Members section and
then configure the following options in the Add
Interfaces dialog box:


Interface - Select a track interface from
the drop-down list.



Weight - Specifies a weight for the
interface, i.e. the weight for overall failure of the
whole track object if this track entry fails.

Select HTTP/Ping/ARP/DNS/TCP radio button:


Click Add, select a packet type from the dropdown list, and then configure the following options in the
Add HTTP/Ping/ARP/DNS/TCP Member dialog box:


www.fs.com

IP Type - Specifies the IP type for the
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Option

Description
track object when the track is implemented by
HTTP/DNS/TCP packets.


IP/Host - Specifies an IP address or host
name for the track object when the track is
implemented by HTTP/Ping/TCP packets.
IP - Specifies an IP address for the track object
when the track is implemented by ARP/NDP
packets.
DNS - Specifies an IP address for the track object
when the track is implemented by DNS packets.



Weight - Specifies a weight for overall
failure of the whole track object if this track entry
fails.



Retries: Specifies a retry threshold. If no
response packet is received after the specified
times of retries, system will determine this track
entry fails, i.e., the track entry is unreachable. The
value range is 1 to 255. The default value is 3.



Interval - Specifies an interval for sending
packets. The value range is 1 to 255 seconds. The
default value is 3.



Egress Interface - Specifies an egress
interface from which
HTTP/Ping/ARP/DNS/TCP packets are sent.



Source Interface- Specifies a source
interface for HTTP/Ping/ARP/DNS/TCP
packets.

Select Traffic Quality radio button:


Click Add in Add Track Members section and
then configure the following options in the Add Traffic
Quality Member dialog box:


www.fs.com

Interface - Specifies the name of the
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Option

Description
tracked interface.


Interval - Specifies the duration of per
track period. The unit is second. The value range
is 1 to 255. The default value is 3. After a track
period is finished, system will reset the tracked
value of new session.



Retries - Specifies the threshold value
which concludes the track entry is failed. The
value range is 1 to 255. The default value is 3.



Weight - Specifies how important this
track failure is to the judgment of track object
failure. The value range is 1 to 255. The default
value is 255.



Low Watermark - Specifies the failure
threshold value of new session success rate. The
value range is 0 to 100. The default value is 30.
During a track period, when the new session
success rate is below the specified low watermark,
system will conclude the track is failed.



High Watermark- Specifies the failure
threshold value of new session success rate. The
value range is 0 to 100. The default value is 50.
During a track period, when the new session
success rate exceeds the specified low watermark,
system will conclude the track is successful.

Note: During a track period, when the new session
success rate is equal to or exceeds the low watermark, and
is equal to or below the low watermark, system will keep
the previous track state.
HA sync

3.
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Select this check box to enable HA sync function. The primary
device will synchronize its information with the backup device.

Click OK. The created track object will be displayed in the track object list.
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URL Filtering
URL filtering controls the access to some certain websites and records log messages for the access
actions. URL filtering helps you control the network behaviors in the following aspects:


Access control to certain category of websites, such as gambling and pornographic
websites.



Access control to certain category of websites during the specified period. For example,
forbid to access IM websites during the office hours.



Access control to the website whose URL contains the specified keywords. For example,
forbid to access the URL that contains the keyword of game.

Configuring URL Filtering
Configuring URL filtering contains two parts:


Create a URL filtering rule



Bind a URL filtering rule to a security zone or policy rule

Part 1: Creating a URL filter rule
1.

Select Object > URL Filter.

2.

Click New.

In the URL Filter Rule Configuration dialog box, configure the following options.
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Option

Description

Name

Specifies the name of the rule.

Control Type

Control types are URL Categoryand URL Keyword Category.
You can select one type for each URL filter rule.
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Option

Description
URL Category controls the access to some certain category of
website. The options are:


SSL inspection: Select the Enable check box to
enable SSL negotiation packets inspection. For HTTPS
traffic, system can acquire the domain name of the site
which you want to access from the SSL negotiation
packets after this feature is configured. Then, system will
perform URL filter in accordance with the domain name.
If SSL proxy is configured at the same time, SSL
negotiation packets inspection method will be preferred
for URL filter.



New: Create a new URL category. For more
information about URL categories, see URL Filter >
User-defined URL DB in the FSOS WebUI User Guide.



Edit: Select a URL category from the list, and
click Edit to edit the selected URL category.



URL category: Shows the name of pre-defined
and user-defined URL categories in the VSYS.



Block: Select the check box to block access to the
corresponding URL category.



Log: Select the check box to log access to the
corresponding URL category.



Other URLS: Specifies the actions to the URLs
that are not in the list, including Block Access and
Record Log.

URL Keyword Category controls the access to the website
whose URL contains the specific keywords. Click the URL
Keyword Categoryoption to configure. The options are:

www.fs.com



New: Creates new keyword categories. For more
information about keyword category, see URL Filter >
Keyword Category in the FSOS WebUI User Guide.



Edit: Select a URL keyword category from the
list, and click Edit to edit the selected URL keyword

294

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

Option

Description
categories.

3.



Keyword category: Shows the name of the
configured keyword categories.



Block: Selects the check box to block access to
the website whose URL contains the specified keywords.



Log: Selects the check box to log the access to
the website whose URL contains the specified keywords.



Other URLS: Specifies the actions to the URLs
that do not contain the keywords in the list, including
Block Access and Record Log.

Click OK to save the settings.

Part 2: Binding a URL filtering rule to a security zone or security policy rule
The URL filtering configurations are based on security zones or policies.


If a security zone is configured with the URL filtering function, system will perform
detection on the traffic that is destined to the binding zone specified in the rule, and then do
according to what you specified.



If a policy rule is configured with the URL filtering function, system will perform
detection on the traffic that is destined to the policy rule you specified, and then respond.



The threat protection configurations in a policy rule are superior to that in a zone rule if
they are specified at the same time, and the URL filtering configurations in a destination zone are
superior to that in a source zone if they are specified at the same time.



To perform the URL filtering function on the HTTPS traffic, see the policy-based URL
filtering.

To create the zone-based URL filtering, take the following steps:
1.

Create a zone. For more information about how to create this, refer to "Security Zone" .

2.

In the Zone Configuration dialog box, select the Threat Protection tab.

3.
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Enable the threat protection that you need, and select the URL filtering rules from the
profile drop-down list below; you can click Add Profile from the profile drop-down list below
to create a URL filtering rule. For more information, see "Part 1: Creating a URL filter rule" .
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4.

Click OK to save the settings.

To create the policy-based URL filtering, take the following steps:
1.
2.

Configure a security policy rule. For more information, see "Configuring a Security
Policy Rule" .
In the Protection tab, select the Enable check box of URL Filtering.

3.

From the Profile drop-down list, select a URL filtering rule. You can also click Add
Profile to create a new URL filtering rule.

4.

To perform the URL filtering function on the HTTPS traffic, you need to enable the SSL
proxy function for this security policy rule. System will decrypt the HTTPS traffic according
to the SSL proxy profile and then perform the URL filtering function on the decrypted traffic.
According to the various configurations of the security policy rule, system will perform the
following actions:
Policy Rule
Actions
Configurations
SSL proxy
enabled
URL filtering
disabled
SSL proxy
enabled
URL filtering
enabled
SSL proxy
disabled
URL filtering
enabled

System decrypts the HTTPS traffic according to the SSL proxy
profile but it does not perform the URL filtering function on the
decrypted traffic.

System decrypts the HTTPS traffic according to the SSL proxy
profile and performs the URL filtering function on the decrypted
traffic.

System performs the URL filtering function on the HTTP traffic
according to the URL filtering profile. The HTTPS traffic will
not be decrypted and system will transfer it.

If the SSL proxy and URL filtering functions are enabled on a security policy rule but the
control type of the selected URL filtering rule is the Web surfing record, the system will not
record the GET and POST methods and the posted contents via HTTPS.
If the zone which the security policy rule binds with is also configured with a URL filtering,
system will perform the following actions:
www.fs.com
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Policy Rule
Zone
Actions
Configurations Configurati
ons
SSL proxy
enabled
URL filtering
disabled
SSL proxy
enabled
URL filtering
enabled
SSL proxy
disabled
URL filtering
enabled
5.

URL
filtering
enabled

System decrypts the HTTPS traffic according to the
SSL proxy profile and performs the URL filtering
function on the decrypted traffic according to the
URL filter rule of the zone.

URL
filtering
enabled

System decrypts the HTTPS traffic according to the
SSL proxy profile and performs the URL filtering
function on the decrypted traffic according to the
URL filtering rule of the policy rule.

URL
filtering
enabled

System performs the URL filtering function on the
HTTP traffic according to the URL filtering rule of
the policy rule. The HTTPS traffic will not be
decrypted and system will transfer it.

Click OK to save the settings.

If necessary, you can go on to configure the functions of "Predefined URL DB" , "URL Lookup" , and
"Warning Page" .
Object
Predefined
URL DB

URL Lookup

Warning Page

www.fs.com

Description
The predefined URL database includes dozens of categories and
tens of millions of URLs and you can use it to specify the URL
categories.
Use the URL lookup function to inquire URL information from
the URL database, including the URL category and the category
type.


Block warning: When your network access is
blocked, a warning page will prompt in the Web browser.



Audit warning: When your network access is
audited, a warning page will prompt in the Web browser.

297

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

Notes:


Only after canceling the binding can you delete the URL filtering rule.



To get the latest URL categories, you are recommended to update the URL database first.
For more information about URL database, see "Predefined URL DB" .



You can export the log messages to specified destinations. For more information about
log messages, see "Log Configuration" .

Viewing URL Hit Statistics
The URL access statistics includes the following parts:


Summary: The statistical information of the top 10 user/IPs, the top 10 URLs, and the
top 10 URL categories during the specified period of time are displayed.



User/IP: The user/IP and detailed hit count are displayed.



URL: The URL and detailed hit count are displayed.



URL Category: The URL category and detailed hit count and traffic are displayed.

To view the URL hit statistics, see "URL Hit" in Monitor.



To view the URL hit statistics, enable URL Hit in "Monitor Configuration" .
To view the traffic of the URL category, enable URL Hit and URL Category Bandwidth
in "Monitor Configuration" .

Viewing Web Surfing Records
To view the Web surfing records, view "URL Logs". Before you view the Web surfing records, see "Log
Configuration" to enable URL Log function.

Configuring Objects
Objects mean the items referenced during URL Filtering profiles configurations. When using URL
filtering function, you need to configure the following objects:
Object
Predefined
URL DB
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Description
The predefined URL database includes dozens of categories and
tens of millions of URLs and you can use it to specify the URL
categories.
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Object

Description

User-defined
URL DB
URL Lookup

Keyword
Category

The user-defined URL database is defined by you and you can
use it to specify the URL category.
Use the URL lookup function to inquire URL information from
the URL database.
Use the keyword category function to customize the keyword
categories.

Warning Page



Block warning: When your network access is
blocked, a warning page will prompt in the Web browser.



Audit warning: When your network access is
audited, a warning page will prompt in the Web browser.

Predefined URL DB
System contains a predefined URL database.
Notes: The predefined URL database is controlled by a license . Only after a URL license is installed,
the predefined URL database can be used.
The predefined URL database provides URL categories for the configurations of a URL filtering. It
includes dozens of categories and tens of millions of URLs .
When identifying the URL category, the user-defined URL database has a higher priority than the
predefined URL database.

Configuring Predefined URL Database Update Parameters
By default, system updates predefined URL database everyday. You can change the update parameters
according to your own requirements. Besides, you can update the predefined URL database from your
local disk.
To change the update parameters, take the following steps:
1.
2.
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Select System > Upgrade Management > Signature Database Update.
In the URL category database update section, you can view the current version of the
database, perform the remote update, configure the remote update, and perform the local
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update.

3.

Select Enable Auto Update to enable the automatic update function and then continue to
specify the frequency and time. Click OK to save your settings.

4.

Click Configure Update Server to configure the update server URL. In the pop-up dialog
box, specify the URL or IP address of the update server, and select the virtual router that can
connect to the server. To restore the URL settings to the default ones, click Restore Default.

5.

Click Configure Proxy Server, then enter the IP addresses and ports of the main proxy
server and the backup proxy server. When the device accesses the Internet through a HTTP
proxy server, you need to specify the IP address and the port number of the HTTP proxy
server. With the HTTP proxy server specified, various signature databases can update
normally.

6.

Click OK to save the settings.

Upgrading Predefined URL Database Online
To upgrade the URL database online, take the following steps:
1.
2.

Select System > Upgrade Management > Signature Database Update.
In the URL category database update section, click Update to update the predefined
URL database.

Upgrading Predefined URL Database from Local
To upgrade the predefined URL database from local, take the following steps:
1.
2.
3.

System > Upgrade Management > Signature Database Update
In the URL category database update section, click Browse to select the URL database
file from your local disk.
Click Upload to update the predefined URL database.

Notes: You can not upgrade the predefined URL database from local in non-root VSYS.

www.fs.com
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User-defined URL DB
Besides categories in predefined URL database, you can also create user-defined URL categories, which
provides URL categories for the configurations of URL filtering. When identifying the URL category,
the user-defined URL database has a higher priority than the predefined URL database.
System provides three predefined URL categories: custom1, custom2, custom3. You can import your
own URL lists into one of the predefined URL categories.
Notes: You can not import your own URL lists into one of the predefined URL category in non-root
VSYS.

Configuring User-defined URL DB
To configure a user-defined URL category, take the following steps:
1.
2.
3.

4.

At the top-right corner, select Configuration > User-defined URL DB. The User-defined
URL DB dialog box will appear.
Click New. The URL Category dialog box will appear.

Type the category name in the Category box. URL category name cannot only be a
hyphen (-). And you can create at most 16 user-defined categories.

5.

Type a URL into the URL http(s):// box.

6.

Click Add to add the URL and its category to the table.

7.

8.
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Select Object > URL Filtering.

To edit an existing one, select it and then click Edit. After editing it, click Add to save the
changes.
Click OK to save the settings.
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Importing User-defined URL
System supports to batch imported user-defined URL lists into the predefined URL category named
custom1/2/3. To import user-defined URL, take the following steps:
1.
2.

Select Object > URL Filtering.
At the top-right corner, select Configuration > User-defined URL DB. The User-defined
URL DB dialog box will appear.

3.

Select one of the predefined URL category(custom1/2/3), and then click Import.

4.

In the Batch Import URL dialog box, click Browse button to select your local URL file.
The file should be less than 1 M, and have at most 1000 URLs. Wildcard is supported to use
once in the URL file, which should be located at the start of the address.

5.

Click OK to finish importing.

Clearing User-defined URL
In the predefined URL category named custom1/2/3, clear a user-defined URL, take the following steps:
1.

Select Object > URL Filtering.

2.

At the top-right corner, select Configuration > User-defined URL DB. The User-defined
URL DB dialog box will appear.

3.

Select one of the predefined URL categories(custom1/2/3), and then click Clear. The
URL in the custom 1/2/3 will be cleared from the system.

URL Lookup
You can inquire a URL to view the details by URL lookup, including the URL category and the category
type.

Inquiring URL Information
To inquiry URL information, take the following steps:
1.
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Select Object > URL Filtering.
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2.

At the top-right corner, click Configuration > URL Lookup. The URL Lookup dialog
box will appear.

3.

Type the URL into the Please enter the URL to inquire box.

4.

Click Inquire, and the results will be displayed at the bottom of the dialog box.

Configuring URL Lookup Servers
URL lookup server can classify an uncategorized URL (URL is neither in predefined URL database nor
in user-defined URL database) you have accessed, and then add it to the URL database during database
updating. By default, the URL lookup servers are enabled.
To configure a URL lookup server, take the following steps:
1.
2.

At the top-right corner, Select Configuration > Predefined URL DB. The Predefined
URL DB dialog box will appear.

3.

Click Inquiry Server Configuration. The Predefined URL DB Inquiry Server
Configuration dialog box will appear.

4.

In the Inquiry server section, double-click the cell in the IP/Port/Virtual Router column
of Server1/2 and type a new value.

5.

www.fs.com

Select Object > URL Filtering.

Select the check box in the Enable column to enable this URL lookup server.
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6.

Click OK to save the settings.

Keyword Category
You can customize the keyword category and use it in the URL filtering function.
After configuring a URL filtering rule, system will scan traffic according to the configured keywords and
calculate the trust value for the hit keywords. The calculating method is: adding up the results of times *
trust value of each keyword that belongs to the category. Then system compares the sum with the
threshold 100 and performs the following actions according to the comparison result:


If the sum is larger than or equal to category threshold (100), the configured category
action will be triggered;



If more than one category action can be triggered and there is block action configured,
the final action will be Block;



If more than one category action can be triggered and all the configured actions are
Permit, the final action will be Permit.

For example, a URL filtering rule contains two keyword categories C1 with action block and C2 with
action permit. Both of C1 and C2 contain the same keywords K1 and K2. Trust values of K1 and K2 in
C1 are 20 and 40. Trust values of K1 and K2 in C2 are 30 and 80.
If system detects 1 occurrence of K1 and K2 each on a URL, then C1 trust value is 20*1＋
40*1=60<100, and C2 trust value is 30*1+80*1=110>100. As a result, the C2 action is triggered and the
URL access is permitted.
If system detects 3 occurrences of K1 and 1 occurrence of K2 on a URL, then C1 trust value is
20*3+40*1=100, and C2 trust value C2 is 30*3+80*1=170>100. Conditions for both C1 and C2 are
satisfied, but the block action for C1 is triggered, so the web page access is denied.

Configuring a Keyword Category
To configure a keyword category, take the following steps:
1.
2.
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Select Object > URL Filtering.
At the top-right corner, select Configuration > Keyword Category. The Keyword
Category dialog box will appear.
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3.

Click New. The Keyword Category Configuration dialog box will appear.

4.

Type the category name.

5.

Click New. In the slide area, specify the keyword, character matching method
(simple/regular expression), and trust value (100 by default).

6.

Click Add to add the keyword to the list below.

7.

Repeat the above steps to add more keywords.

8.

To delete a keyword, select the keyword you want to delete from the list and click Delete.

9.

Click OK to save your settings.

Warning Page
The warning page shows the user block information and user audit information.

Configuring Block Warning
If the internet behavior is blocked by the URL filtering function, the Internet access will be denied. The
information of Access Denied will be shown in your browser, and some web surfing rules will be shown
to you on the warning page at the same time. According to the different network behaviors, the default
block warning page includes the following two situations:


www.fs.com

Visiting a certain type of URL.
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Visiting the URL that contains a certain type of keyword category.

The block warning function is disabled by default. To configure the block warning function, take the
following steps:
1.
2.

Click Object > URL Filtering.
At the top-right corner, select Configuration > Warning Page. The Warning Page dialog
box will appear.

3.

In the Block Warning section, select Enable.

4.

Configure the display information in the blocking warning page.
Option

Description

Default

Use the default blocking warning page as shown above.

Redirect page

Redirect to the specified URL. Type the URL in the URL http://
box. You can click Detection to verify whether the URL is valid.

Custom

5.
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Customize the blocking warning page. Type the title in the Title
box and the description in the Description box. You can click
Preview to preview the blocking warning page.

Click OK to save the settings.
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Configuring Audit Warning
After enabling the audit warning function, when your network behavior matches the configured URL
filtering rule, your HTTP request will be redirected to a warning page where the audit and privacy
protection information is displayed. See the picture below:

The audit warning function is disabled by default. To configure the audit warning function, take the
following steps:
1.
2.

Select Object > URL Filtering.
At the top-right corner, select Configuration > Warning Page. The Warning Page dialog
box will appear.

3.

In the Audit Warning section, select Enable.

4.

Configure the display information in the audit warning page.

5.

Option

Description

Default

Use the audit blocking warning page as shown above.

Custom

Customize the audit blocking warning page. Type the title in the
Title box and the description in the Description box. You can
click Preview to preview the audit warning page.

Click OK to save the settings.

Configuring the URL Blacklist/Whitelist
You can further control the access to some websites by configuring URL blacklists and whitelists.


After the URL blacklist is configured, when you send an access request to the specified
URL in the blacklist, the system will block the request.



After the URL whitelist is configured, when you send an access request to the specified
URL in the whitelist, system will not perform URL filtering for the access request and let the
request pass



The URL blacklist, the URL whitelist and the URL filtering rule all configured with URL
categories, the matching priority for URL category filtering is: the URL blacklist > the URL
whitelist > the URL filtering rule.

www.fs.com
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Notes:


An URL category can only be referenced by an object (URL blacklist, URL whitelist or
URL filtering profile). For example, when the URL category "Advertisement" has been added
to the URL blacklist, this URL category cannot be added to the URL whitelist, and it will not
be referenced in the URL filtering profile



Non-root VSYS does not support the URL blacklist\whitelist function, and the URL
blacklist/whitelist configuration under root VSYS does not take effect and has no effect on
non-root VSYS.

Configuring the URL Blacklist
To configure the URL blacklist, take the following steps:
1.
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Click Object > URL Filtering > URL Blacklist/Whitelist.

2.

Select <URL Blacklist> tab to open the URL blacklist page, which displays all URL
categories that have been added to the URL blacklist and the corresponding URL type and
description.

3.

Click Set to open the URL Blacklist dialog box, and add the URL category to the URL
blacklist in the dialog box.

4.

The "URL category" on the left contains all URL categories that can be referenced
(predefined URL DB and user-defined URL DB). You can also click New to create a new
URL category. For specific steps, see Configuring_User-defined_URL_DB.

5.

In the "URL category" on the left, select the URL category that needs to be added to the
URL blacklist, and click the Add to add the URL category entry to the "URL blacklist" list.
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6.
7.

If you need to delete the URL category entry in the URL blacklist, in the "URL blacklist"
list on the right, select the URL category entry you want to delete and click Remove.
Click OK.

Configuring the URL Whitelist
To configure the URL whitelist, take the following steps:
1.
2.

Select <URL Whitelist> tab to open the URL whitelist page, which displays all URL
categories that have been added to the URL whitelist and the corresponding URL type and
description.

3.

Click Set to open the URL Whitelist dialog box, and add the URL category to the URL
whitelist in the dialog box.

4.

The "URL category" on the left contains all URL categories that can be referenced
(predefined URL DB and user-defined URL DB). You can also click New to create a new
URL category. For specific steps, see Configuring_User-defined_URL_DB.

5.

In the "URL category" on the left, select the URL category that needs to be added to the
URL whitelist, and click the Add to add the URL category entry to the "URL whitelist" list.

6.

If you need to delete the URL category entry in the URL whitelist, in the "URL whitelist"
list on the right, select the URL category entry you want to delete and click Remove.

7.
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Click Object > URL Filtering > URL Blacklist/Whitelist.

Click OK.
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Data Security
This feature may not be available on all platforms. Please check your system's actual page to see if your
device delivers this feature.
The data security function allows you to flexibly configure control rules to comprehensively control and
audit (by behavior logs and content logs) on user network behavior.
Data security can audit and filter in the following network behaviors:
Function

Description

File filter

Checks the files transported through HTTP, FTP, SMTP, POP3
protocols and control them according to the file filter rules.

Content filter



Web content :Controls the network behavior of
visiting the webpages that contain certain keywords, and
log the actions.



Web posting: Controls the network behavior of
posting on websites and posting specific keywords, and
logs the posting action and posted content.





Email filter: Controls and audit SMTP mails :


Control and audit all the behaviors of
sending emails;



Control and audit the behaviors of
sending emails that contain specific sender,
recipient, keyword or attachment.

HTTP/FTP control: Controls and audits the
actions of HTTP and FTP applications:


FTP methods, including Login, Get, and
Put;



Network
Behavior
Record

www.fs.com

HTTP methods, including Connect, Get,
Put, Head, Options, Post, and Trace;

Audits the IM applications behaviors and record log messages
for the access actions.
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Related Topics:


"Configuring Objects"



"File Filter"



"Content Filter"



"Network Behavior Record"

Configuring Objects
Objects mean the items referenced during Content Filter rules. When using the data security function,
you need to configure the following objects:
Object
Predefined
URL DB

User-defined
URL DB

URL Lookup

Keyword
Category

Warning Page

Bypass

www.fs.com

Description
The predefined URL database includes dozens of categories and
tens of millions of URLs and you can use it to specify the URL
category and URL range for the URL category/Web posting
functions.
The user-defined URL database is defined by yourself and you
can use it to specify the URL category and URL range for the
URL category/Web posting functions.
Use the URL lookup function to inquire URL information from
the URL database.
Use the keyword category function to customize the keyword
categories. You can use it to specify the keyword for the URL
category/Web posting/email filter functions.


Block warning: When your network access is
blocked, you will be prompted with a warning page in the
Web browser.



Audit warning: When your network access is
audited, you will be prompted with a warning page in the
Web browser.

Domains that are not controlled by the internet behavior control
rules.
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Object

Description

Domain
Exempt User

Users that are not controlled by the internet behavior control
rules.

Predefined URL DB
The system contains a predefined URL database.
Notes: The predefined URL database is controlled by a license controlled. Only after a URL license is
installed, the predefined URL database can be used.
The predefined URL database provides URL categories for the configurations of Web content/Web
posting. It includes dozens of categories and tens of millions of URLs .
When identifying the URL category of a URL, the user-defined URL database has a higher priority than
the predefined URL database.

Configuring Predefined URL Database Update Parameters
By default, the system updates predefined URL database everyday. You can change the update
parameters according to your own requirements. Besides, you can update the predefined URL database
from your local disk.
To change the update parameters:
1.
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Select System > Upgrade Management > Signature Database Update.

2.

In the URL category database update section, you can view the current version of the
database, perform the remote update, configure the remote update, and perform the local
update.

3.

Select Enable Auto Update to enable the automatic update function. And then continue
to specify the frequency and time. Click OK to save your settings.

4.

Click Configure Update Server to configure the update server URL. In the pop-up dialog,
specify the URL or IP address of the update server, and select the virtual router that can
connect to the server. To restore the URL settings to the default ones, click Restore Default.
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5.

6.

Click Configure Proxy Server, then enter the IP addresses and ports of the main proxy
server and the backup proxy server. When the device accesses the Internet through a HTTP
proxy server, you need to specify the IP address and the port number of the HTTP proxy
server. With the HTTP proxy server specified, various signature database can update normally.
Click OK to save the settings.

Upgrading Predefined URL Database Online
To upgrade the URL database online:
1.
2.

Select System > Upgrade Management > Signature Database Update.
In the URL category database update section, click Update to update the predefined
URL database.

Upgrading Predefined URL Database from Local
To upgrade the predefined URL database from local:
1.
2.
3.

System > Upgrade Management > Signature Database Update
In the URL category database update section, click Browse to select the URL database
file from your local disk.
Click Upload to update the predefined URL database.

User-defined URL DB
Besides categories in predefined URL database, you can also create user-defined URL categories, which
provides URL categories for the configurations of Web content/Web posting. When identifying the
URL category, the user-defined URL database has a higher priority than the predefined URL database.
System provides three predefined URL categories: custom1, custom2, custom3. You can import your
own URL lists into one of the predefined URL category.

Configuring User-defined URL DB
To configure a user-defined URL category:
1.
2.
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Select Object > Data Security > Content Filter > Web Content/Web Posting.
At the top-right corner, select Configuration > User-defined URL DB. The User-defined
URL DB dialog appears.
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3.

4.

Click New. The URL Category dialog appears.

Type the category name in the Category box. URL category name cannot only be a
hyphen (-). And you can create at most 16 user-defined categories.

5.

Type a URL into the URL http(s):// box.

6.

Click Add to add the URL and its category to the table.

7.

8.

To edit an existing one, select it and then click Edit. After editing it, click Add to save the
changes.
Click OK to save the settings.

Importing User-defined URL
System supports to batch import user-defined URL lists into the predefined URL category named
custom1/2/3. To import user-defined URL:
1.
2.
3.
4.

5.

Select Object > URL Filter.
At the top-right corner, select Configuration > User-defined URL DB. The User-defined
URL DB dialog appears.
Select one of the predefined URL category(custom1/2/3), and then click Import.
In the Batch Import URL dialog, click Browse button to select your local URL file. The
file should be less than 1 M, and has at most 1000 URLs. Wildcard is supported to use once in
the URL file, which should be located at the start of the address.
Click OK to finish importing.

Clearing User-defined URL
In the predefined URL category named custom1/2/3, clear user-defined URL:

www.fs.com
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1.

Select Object > URL Filter.

2.

At the top-right corner, select Configuration > User-defined URL DB. The User-defined
URL DB dialog appears.

3.

Select one of the predefined URL category(custom1/2/3), and then click Clear, the URL
in the custom 1/2/3 will be cleared from the system.

URL Lookup
You can inquire a URL to view the details by URL lookup, including the URL category and the category
type.

Inquiring URL Information
To inquiry URL information:
1.
2.

Select Object > Data Security>Content Filter> Web Content/Web Posting.
At the top-right corner, click Configuration > URL Lookup. The URL Lookup dialog
appears.

3.

Type the URL into the Please enter the URL to inquire box.

4.

Click Inquire, and the results will be displayed at the bottom of the dialog.

Configuring URL Lookup Servers
URL lookup server can classify an uncategorized URL (URL is neither in predefined URL database nor
in user-defined URL database) you have accessed, and then add it to the URL database during database
updating. By default, the URL lookup servers are enabled.
To configure a URL lookup server:
1.
www.fs.com

Select Object > Data Security>Content Filter> Web Content/Web Posting.
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2.

At the top-right corner, Select Configuration > Predefined URL DB. The Predefined
URL DB dialog appears.

3.

Click Inquiry Server Configuration. The Predefined URL DB Inquiry Server
Configuration dialog appears.

4.

In the Inquiry server section, double-click the cell in the IP/Port/Virtual Router column
of Server1/2 and type a new value.

5.

Select the check box in the Enable column to enable this URL lookup server.

6.

Click OK to save the settings.

Keyword Category
You can customize the keyword category and use it in the internet behavior control function.
After configuring a internet behavior control rule, the system will scan traffic according to the
configured keywords and calculate the trust value for the hit keywords. The calculating method is:
adding up the results of times * trust value of each keyword that belongs to the category. Then the
system compares the sum with the threshold 100 and performs the following actions according to the
comparison result:


If the sum is larger than or equal to category threshold (100), the configured category
action will be triggered;



If more than one category action can be triggered and there is block action configured,
the final action will be Block;



If more than one category action can be triggered and all the configured actions are
Permit, the final action will be Permit.

For example, a web content rule contains two keyword categories C1 with action block and C2 with
action permit. Both of C1 and C2 contain the same keywords K1 and K2. Trust values of K1 and K2 in
C1 are 20 and 40. Trust values of K1 and K2 in C2 are 30 and 80.
If the system detects 1 occurrence of K1 and K2 each on a web page, then C1 trust value is 20*1＋
40*1=60<100, and C2 trust value is 30*1+80*1=110>100. As a result, the C2 action is triggered and the
web page access is permitted.

www.fs.com
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If the system detects 3 occurrences of K1 and 1 occurrence of K2 on a web page, then C1 trust value is
20*3+40*1=100, and C2 trust value C2 is 30*3+80*1=170>100. Conditions for both C1 and C2 are
satisfied, but the block action for C1 is triggered, so the web page access is denied.

Configuring a Keyword Category
To configure a keyword category:
1.
2.

Select Object > Data Security>Content Filter> Web Content/Web Posting/Email Filter.
At the top-right corner, Select Configuration > Keyword Category. The Keyword
Category dialog appears.

3.

Click New. The Keyword Category Configuration dialog appears.

4.

Type the category name.

5.

Click New. In the slide area, specify the keyword, character matching method
(simple/regular expression), and trust value (100 by default).

6.

Click Add to add the keyword to the list below.

7.

Repeat the above steps to add more keywords.

8.

To delete a keyword, select the keyword you want to delete from the list and click Delete.

9.

Click OK to save your settings.

Warning Page
The warning page shows the user block information and user audit information.

www.fs.com
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Configuring Block Warning
If the internet behavior is blocked by the internet behavior control function, the Internet access will be
denied. The information of Access Denied will be shown in your browser, and some web surfing rules
will be shown to you on the warning page at the same time. See the picture below:

After enabling the block warning function, block warning information will be shown in the browser
when one of the following actions is blocked:


Visiting the web page that contains a certain type of keyword category



Posting information to a certain type of website or posting a certain type of keywords



HTTP actions of Connect, Get, Put, Head, Options, Post, and Trace. HTTP binary file
download, such as .bat, .com. Downloading ActiveX and Java Applet.

The block warning function is enabled by default. To configure the block warning function:

www.fs.com

1.

Click Object > Data Security>Content Filter> Web Content/Web Posting/Email
Filter/HTTP/FTP Control.

2.

At the top-right corner, Select Configuration > Warning Page. The Warning Page dialog
appears.

3.

In the Block Warning section, select Enable.

4.

Configure the display information in the blocking warning page.
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Option

Description

Default

Use the default blocking warning page as shown above.

Redirect page

Redirect to the specified URL. Type the URL in the URL http://
box. You can click Detection to verify whether the URL is valid.

Custom

5.

Customize the blocking warning page. Type the title in the Title
box and the description in the Description box. You can click
Preview to preview the blocking warning page.

Click OK to save the settings.

Configuring Audit Warning
After enabling the audit warning function, when your internet behavior matches the configured internet
behavior rules, your HTTP request will be redirected to a warning page, on which the audit and privacy
protection information is displayed. See the picture below:

The audit warning function is disabled by default. To configure the audit warning function:
1.

Select Object > Data Security>Content Filter> Web Content/Web Posting/Email
Filter/HTTP/FTP Control.

2.

At the top-right corner, Select Configuration > Warning Page. The Warning Page dialog
appears.

3.

In the Audit Warning section, select Enable.

4.

Click OK to save the settings.

Bypass Domain
Regardless of internet behavior control rules, requests to the specified bypass domains will be allowed
unconditionally.
To configure a bypass domain:
1.
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Select Object > Data Security>Content Filter> Web Content/Web Posting/Email
Filter/HTTP/FTP Control.
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2.

3.
4.
5.

At the top-right corner, Select Configuration > Bypass Domain. The Bypass Domain
dialog appears.

In the text box, type the domain name.
Click Add. The domain name will be added to the system and displayed in the bypass
domain list.
Click OK to save the settings.

Exempt User
The Exempt User function is used to specify the users who will not be controlled by the internet
behavior control rules. The system supports the following types of exempt user: IP, IP range, role, user,
user group, and address entry.
To configure the exempt user:
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1.

Select Object > Data Security>Content Filter> Web Content/Web Posting/Email
Filter/HTTP/FTP Control.

2.

At the top-right corner, Select Configuration > Exempt User. The Exempt User dialog
appears.
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3.

Select the type of the user from the Type drop-down list.

4.

Configure the corresponding options.

5.

Click Add. The user will be added to the system and displayed in the exempt user list.

6.

Click OK to save the settings.

File Filter
The file filter function checks the files transported through HTTP, FTP, SMTP, POP3 protocols and
control them according to the file filter rules.


Be able to check and control the files transported through GET and POST methods of
HTTP, FTP, SMTP, and POP3.



Support file type filter conditions.



Support block, log, and permit actions.

After you bind the file filter profile to a policy rule, the system will process the traffic that matches the
rule according to the profile.

Creating File Filter Rule
Use the file filter rule to specify the protocol that you want to check, the filter conditions, and the
actions.
To create a file filter rule:
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1.

Select Object > Data Security > File Filter.

2.

Click New.

3.

In the dialog box, enter values.
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Option

Description

Name

Specifies the name of the file filter rule.

Filter Rule
ID

The ID of file filter rule item.
If one filter rule item is configured with the block action and the
file happens to match this rule, then the system will block the
uploading/downloading of this file.

File Type

Specify the file type. Click on the column's cells and select from
the drop-down menu. You can specify more than one file types.
To control the file type that not supported, you can use the
UNKNOWN type.
When the transmitted file is a particular type, the system will
trigger the actions. The file filter function can identify the
following file types:
7Z, AI, APK, ASF, AVI, BAT, BMP, CAB, CATPART, CDR,
CIN, CLASS, CMD, CPL, DLL, DOC, DOCX, DPX, DSN,
DWF, DWG, DXF, EDIT, EMF, EPS, EPUB, EXE, EXR,
FLA, FLV, GDS, GIF, GZ, HLP, HTA, HTML, IFF, ISO, JAR,
JPG, KEY, LNK, LZH, MA, MB, MDB, MDI, MIF, MKV,
MOV, MP3, MP4, MPEG, MPKG, MSI, NUMBERS, OCX,
PAGES, PBM, PCL, PDF, PGP, PIF, PL, PNG, PPT, PPTX,
PSD, RAR, REG, RLA, RMVB, RPF, RTF, SGI, SH, SHK, STP,
SVG, SWF, TAR, TDB, TIF, TORRENT, TXT, VBE, WAV,
WEBM, WMA, WMF, WMV, WRI, WSF, XLS, XLSX, XML,
XPM, ZIP, UNKNOWN

www.fs.com

Protocol

Specifies the protocols. http-get represents to check the files
transported through the GET method of HTTP. http-post
represents to check the files transported through the POST
method of HTTP. ftp represents to check the files transported
through FTP. smtp represents to check the files transported
through SMTP. pop3 represents to check the files transported
through POP3. You can specify more than one protocol types.
This option is required.

Action

Specify the action to control the files that matches the filter
conditions. You can specify block or log. This option is required.

322

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

4.

Click OK.

Content Filter
This feature may not be available on all platforms. Please check your system's actual page to see if your
device delivers this feature.
Includes：


"Web Content" : Controls the network behavior of visiting the webpages that contain
certain keywords, and log the actions.



"Web Posting" : Controls the network behavior of posting on websites and posting
specific keywords, and logs the posting action and posted content.



"Email Filter" :Controls and audit SMTP mails :





Control and audit all the behaviors of sending emails.
Control and audit the behaviors of sending emails that contain specific sender,
recipient, keyword or attachment.
"HTTP/FTP Control" :Controls and audits the actions of HTTP and FTP applications:



FTP methods, including Login, Get, and Put.



HTTP methods, including Connect, Get, Put, Head, Options, Post, and Trace.

Web Content
The web content function is designed to control the network behavior of visiting the websites that
contain certain keywords. For example, you can configure to block the access to website that contains
the keyword "gamble", and record the access action and website information in the log.

Configuring Web Content
Configuring Web Content contains two parts:


Create a Web Content rule



Bind a Web Content rule to a security zone or policy rule

Part 1: Creating a web content rule
1.

www.fs.com

Select Object > Data Security > Content Filter > Web Content.
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2.

Click New.

In the Web Content Rule Configuration dialog box, enter values.
Option

Description

Name

Rule Name

Action

Defines the action when a keyword is matched.


Control Range

www.fs.com

New: Creates new keyword categories. For more
information about keyword category, see "Configuring
Objects" .



Edit: Edits selected keyword category.



Keyword category: Shows the name of
configured keyword categories.



Block: Select the check box to block the web
pages containing the corresponding keywords.



Log: Select the check box to record log messages
when visiting the web pages containing the
corresponding keywords.



Record contents: Select the check box to record
the keyword context. This option is available only when
the device has a storage media (SD card, U disk, or
storage module provided by FS) with the NBC license
installed.

Specify the coverage of this rule. By default, the rule applies to all
website.
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Option

Description
1.
2.

Click Control Range.
Select or unselect the websites you want to
monitor and control.

3.
3.

Click OK.

Click OK.

Part 2: Binding a Web Content rule to a security zone or security policy rule
The Web content configurations are based on security zones or policies.


If a security zone is configured with the Web content function, the system will perform
detection on the traffic that is destined to the binding zone specified in the rule, and then do
according to what you specified.



If a policy rule is configured with the Web content function, the system will perform
detection on the traffic that is destined to the policy rule you specified, and then response.



The threat protection configurations in a policy rule is superior to that in a zone rule if
specified at the same time, and the Web content configurations in a destination zone is superior
to that in a source zone if specified at the same time.

To realize the zone-based Web Content:
1.
2.
3.

4.

Create a zone. For more information about how to create, refer to "Security Zone" on
Page 37.
In the Zone Configuration dialog, select Data Security tab.
Enable the threat protection you need, and select a Web content rules from the profile
drop-down list below; or you can click Add Profile from the profile drop-down list below, to
create a Web content rule, see Creating a Web content rule.
Click OK to save the settings.

To realize the policy-based Web content:
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1.

Configure a security policy rule. See "Configuring a Security Policy Rule" .

2.

In the Data Security tab, select the Enable check box of Web Content.
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3.

From the Profile drop-down list, select a Web Content rule. You can also click Add
Profile to create a new Web Content rule.

4.

Click OK to save the settings.

If necessary, you can configure some additional features by going to the right top corner and click
Configuration.
Option

Description

Predefined
URL DB

The predefined URL database includes dozens of categories and
tens of millions of URLs and you can use it to specify the URL
category and URL range for the URL category/Web posting
functions.

User-defined
URL DB

URL Lookup

Warning Page

The user-defined URL database is defined by yourself and you
can use it to specify the URL category and URL range for the
URL category/Web posting functions.
Use the URL lookup function to inquire URL information from
the URL database.


Block warning: When your network access is
blocked, you will be prompted with a warning page in the
Web browser.



Audit warning: When your network access is
audited, you will be prompted with a warning page in the
Web browser.

Domains that are not controlled by the internet behavior control
Bypass Domain rules.
Exempt User

Users that are not controlled by the internet behavior control
rules.

Notes:

www.fs.com



To enusre you have the latest URL database, it is better to update your database first.
Refer to "Configuring Objects" .



You can export logs to a designated destination. Refer to "Log Configuration" .
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By default, a rule will immediately take effect after you click OK to complete
configuration.

Viewing Monitored Results of Keyword Blocking in Web Content
If you have configured email filter with keyword blocking, you can view the monitored results of
blocking those words.
Select Monitor > Keyword Block > Web Content, you will see the monitored results. For more about
monitoring, refer to "Web Content" .

Viewing Logs of Keyword Blocking in Web Content
To see the system logs of keyword blocking in web content, please refer to the "Content Filter Logs" .

Web Posting
The web posting function can control the network behavior of posting on websites and posting specific
keywords, and can log the posting action and posting content. For example, forbid the users to post
information containing the keyword X, and record the action log.

Configuring Web Posting
Configuring Web Posting contains two parts:


Create a web posting rule



Bind a web posting rule to a security zone or policy rule

Part 1: Creating a web posting rule

www.fs.com

1.

Select Object > Data Security > Content Filter > Web Posting.

2.

Click New.
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In the Web Posting Rule Configuration dialog, enter values.
Option

Description

Name

Specifies the rule name.

All posting
information

The action applies to all web posting content.


Block: Select to block all web posting behaviors.



Record Log: Select to record all logs about web
posting.

Posting
information
with specific
keyword

Control Range

Controls the action of posting specific keywords. The options
are:


New: Creates new keyword categories. For more
information about keyword category, see "Keyword
Category" .



Edit: Edits selected keyword category.



Keyword category: Shows the name of
configured keyword categories.



Block: Blocks the posting action of the
corresponding keywords.



Log: Records log messages when posting the
corresponding keywords.

Specify the coverage of this rule. By default, the rule applies to all
website.
1.
2.
3.

3.

Click Control Range.
Select or unselect the websites you want to
monitor and control.
Click OK.

Click OK.

Part 2: Binding a Web Posting rule to a security zone or security policy rule
The web posting configurations are based on security zones or policies.

www.fs.com
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If a security zone is configured with the web posting function, the system will perform
detection on the traffic that is destined to the binding zone specified in the rule, and then do
according to what you specified.



If a policy rule is configured with the web posting function, the system will perform
detection on the traffic that is destined to the policy rule you specified, and then response.



The threat protection configurations in a policy rule is superior to that in a zone rule if
specified at the same time, and the web posting configurations in a destination zone is superior
to that in a source zone if specified at the same time.

To realize the zone-based web posting:
1.

Create a zone. For more information about how to create, refer to "Security Zone" .

2.

In the Zone Configuration dialog, select Data Security tab.

3.

Enable the threat protection you need, and select a Web content rules from the profile
drop-down list below; or you can click Add Profile from the profile drop-down list below, to
create a Web content rule, see Creating a web posting rule.

4.

Click OK to save the settings.

To realize the policy-based web posting:
1.

Configure a security policy rule. See "Configuring a Security Policy Rule" .

2.

In the Data Security tab, select the Enable check box of web posting.

3.

From the Profile drop-down list, select a web posting rule. You can also click Add
Profile to create a new web posting rule.

4.

Click OK to save the settings.

If necessary, you can configure some additional features by going to the right top corner and click
Configuration.
Option
Predefined
URL DB

User-defined
URL DB
www.fs.com

Description
The predefined URL database includes dozens of categories and
tens of millions of URLs and you can use it to specify the URL
category and URL range for the URL category/Web posting
functions.
The user-defined URL database is defined by yourself and you
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Option

Description
can use it to specify the URL category and URL range for the
URL category/Web posting functions.

URL Lookup

Warning Page

Use the URL lookup function to inquire URL information from
the URL database.


Block warning: When your network access is
blocked, you will be prompted with a warning page in the
Web browser.



Audit warning: When your network access is
audited, you will be prompted with a warning page in the
Web browser.

Domains that are not controlled by the internet behavior control
Bypass Domain rules.
Exempt User

Users that are not controlled by the internet behavior control
rules.

Notes:


To enusre you have the latest URL database, it is better to update your database first.
Refer to "Configuring Objects".



If there is an action conflict between setting for "all websites" and "specific keywords",
when a traffic matches both rules, the "deny" action shall prevail.




You can export logs to a designated destination. Refer to "Log Configuration".
By default, a rule will immediately take effect after you click OK to complete
configuration.

Viewing Monitored Results of Keyword Blocking in Web Posts
If you have configured web posting rule with keyword blocking, you can view the monitored results of
blocking those words.
Select Monitor > Keyword Block > Web Posting, you will see the monitored results. For more about
monitoring, refer to "Keyword Block".

www.fs.com
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Viewing Logs of Keyword Blocking in Web Posts
To see the system logs of keyword blocking in web posts, please refer to the "Content Filter Logs".

Email Filter
The email filter function is designed to control the email sending actions according to the sender,
receiver, email content and attachment, and record the sending log messages. Both the SMTP emails and
the web mails can be controlled.

Configuring Email Filter
Configuring email filter contains two parts:


Create an email filter rule



Bind an email filter rule to a security zone or policy rule

Part 1: Creating an email filter rule
1.

Select Object > Data Security > Content Filter > Email Filtering Log.

2.

Click New.

In the dialog box, enter values.
Option

Description

Name

Specifies the rule name.

Control Type

All emails - This option applies to all the sending emails.
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Record Log - Select this check box if you want all
emails to be logged.
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Option

Description
Specific mail items - This option applies to specific mail items.
To configure the email sender:
1.

Click Sender.

2.

In the prompt, enter sender's email address.

3.

Click Add.

4.
5.

You may select to block the sender or keep a
record.
Click OK.

To configure the email receiver:
1.
2.
3.
4.
5.

Click Recipient.
In the prompt, enter email receiver's email
address.
Click Add.
You may select to block the receiver or keep a
record.
Click OK.

To configure the email content keywords:
1.

Click email content.

2.

In the prompt, click Add. See the Keyword
Category part in "Configuring Objects".

3.

You may select to block the email containing
keywords or keep a record.

Other
emails

Select an action for emails other than
which are added above.

Exempt Email
Exempt Email

To configure mail addresses that do not follow the regulations of
email filter:
1.
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Click Exempt Email.
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Option

Description
2.

In the prompt, enter emails that do not obey
email filter.

3.

Click Add, and you can add more.

4.

Click OK.

Part 2: Binding an Email filter rule to a security zone or security policy rule
The email filter configurations are based on security zones or policies.


If a security zone is configured with the email filter function, the system will perform
detection on the traffic that is destined to the binding zone specified in the rule, and then do
according to what you specified.



If a policy rule is configured with the email filter function, the system will perform
detection on the traffic that is destined to the policy rule you specified, and then response.



The threat protection configurations in a policy rule is superior to that in a zone rule if
specified at the same time, and the email filter configurations in a destination zone is superior to
that in a source zone if specified at the same time.

To realize the zone-based email filter:
1.

Create a zone. For more information about how to create, refer to "Security Zone".

2.

In the Zone Configuration dialog, select Threat Protection tab.

3.

4.

Enable the threat protection you need, and select an email filter rules from the profile
drop-down list below; or you can click Add Profile from the profile drop-down list below, to
create an email filter rule, see Creating an email filter rule.
Click OK to save the settings.

To realize the policy-based email filter:
1.

Configure a security policy rule. See "Configuring a Security Policy Rule".

2.

In the Protection tab, select the Enable check box of email filter.

3.
4.
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From the Profile drop-down list, select an email filter rule. You can also click Add Profile
to create a new email filter rule.
Click OK to save the settings.
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If needed, you can also configure SSL proxy, keyword category, warning page, bypass domain and user
exempt user.
To configure those features, click Configuration on the right top corner of the Email Filtering Log list
page.
Option

Description

Keyword
Category

Use the keyword category function to customize the keyword
categories. You can use it to specify the keyword for the URL
category/Web posting/email filter functions.

Warning Page



Block warning: When your network access is
blocked, you will be prompted with a warning page in the
Web browser.



Audit warning: When your network access is
audited, you will be prompted with a warning page in the
Web browser.

Domains that are not controlled by the internet behavior control
Bypass Domain rules.
Exempt User

Users that are not controlled by the internet behavior control
rules.

Notes:


If an email filter rule has added all three of Audit/Block Sender, Receiver and email
content, the rule will take effect when one of them is hit.



You can export logs to a designated destination. Refer to "Log Configuration".



By default, a rule will immediately take effect after you click OK to complete
configuration.

Viewing Monitored Results of Email Keyword Blocking
If you have configured email filter with keyword blocking, you can view the monitored results of
blocking those words.
Select Monitor > Keyword Block > Email Content, you will see the monitored results. For more about
monitoring, refer to "Email Content".

www.fs.com
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Viewing Logs of Emails Keyword Blocking
To see the system logs of email's keywords, please refer to the "Content Filter Logs".

HTTP/FTP Control
The HTTP/FTP control function is designed to control and audit (record log messages) the actions of
HTTP and FTP applications, including:


Behavior control and audit of controlling the actions of Login, Get, and Put action in
FTP;



Behavior control and audit of controlling the actions of Connect, Get, Put, Head,
Options, Post, Trace, Delete in HTTP.

Configuring HTTP/FTP Control
Configuring HTTP/FTP behavior control contains two parts:


Create an HTTP/FTP behavior control rule



Bind an HTTP/FTP behavior control rule to a security zone or policy rule

Part 1: Creating an HTTP/FTP behavior control rule
1.

Select Object > Data Security > Content Filter > HTTP/FTP Control.

2.

Click New.

In the HTTP/FTP Control Rule Configuration dialog box, enter values.
Option

Description

Name

Specifies the rule name.

Action

www.fs.com
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Option
FTP

Description
Controls the FTP methods, including Login, Get, and Put.
Expand FTP, and configure the FTP control options.


From the first drop-down list, select the method
to be controlled, it can be GET, PUT, or Login.



Type the file name (for the method of GET or
PUT) or user name (for the method of Login) into the
next box.



From the second drop-down list, select the
action. It can be Block or Permit.



From the third drop-down list, specify whether to
record the log messages.




HTTP

Repeat Step 1 to 5 to add more control entries.
To edit/delete a control entry, select the entry from the
list, and then click Edit or Delete.

Controls the HTTP methods, including Connect, GET, PUT,
Head, Options, Post, Trace, and Delete. Expand HTTP, and
configure the HTTP control options.


From the first drop-down list, select the method
to be controlled, it can be Connect, GET, PUT, Head,
Options, Post, Trace, or Delete.



Type the domain name into the next box.



From the second drop-down list, select the
action. It can be Block or Permit.



From the third drop-down list, specify whether to
record the log messages.
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Click Add.

Click Add.
Repeat Step 1 to 5 to add more control entries.
To edit/delete a control entry, select the entry from the
list, and then click Edit or Delete.
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3.

Click OK.

Part 2: Binding a HTTP/FTP behavior control rule to a security zone or security policy rule
The HTTP/FTP behavior control configurations are based on security zones or policies.


If a security zone is configured with the HTTP/FTP behavior control function, the
system will perform detection on the traffic that is destined to the binding zone specified in the
rule, and then do according to what you specified.



If a policy rule is configured with the HTTP/FTP behavior control function, the system
will perform detection on the traffic that is destined to the policy rule you specified, and then
response.



The threat protection configurations in a policy rule is superior to that in a zone rule if
specified at the same time, and the HTTP/FTP behavior control configurations in a destination
zone is superior to that in a source zone if specified at the same time.

To realize the zone-based HTTP/FTP behavior control:
1.

Create a zone. For more information about how to create, refer to "Security Zone".

2.

In the Zone Configuration dialog, select Data Security tab.

3.

4.

Enable the threat protection you need, and select an email filter rules from the profile
drop-down list below; or you can click Add Profile from the profile drop-down list below, to
create a HTTP/FTP behavior control rule, see Creating a HTTP/FTP behavior control rule.
Click OK to save the settings.

To realize the policy-based HTTP/FTP behavior control:
1.

Configure a security policy rule. See "Configuring a Security Policy Rule".

2.

In the Data Security tab, select the Enable check box of HTTP/FTP behavior control.

3.
4.

From the Profile drop-down list, select a HTTP/FTP behavior control rule. You can
also click Add Profile to create a new HTTP/FTP behavior control rule.
Click OK to save the settings.

If necessary, you can configure some additional features by going to the right top corner and click
Configuration.
Option

www.fs.com

Description
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Option

Description

Predefined
The predefined URL database includes dozens of categories and
URL database
tens of millions of URLs and you can use it to specify the URL
category and URL range for the URL category/Web posting
functions.
User-defined
The user-defined URL database is defined by yourself and you
URL database
can use it to specify the URL category and URL range for the
URL category/Web posting functions.
URL lookup

Use the URL lookup function to inquire URL information from
the URL database.

Keyword
category

Customizes keyword categories as needed.

Warning Page



Block warning: When your network access is
blocked, you will be prompted with a warning page in the
Web browser.



Audit warning: When your network access is
audited, you will be prompted with a warning page in the
Web browser.

Domains that are not controlled by the internet behavior control
Bypass Domain rules.
Exempt User

Users that are not controlled by the internet behavior control
rules.

Notes:



You can export logs to a designated destination. Refer to "Log Configuration".
By default, a rule will immediately take effect after you click OK to complete
configuration.

Viewing Logs of HTTP/FTP Behavior Control
To see the system logs of HTTP/FTP behavior control, please refer to the "Content Filter Logs".
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Network Behavior Record
Network behavior record function audits the IM applications behaviors and record log messages for the
access actions, includes:


Audits the QQ, WeChat and sinaweibo user behaviors.



Log the access behaviors.

Configuring Network Behavior Recording
Configuring network behavior record contains two parts:


Create a network behavior record rule



Bind a network behavior record rule to a security zone or policy rule

Part 1: Creating a NBR rule
1.

Select Object > Data Security > Network Behavior Record.

2.

Click New.

In the Network Behavior Record Configuration dialog box, enter values.
Option

Description

Name

Rule Name

IM
QQ

To audits the QQ behavior.
1.
2.
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Select the QQ checkbox.
Timeout: Specifies the timeout value. The unit is
minute. The default value is 10. During the timeout
period, the IM user traffic of the same UID will not

339

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

Option

Description

trigger the new logs and after the timeout reaches, it
will trigger new logs.
WeChat

To audits the WeChat behavior.
1.
2.

Sina Weibo

Select the Wechat checkbox.
Timeout: Specifies the timeout value. The unit is
minute. The default value is 20. During the timeout
period, the IM user traffic of the same UID will not
trigger the new logs and after the timeout reaches, it
will trigger new logs.

To audits the sina weibo behavior.
1.
2.

Select the Sina Weibo checkbox
Timeout: Specifies the timeout value. The unit is
minute. The default value is 20. During the timeout
period, the IM user traffic of the same UID will not
trigger the new logs and after the timeout reaches, it
will trigger new logs.

Web Surfing Record
URL Log

logs the GET and POST methods of HTTP.
 Get: Records the logs when having GET methods.
 Post: Records the logs when having POST methods.

POST Content

3.

Post Content: Records the posted content.

Click OK.

Part 2: Binding a network behavior record rule to a security zone or security policy rule
The network behavior record configurations are based on security zones or policies.


If a security zone is configured with the network behavior record function, the system
will perform detection on the traffic that is destined to the binding zone specified in the rule, and
then do according to what you specified.

www.fs.com
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If a policy rule is configured with the network behavior record function, the system will
perform detection on the traffic that is destined to the policy rule you specified, and then
response.



The threat protection configurations in a policy rule is superior to that in a zone rule if
specified at the same time, and the network behavior record configurations in a destination zone
is superior to that in a source zone if specified at the same time.

To realize the zone-based network behavior record:
1.

Create a zone. For more information about how to create, refer to "Security Zone".

2.

In the Zone Configuration dialog, select Data Security tab.

3.

4.

Enable the threat protection you need, and select a network behavior record rules from
the profile drop-down list below; or you can click Add Profile from the profile drop-down list
below, to create a network behavior record rule, see Creating a network behavior record rule.
Click OK to save the settings.

To realize the policy-based network behavior record:
1.

Configure a security policy rule. See "Configuring a Security Policy Rule".

2.

In the Data Security tab, select the Enable check box of network behavior record.

3.

From the Profile drop-down list, select a network behavior record rule. You can also
click Add Profile to create a new network behavior record rule.

4.

Click OK to save the settings.



You can export logs to a designated destination. Refer to "Log Configuration"

Notes:



By default, a rule will immediately take effect after you click OK to complete
configuration

Viewing Logs of Network Behavior Recording
To see the logs of network behavior recording, please refer to the "Network Behavior Record Logs".

www.fs.com
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NetFlow
NetFlow is a data exchange method, which records the source /destination address and port numbers of
data packets in the network. It is an important method for network traffic statistics and analysis.
NetFlow supports the NetFlow Version 9. With this function configured, the device can collect user's
ingress traffic according to the NetFlow profile, and send it to the server with NetFlow data analysis tool,
so as to detect, monitor and charge traffic.
Related Topics:


"Configuring NetFlow"

Configuring NetFlow
The NetFlow configurations are based on interfaces.
To configure the interface-based NetFlow, take the following steps:
1.
2.
3.

Click Object > NetFlow > Configuration. Select Enable check box to enable the
NetFlow function.
Click Object > NetFlow > Profile to create a NetFlow rule .
Bind the NetFlow rule to an interface. Click Network > Interface. Select the interface
you want to bind or click New to create a new interface. In the Interface Configuration dialog
box, select the Basic tab and then select a NetFlow rule from the NetFlow configuration
drop-down list.

Configuring a NetFlow Rule
To configure the NetFlow rule, take the following steps:
1.
2.
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Click Object > NetFlow > Profile.
Click New to create a new NetFlow rule. To edit an existing one, select the check box of
this rule and then click Edit.
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In the NetFlow Configuration dialog box, configure the following options
Option

Description

Name

Enter the name of the NetFlow rule.

Template
Refresh Rate

Enterprise
Field
Server

You can configure the NetFlow template refresh rate by time or
number of packets, after which system will refreshes the NetFlow
rule.


Time: Specifies the time after which system
refreshes the NetFlow rule. The range is 1 to 3600
minutes. The default value is 30 minutes.



Packets: Specifies the number of packets. When
the number of NetFlow packets exceeds the specified
value, system will refreshes the NetFlow rule. The range
is 1 to 600. The default value is 20.

Select the Enterprise Field check box, and the collected NetFlow
traffic information will contain enterprise field information.
To configure the NetFlow server, take the following steps:
1.
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Type the server name, IP address and port
number into the Server Name, IP and Port box
respectively.
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Option

Active
Timeout

Description
2.

Click Add to add a NetFlow server which will be
displayed in the list below.

3.

Repeat the above steps to add more servers. You
can add up to 2 servers. To delete a server, select the
server check box you want to delete from the list and
click Delete.

The active timeout value is the time after which the device will
send the collected NetFlow traffic information to the specified
server once.
Type the active timeout value into the Active Timeout box. The
range is 1 to 60 minutes. The default value is 5 minutes.

Source
Interface
Source IP
Address

3.

Select the source interface for sending NetFlow traffic
information in the Source Interface drop-down list.
After specifying the source interface, the system will
automatically acquire and display the management IP address or
the secondary IP address of the source interface in the dropdown list.

Click OK to save the settings.

NetFlow Global Configurations
To configure the NetFlow global configurations, take the following steps:
1.
2.
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Select Object > NetFlow > Configuration.
Select the Open NetFlow check box of NetFlow to enable the NetFlow function. Clear
the check box to disable the NetFlow function. The NetFlow function will take effect after
rebooting.
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Chapter 10 Policy
The Policy module provides the following functions:


Security policy: Security policy is the basic function of devices that are designed to
control the traffic forwarding between security zones/segments. By default all traffic between
security zones/segments will be denied.



NAT: When the IP packets pass through the devices or routers, the devices or routers
will translate the source IP address and/or the destination IP address in the IP packets.



iQoS: iQoS is used to provide different priorities to different traffic, in order to control
the delay and flapping, and decrease the packet loss rate. iQoS can assure the normal
transmission of critical business traffic when the network is overloaded or congested.



Session limit: The session limit function limits the number of sessions and controls the
session rate to the source IP address, destination IP address, specified IP address, service, or
role/user/user group, thereby protecting from DoS attacks and control the bandwidth of
applications, such as IM or P2P.



ARP Defense: The ARP defense is used to protect your network against various ARP
attacks.



Internet behavior control: The Internet behavior control allows you to flexibly configure
control rules to comprehensively control and audit (by behavior logs and content logs) on user
network behavior.



Global blacklist: After adding the IP addresses or services to the global blacklist, system
will perform the block action to the IP address and service until the block duration ends.

Security Policy
Security policy is the basic function of devices that is designed to control the traffic forwarding between
security zones/segments. Without security policy rules, the devices will deny all traffic between security
zones/segments by default. After configuring the security policy rule, the device can identify what traffic
between security zones or segments will be permitted, and the others will be denied.
The basic elements of policy rules:


The source zone and address of the traffic



The destination zone and address of the traffic



The service type of the traffic

www.fs.com

345

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE



Actions that the devices will perform when processing the specific type of traffic,
including Permit, Deny, Tunnel, From tunnel, WebAuth, and Portal server.

Generally a security policy rule consists of two parts: filtering conditions and actions. You can set the
filtering conditions by specifying traffic's source zone/address, destination zone/address, service type,
and user. Each policy rule is labeled with a unique ID which is automatically generated when the rule is
created. You can also specify a policy rule ID at your own choice. All policy rules in system are arranged
in a specific order. When traffic flows into a device, the device will query for policy rules by turn, and
processes the traffic according to the first matched rule.
The max global security policy rule numbers may vary in different models.
Security policy supports IPv4 and IPv6 address. If IPv6 is enabled, you can configure IPv6 address entry
for the policy rule.
This section contains the following contents:



Configure a security policy rule
Manage the security policy rules: enable/disable a policy rule, clone a policy rule, adjust
security rule position, configure default action, view and clear policy hit count, hit count check,
and rule redundancy check.



Configure a security policy group



View and search the security policy rules/ security policy groups

Configuring a Security Policy Rule
To configure a security policy rule, take the following steps:
1.

Select Policy > Security Policy.

2.

At the top-right corner of list, click Policy.

3.

At the top-left corner, click New. The Policy Configuration dialog box will appear.
In the Basic tab, configure the corresponding options.
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Option

Description

Name

Type the name of the security policy.

Type

Select the IP type, including IPv4 or IPv6. Only the IPv6 firmware
can configure the IPv6 type. If IPv6 is selected, all of the IPv6/prefix,
IP range, and address should be configured in the IPv6 format.
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Option

Description

Source Information
Zone

Specifies a source zone.

Address

Specifies the source addresses.
1.
Select an address type from the Address drop-down
list.
2.
Select or type the source addresses based on the
selected type.
3.

Click

to add the addresses to the right pane.

4.
After adding the desired addresses, click the blank
area in this dialog box to complete the source address
configuration.
You can also perform other operations:

When selecting the Address Book type, you can click
Add to create a new address entry.

The default address configuration is any. To restore
the configuration to this default one, select the any check box.
User

Specifies a role, user or user group for the security policy rule.
1.
From the User drop-down menu, select the AAA
server where the users and user groups reside. To specify a
role, select Role from the AAA Server drop-down list.
2.
Based on the type of AAA server, you can execute
one or more actions: search a user/user group/role, expand
the user/user group list, enter the name of the user/user
group.
3.
After selecting users/user groups/roles, click
add the them to the right pane.

to

4.
After adding the desired objects, click the blank area
in this dialog box to complete the user configuration.
Destination
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Zone

Specifies a destination zone.

Address

Specifies the destination addresses.
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Option

Description
1.
Select an address type from the Address drop-down
list.
2.
Select or type the destination addresses based on the
selected type.
3.

Click

to add the addresses to the right pane.

4.
After adding the desired addresses, click the blank
area in this dialog box to complete the destination address
configuration.
You can also perform other operations:

When selecting the Address Book type, you can click
Add to create a new address entry.

The default address configuration is any. To
restore the configuration to this default one, select the any
check box.
Other Information
Service

Specifies a service or service group.
1.
From the Service drop-down menu, select a type:
Service, Service Group.
2.
You can search the desired service/service group,
expand the service/service group list.
3.
After selecting the desired services/service groups,
click to add them to the right pane.
4.
After adding the desired objects, click the blank area
in this dialog box to complete the service configuration.
You can also perform other operations:


To add a new service or service group, click Add.


The default service configuration is any. To
restore the configuration to this default one, select the any
check box.
Applicatio Specifies an application/application group/application filters.
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Option

Description

n

1.
From the Application drop-down menu, you can
search the desired application/application
group/application filter, expand the list of
applications/application groups/application filters.
2.
After selecting the desired applications/application
groups/application filters, click to add them to the right
pane.
3.
After adding the desired objects, click the blank area
in this dialog box to complete the application
configuration.
You can also perform other operations:

To add a new application group, click New
AppGroup.


To add a new application filter, click New AppFilter.

Action
Action

Specifies an action for the traffic that is matched to the policy rule,
including:

Permit - Select Permit to permit the traffic to pass
through.


Deny - Select Deny to deny the traffic.


WebAuth - Performs Web authentication on the
matched traffic. Select WebAuth from the drop-down list
after selecting the Secured Connection option, and then select
an authentication server from the following drop-down list.

From tunnel (VPN) - For the traffic from a peer to
local, if this option is selected, system will first determine if
the traffic originates from a tunnel. Only such traffic will be
permitted. Select From tunnel (VPN) from the drop-down list
after selecting the Secured Connection option, and then select
a tunnel from the following drop-down list.

Tunnel (VPN) - For the traffic from local to a peer,
select this option to allow the traffic to pass through the VPN
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Option

Description
tunnel. Select Tunnel (VPN) from the drop-down list after
selecting the Secured Connection option, and then select a
tunnel from the following drop-down list.

Portal server - Performs portal authentication on the
matched traffic. Select Portal server from the drop-down list
after selecting the Secured Connection option, and then type
the URL address of the portal server.

Enable
Web
Redirect

Enable the Web redirect function to redirect the HTTP request from
clients to a specified page automatically. With this function enabled,
system will redirect the page you are requesting over HTTP to a
prompt page.
1.

Select the Enable Web Redirect check box.

2.
Type a redirect URL into the Notification page URL
box.
When using Web redirect function, you need to configure the Web
authentication function. For more configurations, see "User Online
Notification".
In the Protection tab, configure the corresponding options.
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Option

Description

Antivirus

Specifies an antivirus profile. The combination of security policy
rule and antivirus profile enables the devices to implement finegrained application layer policy control.

IPS

Specifies an IPS profile. The combination of security policy rule
and IPS profile enables the devices to implement fine-grained
application layer policy control.

URL Filtering

Specifies a URL filter profile. The combination of security policy
rule and URL filter profile enables the devices to implement finegrained application layer policy control.

Sandbox

Specifies a sandbox profile. The combination of security policy
rule and sandbox profile enables the devices to implement finegrained application layer policy control.

Botnet C&C
Prevention

Specifies a botnet C&C prevention profile. The combination of
security policy rule and botnet C&C prevention profile enables
the devices to implement fine-grained application layer policy
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Option

Description
control.

In the Data Security tab, configure the corresponding options.
Option

Description

File Filter

Specifies a file filter profile. The combination of security policy rule
and file filter profile enables the devices to implement fine-grained
application layer policy control.

Content
Filter

Network
Behavior
Record



Web Content: Specifies a web content profile. The
combination of security policy rule and Web Content profile
enables the devices to implement fine-grained application
layer policy control.



Web Posting: Specifies a web posting profile. The
combination of security policy rule and web posting profile
enables the devices to implement fine-grained application
layer policy control.



Email Filter: Specifies an email filter profile. The
combination of security policy rule and email filter profile
enables the devices to implement fine-grained application
layer policy control.



HTTP/FTP Control: Specifies a HTTP/FTP control
profile. The combination of security policy rule and
HTTP/FTP control profile enables the devices to implement
fine-grained application layer policy control.

Specifies a NBR profile. The combination of security policy rule and
NBR profile enables the devices to implement fine-grained
application layer policy control.

In the Options tab, configure the corresponding options.
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Option

Description

Schedule

Specifies a schedule when the security policy rule takes effect.
Select a desired schedule from the Schedule drop-down list. This
option supports fuzzy search. After selecting the desired
schedules, click the blank area in this dialog box to complete the
schedule configuration.
To create a new schedule, click New Schedule.
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Option

Description

Log

You can log policy rule matching in the system logs according to
your needs.


For the policy rules of Permit, logs will be
generated in two conditions: the traffic that is matched to
the policy rules starts and ends its session.



For the policy rules of Deny, logs will be
generated when the traffic that is matched to the policy
rules is denied.

Select one or more check boxes to enable the corresponding log
types.

4.
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Deny - Generates logs when the traffic that is
matched to the policy rules is denied.



Session start - Generates logs when the traffic
that is matched to the policy rules starts its session.



Session end - Generates logs when the traffic that
is matched to the policy rules ends its session.

SSL Proxy

Specifies a SSL proxy profile. The combination of security policy
rule and SSL proxy profile enables the devices to decrypt the
HTTPS traffic.

Position

Select a rule position from the Position drop-down list.
Each policy rule is labeled with a unique ID or name. When
traffic flows into a device, the device will query for the policy
rules by turn, and processes the traffic according to the first
matched rule. However, the policy rule ID is not related to the
matching sequence during the query. The sequence displayed in
policy rule list is the query sequence for policy rules. The rule
position can be an absolute position, i.e., at the top or bottom, or
a relative position, i.e., before or after an ID or a name.

Description

Type descriptions into the Description box.

Click OK to save your settings.
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Managing Security Policy Rules
Managing security policy rules include the following matters: enable/disable a policy rule, clone a policy
rule, adjust security rule position, configure default action, view and clear policy hit count, hit count
check, and rule redundancy check.

Enabling/Disabling a Policy Rule
By default the configured policy rule will take effect immediately. You can terminate its control over the
traffic by disabling the rule.
To enable/disable a policy rule:
1.

Select Policy > Security Policy.

2.

At the top-right corner of list, click Policy.

3.

Select the security policy rule that you want to enable/disable.

4.

Click ..., and then select Enable or Disable to enable or disable the rule.

The disabled rule will not display in the list. Click ..., and then select Show Disabled Policies to show
them.

Cloning a Policy Rule
When there are a large number of policy rules in system, to create a policy rule which is similar to an
configured policy rule easily, you can copy the policy rule and paste it to the specified location.
To clone a policy rule, take the following steps:
1.

Select Policy > Security Policy.

2.

At the top-right corner of list, click Policy.

3.

Select the security policy rule that you want to clone and click Copy.

4.

Click Paste. In the pop-up, select the desired position. Then the rule will be cloned to the
desired position.

Adjusting Security Policy Rule Position
To adjust the rule position, take the following steps:

www.fs.com

1.

Select Policy > Security Policy.

2.

At the top-right corner of list, click Policy.

3.

Select the check box of the security policy whose position will be adjusted.
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4.
5.

Click Move.
In the pop-up menu, type the rule ID or name , and click Before ID , After ID , Before
Name or After Name. Then the rule will be moved before or after the specified ID or name.

Configuring Default Action
You can specify a default action for the traffic that is not matched with any configured policy rule.
System will process the traffic according to the specified default action. By default system will deny such
traffic.
To specify a default policy action, take the following steps:
1.

Select Policy > Security Policy.

2.

At the top-right corner of list, click Policy.

3.

Click ... and select Default Policy Action.
In the Default Policy Action dialog box, configure the following options.
Option

Description

Hit count

Shows the statistics on policy matching.

Default action

Log

4.

Specify a default action for the traffic that is not matched with
any configured policy rule.


Click Permit to permit the traffic to pass through.



Click Deny to deny the traffic.

Configure to generate logs for the traffic that is not matched
with any configured policy rule. By default system will not
generate logs for such traffic. To enable log, select the Enable
check box, and system will generate logs for such traffic.

Click OK to save your changes.

Viewing and Clearing Policy Hit Count
System supports statistics on policy hit counts, i.e., statistics on the matching between traffic and policy
rules. Each time the inbound traffic is matched with a certain policy rule, the hit count will increase by 1
automatically.
To view a policy hit count, click Policy > Security Policy. In the policy rule list, view the statistics on
policy hit count under the Hit Count column.
To clear a policy hit count, take the following steps:
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1.

Select Policy > Security Policy.

2.

At the top-right corner of list, click Policy.

3.

Click ... and select Clearing Policy Hit Count.
In the Clearing Hit Count dialog box, configure the following options.
Option

Description

All policies

Clears the hit counts for all policy rules.

Default policy Clears the hit counts for the default action policy rules.

4.

Policy ID

Clears the hit counts for a specified ID policy rule.

Name

Clears the hit counts for a specified name policy rule.

Click OK to perform the hit count clearing.

Hit Count Check
System supports to check policy rule hit counts.
To check hit count, take the following steps:
1.

Select Policy > Security Policy.

2.

At the top-right corner of list, click Policy.

3.

Click ... and select Hit Count Check. After the check, the policy rules whose hit count is
0 will be highlighted. That means that the policy rule is not used in system.

Rule Redundancy Check
In order to make the rules in the policy effective, system provides a method to check the conflicts
among rules in a policy. With this method, administrators can check whether the rules overshadow each
other.
To start a rule redundancy check, take the following steps:
1.

Select Policy > Security Policy.

2.

At the top-right corner of list, click Policy.

3.

Click ... and select Redundancy Check. After the check, system will highlight the policy
rule which is overshadowed.
Notes: Status will be shown below the policy list when redundancy check is started. It is
not recommended to edit a policy rule during the redundancy check. You can click
stop the check manually.
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Schedule Validity Check
In order to make sure that the policies based on schedule are effective, system provides a method to
check the validity of policies. After checking the policy, the invalid policies based on schedule will be
highlighted by yellow.
To check schedule validity:
1.

Select Policy > Security Policy .

2.

At the top-right corner of list, click Policy to enter the Security Policy page.

3.

Click ... and select Schedule Validity Check. After check, system will highlight the invalid
policy based on schedule by yellow. Meanwhile, you can view the validity status in the policy
list.

Showing Disabled Policies
To show disabled policies:
1.

Select Policy > Security Policy .

2.

At the top-right corner of list, click Policy to enter the Security Policy page.

3.

Click ... and select Show Disabled Policies. The disabled policies will be highlighted by
green in the policy list.

Notes:
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By default( the "Schedule Validity Check" and "Show Disabled Policies" are not selected),
the policy list only displays the enabled policies which are not highlighted.



When you select both "Schedule Validity Check" and "Show Disabled Policies", the
policy is managed as follows:
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The policy list will display the "Validity" column, which shows the validity status
of policies.



The invalid policy based on schedule will be highlighted by yellow no matter if
the policy is disabled or not.



If the valid policy based on schedule is disabled, it will be highlighted by green.

Configuring a Policy Group
You can organize some policy rules together to form a policy group, and configure the policy group
directly.
Configuring a security policy group include the following matters: creating a policy group, deleting a
policy group, enable/disable a policy group, add/delete a policy rule member, edit a policy group and
show disabled policy group.

Creating a Policy Group
To create a policy group, take the following steps:
1.

Select Policy > Security Policy .

2.

At the top-right corner of list, click Policy Group to enter the Security Policy Group
page.

3.

Click New,the Policy Group Configuration dialog box will appear.

In the Policy Group Configuration dialog, configure the corresponding options.

4.

Option

Description

Name

Specifies the name of the policy group. The length is 1 to 95
characters.

Description

Specifies the new description. You can enter at most 255
characters.

Add Policy

In the policy rules list, select the security policy rule that you
want to add to the policy group.

Click OK to save your settings.

Deleting a Policy Group
To delete a policy group, take the following steps:
1.
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Select Policy > Security Policy .
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2.

At the top-right corner of list, click Policy Group to enter the Security Policy Group
page.

3.

Select the check box of the policy group that you want to delete, and click Delete.

Enabling/Disabling a Policy Group
By default the configured policy group will take effect immediately.
To enable/disable a policy group, take the following steps:
1.

Select Policy > Security Policy .

2.

At the top-right corner of list, click Policy Group to enter the Security Policy Group
page.

3.

Select the check box of the policy group that you want to enable or disable, and click the
enable button under Status column. The enabled state is displayed as
state is displayed as

, and the disabled

.

Adding/Deleting a Policy Rule Member
To add a policy rule member to the policy group, take the following steps:
1.

Select Policy > Security Policy .

2.

At the top-right corner of list, click Policy Group to enter the Security Policy Group
page.

3.

In the policy group list, click the "+" in front of the policy group item to expand the
member list of the policy group.

4.

Click Add Members button to open Policy Group-Add policy dialog box, which displays
the list of policy rules that are not added to policy group.

5.

Select the check box of the policy rules that you want to add to the policy group.

6.

Click OK to save your settings.

Notes: A policy rule only can be added to a policy group.
To delete a policy rule member to the policy group, take the following steps:
1.

Select Policy > Security Policy .

2.

At the top-right corner of list, click Policy Group to enter the Security Policy Group
page.
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3.

In the policy group list, click the "+" in front of the policy group item to expand the
member list of the policy group.

4.

Select the check box of the policy group that needs to be deleted, and click Delete .

Editing a Policy Group
To modify the name or description of policy group, take the following steps:
1.

Select Policy > Security Policy .

2.

At the top-right corner of list, click Policy Group to enter the Security Policy Group
page.

3.

Select the check box of the policy group that you want to edit, and click Edit.

4.

Modify the name or description of policy group in the Policy Group Configuration
dialog.

Showing Disabled Policy Group
To show disabled policy groups, take the following steps:
1.

Select Policy > Security Policy .

2.

At the top-right corner of list, click Policy Group to enter the Security Policy Group
page.

3.

Select the check box of Show Disabled Policy Group. The disabled policy group will be
displayed in the policy group list, otherwise the policy group list will show only the enabled
policy group.

Viewing and Searching Security Policy Rules/ Policy Groups
You can view and search the policy rules or policy groups in the policy/ policy group list.

Viewing the Policy/ Policy Group
View the security policy rules in the policy rule list.




Each column displays the corresponding configurations.
Click the
button under Session column in the Policy list, and then the Session Detail
dialog box will appear. You can view the current session status of the selected policy.

www.fs.com

359

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE



Hover over your mouse on the configuration in a certain column. Then based on the
configuration type, the WebUI displays either the icon or the detailed configurations.



You can view the detailed configurations directly.
You can click the
Filter or Detail.



icon. Based on the configuration type, the WebUI displays

Click Detail to see the detailed configurations.
Click Filter, the filter condition of the configuration you are hovering
over with your mouse appears on the top of the list, and then you can filter the
policy according to the filter condition. For detailed information of filtering
policy rules, see Searching Security Policy Rules/ Policy Groups.

View the policy groups in the policy group list.



Each column displays the corresponding configurations.



You can view the current policy group status in Status column. The enabled state is
displayed as

, and the disabled state is displayed as

.

Searching Security Policy Rules/ Policy Groups
Use the Filter to search for the policy rules that match the filter conditions.
1.
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Click Policy > Security Policy.

2.

At the top-right corner of list, click Policy/ Policy Group to enter the Security Policy/
Security Policy Group page.

3.

At the top-right corner of the Security Policy/ Security Policy Group page, click Filter.
Then a new row appears at the top.
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4.
5.

Click +Filter to add a new filter condition. Then select a filter condition from the dropdown menu and enter a value.
Press Enter to search for the policy rules that matches the filter conditions.

6.

Repeat the above two steps to add more filter conditions. The relationship between each
filter condition is AND.

7.

To delete a filter condition, hover your mouse on that condition and then click the
icon. To close the filter, click the

icon on the right side of the row.

Save the filter conditions.
1.

After adding the filter conditions, click the + Filter after the next arrow, in the dropdown menu, click Save Filters.

2.

Specifies the name of the filter condition to save, the maximum length of name is 32
characters, and the name supports only Chinese and English characters and underscores.

3.

Click the Save button on the right side of the text box.

4.

To use the saved filter condition, double click the name of the saved filter condition.

5.

To delete the saved filter condition, click on the right side of the filter condition.



You can add up to 20 filter conditions as needed.



After the device has been upgraded, the saved filter condition will be cleared.

Notes:

User Online Notification
The system provides the policy-based user online notification function. The user online notification
function integrates WebAuth function and Web redirect function.
After configuring the user online notification function, system redirects your HTTP request to a new
notification page when you visit the Internet for the first time. In the process, a prompt page (see the
picture below) will be shown first, and after you click continue on this page, system will redirect your
request to the specified notification page. If you want to visit your original URL, you need to type the
URL address into the Web browser.
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Before you enable the user online notification function, you must configure the WebAuth function. For
more information about configuring WebAuth function, view "Web Authentication".

Configuring User Online Notification
To configure the user online notification function, take the following steps:
1.
2.

3.
4.
5.

Select Policy > Security Policy.
Select the security policy rule with which you want to enable the user online notification
function. Generally, it is recommended to select the security policy rule which is under the
WebAuth policy rule and whose action is permit to transmit the HTTP traffic.
Click Edit.
In the Basic Configuration tab, select the Enable Web Redirect check box and type the
notification URL into the Notification page URL box.
Click OK to save the settings.

Configuring the Parameters of User Online Notification
The parameters are:


Idle time: The time that an online user stays online without traffic transmitting. If the idle
time is exceeded, the HTTP request will be redirected to the user online notification page again.



Background picture: You can change the background picture on the prompt page.

To configure the parameters, take the following steps:
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1.

Select Policy > Security Policy.

2.

Select the security policy rule with the user online notification function enabled.

3.

Click

4.

Type the idle time value into the Idle time box. The range is 0 to 1440 minutes.

and select Web Redirect Configuration.
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5.

Change the background picture of the prompt page. Click Browse to choose the picture
you want, and then click Upload. The uploaded picture must be zipped and named as logo.jpg,
with the suggested size of 120px*40px.

Viewing Online Users
After configuring the user online notification function, you can get the information of online users from
the Online Notification Users dialog box.
1.

Select Policy > Security Policy.

2.

Click

3.

In the Web Redirect IP List dialog box, view the following information.

and select Web Redirect IP List.

Option

Description

IP address

The IP address of the online user.

Sessions

Session number of the online user.

Interface

The source interface of the online user.

Lifetime (s)

The period of time during which the user is staying online.

Expiration (s)

The idle time of the user.

NAT
NAT, Network Address Translation, translates the IP address within an IP packet header to another IP
address. When the IP packets pass through the devices or routers, the devices or routers will translate
the source IP address and/or the destination IP address in the IP packets. In practice, NAT is mostly
used to allow the private network to access the public network, vice versa.

Basic Translation Process of NAT
When a device is implementing the NAT function, it lies between the public network and the private
network. The following diagram illustrates the basic translation process of NAT.
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As shown above, the device lies between the private network and the public network. When the internal
PC at 10.1.1.2 sends an IP packet (IP packet 1) to the external server at 202.1.1.2 through the device, the
device checks the packet header. Finding that the IP packet is destined to the public network, the device
translates the source IP address 10.1.1.2 of packet 1 to the public IP address 202.1.1.1 which can get
routed on the Internet, and then forwards the packet to the external server. At the same time, the device
also records the mapping between the two addresses in its NAT table. When the response packet of IP
packet 1 reaches the device, the device checks the packet header again and finds the mapping records in
its NAT table, and replaces the destination address with the private address 10.1.1.2. In this process, the
device is transparent to the PC and the Server. To the external server, it considers that the IP address of
the internal PC is 202.1.1.1 and knows nothing about the private address 10.1.1.2. Therefore, NAT hides
the private network of enterprises.

Implementing NAT
The devices translate the IP address and port number of the internal network host to the external
network address and port number, and vice versa. This is the translation between the "private IP address
+ port number" and "public IP address + port number".
The devices achieve the NAT function through the creation and implementation of NAT rules. There
are two types of NAT rules, which are source NAT rules (SNAT Rule) and destination NAT rules
(DNAT Rule). SNAT translates source IP addresses, thereby hiding the internal IP addresses or sharing
the limited IP addresses; DNAT translates destination IP addresses, and usually the IP addresses of
internal servers (such as the WWW server or SMTP server) protected by the device is translated to
public IP addresses.

Configuring SNAT
To create an SNAT rule, take the following steps:
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1.

Select Policy > NAT > SNAT.

2.

Click New. The SNAT Configuration dialog box will appear.
364

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

In the Basic tab, configure the following options.
Requirements
Virtual Router Specifies a VRouter for the SNAT rule. The SNAT rule will take
effect when
the traffic flows into this VRouter and matches
the SNAT rule conditions.
Source Address Specifies the source IP address of the traffic, including:

Address Entry - Select an address entry from the
drop-down list.


IP Address - Type an IP address into the box.


IP/Netmask - Type an IP address and its
netmask into the box.
Destination
Address

Specifies the destination IP address of the traffic, including:

Address Entry - Select an address entry from the
drop-down list.


IP Address - Type an IP address into the box.


IP/Netmask - Type an IP address and its
netmask into the box.
Ingress Traffic

Specifies the ingress traffic, the default value is all traffic.

All traffic - Specifies all traffic as the ingress
traffic. Traffic from any ingress interfaces will continue
to match this SNAT rule.

Ingress Interface - Specifies the ingress interface
of traffic. Select an interface from the drop-down list.
When the interface is specified, only the traffic from this
interface will continue to match this SNAT rule, while
traffic from other interfaces will not.

Egress

Specifies the egress traffic, the default value is all traffic.

All traffic - Specifies all traffic as the egress
traffic. Traffic from all egress interfaces will continue to
match this SNAT rule.

Egress Interface - Specifies the egress interface of
traffic. Select an interface from the drop-down list. When
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Requirements
the interface is specified, only the traffic from this
interface will continue to match this SNAT rule, while
traffic from other interfaces will not.

Next Virtual Router - Specifies the next virtual
router of traffic. Select a virtual router from the dropdown list.
Service

Specifies the service type of the traffic from the drop-down list.
To create a new service or service group, click New Service or
New Group.

Translated to
Translated

Specifies the translated NAT IP address, including:

Egress IF IP - Specifies the NAT IP address to
be an egress interface IP address.

Specified IP - Specifies the NAT IP address to be
a specified IP address. After selecting this option,
continue to specify the available IP address in the
Address drop-down list.


Mode

No NAT - Do not implement NAT.

Specifies the translation mode, including:

Static - Static mode means one-to-one
translation. This mode requires the translated address
entry to contain the same number of IP addresses as that
of the source address entry.

Dynamic IP - Dynamic IP mode means
multiple-to-one translation. This mode translates the
source address to a specific IP address. Each source
address will be mapped to a unique IP address, until all
specified addresses are occupied.

Dynamic port - Called PAT. Multiple source
addresses will be translated to one specified IP address in
an address entry.
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If Sticky is enabled, all sessions from an
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Requirements
IP address will be mapped to the same fixed IP
address. Click the Enable check box behind
Sticky to enable Sticky. You can also track if the
public address after NAT is available, i.e., use the
translated address as the source address to track
if the destination website or host is accessible.
Select the Enable check box behind Track to
enable the function, and select a track object
from the drop-down list.

If Round-robin is enabled, all sessions
from an IP address will be mapped to the same
fixed IP address. Click the Enable check box
behind Round-robin to enable Round-robin.

If Sticky and Round-robin are not
enabled, the first address in the address entry will
be used first; when the port resources of the first
address are exhausted, the second address will be
used.
Note：The Sticky function and the Round-robin function are
mutually exclusive and cannot be configured at the same time.
Others
HA Group

Specifies the HA group that the SNAT rule belongs to. The
default setting is 0.

Description

Types the description.

In the Advanced tab, configure the corresponding options.
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Option

Description

NAT Log

Select the Enable check box to enable the log function
for this SNAT rule. The system will generate log
information when there is traffic matching this NAT
rule.

Position

Specifies the position of the rule. Each SNAT rule has a
unique ID. When the traffic is flowing into the device,
the device will search the SNAT rules in order, and then
implement NAT on the source IP of the traffic
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Option

Description
according to the first matched rule. The sequence of the
ID shown in the SNAT rule list is the order of the rule
matching. Select one of the following items from the
drop-down list:

ID

3.



Bottom - The rule is located at the
bottom of all the rules in the SNAT rule list. By
default, system will put the newly-created SNAT
rule at the bottom of all SNAT rules.



Top - The rule is located at the top of all
the rules in the SNAT rule list.



Before ID - Type the ID number into the
text box. The rule will be located before the ID
you specified.



After ID - Type the ID number into the
text box. The rule will be located after the ID
you specified.

Specifies the method you get the rule ID. Each rule has
its unique ID. It can be automatically assigned by system
or manually assigned by yourself. If you select Manually
assign , type an ID number into the box behind.

Click OK to save the settings.

Enabling/Disabling a SNAT Rule
By default the configured SNAT rule will take effect immediately. You can terminate its control over the
traffic by disabling the rule.
To enable/disable a policy rule:
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1.

Select Policy > NAT > SNAT.

2.

Select the SNAT rule that you want to enable/disable.

3.

Click Enable or Disable to enable or disable the rule.
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Adjusting Priority
Each SNAT rule has a unique ID. When the traffic flows into the device, the device will search the
SNAT rules in order and then implement NAT on the source IP of the traffic according to the first
matched rule. The sequence of the ID shown in the SNAT rule list is the order of the rule matching.
To adjust priority, take the following steps:
1.

Select Policy > NAT > SNAT.

2.

Select the rule you want to adjust its priority and click Priority.

3.

In the Priority dialog box, move the selected rule to:


4.

Top: The rule is moved to the top of all of the rules in the SNAT rule list.



Bottom: The rule is moved to the bottom of all of the rules in the SNAT rule list.
By default, system will put the newly-created SNAT rule at the bottom of all of the
SNAT rules.



Before ID: Specifies an ID number. The rule will be moved before the ID you
specified.



After ID: Specifies an ID number. The rule will be moved after the ID you
specified.

Click OK to save the settings.

Copying/Pasting a SNAT Rule
When there are a large number of NAT rules in system, to create a NAT rule which is similar to an
configured NAT rule easily, you can copy the NAT rule and paste it to the specified location.
To copy/paste a SNAT rule, take the following steps:
1.

Select Policy > NAT > SNAT.

2.

Select the SNAT rule that you want to clone and click Copy.

3.

www.fs.com

Click Paste. In the pop-up, select the desired position. Then the rule will be cloned to the
desired position.


Top: The rule is pasted to the top of all the rules in the SNAT rule list.



Bottom: The rule is pasted to the bottom of all the rules in the SNAT rule list.



Before the Rule Selected: The rule will be pasted before the Rule being selected.



After the Rule Selected: The rule will be pasted after the Rule being selected.
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Exporting NAT444 Static Mapping Entries
You can export the NAT444 static mapping entries to a file . The exported file contains the ID, source
IP address, translated IP address, start port, end port, and the protocol information.
To export the NAT444 static mapping entries, take the following steps:
1.

Select Policy > NAT > SNAT.

2.

Click Export NAT444 Static Mapping Entries.

3.

Select a location to store the file and click Save.

The exported file is CSV format. It is recommended to export the file through the management interface.

Hit Count
The system supports statistics on SNAT rule hit counts, i.e., statistics on the matching between traffic
and SNAT rules. Each time the inbound traffic is matched to a certain SNAT rule, the hit count will
increment by 1 automatically.
To view a SNAT rule hit count, click Policy > NAT > SNAT. In the SNAT rule list, view the statistics
on SNAT rule hit count under the Hit Count column.

Clearing NAT Hit Count
To clear a SNAT rule hit count, take the following steps:
1.

Select Policy > NAT > SNAT.

2.

Click Hit Count, and select Clearing NAT Hit Count in the pop-up list.

3.

In the Clearing NAT Hit Count dialog box, configure the following options:

4.



All NAT: Clears the hit counts for all NAT rules.



NAT ID: Clears the hit counts for a specified NAT rule ID.

Click OK.

Hit Count Check
System supports to check policy rule hit counts.
To check hit count, take the following steps:
1.
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Select Policy > NAT > SNAT.
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2.

Click Hit Count, and select Hit Count Check in the pop-up list. After the check, the
NAT rules whose hit count is 0 will be highlight, that is to say, the NAT rule is not used in
system.

Configuring DNAT
DNAT translates destination IP addresses, usually the IP addresses of internal servers (such as the
WWW server or SMTP server) protected by the device is translated to the public IP addresses.

Configuring an IP Mapping Rule
To configure an IP mapping rule, take the following steps:
1.

Select Policy > NAT > DNAT.

2.

Click New and select IP Mapping.
In the IP Mapping Configuration dialog box, configure the corresponding options.
Requirements
Virtual Router Specifies a VRouter for the DNAT rule. The DNAT rule will
take effect when
the traffic flows into this VRouter and
matches the DNAT rule conditions.
Destination
Address

Specifies the destination IP address of the traffic, including:




Address Entry - Select an address entry from the
drop-down list.
IP Address - Type an IP address into the box.
IP/Netmask - Type an IP address and its
netmask into the box.

Mapping
Mapped to

Specifies the translated NAT IP address, including Address
Entry, IP Address, and IP/Netmask. The number of the
translated NAT IP addresses you specified must be the same as
the number of the destination IP addresses of the traffic.

Others

3.
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HA Group

Specifies the HA group that the DNAT rule belongs to. The
default setting is 0.

Description

Types the description.

Click OK to save the settings.
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Configuring a Port Mapping Rule
To configure a port mapping rule, take the following steps:
1.

Select Policy > NAT > DNAT.

2.

Click New and select Port Mapping.
In the Port Mapping Configuration dialog, configure the corresponding options.
Requirements
Virtual Router Specifies a VRouter for the DNAT rule. The DNAT rule will
take effect when the traffic flows into this VRouter and matches
the DNAT rule conditions.
Destination
Address

Specifies the destination IP address of the traffic, including:




Service

Address Entry - Select an address entry from the
drop-down list.
IP Address - Type an IP address into the box.
IP/Netmask - Type an IP address and its
netmask into the box.

Specifies the service type of the traffic from the drop-down list.
To create a new service or service group, click New Service or
New Group.

Mapping
Mapped to

Specifies the translated NAT IP address, including Address
Entry, IP Address, and IP/Netmask. The number of the
translated NAT IP addresses you specified must be the same as
the number of the destination IP addresses of the traffic.

Port Mapping

Types the translated port number of the Intranet server. The
available range is 1 to 65535.

Others

3.
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HA Group

Specifies the HA group that the DNAT rule belongs to. The
default setting is 0.

Description

Types the description.

Click OK to save the settings.
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Configuring an Advanced NAT Rule
You can create a DNAT rule and configure the advanced settings, or you can edit the advanced settings
of an exiting DNAT rule.
To create a DNAT rule and configure the advanced settings, take the following steps:
1.
2.

Select Policy > NAT > DNAT.
Click New and select Advanced Configuration. To edit the advanced settings of an
existing DNAT rule, select it and click Edit. The DNAT configuration dialog box will appear.
In the Basic tab, configure the following options.
Requirements
Virtual Router Specifies a VRouter for the DNAT rule. The DNAT rule will
take effect when
the traffic flows into this VRouter and
matches the DNAT rule conditions.
Source Address Specifies the source IP address of the traffic, including:



Destination
Address

IP Address - Type an IP address into the box.
IP/Netmask - Type an IP address and its
netmask into the box.

Specifies the destination IP address of the traffic, including:




Service

Address Entry - Select an address entry from the
drop-down list.

Address Entry - Select an address entry from the
drop-down list.
IP Address - Type an IP address into the box.
IP/Netmask - Type an IP address and its
netmask into the box.

Specifies the service type of the traffic from the drop-down list.
To create a new service or service group, click Add.

Translated to
Action
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Specifies the action for the traffic you specified, including:


NAT - Implements NAT for the eligible traffic.



No NAT - Do not implement NAT for the
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Requirements
eligible traffic.
Translate to

When selecting the NAT option, you need to specify the
translated IP address. The options include Address Entry, IP
Address, IP/Netmask, and SLB Server Pool. For more
information about the SLB Server Pool, view "SLB Server Pool
".

Translate Service Port to
Port

Select Enable to translate the port number of the service that
matches the conditions above.

Load Balance

Select Enable to enable the function. Traffic will be balanced to
different Intranet servers.

Others
Redirect

Select Enable to enable the function.
When the number of this Translate to is different from the
Destination Address of the traffic or the Destination Address
address is any, you must enable the redirect function for this
DNAT rule.

HA Group

Specifies the HA group that the DNAT rule belongs to. The
default setting is 0.

Description

Types the description.

In the Advanced tab, configure the following options.
Track Server
Track Ping
Packets

After enabling this function, system will send Ping packets to
check whether the Intranet servers are reachable.

Track TCP
Packets

After enabling this function, System will send TCP packets to
check whether the TCP ports of Intranet servers are reachable.

TCP Port

Specifies the TCP port number of the monitored Intranet server.

Others
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NAT Log

Enable the log function for this DNAT rule to generate the log
information when traffic matches this NAT rule.

Position

Specifies the position of the rule. Each DNAT rule has a unique
ID. When the traffic is flowing into the device, the device will
search the DNAT rules by sequence, and then implement
DNAT on the source IP of the traffic according to the first
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Track Server
matched rule. The sequence of the ID shown in the DNAT rule
list is the order of the rule matching. Select one of the following
items from the drop-down list:

ID

3.



Bottom - The rule is located at the bottom of all
of the rules in the DNAT rule list. By default, the system
will put the newly-created DNAT rule at the bottom of
all of the SNAT rules.



Top - The rule is located at the top of all of the
rules in the DNAT rule list.



Before ID - Type the ID number into the text
box. The rule will be located before the ID you specified.



After ID - Type the ID number into the text
box. The rule will be located after the ID you specified.

The ID number is used to distinguish between NAT rules.
Specifies the method you get the rule ID. It can be automatically
assigned by system or manually assigned by yourself.

Click OK to save the settings.

Enabling/Disabling a DNAT Rule
By default the configured DNAT rule will take effect immediately. You can terminate its control over
the traffic by disabling the rule.
To enable/disable a policy rule, take the following steps:
1.

Select Policy > NAT > DNAT.

2.

Select the DNAT rule that you want to enable/disable.

3.

Click Enable or Disable to enable or disable the rule.

Copying/Pasting a DNAT Rule
When there are a large number of NAT rules in system, to create a NAT rule which is similar to an
configured NAT rule easily, you can copy the NAT rule and paste it to the specified location.
To copy/paste a DNAT rule, take the following steps:
1.
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Select Policy > NAT > DNAT.
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2.
3.

Select the DNAT rule that you want to clone and click Copy.
Click Paste. In the pop-up, select the desired position. Then the rule will be cloned to the
desired position.


Top: The rule is pasted to the top of all of the rules in the DNAT rule list.



Bottom: The rule is pasted to the bottom of all of the rules in the DNAT rule
list.



Before the Rule Selected: The rule will be pasted before the Rule selected.



After the Rule Selected: The rule will be pasted after the Rule selected.

Adjusting Priority
Each DNAT rule has a unique ID. When the traffic is flowing into the device, the device will search the
DNAT rules in order, and then implement NAT of the source IP of the traffic according to the first
matched rule. The sequence of the ID shown in the DNAT rule list is the order of the rule matching.
To adjust priority, take the following steps:
1.

Select Policy > NAT > DNAT.

2.

Select the rule you want to adjust its priority and click Priority.

3.

In the Priority dialog box, move the selected rule to:


4.

Top: The rule is moved to the top of all of the rules in the DNAT rule list.



Bottom: The rule is moved to the bottom of all of the rules in the DNAT rule
list. By default, system will put the newly-created DNAT rule at the bottom of all of
the DNAT rules.



Before ID: Specifies an ID number. The rule will be moved before the ID you
specified.



After ID: Specifies an ID number. The rule will be moved after the ID you
specified.

Click OK to save the settings.

Hit Count
The system supports statistics on DNAT rule hit counts, i.e., statistics on the matching between traffic
and DNAT rules. Each time the inbound traffic is matched to a certain DNAT rule, the hit count will
increment by 1 automatically.
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To view a DNAT rule hit count, click Policy > NAT > DNAT. In the DNAT rule list, view the
statistics on DNAT rule hit count under the Hit Count column.

Clearing NAT Hit Count
To clear a DNAT rule hit count, take the following steps:
1.

Select Policy > NAT > DNAT.

2.

Click Hit Count, and select Clearing NAT Hit Count in the pop-up list.

3.

In the Clearing NAT Hit Count dialog box, configure the following options:

4.



All NAT: Clears the hit counts for all NAT rules.



NAT ID: Clears the hit counts for a specified NAT rule ID.

Click OK.

Hit Count Check
System supports to check policy rule hit counts.
To check hit count, take the following steps:
1.
2.

Select Policy > NAT > DNAT.
Click Hit Count, and select Hit Count Check in the pop-up list. After the check, the
NAT rules whose hit count is 0 will be highlighted. This shows that the NAT rule is not being
used in system.

NAT Hit Analysis
System supports to check the NAT rule hit counts, with the statistics of the first hit time, the last hit
time, and the days since last hit, you can identify the NAT rules that need to be cleared. You can view
the specified NAT rules by setting up filters.
To check the hit counts, take the following steps:
1.

Select Policy > NAT > SNAT Hit Analysis or Policy > NAT > DNAT Hit Analysis.

2.

Select filter conditions from the +Filter drop-down list, and configure filter conditions as
needed.

Configure the options as follows.
Option
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Option

Description

Virtual Router

Specifies the virtual router of NAT rule.

ID

Specifies the ID of NAT rule.

Days Since First Specifies the day after the first hit. Then the NAT rules which were hit
Hit>
before the specified day will be displayed.
Unhit Rules

Specifies the rules that were never hit.

Days Since Last Specifies the day after the last hit. Then the NAT rules before the
Hit>
specified day will be displayed.
Days Since NAT Specifies the day after the NAT rue is created. Then the NAT rules
Created>
before the specified day will be displayed.
3.

Click Analyze button to view the latest result of NAT Hit Analysis.

4.

Click

icon in front of NAT rule ID to view the details of the NAT rule.

5.

Click icon on the left side of +Filter to save the selected filters. Click Save Filters, type
the name of the filters and click Save. After saved, the combined filters can be selected directly
in the drop-down list.

6.

To delete a filter condition, hover your mouse on that condition and then click
To delete all filter conditions, click the
icon on the right side of the row.

icon.

Notes: "Virtual Router" are required in the filter condition.
To clear a policy hit count, take the following steps:
1.

Select Policy > NAT > SNAT Hit Analysis or Policy > NAT > DNAT Hit Analysis.

2.

Click Clear.

In the Clearing NAT Hit Count dialog box, configure the following options.

3.

Option

Description

All NATs

Clears the hit counts of all NAT rules.

NAT ID

Clears the hit counts of a specified ID NAT rule.

Click OK.

You can also perform other operations:
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Click

icon to delete the NAT rule.
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Click

icon to disable the NAT rule.

SLB Server
View SLB server status: After you enabling the track function (PING track, TCP track, or UDP track),
system will list the status and information of the intranet servers that are tracked.
View SLB server pool status: After you enabling the server load balancing function, system will monitor
the intranet servers and list the corresponding status and information.

Viewing SLB Server Status
To view the SLB server status, take the following steps:
1.
2.

Select Policy > NAT > SLB Server Status.
You can set the filtering conditions according to the virtual router, SLB server pool, and
server address and then view the information.
Option

Description

Server

Shows the IP address of the server.

Port

Shows the port number of the server.

Status

Shows the status of the server.

Current
Sessions

Shows the number of current sessions.

DNAT

Shows the DNAT rules that uses the server.

HA Group

Shows the HA group that the server belongs to.

Viewing SLB Server Pool Status
To view the SLB server pool status, take the following steps:
1.
2.
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Select Policy > NAT > SLB Server Pool Status.
You can set the filtering conditions according to the virtual router, algorithm, and server
pool name and then view the information.
Option

Description

Name

Shows the name of the server pool name.

Algorithm

Shows the algorithm used by the server pool.

DNAT

Shows the DNAT rules that use the server.

Abnormal

Shows the number of abnormal servers and the total number of
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Option

Description

Server/All
Servers

the servers.

Current
Sessions

Shows the number of current sessions.

iQoS
System provides iQoS (intelligent quality of service) which guarantees the customer's network
performance, manages and optimizes the key bandwidth for critical business traffic, and helps the
customer greatly in fully utilizing their bandwidth resources.
iQoS is used to provide different priorities to different traffic, in order to control the delay and flapping,
and decrease the packet loss rate. iQoS can assure the normal transmission of critical business traffic
when the network is overloaded or congested. iQoS is controlled by license. To use iQoS, apply and
install the iQoS license.

Implement Mechanism
The packets are classified and marked after entering system from the ingress interface. For the classified
and marked traffic, system will smoothly forward the traffic through the shaping mechanism, or drop the
traffic through the policing mechanism. If the shaping mechanism is selected to forward the traffic, the
congestion management and congestion avoidance mechanisms will give different priorities to different
types of packets so that the packets of higher priority can pass though the gateway earlier to avoid
network congestion.
In general, implementing iQoS includes:


Classification and marking mechanism: Classification and marking is the process of
identifying the priority of each packet. This is the first step of iQoS.



Policing and shaping mechanisms: Policing and shaping mechanisms are used to identify
traffic violation and make responses. The policing mechanism checks the traffic in real time and
takes immediate actions according to the settings when it discovers a violation. The shaping
mechanism works together with queuing mechanism. It makes sure that the traffic will never
exceed the defined flow rate so that the traffic can go through that interface smoothly.



Congestion management mechanism: Congestion management mechanism uses the
queuing theory to solve problems in the congested interfaces. As the data rate can be different
among different networks, congestion may happen to both wide area network (WAN) and local
area network (LAN). Only when an interface is congested will the queuing theory begin to work.
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Congestion avoidance mechanism: Congestion avoidance mechanism is a supplement to
the queuing algorithm, and it also relies on the queuing algorithm. The congestion avoidance
mechanism is designed to process TCP-based traffic.

Pipes and Traffic Control Levels
System supports two-level traffic control: level-1 control and level-2 control. In each level, the traffic
control is implemented by pipes.

Pipes
By configuring pipes, the devices implement iQoS. Pipe, which is a virtual concept, represents the
bandwidth of transmission path. System classifies the traffic by using the pipe as the unit, and controls
the traffic crossing the pipes according to the actions defined for the pipes. For all traffic crossing the
device, they will flow into virtual pipes according to the traffic matching conditions they match. If the
traffic does not match any condition, they will flow into the default pipe predefined by the system.
Pipes, except the default pipe, include two parts of configurations: traffic matching conditions and traffic
management actions:


Traffic matching conditions: Defines the traffic matching conditions to classify the traffic
crossing the device into matched pipes. System will limit the bandwidth to the traffic that
matches the traffic matching conditions. You can define multiple traffic matching conditions to a
pipe. The logical relation between each condition is OR. When the traffic matches a traffic
matching condition of a pipe, it will enter this pipe. If the same conditions are configured in
different root pipes, the traffic will first match the root pipe listed at the top of the Level-1
Control list in the Policy > iQoS page.



Traffic management actions: Defines the actions adopted to the traffic that has been
classified to a pipe. The data stream control includes the forward control and the backward
control. Forward control controls the traffic that flows from the source to the destination;
backward control controls the traffic flows from the destination to the source.

To provide flexible configurations, system supports the multiple-level pipes. Configuring multiple-level
pipes can limit the bandwidth of different applications of different users. This can ensure the bandwidth
for the key services and users. Pipes can be nested to at most four levels. Sub pipes cannot be nested to
the default pipe. The logical relation between pipes is shown as below:
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You can create multiple root pipes that are independent. At most three levels of sub
pipes can be nested to the root pipe.



For the sub pipes at the same level, the total of their minimum bandwidth cannot exceed
the minimum bandwidth of their upper-level parent pipe, and the total of their maximum
bandwidth cannot exceed the maximum bandwidth of their upper-level parent pipe.



If you have configured the forward or backward traffic management actions for the root
pipe, all sub pipes that belong to this root pipe will inherit the configurations of the traffic
direction set on the root pipe.



The root pipe that is only configured the backward traffic management actions cannot
work.

The following chart illustrates the application of multiple-level pipes in a company. The administrator
can create the following pipes to limit the traffic:
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1.

Create a root pipe to limit the traffic of the office located in Beijing.

2.

Create a sub pipe to limit the traffic of its R&D department.

3.

Create a sub pipe to limit the traffic of the specified applications so that each application
has its own bandwidth.

4.

Create a sub pipe to limit the traffic of the specified users so that each user owns the
defined bandwidth when using the specified application.
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Traffic Control Levels
System supports two-level traffic control: level-1 control and level-2 control. In each level, the traffic
control is implemented by pipes. Traffic that is dealt with by level-1 control flows into the level-2
control, and then system performs the further management and control according to the pipe
configurations of level-2 control. After the traffic flowing into the device, the process of iQoS is shown
as below:

According to the chart above, the process of traffic control is described below:
1.

The traffic first flows into the level-1 control, and then system classifies the traffic into
different pipes according to the traffic matching conditions of the pipe of level-1 control. The
traffic that cannot match any pipe will be classified into the default pipe. If the same
conditions are configured in different root pipes, the traffic will first match the root pipe listed
at the top of the Level-1 Control list in the Policy > iQoS page. After the traffic flows into the
root pipe, system classifies the traffic into different sub pipes according to the traffic matching
conditions of each sub pipe.

2.

According to the traffic management actions configured for the pipes, system manages
and controls the traffic that matches the traffic matching conditions.

3.

The traffic dealt with by level-1 control flows into the level-2 control. System manages
and controls the traffic in level-2 control. The principles of traffic matching, management and
control are the same as the one of the level-1 control.

4.

Complete the process of iQoS.

Related Links:
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"Enabling iQoS"



"Pipes"

Enabling iQoS
To enable iQoS, take the following steps:
1.

Select Policy > iQoS > Configuration.

2.

Select the Enable iQoS check box.

3.

If you select the Enable NAT IP matching check box in Level-1 Control or Level-2
Control, system will use the IP addresses between the source NAT and the destination NAT
as the matching items. If the matching is successful, system will limit the speed of these IP
addresses.
Notes: Before enabling NAT IP matching, you must config the NAT rules. Otherwise, the
configuration will not take effect.

4.

Click Apply to save the configurations.

Pipes
By using pipes, devices implement iQoS. Pipes in different traffic control levels will take effect in
different stages.
Configuring pipes includes the following sections:
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1.

Create the traffic matching conditions, which are used to capture the traffic that matches
these conditions. If configuring multiple traffic matching conditions for a pipe, the logical
relation between each condition is OR.

2.

Create a white list according to your requirements. System will not control the traffic in
the white list. Only root pipe and the default pipe support the white list.
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3.

Specify the traffic management actions, which are used to deal with the traffic that is
classified into a pipe.

4.

Specify the schedule. The pipe will take effect during the specified time period.

Basic Operations
Select Policy > iQoS > Policy to open the Policy page.

You can perform the following actions in this page:


Disable the level-2 traffic control: Click Disable second level control. The pipes in the
level-2 traffic control will not take effect. The Level-2 Control tab will not appears in this page.



View pipe information: The pipe list displays the name, mode, action, schedule, and the
description of the pipes.


Click the



Click the

icon of the root pipe or the sub pipe to view the condition settings.



Click the

icon of the root pipe to view the white list settings.



icon to expand the root pipe and display its sub pipes.

represents the root pipe is usable,

represents the root pipe is unusable,

represents the sub pipe is usable,
represents the sub pipe is unusable,
the gray text represents the pipe is disabled.


Create a root pipe: Select the Level-1 Control or Level-2 Control tab, then click New in
the menu bar to create a new root pipe.



Create a sub pipe: Click the
corresponding sub pipe.



Click Enable in the menu bar to enable the selected pipe. By default, the newly-created
pipe will be enabled.



icon of the root pipe or the sub pipe to create the

Click Disable in the menu bar to disable the selected pipe. The disabled pipe will not take
effect.
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Click Delete to delete the selected pipe. The default pipe cannot be deleted.
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Configuring a Pipe
To configure a pipe, take the following steps:
1.
2.

According to the methods above, create a root pipe or sub pipe. The Pipe Configuration
page appears.
In the Basic tab, specify the basic pipe information.
Option

Description

Parent
Displays the control level or the parent pipe of the newly created pipe.
Pipe/Control Level
Pipe Name

Specify a name for the new pipe.

Description

Specify the description of this pipe.

Mode

3.

Shape, Policy, or Monitor.


The Shape mode can limit the data transmission rate and
smoothly forward the traffic. This mode supports the bandwidth
borrowing and priority adjusting for the traffic within the root pipe.



The Policy mode will drop the traffic that exceeds the bandwidth
limit. This mode does not support the bandwidth borrowing and priority
adjusting, and cannot guarantee the minimum bandwidth.



The Monitor mode will monitor the matched traffic, generate the
statistics, and will not control the traffic.



Bandwidth borrowing: All of the sub pipes in a root pipe can lend
their idle bandwidth to the pipes that are lacking bandwidth. The
prerequisite is that their bandwidth must be enough to forward the traffic
in their pipes.



Priority adjusting: When there is traffic congestion, system will
arrange the traffic to enter the waiting queue. You can set the traffic to
have higher priority and system will deal with the traffic in order of
precedence.

In the Condition tab, click New.
In the Condition Configuration tab, configure the corresponding options.
Option

Description

Source Information
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Option

Description

Zone

Specify the source zone of the traffic. Select the zone name from
the drop-down menu.

Interface

Specify the source interface of the traffic. Select the interface
name from the drop-down menu.

Address

Specify the source address of the traffic.
1.

Select an address type from the Address dropdown list.

2.

Select or type the source addresses based on the
selected type.

3.
4.

Click

to add the addresses to the right pane.

After adding the desired addresses, click the blank
area in this dialog box to complete the address
configuration.

You can also perform other operations:


When selecting the Address Book type, you can
click Add to create a new address entry.



The default address configuration is any. To
restore the configuration to this default one, select the
any check box.

Destination Information
Zone

Specify the destination zone of the traffic. Select the zone name
from the drop-down menu.

Interface

Specify the destination interface of the traffic. Select the interface
name from the drop-down menu.

Address

Specify the destination address of the traffic.
1.

Select an address type from the Address dropdown list.

2.

Select or type the source addresses based on the
selected type.

3.
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Click

to add the addresses to the right pane.
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Option

Description
4.

After adding the desired addresses, click the blank
area in this dialog box to complete the address
configuration.

You can also perform other operations:

User
Information

Service

www.fs.com



When selecting the Address Book type, you can
click Add to create a new address entry.



The default address configuration is any. To
restore the configuration to this default one, select the
any check box.

Specify a user or user group that the traffic belongs to.
1.

From the User drop-down menu, select the AAA
server where the users and user groups reside.

2.

Based on different types of AAA server, you can
execute one or more actions: search a user/user
group/role, expand the user/user group list, and enter
the name of the user/user group.

3.

After selecting users/user groups/roles, click
to add them to the right pane.

4.

After adding the desired objects, click the blank
area in this dialog box to complete the user
information configuration.

Specify a service or service group that the traffic belongs to.
1.

From the Service drop-down menu, select a type:
Service, Service Group.

2.

You can search the desired service/service group,
expand the service/service group list.

3.

After selecting the desired services/service
groups, click to add them to the right pane.

4.

After adding the desired objects, click the blank
area in this dialog box to complete the service
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Option

Description
configuration.
You can also perform other operations:



Application

To add a new service or service group, click Add.
The default service configuration is any. To
restore the configuration to this default one, select the
any check box.

Specify an application, application group, or application filters
that the traffic belongs to.
1.

From the Application drop-down menu, you can
search the desired application/application
group/application filter, expand the list of
applications/application groups/application filters.

2.

After selecting the desired
applications/application groups/application filters,
click to add them to the right pane.

3.

After adding the desired objects, click the blank
area in this dialog to complete the application
configuration.

You can also perform other operations:

URL Category



To add a new application group, click New
AppGroup.



To add a new application filter, click New
AppFilter.

Specifies the URL category that the traffic belongs to.
After the user specifies the URL category, the system matches
the traffic according to the specified category.
1.

2.
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In the "URL category" drop-down menu, the
user can select one or more URL categories, up to 8
categories.
After selecting the desired filters, click the blank
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Option

Description
area in this dialog to complete the configuration.
To add a new URL category, click the "New" button, the page
will pop up "URL category" dialog box. In this dialog box, the
user can configure the category name and URL.
Select a URL category, click the "Edit" button, the page will pop
up "URL category" dialog box. In this dialog box, the user can
edit the URL in the category.

Advanced
VLAN
TOS

4.
5.

Specify the VLAN information of the traffic.
Specify the TOS fields of the traffic; or click Configure to specify
the TOS fields of the IP header of the traffic in the TOS
Configuration dialog box.


Precedence: Specify the precedence.



Delay: Specify the minimum delay.



Throughput: Specify the maximum throughput.



Reliability: Specify the highest reliability.



Cost: Specify the minimum cost.



Reserved: Specify the normal service.

If you are configuring root pipes, you can specify the white list settings based on the
description of configuring conditions.
In the Action tab, configuring the corresponding actions.
Forward (From source to destination)
The following configurations control the traffic that flows from the source to the
destination. For the traffic that matches the conditions, system will perform the
corresponding actions.
Pipe
Bandwidth

When configuring the root pipe, specify the pipe bandwidth.
When configuring the sub pipe, specify the maximum bandwidth
and the minimum bandwidth of the pipe:
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Min Bandwidth: Specify the minimum
bandwidth. If you want this minimum bandwidth to be
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reserved and cannot be used by other pipes, select
Enable Reserved Bandwidth.

Limit type

Specify the maximum bandwidth and minimum bandwidth of
the pipe for each user/IP:




Limit by

www.fs.com

Max Bandwidth: Specify the maximum
bandwidth.

Type: Select the type of the bandwidth limitation:
No Limit, Limit Per IP, or Limit Per User.


No Limit represents that system will not
limit the bandwidth for each IP or each user.



Limit Per IP represents that system will
limit the bandwidth for each IP. In the Limit by
section, select Source IP to limit the bandwidth
of the source IP in this pipe; or select Destination
IP to limit the bandwidth of the destination IP in
this pipe.



Limit Per User represents that system will
limit the bandwidth for each user. In the Limit by
section, specify the minimum/maximum
bandwidth of the users.

When configuring the root pipe, you can select
the Enable Average Bandwidth check box to make each
source IP, destination IP, or user to share an average
bandwidth.

When the Limit type is Limit Per IP or Limit Per User, you need
to specify the minimum bandwidth or the maximum bandwidth:


Min Bandwidth: Specify the minimum
bandwidth.



Max Bandwidth: Specify the maximum
bandwidth.



Delay: Specify the delay time, whose value ranges
from 1 second to 3600 seconds. The maximum
bandwidth limit of each IP/ user is not effective within
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the delay time range.
Advanced
Priority

TOS

Specify the priority for the pipes. Select a number, between 0 and
7, from the drop-down menu. The smaller the value is, the higher
the priority is. When a pipe has higher priority, system will first
deal with the traffic in it and borrow the extra bandwidth from
other pipes for it. The priority of the default pipe is 7.
Specify the TOS fields of the traffic; or click Configure to
specify the TOS fields of the IP header of the traffic in the
appeared TOS Configuration page.


Precedence: Specify the precedence.



Delay: Specify the minimum delay.



Throughput: Specify the maximum throughput.



Reliability: Specify the highest reliability.



Cost: Specify the minimum monetary cost.



Reserved: Specify the normal service.

Limit Opposite
Select the Limit Opposite Bandwidth check box to configure the
Bandwidth
value of limit-strength.The smaller the value, the smaller the
limit.
Backward (From condition's destination to source)
The following configurations control the traffic that flows from the destination
to the source. For the traffic that matches the conditions, system will perform the
corresponding actions.
Pipe
Bandwidth

When configuring the root pipe, specify the pipe bandwidth.
When configuring the sub pipe, specify the maximum bandwidth
and the minimum bandwidth of the pipe:
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Min Bandwidth: Specify the minimum
bandwidth. If you want this minimum bandwidth to be
reserved and cannot be used by other pipes, select
Enable Reserved Bandwidth.
Max Bandwidth: Specify the maximum
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bandwidth.
Limit type

Specify the maximum bandwidth and minimum bandwidth of
the pipe for each user/IP:




Limit by

Type: Select the type of the bandwidth limitation:
No Limit, Limit Per IP, or Limit Per User.


No Limit represents that system will not
limit the bandwidth for each IP or each user.



Limit Per IP represents that system will
limit the bandwidth for each IP. In the Limit by
section, select Source IP to limit the bandwidth
of the source IP in this pipe; or select Destination
IP to limit the bandwidth of the destination IP in
this pipe.



Limit Per User represents that system will
limit the bandwidth for each user. In the Limit by
section, specify the minimum/maximum
bandwidth of the users.

When configuring the root pipe, you can select
the Enable Average Bandwidth check box to make each
source IP, destination IP, or user to share an average
bandwidth.

When the Limit type is Limit Per IP or Limit Per User, you need
to specify the minimum bandwidth or the maximum bandwidth:


Min Bandwidth: Specify the minimum
bandwidth.



Max Bandwidth: Specify the maximum
bandwidth.



Delay：Specify the delay time, whose value
ranges from 1 second to 3600 seconds. The maximum
bandwidth limit of each IP/ user is not effective within
the delay time range.

Advanced
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Priority

TOS

Specify the priority for the pipes. Select a number, between 0 and
7, from the drop-down menu. The smaller the value is, the higher
the priority is. When a pipe has higher priority, system will first
deal with the traffic in it and borrow the extra bandwidth from
other pipes for it. The priority of the default pipe is 7.
Specify the TOS fields of the traffic; or click Configure to
specify the TOS fields of the IP header of the traffic in the
appeared TOS Configuration page.


Precedence: Specify the precedence.



Delay: Specify the minimum delay.



Throughput: Specify the maximum throughput.



Reliability: Specify the highest reliability.



Cost: Specify the minimum monetary cost.



Reserved: Specify the normal service.

Limit Opposite
Select the Limit Opposite Bandwidth check box to configure the
Bandwidth
value of limit-strength.The smaller the value, the smaller the
limit.
6.
7.

In the Schedule tab, configure the time period when the pipe takes effect. Select the
schedule from the drop-down list, or create a new one.
Click OK to save the settings.

Viewing Statistics of Pipe Monitor
To view the statistics of pipe monitor, see "iQoS Monitor".

Session Limit
The devices support zone-based session limit function. You can limit the number of sessions and
control the session rate to the source IP address, destination IP address, specified IP address,
applications or role/user/user group, thereby protecting from DoS attacks and controlling the
bandwidth of applications, such as IM or P2P.
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Configuring a Session Limit Rule
To configure a session limit rule, take the following steps:
1.

Select Policy > Session Limit.

2.

Click New. The Session Limit Configuration dialog box will appear.

3.

Select the zone where the session limit rule is located.

4.

Configure the limit conditions.
IP
Select the IP check box to configure the IP limit conditions.
IP

Source IP

Select the IP radio button and then select an IP address entry.


Select All IPs to limit the total number of
sessions to all IP addresses.



Select Per IP to limit the number of sessions to
each IP address.

Select the Source IP radio button and specify the source IP
address entry and destination IP address entry. When the
session's source IP and destination IP are both within the
specified range, system will limit the number of session as
follows:


When you select Per Source IP, system will limit
the number of sessions to each source IP address.



When you select Per Destination IP, system will
limit the number of sessions to each destination IP
address.

Protocol
Protocol

Limits the number of sessions to the protocol which has been
set in the textbox.

Application
Application

Limits the number of sessions to the selected application.

Role/User/User Group
Select the Role/User/User Group check box to configure the corresponding
limit conditions.
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IP
Role

Select the Role radio button and a role from the Role dropdown list to limit the number of sessions of the selected role.

User

Select the User radio button and a user from the User dropdown list to limit the number of sessions of the selected user.

User Group

Select the User Group radio button and a user group from the
User Group drop-down list to limit the number of sessions of
the selected user group.


Next to the User Group radio button, select All
Users to limit the total number of sessions to all of the
users in the user group.



Next to the User Group radio button, select Per
User to limit the number of sessions to each user.

Schedule
Schedule

5.

Select the Schedule check box and choose a schedule you need
from the drop-down list to make the session limit rule take effect
within the time period specified by the schedule.

Configure the limit types.
Session Type
Session Number

Specify the maximum number of sessions. The value
range is 0 to 1048576. The value of 0 indicates no
limitation.

New Connections/5s Specify the maximum number of sessions created per 5
seconds. The value range is 1 to 1048576.
6.
7.
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Click OK to save your settings.
Click Switch Mode to select a matching mode. If you select Use the Minimum Value and
an IP address matches multiple session limit rules, the maximum number of sessions of this IP
address is limited to the minimum number of sessions of all matched session limit rules; if you
select Use the Maximum Value and an IP address matches multiple session limit rules, the
maximum number of sessions of this IP address is the maximum number of sessions of all
matched session limit rules.
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Clearing Statistic Information
After configuring a session limit rule, the sessions which exceed the maximum number of sessions will
be dropped. You can clear the statistical information of the dropped sessions of specified session limit
rule according to your need.
To clear statistic information, take the following steps:
1.

Select Policy > Session Limit.

2.

Select the rule whose session's statistical information you want to clear.

3.

Click Clear.

Share Access
Share access means multiple endpoints access network with the same IP. The function of share access
can block access from unknown device and allocate bandwidth for users, so as to prevent possible risks
and ensure good online experience.

Configuring Share Access Rules
To configure a share access rule, take the following steps:
1.

Select Policy > Share Access.

2.

Click New. The Share Access Configuration dialog box will appear.
Option

Description

Name

Specifies the name of share access rule.

Source Zone

Specify the source zone of share access.

Source Address Specify the source IP address segment of share access.
Schedule

Specify the schedule of share access. The share access rule takes
effect in the period specified by the schedule. If the schedule is
not configured, the share access rule will always be effective.

Maximum
Endpoint

Specify the maximum number of share access endpoints. The
range is 1-15. The default value is 2.

Action

When the number of endpoints with the same IP address exceeds
the maximum allowed to be shared by system, the IP address of
the endpoints will be processed according to the specified action.
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Log Only: When the number of shared access
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Option

Description
endpoints exceeds the maximum, system will only record
logs of the IP address out of limit, without affecting the
normal connection of the access endpoints.


Warning: When the number of shared access
endpoints exceeds the maximum, system will send
warnings to endpoints out of limit and record logs during
the specified control duration.


Endpoint
Timeout

Control Duration: Specify the control
duration of warning. The range is 30-3600s. The
default value is 60s. After the duration is over, the
system will re-detect whether the number of
access endpoints exceeds the maximum.

Specify the timeout time of endpoint. After the timeout time,
when the endpoint no longer accesses network with the IP,
system will clear the endpoint information. The range is 30086400s. The default value is 600s.

ARP Defense
FSOS provides a series of ARP defense functions to protect your network against various ARP attacks,
including:


ARP Learning: Devices can obtain IP-MAC bindings in an Intranet from ARP learning,
and add them to the ARP list. By default this function is enabled. The devices will always keep
ARP learning on, and add the learned IP-MAC bindings to the ARP list. If any IP or MAC
address changes during the learning process, the devices will add the updated IP-MAC binding
to the ARP list. If this function is disabled, only IP addresses in the ARP list can access the
Internet.



MAC Learning: Devices can obtain MAC-Port bindings in an Intranet from MAC
learning, and add them to the MAC list. By default this function is enabled. The devices will
always keep MAC learning on, and add the learned MAC-Port bindings to the MAC list. If any
MAC address or port changes during the learning process, the devices will add the updated
MAC-Port binding to the MAC list.



IP-MAC-Port Binding: If IP-MAC, MAC-Port or IP-MAC-Port binding is enabled,
packets that are not matched to the binding will be dropped to protect against ARP spoofing or
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MAC address list attacks. The combination of ARP and MAC learning can achieve the effect of
"real-time scan + static binding", and make the defense configuration more simple and effective.


ARP Inspection: Devices support ARP Inspection for interfaces. With this function
enabled, FSOS will inspect all ARP packets passing through the specified interfaces, and
compare the IP addresses of the ARP packets with the static IP-MAC bindings in the ARP list
and IP-MAC bindings in the DHCP Snooping list.



DHCP Snooping: With this function enabled, system can create a binding relationship
between the MAC address of the DHCP client and the allocated IP address by analyzing the
packets between the DHCP client and server.



Host Defense: With this function enabled, the system can send gratuitous ARP packets
for different hosts to protect them against ARP attacks.

Configuring ARP Defense
Configuring Binding Settings
Devices support IP-MAC binding, MAC-Port binding and IP-MAC-Port binding to reinforce network
security control. The bindings obtained from ARP/MAC learning and ARP scan are known as dynamic
bindings, and those manually configured are known as static bindings.

Adding a Static IP-MAC-Port Binding
To add a static IP-MAC-Port binding, take the following steps:
1.

Select Policy > ARP Defense > IP-MAC Binding.

2.

Click New.
In the IP-MAC Binding Configuration, configure the corresponding settings.
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Option

Description

MAC

Specify a MAC address.

IP

Select the Enable check box to enable the IP-MAC binding,
and specify an IP address.

Port

Select the Enable check box to enable the port binding, select
a port from the drop-down list behind.

VLAN ID

If the port belongs to a VLAN, select the VLAN ID from the
VLAN ID drop-down list.

Virtual Router

Select the virtual router that the binding item belongs to. By
default, the binding item belongs to trust-vr.
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Option

3.

Description

Description

Specify the description for this item.

Authenticated
ARP

Select Enable to enable the authenticated ARP function.

Click OK to save the settings.

Obtaining a Dynamic IP-MAC-Port Bindings
Devices can obtain dynamic IP-MAC-Port binding information from:


ARP/MAC learning



IP-MAC scan

To configure the ARP/MAC learning, take the following steps:
1.

Select Policy > ARP Defense > IP-MAC Binding.

2.

Select Others and click ARP/MAC Learning from the pop-up menu.

3.

In the ARP/MAC Learning Configuration dialog box, select the interface that you want
to enable the ARP/MAC learning function.

4.

Click Enable and then select ARP Learning or MAC Learning in the pop-up menu. The
system will enable the selected function on the interface you select.

5.

Close the dialog box and return to the IP-MAC Binding tab.

To configure the ARP scan, take the following steps:
1.

Select Policy > ARP Defense > IP-MAC Binding.

2.

Select Binding Configuration and then click IP-MAC Scan from the pop-up menu.

3.

In the IP-MAC Scan dialog box, enter the start IP and the end IP.

4.

Click OK to start scanning the specified IP addresses. The result will display in the table
in the IP-MAC binding tab.

Bind the IP-MAC-Port Binding Item
To bind the IP-MAC-Port binding item, take the following steps:
1.
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Select Policy > ARP Defense > IP-MAC Binding.
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2.

Select Binding Configuration and then click Bind All from the pop-up menu.

3.

In the Bind All dialog box, select the binding type.

4.

Click OK to complete the configurations.

To unbind an IP-MAC-Port binding item:
1.

Select Policy > ARP Defense > IP-MAC Binding.

2.

Select Binding Configuration and then click Unbind All from the pop-up menu.

3.

In the Unbind All dialog box, select the unbinding type.

4.

Click OK to complete the configurations.

Importing/Exporting Binding Information
To import the binding information, take the following steps:
1.

Select Policy > ARP Defense > IP-MAC Binding.

2.

Select Others and then click lmport from the pop-up menu.

3.

In the Import dialog box, click Browse to select the file that contains the binding
information. Only the UTF-8 encoding file is supported.

To export the binding information, take the following steps:
1.

Select Policy > ARP Defense > IP-MAC Binding.

2.

Select Others and then click Export from the pop-up menu.

3.

Choose the binding information type.

4.

Click OK to export the binding information to a file.

Configuring ARP Inspection
Devices support ARP Inspection for interfaces. With this function enabled, system will inspect all the
ARP packets passing through the specified interfaces, and compare the IP addresses of the ARP packets
with the static IP-MAC bindings in the ARP list and IP-MAC bindings in the DHCP Snooping list:


If the IP address is in the ARP list and the MAC address matches, the ARP packet will
be forwarded;



If the IP address is in the ARP list but the MAC address does not match, the ARP packet
will be dropped;
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If the IP address is not in the ARP list, continue to check if the IP address is in the
DHCP Snooping list;



If the IP address is in the DHCP Snooping list and the MAC address also matches, the
ARP packet will be forwarded;



If the IP address is in the DHCP Snooping list but the MAC address does not match,
the ARP packet will be dropped;



If the IP address is not in the DHCP Snooping, the ARP packet will be dropped or
forwarded according to the specific configuration.

Both the VSwitch and VLAN interface of the system support ARP Inspection. This function is disabled
by default.
To configure ARP Inspection of the VSwitch interface, take the following steps:
1.

Select Policy > ARP Defense > ARP Inspection.

2.

System already lists the existing VSwitch interfaces.

3.

Double-click the item of a VSwitch interface.

4.

In the Interface Configuration dialog box, select the Enable check box.

5.

To drop the traffic whose sender's IP address is not in the ARP table, select Drop. To
forward the traffic whose sender's IP address is not in the ARP table, select Forward.

6.

Click OK to save the settings and close the dialog box.

7.

For the interfaces belonging to the VSwitch interface, you can set the following options:

8.



If you do not need the ARP inspection in the interface, in the Advanced Options
section, double-click the interface and select Do Not Inspect option in the pop-up
dialog box.



Configure the number of ARP packets received per second. When the ARP
packet rate exceeds the specified value, the excessive ARP packets will be dropped.
The value range is 0 to 10000. The default value is 0, i.e., no rate limit.

Click OK to save the settings.

To configure the ARP inspection of the VLAN interface, take the following steps:
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1.

Select Policy > ARP Defense > ARP Inspection.

2.

Click New.
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3.
4.

5.

6.

In the Interface Configuration dialog box, specify the VLAN ID.
To drop the traffic whose sender's IP address is not in the ARP table, select Drop. To
forward the traffic whose sender's IP address is not in the ARP table, select Forward.
For the interfaces belongs to the VLAN, you can set the following options:


If you do not need the ARP inspection in the interface, in the Advanced Options
section, double-click the interface and select Do Not Inspect option in the pop-up
dialog box.



Configure the number of ARP packets received per second. When the ARP
packet rate exceeds the specified value, the excessive ARP packets will be dropped.
The value range is 0 to 10000. The default value is 0, i.e., no rate limit.

Click OK to save the settings.

Configuring DHCP Snooping
DHCP, Dynamic Host Configuration Protocol, is designed to allocate appropriate IP addresses and
related network parameters for sub networks automatically. DHCP Snooping can create a binding
relationship between the MAC address of the DHCP client and the allocated IP address by analyzing the
packets between the DHCP client and the server. When ARP Inspection is also enabled, the system will
check if an ARP packet passing through can be matched to any binding on the list. If not, the ARP
packet will be dropped. In the network that allocates addresses via DHCP, you can prevent against ARP
spoofing attacks by enabling ARP inspection and DHCP Snooping.
DHCP clients look for the server by broadcasting, and only accept the network configuration parameters
provided by the first reachable server. Therefore, an unauthorized DHCP server in the network might
lead to DHCP server spoofing attacks. The devices can prevent DHCP server spoofing attacks by
dropping DHCP response packets on related ports.
Besides, some malicious attackers send DHCP requests to a DHCP server in succession by forging
different MAC addresses, and eventually lead to IP address unavailability to legal users by exhausting all
the IP address resources. This kind of attacks is commonly known as DHCP Starvation. The devices can
prevent against such attacks by dropping request packets on related ports, setting rate limit or enabling
validity check.
The VSwitch interface of the system supports DHCP snooping. This function is disabled by default.
To configure DHCP snooping, take the following steps:
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1.

Select Policy > ARP Defense > DHCP Snooping.

2.

Click DHCP Snooping Configuration.
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3.

In the Interface tab, select the interfaces that need the DHCP snooping function.

4.

Click Enable to enable the DHCP snooping function.

5.

In the Port tab, configure the DHCP snooping settings:

6.



Validity check: Check if the client's MAC address of the DHCP packet is the
same as the source MAC address of the Ethernet packet. If not, the packet will be
dropped. Select the interfaces that need the validity check and then click Enable to
enable this function.



Rate limit: Specify the number of DHCP packets received per second on the
interface. If the number exceeds the specified value, system will drop the excessive
DHCP packets. The value range is 0 to 10000. The default value is 0, i.e., no rate limit.
To configure the rate limit, double-click the interface and then specify the value in the
Rate text box in the pop-up Port Configuration dialog box.



Drop: In the Port Configuration dialog box, if the DHCP Request check box is
selected, the system will drop all of the request packets sent by the client to the server;
if the DHCP Response check box is selected, system will drop all the response packets
returned by the server to the client.

Click OK to save the settings.

Viewing DHCP Snooping List
With DHCP Snooping enabled, system will inspect all of the DHCP packets passing through the
interface, and create and maintain a DHCP Snooping list that contains IP-MAC binding information
during the process of inspection. Besides, if the VSwitch, VLAN interface or any other Layer 3 physical
interface is configured as a DHCP server, the system will create IP-MAC binding information
automatically and add it to the DHCP Snooping list even if DHCP Snooping is not enabled. The
bindings in the list contain information like legal users' MAC addresses, IPs, interfaces, ports, lease time,
etc.
To view the DHCP snooping list, take the following steps:
1.

Select Policy > ARP Defense > DHCP Snooping.

2.

In the current page, you can view the DHCP snooping list.

Configuring Host Defense
Host Defense is designed to send gratuitous ARP packets for different hosts to protect them against
ARP attacks.
To configure host defense, take the following steps:
www.fs.com
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1.

Select Policy > ARP Defense > Host Defense.

2.

Click New.
In the Host Defense dialog box, configure the corresponding options.
Sending Settings
Interface

Specify an interface that sends gratuitous ARP packets.

Excluded Port Specify an excluded port, i.e., the port that does not send
gratuitous ARP packets. Typically it is the port that is connected
to the proxied host.
Host

3.
4.

IP

Specify the IP address of the host that uses the device as a proxy.

MAC

Specify the MAC address of the host that uses the device as a
proxy.

Sending Rate

Specify a gratuitous ARP packet that sends rate. The value range
is 1 to 10/sec. The default value is 1.

Click OK to save your settings and return to the Host Defense page.
Repeat Step 2 and Step 3 to configure gratuitous ARP packets for more hosts. You can
configure the device to send gratuitous ARP packets for up to 16 hosts.

SSL Proxy
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
To assure the security of sensitive data when being transmitting over networks, more and more websites
adopt SSL encryption to protect their information. The device provides the SSL proxy function to
decrypt HTTPS traffic. The SSL proxy function works in the following two scenarios:
The first scenario, the device works as the gateway of Web clients. The SSL proxy function replaces the
certificates of encrypted websites with the SSL proxy certificate to get the encrypted information and
send the SSL proxy certificates to the client’s Web browser. During the process, the device acts as a
SSL client and SSL server to establish connections to the Web server and Web browser respectively. The
SSL proxy certificate is generated by using the device's local certificate and re-signing the website
certificate. The process is described as below:
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The second scenario, the device works as the gateway of Web servers. The device with SSL proxy
enabled can work as the SSL server, use the certificate of the Web server to establish the SSL connection
with Web clients (Web browsers), and send the decrypted traffic to the internal Web server.

Work Mode
There are three work modes. For the first scenario, the SSL proxy function can work in the "Client
Inspection - Proxy" mode ; for the second scenario, the SSL proxy function can work in the "Server
Inspection - Offload" mode and "Server Inspection - Proxy" mode.
When the SSL proxy function works in the "Client Inspection - Proxy" mode, it can perform the SSL
proxy on specified websites.
For the websites that do not need SSL proxy, it dynamically adds the IP address and port of the websites
to a bypass list, and the HTTPS traffic will be bypassed.
For the websites proxied by the SSL proxy function, the device will check the parameters of the SSL
negotiation. When a parameter matches an item in the checklist, the corresponding HTTPS traffic can
be blocked or bypassed according to the action you specified.



If the action is Block, the HTTPS traffic will be blocked by the device.
If the action is Bypass, the HTTPS traffic will not be decrypted. Meanwhile, the device
will dynamically add the IP address and port number of the Website to the bypass list, and the
HTTPS traffic will be bypassed.

The device will decrypte the HTTPS traffic that are not blocked or bypassed.
When the SSL proxy function works in the "Server Inspection - Offload" mode, it will proxy the SSL
connections initialized by Web clients, decrypt the HTTPS traffic, and send the HTTPS traffic as
plaintext to the Web server.
When the SSL proxy function works in the "Server Inspection - Proxy" mode, it will proxy the SSL
connections initialized by Web clients, decrypt the HTTPS traffic, and re-encrypt the traffic and send it
to the Web server.
You can integrate SSL proxy function with the followings:


Integrate with the application identification function. Devices can decrypte the HTTPS
traffic encrypted using SSL by the applications and identify the application. After the application
identification, you can configure the policy rule, QoS, session limit, policy-based route.



Integrate with the Web content function, Web post function, and email filter function.
Devices can audit the actions that access the HTTPS website.
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Integrate with AV, IPS, and URL. Devices can perform the AV protection, IPS
protection, and URL filtering on the decrypted HTTPS traffic.

Working as Gateway of Web Clients
To implement the SSL proxy, you need to bind a SSL proxy profile to the policy rule. After binding the
SSL proxy profile to a policy rule, system will use the SSL proxy profile to deal with the traffic that
matches the policy rule. To implement the SSL proxy, take the following steps:
1.

Configure the corresponding parameters of SSL negotiation, including the following
items: specify the PKI trust domain of the device certificates, obtain the CN value of the
subject field from the website certificate, and import a device certificate to the Web browser.

2.

Configure a SSL proxy profile, including the following items: choose the work mode, set
the website list (use the CN value of the Subject field of the website certificate), configure the
actions to the HTTPS traffic when its SSL negotiation matches the item in the checklist,
enable the audit warning page, and so on.

3.

Bind a SSL proxy profile to a proper policy rule. The device will decrypt the HTTPS
traffic that matches the policy rule and is not blocked or bypassed by the device.

Configuring SSL Proxy Parameters
Configuring SSL proxy parameters includes the following items:


Specify the PKI trust domain of the device certificate



Obtain the CN value of the website certificate



Import a device certificate to a Web browser

Specifying the PKI Trust Domain of Device Certificate
By default, the certificate of the default trust domain trust_domain_ssl_proxy_2048 will be used to
generate the SSL proxy certificate with the Web server certificate together, and then system will issue the
generated SSL proxy certificate to the client. You can specify another PKI trust domain in system as the
trust domain of the device certificate. The specified trust domain must have a CA certificate, local
certificate, and the private key of the local certificate. To specify a trust domain, take the following steps:

www.fs.com

1.

Click Policy > SSL Proxy.

2.

At the top-right corner of the page, click Trust Domain Configuration.

3.

Select a trust domain from the Trust domain drop-down list.
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4.



The trust domain of trust_domain_ssl_proxy uses RSA and the modulus size is
1024 bits.



The trust domain of trust_domain_ssl_proxy_2048 uses RSA and the modulus
size is 2048 bits.

Click OK to save the settings.

Obtaining the CN Value
To get the CN value in the Subject field of the website certificate, take the following steps (take
www.gmail.com as the example):
1.

Open the IE Web browser, and visit https://www.gmail.com.

2.

Click the Security Report button (

3.

In the pop-up dialog box, click View certificates.

4.

In the Details tab, click Subject. You can view the CN value in the text box.

) next to the URL.

Importing Device Certificate to Client Browser
In the proxy process, the SSL proxy certificate will be used to replace the website certificate. However,
there is no SSL proxy certificate's root certificate in the client browser, and the client cannot visit the
proxy website properly. To address this problem, you have to import the root certificate (certificate of
the device) to the browser.
To export the device certificate to local PC firstly, take the following steps:
1.
2.

3.

Export the device certificate to local PC. Select System > PKI.
In the Management tab in the PKI Management dialog box, configure the options as
below:


Trust domain: trust_domain_ssl_proxy or trust_domain_ssl_proxy_2048



Content: CA certificate



Action: Export

Click OK and select the path to save the certificate. The certificate will be saved to the
specified location.

Then, import the device certificate to the client browser. Take Internet Explorer as an example:
1.
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2.

From the toolbar, select Tools > Internet Options.

3.

In the Content tab, click Certificates.

4.

In the Certificates dialog box, click the Trusted Root Certification Authorities tab.

5.

Click Import. Import the certificate following the Certificate Import Wizard.

Configuring a SSL Proxy Profile
Configuring a SSL proxy profile includes the following items: choose the work mode, set the website list
(use the CN value of the Subject field of the website certificate), configure the actions to the HTTPS
traffic when its SSL negotiation matches the item in the checklist, enable the audit warning page, and so
on. System supports up to 32 SSL proxy profiles and each profile supports up to 10,000 statistic website
entries.
To configure a SSL proxy profile, take the following steps:
1.

Click Policy > SSL Proxy.

2.

At the top-left corner, click New to create a new SSL proxy profile.
In the Basic tab, configure the settings.
Option

Description

Name

Specify the name of the SSL proxy profile.

Description

Add the description.

Mode

When the device works as the gateway of Web clients, the SSL
proxy function can work in the "Client Inspection - Proxy"
mode.

Common
Name

Set the website list based on the work mode. When the SSL
proxy is in the "Client Inspection - Proxy" mode, set the websites
that will not be proxied by the SSL proxy function and the device
will perform the SSL proxy on other websites.
To set the website list, specify the CN value of the subject field
of the website certificate and then click Add.

Warning
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Select Enable to enable the warning page. When the HTTPS
traffic is decrypted by the SSL proxy function, the request to a
HTTPS website will be redirected to a warning page of SSL
proxy. In this page, system notifies the users that their access to
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Option

Description
HTTPS websites are being monitored and asks the users to
protect their privacy.

In the Decryption Configuration tab, configure the settings.
Option

Description

After system completes the SSL negotiation, the traffic that is not blocked or
bypassed will be decrypted. When the parameters match multiple items in the
checklist and you configure difference actions to different items, the Block action
will take effect. The corresponding HTTPS traffic will be blocked.
Key Modulus

Specify the key pair modulus size of the private/public keys that
are associated with the SSL proxy certificate. You can select 1024
bits or 2048 bits.

Encryption mode check
Unsupported
version

Check the SSL protocol version used by the server.

When the SSL protocol used by the SSL server is
not supported in system, you can select Block to block its
HTTPS traffic, or select Bypass to bypass its HTTPS
traffic.

When the SSL protocol used by the SSL server is
supported, it will continue to check other items.

Unsupported
encryption
algorithms

Check the encryption algorithm used by the server.

When the encryption algorithm used by the SSL
server is not supported in system, you can select Block to
block its HTTPS traffic, or select Bypass to bypass its
HTTPS traffic.

When the encryption algorithm used by the SSL
server is supported, it will continue to check other items.

Unknown
Error
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Check the unknown error.

When SSL negotiation fails and the cause of
failure can’t be confirmed, you can select Block to
block its HTTPS traffic, or select Bypass to bypass its
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Option

Description
HTTPS traffic.

When system do not need check unknown failure,
it will continue to check other items.

Blocking SSL
version
Blocking
encryption
algorithm

When the SSL server uses the specified version of SSL protocol,
system can block its HTTPS traffic.
When the SSL server uses the specified encryption algorithm,
system can block its HTTPS traffic.

Server certificate check
Expired
certificate

3.

Check the certificate used by the server. When the certificate is
overdue, you can select Block to block its HTTPS traffic, or
select Bypass to bypass its HTTPS traffic, or select Decrypt to
decrypt the HTTPS traffic.

Click OK to save the settings.

Working as Gateway of Web Servers
To implement SSL proxy, you need to bind a SSL proxy profile to the policy rule. After binding the SSL
proxy profile to a policy rule, system will use the SSL proxy profile to deal with the traffic that matches
the policy rule. To implement SSL proxy, take the following steps:
1.

Configure a SSL proxy profile includes the following items: choose the work mode,
specify the trust domain of the Web server certificate and the HTTP port number of the Web
server.

2.

Bind a SSL proxy profile to a proper policy rule. The device will decrypt the HTTPS
traffic that matches the policy rule.

Configuring a SSL Proxy Profile
Configuring a SSL proxy profile includes the following items: choose the work mode, specify the trust
domain of the Web server certificate and the HTTP port number of the Web server.
To configure a SSL proxy profile, take the following steps:
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1.

Click Policy > SSL Proxy.

2.

At the top-left corner, click New to create a new SSL proxy profile.
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In the Basic tab, configure the settings.
Option

Description

Name

Specify the name of the SSL proxy profile.

Description

Add the description.

Mode

When the device works as the gatetway of Web servers, the SSL
proxy function can work in the "Server Inspection - Offload"
mode.


3.

When the SSL proxy function works in the
"Server Inspection - Offload" mode, it will proxy the SSL
connections initialized by Web clients, decrypt the
HTTPS traffic, and send the HTTPS traffic as plaintext
to the Web server.

Service Port

Specify the HTTP port number of the Web server. In Server
Inspection - Offload Mode, the default port number is 80. In the
Server Inspection - Proxy Mode, the default port number is 443.

Server Trust
Domain

Since the device will work as the SSL server and use the
certificate of the Web server to establish the SSL connection
with Web clients (Web browsers), you need to import the
certificate and the key pair into a trust domain in the device. For
more information about importing the certificate and the key
pair, see "PKI".
After you complete the importing, select the trust domain used
by this SSL Profile.

Warning

Select Enable to enable the warning page. When the HTTPS
traffic is decrypted by the SSL proxy function, the request to a
HTTPS website will be redirected to a warning page of SSL
proxy. In this page, system notifies the users that their access to
HTTPS websites are being monitored and asks the users to
protect their privacy.

Click OK to save the settings.

Binding an SSL Proxy Profile to a Policy Rule
After binding the SSL proxy profile to a policy rule, system will process the traffic that is matched to the
rule according to the profile configuration. To bind the SSL proxy profile to a policy rule, see "Security
Policy".
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Global Blacklist
After adding the IP addresses or services to the global blacklist, system will perform the block action to
the IP address and service until the block duration ends. You can manually add IP addresses or services
to the blacklist and system can also automatically add the IP addresses or services to the blacklist after
you configure the IPS module.
Configuring global blacklist includes IP block settings and service block settings, and both IPv4 and
IPv6 address are supported.

Configuring IP Block Settings
To configure the IP block settings, take the following steps:
1.

Select Policy > Global Blacklist > IP Block.

2.

Click New. The Block IP Configuration dialog box will appear.
Configure the corresponding options.
Option

Description

Virtual Router Select the virtual router that the IP address belongs to.

3.

Type

Select the address type, including IPv4 and IPv6.

IP

Type the IP address that you want to block. This IP address can
be not only the source IP address, but also the destination IP
address.

Duration

Type the duration that the IP address will be blocked. The unit is
second. The value ranges from 60 to 3600. The default value is
60.

Click OK to save the settings.

Configuring Service Block Settings
To configure the service block settings, take the following steps:
1.

Select Policy > Global Blacklist > Service Block.

2.

Click New. The Block Service Configuration dialog box will appear.
Configure the corresponding options.
Option
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Option

Description

Virtual Router Select the virtual router that the IP address belongs to.
Type

Select the address type, including IPv4 and IPv6.

Source IP

Type the source IP address of the blocked service. The service
block function will block the service from the source IP address
to the destination IP address.

Destination IP Type the destination IP address of the blocked service.

3.

www.fs.com

Destination
Port

Type the port number of the blocked service.

Protocol

Select the protocol of the blocked service.

Duration

Type the duration that the IP address will be blocked. The unit is
second. The value ranges from 60 to 3600. The default value is
60.

Click OK to save the settings.
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Chapter 11 Threat Prevention
Threat prevention is a device that can detect and block network threats. By configuring the threat
prevention function, FS devices can defend network attacks and reduce losses of the internal network.
Threat protections include:


Anti Virus: It can detect the common file types and protocol types which are most likely
to carry the virus and protect the network from them.. FS devices can detect protocol types of
POP3, HTTP, SMTP, IMAP4 and FTP, and the file types of archives (including GZIP, BZIP2,
TAR, ZIP and RAR-compressed archives), PE , HTML, MAIL, RIFF and JPEG.



Intrusion Prevention: It can detect and protect mainstream application layer protocols
(DNS, FTP, POP3, SMTP, TELNET, MYSQL, MSSQL, ORACLE, NETBIOS), against webbased attacks and common Trojan attacks.



Attack Defense: It can detect various types of network attacks, and take appropriate
actions to protect the Intranet against malicious attacks, thus assuring the normal operation of
the Intranet and systems.



Perimeter Traffic Filtering: It can filter the perimeter traffic based on known IP of
black/white list, and take block action on the malicious traffic that hits the blacklist.

The threat protection configurations are based on security zones and policies.


If a security zone is configured with the threat protection function, system will perform
detection on the traffic that is matched to the binding zone specified in the rule, and then do
according to what you specified.



If a policy rule is configured with the threat protection function, system will perform
detection on the traffic that is matched to the policy rule you specified, and then respond.



The threat protection configurations in a policy rule is superior to that in a zone rule if
specified at the same time, and the threat protection configurations in a destination zone is
superior to that in a source zone if specified at the same time.

Anti Virus
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
The system is designed with an Anti-Virus that is controlled by licenses to provide an AV solution
featuring high speed, high performance and low delay. With this function configured in FSOS, FS
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devices can detect various threats including worms, Trojans, malware, malicious websites, etc., and
proceed with the configured actions.
Anti Virus function can detect the common file types and protocol types which are most likely to carry
the virus and protect the network from them. FS devices can detect protocol types of POP3, HTTP,
HTTPS, SMTP, IMAP4 and FTP, and the file types of archives (including GZIP, BZIP2, TAR, ZIP and
RAR-compressed archives), PE , HTML, MAIL, RIFF and JPEG.
If IPv6 is enabled, Anti Virus function will detect files and protocols based on IPv6.
The virus signature database includes over 10,000 signatures, and supports both daily auto update and
real-time local update. See "Security Policy".
Notes: Anti Virus is controlled by license. To use Anti Virus, apply and install the Anti Virus（AV）
license.

Configuring Anti-Virus
This chapter includes the following sections:


Preparation for configuring Anti-Virus function



Configuring Anti-Virus function



Configuring Anti-Virus global parameters

Preparing
Before enabling Anti-Virus, make the following preparations:
1.
2.

Make sure your system version supports Anti-Virus.
Import an Anti-Virus license and reboot. The Anti-Virus will be enabled after the
rebooting.

Notes:




You need to update the Anti-Virus signature database before enabling the function for
the first time. To assure a proper connection to the default update server, you need to
configure a DNS server for FSOS before updating.
If Anti-Virus is enabled, the max amount of concurrent sessions will decrease by half.

Configuring Anti-Virus Function
The Anti-Virus configurations are based on security zones or policies.
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If a security zone is configured with the Anti-Virus function, system will perform
detection on the traffic that is matched to the binding zone specified in the rule, and then do
according to what you specified.



If a policy rule is configured with the threat protection function, system will perform
detection on the traffic that is matched to the policy rule you specified, and then respond.



The threat protection configurations in a policy rule is superior to that in a zone rule if
specified at the same time, and the threat protection configurations in a destination zone is
superior to that in a source zone if specified at the same time.



To perform the Anti-Virus function on the HTTPS traffic, see the policy-based AntiVirus.

To realize the zone-based Anti-Virus, take the following steps:
1.

Create a zone. For more information, refer to "Security Zone".

2.

In the Zone Configuration dialog, select Threat Protection tab.

3.

4.

Enable the threat protection you need and select an Anti-Virus rule from the profile
drop-down list below; or you can click Add Profile from the profile drop-down list. To creat
an Anti-Virus rule, see Configuring_Anti-Virus_Rule.
Click OK to save the settings.

To realize the zone-based Anti-Virus, take the following steps:
1.

Create a security policy rule. For more information, refer to "Security Policy".

2.

In the Policy Configuration dialog box, select the Protection tab.

3.

Select the Enable check box of Antivirus. Then select an Anti-Virus rule from the Profile
drop-down list, or you can click Add Profile from the Profile drop-down list to create an AntiVirus rule. For more information, see Configuring_Anti-Virus_Rule.

4.

To perform the Anti-Virus function on the HTTPS traffic, you need to enable the SSL
proxy function for the above specified security policy rule. System will decrypt the HTTPS
traffic according to the SSL proxy profile and then perform the Anti-Virus function on the
decrypted traffic.
According to the various configurations of the security policy rule, system will perform the
following actions:
Policy Rule
Actions
Configurations
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Policy Rule
Actions
Configurations
SSL proxy
enabled
Anti-Virus
disabled
SSL proxy
enabled
Anti-Virus
enabled
SSL proxy
disabled
Anti-Virus
enabled

System decrypts the HTTPS traffic according to the SSL proxy
profile but it does not perform the Anti-Virus function on the
decrypted traffic.

System decrypts the HTTPS traffic according to the SSL proxy
profile and performs the Anti-Virus function on the decrypted
traffic.

System performs the Anti-Virus function on the HTTP traffic
according to the Anti-Virus profile. The HTTPS traffic will not
be decrypted and the system will transfer it.

If the destination zone or the source zone specified in the security policy rule are configured
with Anti-Virus as well, system will perform the following actions:
Policy Rule
Zone
Actions
Configurations Configurati
ons
SSL proxy
enabled
Anti-Virus
disabled
SSL proxy
enabled
Anti-Virus
enabled
SSL proxy
disabled
Anti-Virus

www.fs.com

Anti-Virus System decrypts the HTTPS traffic according to the
enabled
SSL proxy profile and performs the Anti-Virus
function on the decrypted traffic according to the
Anti-Virus rule of the zone.
Anti-Virus System decrypts the HTTPS traffic according to the
enabled
SSL proxy profile and performs the Anti-Virus
function on the decrypted traffic according to the
Anti-Virus rule of the policy rule.
Anti-Virus System performs the Anti-Virus function on the
enabled
HTTP traffic according to the Anti-Virus rule of
the policy rule. The HTTPS traffic will not be
decrypted and system will transfer it.
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Policy Rule
Zone
Actions
Configurations Configurati
ons
enabled
5.

Click OK to save the settings.

Configuring an Anti-Virus Rule
To configure an Anti-Virus rule, take the following steps:
1.

Select Object > Antivirus > Profile.

2.

Click New.
In the Anti-Virus Rules Configuration dialog box, enter the Anti-Virus rule configurations.
Option

Description

Name

Specifies the rule name.

File Types

Specifies the file types you want to scan. It can be GZIP, JPEG,
MAIL, RAR, HTML .etc

Protocol Types Specifies the protocol types (HTTP, SMTP, POP3, IMAP4,
FTP) you want to scan and specifies the action the system will
take after the virus is found.




Fill Magic - Processes the virus file by filling
magic words, i.e., fills the file with the magic words
(Virus is found, cleaned) from the beginning to the
ending part of the infected section.
Log Only - Only generates log.



Warning - Pops up a warning page to prompt
that a virus has been detected. This option is only
effective to the messages transferred over HTTP.



Reset Connection - If virus has been detected,
system will reset connections to the files.

Malicious
Select the check box behind Malicious Website Access Control
Website Access to enable the function.
Control
Action
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Option

Description
website is found.


Log Only - Only generates log.



Reset Connection - If a malicious website has
been detected, system will reset connections to the files.



Warning - Pops up a warning page to prompt that
a malicious website has been detected. This option is only
effective to the messages transferred over HTTP.

Enable label E- If an email transferred over SMTP is scanned, you can enable
mail
label email to scan the email and its attachment(s). The scanning
results will be included in the mail body, and sent with the email.
If no virus has been detected, the message of "No virus found"
will be labeled; otherwise information related to the virus will be
displayed in the email, including the filename, result and action.
Type the end message content into the box. The range is 1 to
128.
3.

Click OK.

Notes: By default, according to virus filtering protection level, system comes with three default virus
filtering rules: predef_low, predef_middle, predef_high. The default rule is not allowed to edit or
delete.

Configuring Anti-Virus Global Parameters
To configure the AV global parameters, take the following steps:
1.

Select Object > Antivirus > Configuration.
In AV Global Configuration section, enter the AV global configurations.
Option

Description

Antivirus

Select/clear the Enable check box to enable/disable Anti-Virus.

Max
By default FSOS can scan the files of up to 5 decompression
Decompression layers. To specify a decompression layer, select a value from
Layer
the drop-down list. The value range is 1 to 5. Notes: For
compressed files containing docx, pptx, xlsx, jar, and apk
formats, when Exceed Action is specified as Reset
Connection, the maximum compression layers should be
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Option

Description
added one more layer to prevent download failure.

Exceed Action Specifies an action for the compressed files that exceed the max
decompression layer. Select an action from the drop-down list:

Encrypted
Compressed
File



Log Only - Only generates logs but will not scan
the files. This action is enabled by default.



Reset Connection - If a virus has been detected,
FSOS will reset connections for the files.

Specifies an action for encrypted compressed files:


------ - Will not take any special anti-virus actions
against the files, but might further scan the files
according to the configuration.



Log Only - Only generates logs but will not scan
the files.



Reset Connection - Resets connections for the
files.

2.

Click OK.

Intrusion Prevention System
IPS, Intrusion Prevention System, is designed to monitor various network attacks in real time and take
appropriate actions (like block) against the attacks according to your configuration.
The IPS can implement a complete state-based detection which significantly reduces the false positive
rate. Even if the device is enabled with multiple application layer detections, enabling IPS will not cause
any noticeable performance degradation. Besides, FSOS will update the signature database automatically
everyday to assure its integrity and accuracy.


IPS will support IPv6 address if the IPv6 function is enabled.



By integrating with the SSL proxy function, IPS can monitor the HTTPS traffic.

The protocol detection procedure of IPS consists of two stages: signature matching and protocol parse.


Signature matching: IPS abstracts the interested protocol elements of the traffic for
signature matching. If the elements are matched to the items in the signature database, system
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will process the traffic according to the action configuration. This part of detection is configured
in the Select Signature section.


Protocol parse: IPS analyzes the protocol part of the traffic. If the analysis results show
the protocol part containing abnormal contents, system will process the traffic according to the
action configuration. This part of detection is configured in the Protocol Configuration section.

Notes: Intrusion Prevention System is controlled by a license. To use Threat protection, apply and
install the Intrusion Prevention System (IPS) license.

Signatures
The IPS signatures are categorized by protocols, and identified by a unique signature ID. The signature
ID consists of two parts: protocol ID (1st bit or 1st and 2nd bit) and attacking signature ID (the last 5
bits). For example, in ID 605001, "6" identifies a Telnet protocol, and "00120" is the attacking signature
ID. The 1st bit in the signature ID identifies protocol anomaly signatures, while the others identify
attacking signatures. The mappings between IDs and protocols are shown in the table below:
ID

Protocol ID

Protocol ID

Protocol ID

Protocol

1

DNS

7

OtherTCP

13

TFTP

19

NetBIO
S

2

FTP

8

OtherUDP

14

SNMP

20

DHCP

3

HTTP

9

IMAP

15

MySQL 21

LDAP

4

POP3

10

Finger

16

MSSQL 22

VoIP

5

SMTP

11

SUNRP 17
C

Oracle

-

-

6

Telnet

12

NNTP 18

MSRPC -

-

In the above table, Other-TCP identifies all the TCP protocols other than the standard TCP protocols
listed in the table, and Other-UDP identifies all the UDP protocols other than the standard UDP
protocols listed in the table.

Configuring IPS
This chapter includes the following sections:


Preparation for configuring IPS function



Configuring IPS function
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Preparation
Before enabling IPS, make the following preparations:
1.
2.

Make sure your system version supports IPS.
Import an Intrusion Prevention System (IPS) license and reboot. The IPS will be
enabled after the rebooting.

Notes: If IPS is enabled, the max amount of concurrent sessions will decrease by half.

Configuring IPS Function
The IPS configurations are based on security zones or policies.


To perform the IPS function on the HTTPS traffic, see the policy-based IPS.

To realize the zone-based IPS, take the following steps:
1.

Create a zone. For more information, refer to "Security Zone".

2.

In the Zone Configuration dialog box, select Threat Protection tab.

3.

Enable the IPS you need and select an IPS rules from the profile drop-down list below,
or you can click Add Profile from the profile drop-down list below. To creat an IPS rule, see
Configuring_an_IPS_Rule.

4.

Click a direction (Inbound, Outbound, Bi-direction). The IPS rule will be applied to the
traffic that is matched with the specified security zone and direction.

To realize the policy-based IPS, take the following steps:
1.

Create a policy rule. For more inform action, refer to "Security Policy".

2.

In the Policy Configuration dialog box, select the Protection tab.

3.

Select the Enable check box of IPS. Then select an IPS rule from the Profile drop-down
list, or you can click Add Profile from the Profile drop-down list to creat an IPS rule. For
more information, see Configuring_an_IPS_Rule.

4.

To perform the IPS function on the HTTPS traffic, you need to enable the SSL proxy
function for the above specified security policy rule. System will decrypt the HTTPS traffic
according to the SSL proxy profile and then perform the IPS function on the decrypted traffic.
According to the various configurations of the security policy rule, system will perform the
following actions:
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Policy Rule
Actions
Configurations
SSL proxy
enabled
IPS disabled

System decrypts the HTTPS traffic according to the SSL proxy
profile but it does not perform the IPS function on the decrypted
traffic.

SSL proxy
enabled
IPS enabled

System decrypts the HTTPS traffic according to the SSL proxy
profile and performs the IPS function on the decrypted traffic.

SSL proxy
disabled
IPS enabled

System performs the IPS function on the HTTP traffic according
to the IPS profile. The HTTPS traffic will not be decrypted and
system will transfer it.

If the destination zone or the source zone specified in the security policy rule is configured
with IPS as well, system will perform the following actions:
Policy Rule
Zone
Actions
Configurations Configurati
ons

5.

SSL proxy
enabled
IPS disabled

IPS enabled System decrypts the HTTPS traffic according to the
SSL proxy profile and performs the IPS function
on the decrypted traffic according to the IPS rule of
the zone.

SSL proxy
enabled
IPS enabled

IPS enabled System decrypts the HTTPS traffic according to the
SSL proxy profile and performs the IPS function
on the decrypted traffic according to the IPS rule of
the policy rule.

SSL proxy
disabled
IPS enabled

IPS enabled System performs the IPS function on the HTTP
traffic according to the IPS rule of the policy rule.
The HTTPS traffic will not be decrypted and
system will transfer it.

Click OK to save the settings.

Configuring an IPS Rule
System has three default IPS rules: predef_default , predef_loose and predef_critical.


The predef_default rule includes all the IPS signatures and its default action is reset.



The predef_loose includes all the IPS signatures and its default action is log only.
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424

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE



The predef_critical includes all the IPS signatures with high severity and its default action
is log only.

To configure an IPS rule, take the following steps:
1.
2.
3.
4.

Select Object > Intrusion Prevention System > Profile.
Click New to create a new IPS rule. To edit an existing one, select the check box of this
rule and then click Edit. To view it, click the name of this rule.
Type the name into the Rule name box.
In the Select Signature area, the existing signature sets and their settings will be displayed
in the table. Select the desired signature sets. You can also manage the signature sets, including
New, Edit, and Delete.

Click New to create a new signature set rule.
Option

Description

Creating a new signature set contains:


Select By: Select the method of how to choose the signature set.
There are two methods: Filter and Search Condition.



Action: Specify the action performed on the abnormal traffic that
match the signature set.



Description: Specify the description of signature.

Select By
Filter

System categorizes the signatures according to the following
aspects (aka main categories): affected OS, attack type,
protocol, severity, released year, affected application, and
bulletin board. A signature can be in several subcategories of
one main category. For example, the signature of ID 105001 is
in the Linux subcategory, the FreeBSD subcategory, and Other
Linux subcategory at the same time.

With Filter selected, system displays the main categories and
subcategories above. You can select the subcategories to
choose the signatures in this subcategory. As shown below,
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Option

Description
after selecting the Web Attack subcategory in the Attack Type
main category, system will choose the signatures related to this
subcategory. To view the detailed information of these chosen
signatures, you can click the ID in the table.

When selecting main category and subcategory, note the
following matters:


You can select multiple subcategories of one
main category. The logic relation between them is OR.



The logic relation between each main category
is AND.



For example, you have selected Windows and
Linux in OS and select HIGH in Severity. The chosen
signatures are those whose severity is high and
meanwhile whose affected operating system is either
Windows or Linux.

Search Condition Enter the information of the signatures and press Enter to
search the signatures. System will perform the fuzzy matching
in the following field: attack ID, attack name, description, and
CVE-ID.
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Option

Description

In the search results displayed in the table, select the check box
of the desired signatures. Then click
to add them to the right pane. The ID displayed in the right
pane are the ones that are included in this signature set.
To add all signatures in the left to the right, click
.
Use
or
to cancel the selected signatures or all signatures in the right.
Action
Log Only

Record a log.

Reset

Reset connections (TCP) or sends destination unreachable
packets (UDP) and also generate logs.

Block IP

Block the IP address of the attacker. Specify a block duration.
The value range is 60 to 3600 seconds, and the default value is
60.

Block Service

Block the service of the attacker. Specify a block duration. The
value range is 60 to 3600 seconds, and the default value is 60.

Note: You create several signature sets and some of them contain a particular
signature. If the actions of these signature sets are different and the attack
matches this particular signature , system will adopt the following rules:


www.fs.com

Always perform the stricter action on the attack. The signature set
with stricter action will be matched. The strict level is: Block IP > Block
Service > Rest > Log Only. If one signature set is Block IP with 15s and
the other is Block Service with 30s, the final action will be Block IP with
30s.
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Option


5.
6.

Description
The action of the signature set created by Search Condition has
higher priority than the action of the signature set created by Filter.

Click OK to complete signature set configurations.
In the Protocol Configuration area, click . The protocol configurations specify the
requirements that the protocol part of the traffic must meet. If the protocol part contains
abnormal contents, system will process the traffic according to the action configuration.
System supports the configurations of HTTP, DNS, FTP, MSRPC, POP3, SMTP, SUNRPC,
and Telnet.
In the HTTP tab, select the Protocol tab, and configure the following settings:
Option

Description
Max Scan Length: Specify the maximum length of scanning
when scanning the HTTP packets.
Protocol Anomaly Detection: Select Enable to analyze the HTTP
packets. If abnormal contents exist, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.

HTTP

Banner Detection: Select the Enable check box to enable
protection against HTTP server banners.

Banner information - Type the new information
into the box that will replace the original server banner
information.
Max URI Length: Specify a max URI length for the HTTP
protocol. If the URI length exceeds the limitation, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.

www.fs.com
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Option

Description
Allowed Methods: Specify the allowed HTTP methods.

To protect the Web server, select Web Server in the HTTP tab.
Protecting the Web server means system can detect the following attacks: SQL injection, XSS
injection, external link check, ACL, and HTTP request flood and take actions when detecting
them. A pre-defined Web server protection rule named default is built in. By default, this
protection rule is enabled and cannot be disabled or deleted.
Configure the following settings to protect the Web server:
Option

Description

Name

Specify the name of the Web server protection rule.

Configure
Specify domains protected by this rule.
Domain
Click the link and the Configure Domain dialog box will appear.
Enter the domain names in the Domain text box. At most 5 domains
can be configured. The traffic to these domains will be checked by
the protection rule.
The domain name of the Web server follows the longest match rule
from the back to the front. The traffic that does not match any rules
will match the default Web server. For example, you have configured
two protection rules: rule1 and rule2. The domain name in rule1 is
abc.com. The domain name in rule2 is email.abc.com. The traffic
that visits news.abc.com will match rule1, the traffic that visits
www.email.abc.com will match rule2, and the traffic that visits
www.abc.com.cn will match the default protection rule.
CC URL
Limit

Select the Enable check box to enable the Web Server CC URL
Restriction feature. When this function is enabled, system will block
the traffic of this IP address，whose access frequency exceeds the
threshold.
o
Threshold: Specifies the maximum number of times
a single source IP accesses the URL path per minute. When
the frequency of a source IP address exceeds this threshold,
system will block the flow of the IP. The value ranges from 1
to 65535 times per minute.
o
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Option

Description
default is 60 seconds, in the range of 60 to 3600 seconds.
Over this time, system will release the blocked IP, this IP can
re-visit the Web server.
o
URL Path: Click the link and the Configure URL
Path dialog appears. Enter the URL path in the URL text box
to add or delete. After the configuration, all paths that
contain the name of the path are also counted. System
accesses the frequency statistics for HTTP requests that
access these paths. If the access frequency of the HTTP
request exceeds the threshold, the source IP of the request is
blocked, and the IP will not be able to access the Web server.
For example: configure'/home/ab', system will perform a
frequency check on the 'access/home/ab/login' and
'/home/BC/login' HTTP requests. URL path does not
support the path format which contains the host name or
domain name, for example: you can not configure
www.baidu.com/home/login.html, you should configure '/
home / login.html', and 'www.baidu.com' should be
configured in the corresponding Web server domain name
settings. You can configure up to 32 URL paths. The length
of each path is in the range of 1-255 characters.

SQL
Select the Enable check box to enable SQL injection check.
Injection

Action: Log Only - Record a log. Rest - Reset
Protection
connections (TCP) or sends destination unreachable packets
(UDP) and also generate logs. Block IP - Block the IP
address of the attacker and specify a block duration. Block
Service - Block the service of the attacker and specify a block
duration.
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Sensitivity: Specifies the sensitivity for the SQL
injection protection function. The higher the sensitivity is,
the lower the false negative rate is.



Check point: Specifies the check point for the SQL
injection check. It can be Cookie, Cookie2, Post, Referer or
URI.
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Option

Description

XSS
Select the Enable check box to enable XSS injection check for the
Injection
HTTP protocol.
Protection

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends destination unreachable packets
(UDP) and also generate logs. Block IP - Block the IP
address of the attacker and specify a block duration. Block
Service - Block the service of the attacker and specify a block
duration.


Sensitivity: Specifies the sensitivity for the XSS
injection protection function. The higher the sensitivity is,
the lower the false negative rate is.



Check point: Specifies the check point for the XSS
injection check. It can be Cookie, Cookie2, Post, Referer or
URI.

External
Select the Enable check box to enable external link check for the
Link Check
Web server. This function controls the resource reference from the
external sites.

Referer
check



External link exception: Click this link, and the
External Link Exception Configuration dialog box will
appear. All the URLs configured on this dialog box can be
linked by the Web sever. At most 32 URLs can be specified
for one Web server.



Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends destination unreachable packets
(UDP) and also generate logs.

Select the check box to enable referer checking. System checks the
headers of the HTTP packets and obtains the source site of the
HTTP request. If the source site is in the Header Exception list,
system will release it; otherwise, log or reset the connection. Thus
controlling the Web site from other sites and to prevent chain of
CSRF (Cross Site Request Forgery cross-site request spoofing)
attacks occur.
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Option

Description
exception ' to open the <External link exception>dialog box,
where the configured URL can refer to the other Web site.
Each Web server can be configured with up to 32 URLs.


Iframe
check

Action: Specify the action for the HTTP request for
the chaining behavior, either "Log only" or "Reset".“

Select the checkbox to enable iframe checking. System will identify if
there are hidden iframe HTML pages by this function, then log it or
reset its link.
After iframe checking is enabled, system checks the iframe in the
HTML page based on the specified iframe height and width, and
when any height and width is less than or equal to the qualified value,
system will identify as a hidden iframe attack, record, or reset
connection that occurred.

ACL
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Height: Specifies the height value for the iframe,
range from 0 to 4096.



Width: Specifies the width value of the iframe, range
from 0 to 4096.



Action: Specify the action for the HTTP request that
hides iframe behavior, which is 'Only logged' or 'Reset'.
Log Only - Record a log.
Reset - Reset connections (TCP) or sends destination
unreachable packets (UDP) and also generate logs.

Select the Enable check box to enable access control for the Web
server. The access control function checks the upload paths of the
websites to prevent the malicious code uploading from attackers.


ACL: Click this link, the ACL Configuration dialog
appears. Specify websites and the properties on this dialog.
"Static" means the URI can be accessed statically only as the
static resource (images and text), otherwise, the access will
handle as the action specified (log only/reset); "Block" means
the resource of the website is not allowed to access.



Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends destination unreachable packets
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Option

Description
(UDP) and also generate logs.

HTTP
Select the Enable check box to enable the HTTP request flood
Request
protection. Both IPv4 and IPv6 address are supported.
Flood

Request threshold: Specifies the request threshold.
Protection





For the protected domain name, when the
number of HTTP connecting request per second
reaches the threshold and this lasts 20 seconds,
system will treat it as a HTTP request flood attack,
and will enable the HTTP request flood protection.



For the protected full URL, when the number
of HTTP connecting request per second towards this
URL reaches the threshold and this lasts 20 seconds,
system will treat it as a HTTP request flood attack
towards this URL, and will enable the HTTP request
flood protection.

Full URL: Enter the full URLs to protect particular
URLs. Click this link to configure the URLs, for example,
www.example.com/index.html. When protecting a particular
URL, you can select a statistic object. When the number of
HTTP connecting request per second by the object reaches
the threshold and this lasts 20 seconds, system will treat it as
a HTTP request flood attack by this object, and will enable
the HTTP request flood protection.


x-forwarded-for: Select None, system will not
use the value in x-forwarded-for as the statistic
object. Select First, system will use the first value of
the x-forwarded-for field as the statistic object. Select
Last, system will use the last value of the xforwarded-for field as the statistic object. Select All,
system will use all values in x-forwarded-for as the
statistic object.



x-real-ip: Select whether to use the value in
the x-real-ip field as the statistic field.

When the HTTP request flood attack is discovered, you can make
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Option

Description
the system take the following actions:
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Authentication: Specifies the authentication method.
System judges the legality of the HTTP request on the source
IP through the authentication. If a source IP fails on the
authentication, the current request from the source IP will be
blocked. The available authentication methods are:


Auto (JS Cookie): The Web browser will
finish the authentication process automatically.



Auto (Redirect): The Web browser will finish
the authentication process automatically.



Manual (Access Configuration): The initiator
of the HTTP request must confirm by clicking OK
on the returned page to finish the authentication
process.



Manual (CAPTCHA): The initiator of the
HTTP request must be confirmed by entering the
authentication code on the returned page to finish the
authentication process.



Crawler-friendly: If this check box is selected, system
will not authenticate to the crawler.



Request limit: Specifies the request limit for the
HTTP request flood protection. After configuring the
request limit, system will limit the request rate of each source
IP. If the request rate is higher than the limitation specified
here and the HTTP request flood protection is enabled,
system will handle the exceeded requests according to the
action specified (Block IP/Reset). To record a log, select the
Record log check box.



Proxy limit: Specifies the proxy limit for the HTTP
request flood protection. After configuring the proxy limit,
system will check whether each source belongs to the each
source IP proxy server. If belongs to, according to
configuration to limit the request rate. If the request rate is
higher than the limitation specified here and the HTTP
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Option

Description
request flood protection is enabled, system will handle the
exceeded requests according to the action specified (Block
IP/Reset). To record a log, select the Record log check box.


White List: Specifies the white list for the HTTP
request flood protection. The source IP added to the white
list will not check the HTTP request flood protection.

In the DNS tab, configure the following settings:
Option

Description
Max Scan Length: Specify the maximum length of scanning
when scanning the DNS packets.
Protocol Anomaly Detection: Select Enable to analyze the DNS
packets. If abnormal contents exist, you can:

DNS


Action: Log Only - Record a log. Rest - Reset
connections (TCP) or send the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.

In the FTP tab, configure the following settings:
Option

Description
Max Scan Length: Specify the maximum length of scanning
when scanning the FTP packets.
Protocol Anomaly Detection: Select Enable to analyze the FTP
packets. If abnormal contents exist, you can:

FTP


Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Banner Detection: Select the Enable check box to enable
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Option

Description
protection against FTP server banners.

Banner Information: Type the new information
into the box that will replace the original server banner
information.
Max Command Line Length: Specifies a max length (including
carriage return) for the FTP command line. If the length exceeds
the limits, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Max Response Line Length: Specifies a max length for the FTP
response line.If the length exceeds the limits, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Action for Brute-force: If the login attempts per minute fail for
the times specified by the threshold, system will identify the
attempts as an intrusion and take an action according to the
configuration. Select the Enable check box to enable brute-force.
Non-root VSYS does not support this option.

Login Threshold per Min - Specifies a permitted
authentication/login failure count per minute.

Block IP - Block the IP address of the attacker
and specify a block duration.

Block Service - Block the service of the attacker
and specify a block duration.
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In the MSRPC tab, configure the following settings:
Option

Description
Max Scan Length: Specify the maximum length of scanning
when scanning the MSRPC packets.
Protocol Anomaly Detection: Select Enable to analyze the
MSRPC packets. If abnormal contents exist, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Max bind length: Specifies a max length for MSRPC's binding
packets. If the length exceeds the limits, you can:

MSRPC


Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Max request length: Specifies a max length for MSRPC's request
packets. If the length exceeds the limits, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Action for Brute-force: If the login attempts per minute fail for
the times specified by the threshold, system will identify the
attempts as an intrusion and take an action according to the
configuration. Select the Enable check box to enable brute-force.
Non-root VSYS does not support this option.

Login Threshold per Min - Specifies a permitted
authentication/login failure count per minute.
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Option

Description

Block IP - Block the IP address of the attacker
and specify a block duration.

Block Service - Block the service of the attacker
and specify a block duration.


Block Time - Specifies the block duration.

In the POP3 tab, configure the following settings:
Option

Description
Max Scan Length: Specify the maximum length of scanning
when scanning the POP3 packets.
Protocol Anomaly Detection: Select Enable to analyze the POP3
packets. If abnormal contents exist, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Banner Detection: Select the Enable check box to enable
protection against POP3 server banners.

POP3


Banner information - Type the new information
into the box that will replace the original server banner
information.
Max Command Line Length: Specifies a max length (including
carriage return) for the POP3 command line. If the length
exceeds the limits, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Max Parameter Length: Specifies a max length for the POP3
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Option

Description
client command parameter. If the length exceeds the limits, you
can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends destination unreachable
packets (UDP) and also generates logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Max failure time: Specifies a max failure time (within one single
POP3 session) for the POP3 server. If the failure time exceeds
the limits, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Action for Brute-force: If the login attempts per minute fail for
the times specified by the threshold, system will identify the
attempts as an intrusion and take an action according to the
configuration. Select the Enable check box to enable brute-force.
Non-root VSYS does not support this option.

Login Threshold per Min - Specifies a permitted
authentication/login failure count per minute.

Block IP - Block the IP address of the attacker
and specify a block duration.

Block Service - Block the service of the attacker
and specify a block duration.


Block Time - Specifies the block duration.

In the SMTP tab, configure the following settings:
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Description

SMTP

Max Scan Length: Specify the maximum length of scanning
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Option

Description
when scanning the SMTP packets.
Protocol Anomaly Detection: Select Enable to analyze the SMTP
packets. If abnormal contents exist, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Banner Detection: Select the Enable check box to enable
protection against SMTP server banners.

Banner information - Type the new information
into the box that will replace the original server banner
information.
Max Command Line Length: Specifies a max length (including
carriage return) for the SMTP command line. If the length
exceeds the limits, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Max Path Length: Specifies a max length for the reverse-path and
forward-path field in the SMTP client command. If the length
exceeds the limits, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Max Reply Line Length: Specifies a max length reply length for
the SMTP server. If the length exceeds the limits, you can:
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Option

Description

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Max Text Line Length: Specifies a max length for the E-mail text
of the SMTP client. If the length exceeds the limits, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Max Content Type Length: Specifies a max length for the
content-type of the SMTP protocol. If the length exceeds the
limits, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Max Content Filename Length: Specifies a max length for the
filename of E-mail attachment. If the length exceeds the limits,
you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Max Failure Time: Specifies a max failure time (within one single
SMTP session) for the SMTP server. If the length exceeds the
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Option

Description
limits, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Action for Brute-force: If the login attempts per minute fail for
the times specified by the threshold, system will identify the
attempts as an intrusion and take an action according to the
configuration. Select the Enable check box to enable brute-force.
Non-root VSYS does not support this option.

Login Threshold per Min - Specifies a permitted
authentication/login failure count per minute.

Block IP - Block the IP address of the attacker
and specify a block duration.

Block Service - Block the service of the attacker
and specify a block duration.


Block Time - Specifies the block duration.

In the SUNRPC tab, configure the following settings:
Option

Description
Max Scan Length: Specify the maximum length of scanning
when scanning the SUNRPC packets.
Protocol Anomaly Detection: Select Enable to analyze the
SUNRPC packets. If abnormal contents exist, you can:

SUNRPC


Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Action for Brute-force: If the login attempts per minute fail for
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Option

Description
the times specified by the threshold, system will identify the
attempts as an intrusion and take an action according to the
configuration. Select the Enable check box to enable brute-force.
Non-root VSYS does not support this option.

Login Threshold per Min - Specifies a permitted
authentication/login failure count per minute.

Block IP - Block the IP address of the attacker
and specify a block duration.

Block Service - Block the service of the attacker
and specify a block duration.


Block Time - Specifies the block duration.

In the Telnet tab, configure the following settings:
Option

Description
Max Scan Length: Specify the maximum length of scanning
when scanning the Telnet packets.
Protocol Anomaly Detection: Select Enable to analyze the Telnet
packets. If abnormal contents exist, you can:

Telnet


Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends the destination unreachable
packets (UDP) and also generate logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
Username/Password Max Length: Specifies a max length for the
username and password used in Telnet. If the length exceeds the
limits, you can:

Action: Log Only - Record a log. Rest - Reset
connections (TCP) or sends destination unreachable
packets (UDP) and also generates logs. Block IP - Block
the IP address of the attacker and specify a block
duration. Block Service - Block the service of the attacker
and specify a block duration.
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Option

Description
Action for Brute-force: If the login attempts per minute fail for
the times specified by the threshold, system will identify the
attempts as an intrusion and take an action according to the
configuration. Select the Enable check box to enable brute-force.
Non-root VSYS does not support this option.

Login Threshold per Min - Specifies a permitted
authentication/login failure count per minute.

Block IP - Block the IP address of the attacker
and specify a block duration.

Block Service - Block the service of the attacker
and specify a block duration.


Block Time - Specifies the block duration.

7.

Click Save to complete the protocol configurations.

8.

Click OK to complete the IPS rule configurations.

IPS Global Configuration
Configuring the IPS global settings includes:


Enable the IPS function



Specify how to merge logs



Specify the work mode

Click Object > Intrusion Prevention System > Configuration to configure the IPS global settings.
Option
IPS

Description
Select/clear the Enable check box to enable/disable the IPS
function.

Log Aggregate
System can merge IPS logs which have the same protocol ID, the
Type
same VSYS ID, the same Signature ID, the same log ID, and the
same merging type. Thus it can help reduce the number of logs
and avoid receiving redundant logs. The function is disabled by
default.

www.fs.com

444

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

Option

Description
Select the merging types in the drop-down list:


---- - Do not merge any logs.



Source IP - Merge the logs with the same Source
IP.

Aggregate
Time
Mode



Destination IP - Merge the logs with the same
Destination IP.



Source IP, Destination IP - Merge the logs with
the same Source IP and the same Destination IP.

Specifies the time granularity for IPS threat log of the same
merging type ( specified above) to be stored in the database. At
the same time granularity, the same type of log is only stored
once. It ranges from 10 to 600 seconds.
Specifies a working mode for IPS:


IPS - If attacks have been detected, FSOS will
generate logs, and will also reset connections or block
attackers. This is the default mode.



Log only - If attacks have been detected, FSOS
will only generate logs, but will not reset connections or
block attackers.

After the configurations, click OK to save the settings.
Notes: Non-root VSYS does not support IPS global configuration.

Signature List
Select Object > Intrusion Prevention System > Signature List. You can see the signature list.
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The upper section is for searching signatures. The lower section is for managing signatures.

Searching Signatures
In the upper section, set the search conditions and then click Search to search the signatures that match
the condition.
To clear all search conditions, click Reset. To save the search conditions, click Save Selection As to name
this set of search conditions and save it.

Managing Signatures
You can view signatures, create a new signature, load the database, delete a signature, edit a signature,
enable a signature, and disable a signature.


View signatures: In the signature list, click the ID of a signature to view the details.



Create a new signature: click New.

In the Basic Configuration tab, configure the following settings:
Option

Description

Name

Specifies the signature name.

Description

Specifies the signature descriptions.

Protocol

Specifies the affected protocol.

Flow

Specifies the direction.

To_Server means the package of attack is from
the server to the client.
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Option

Description
the client to the server.


Source Port

Any includes To_Server and To_Client.

Specifies the source port of the signature.


Any - Any source port.


Included - The source port you specified should
be included. It can be one port, several ports, or a range.
Specifies the port number in the text box, and use "," to
separate.

Excluded - The source port you specified should
be excluded. It can be one port, several ports, or a range.
Specifies the port number in the text box, and use "," to
separate.
Destination
Port

Specifies the destination port of the signature.


Any - Any destination port.


Included - The destination port you specified
should be included. It can be one port, several ports, or a
range. Specifies the port number in the text box, and use
"," to separate.

Excluded - The destination port you specified
should be excluded. It can be one port, several ports, or a
range. Specifies the port number in the text box, and use
"," to separate.
Dsize

Specifies the payload message size. Select "----",">", "<" or "="
from the drop-down list and specifies the value in the text box. "---" means no setting of the parameters.

Severity

Specifies the severity of the attack.

Attack Type

Select the attack type from the drop-down list.

Application

Select the affected applications. "----" means all applications.

Operating
System

Select the affected operating system from the drop-down list. "---" means all the operating systems.

Bulletin Board Select a bulletin board of the attack.
Year
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Option

Description

Detection
Filter

Specifies the frequency of the signature rule.

Track - Select the track type from the drop-down
list. It can be by_src or by_dst. System will use the
statistic of the source IP or the destination IP to check
whether the attack matches this rule.

Count - Specifies the maximum times the rule
occurs in the specified time. If the attacks exceed the
Count value, system will trigger rules and act as specified.

Seconds - Specifies the interval value of the rule
occurs.

In the Content tab, click New to specify the content of the signature:
Option

Description

Content

Specifies the signature content. Select the following check box if
needed:


Relative

HEX - Means the content is hexadecimal.



Case Insensitive - Means the content is not case
sensitive.



URI - Means the content needs to match URI
field of HTTP request.

Specifies the signature content location.




If Beginning is selected, system will search from
the header of the application layer packet.


Offset: System will start searching after
the offset from the header of the application layer
packet. The unit is byte.



Depth: Specifies the scanning length after
the offset. The unit is byte.

If Last Content is selected, system will search
from the content end position.
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Option

Description
the distance from the former content end
position. The unit is byte.


Within: Specifies the scanning length after
the distance. The unit is byte.



Load the database: After you create a new signature, click Load Database to make the
newly created signature take effect.



Edit a signature: Select a signature and then click Edit. You can only edit the user-defined
signature. After editing the signature, click Load Database to make the modifications take effect.



Delete a signature: Select a signature and then click Delete. You can only delete the userdefined signature. After deleting the signature, click Load Database to make the deletion take
effect.



Enable/Disable signatures: After selecting signatures, click Enable or Disable.

Notes: Non-root VSYS does not support signature list.

Configuring IPS White list
The device detects the traffic in the network in real time. When a threat is detected, the device generates
alarms or blocks threats. With the complexity of the network environment, the threat of the device will
generate more and more warning, too much threat to the user can not start making the alarm, and many
of them are false positives. By providing IPS whitelist, the system no longer reports alarms or blocks to
the whitelist, thus reducing the false alarm rate of threats. The IPS whitelist consists of source address,
destination address, and threat ID, and the user selects at least one item for configuration.
To configure an IPS white list :
1.

Select Object> Intrusion Prevention System >Whitelist

2.

Click New.
In the WhiteList Configuration dialog , enter the White List configurations.
Option

Description

Name

Specifies the white-list name.

Type

Select the address type, including IPv4 or IPv6.

Source Address Specifies the source address of the traffic to be matched by IPS.
Destination
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Option

Description

Address

IPS.

Signature ID

Select the signature ID from the drop-down list. A whitelist can
be configured with a maximum of one threat ID. When the
threat ID is not set, the traffic can be filtered based on the source
and destination IP address. When user have configured threat
ID, the source address, destination address and threat ID must
be all matched successfully before the packets can be released.

3.

Click OK.

Attack-Defense
There are various inevitable attacks in networks, such as compromise or sabotage of servers, sensitive
data theft, service intervention, or even direct network device sabotage that causes service anomaly or
interruption. Security gates, belonging to a category of network security devices, must be designed with
attack defense functions to detect various types of network attacks, and take appropriate actions to
protect the Intranet against malicious attacks, thus assuring the normal operation of the Intranet and
systems.
Devices provide attack defense functions based on security zones, and can take appropriate actions
against network attacks to assure the security of your network systems.

ICMP Flood and UDP Flood
An ICMP Flood/UDP Flood attack sends huge amounts of ICMP messages (such as ping)/UDP
packets to a target within a short period and requests for a response. Due to the heavy load, the attacked
target cannot complete its normal transmission task.

ARP Spoofing
LAN transmits network traffic based on MAC addresses. ARP spoofing attacks occur by filling in the
wrong MAC address and IP address to make a wrong corresponding relationship of the target host's
ARP cache table. This will lead to the wrong destination host IP packets, and the packet network's target
resources will be stolen.

SYN Flood
Due to resource limitations, a server will only permit a certain number of TCP connections. SYN Flood
just makes use of this weakness. During the attack an attacker will craft a SYN packet, set its source
address to a forged or non-existing address, and initiate a connection to a server. Typically the server
should reply the SYN packet with SYN-ACK, while for such a carefully crafted SYN packet, the client
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will not send any ACK for the SYN-ACK packet, leading to a half-open connection. The attacker can
send large amount of such packets to the attacked host and establish are equally large number of halfopen connections until timeout. As a result, resources will be exhausted and normal accesses will be
blocked. In the environment of unlimited connections, SYN Flood will exhaust all the available memory
and other resources of the system.

WinNuke Attack
A WinNuke attack sends OOB (out-of-band) packets to the NetBIOS port (139) of a Windows system,
leading to NetBIOS fragment overlap and host crash. Another attacking vector is ICMP fragment.
Generally an ICMP packet will not be fragmented; so many systems cannot properly process ICMP
fragments. If your system receives any ICMP fragment, it's almost certain that the system is under attack.

IP Address Spoofing
IP address spoofing is a technology used to gain unauthorized access to computers. An attacker sends
packets with a forged IP address to a computer, and the packets are disguised as if they were from a real
host. For applications that implement validation based on IP addresses, such an attack allows
unauthorized users to gain access to the attacked system. The attacked system might be compromised
even if the response packets cannot reach the attacker.

IP Address Sweep and Port Scan
This kind of attack makes a reconnaissance of the destination address and port via scanners, and
determines the existence from the response. By IP address sweeping or port scanning, an attacker can
determine which systems are alive and connected to the target network, and which ports are used by the
hosts to provide services.

Ping of Death Attack
Ping of Death is designed to attack systems by some over-sized ICMP packets. The field length of an IP
packet is 16 bits, which means the max length of an IP packet is 65535 bytes. For an ICMP response
packet, if the data length is larger than 65507 bytes, the total length of ICMP data, IP header (20 bytes)
and ICMP header (8 bytes) will be larger than 65535 bytes. Some routers or systems cannot properly
process such a packet, and might result in crash, system down or reboot.

Teardrop Attack
Teardrop attack is a denial of service attack. It is a attack method based on morbid fragmented UDP
packets, which works by sending multiple fragmented IP packets to the attacker (IP fragmented packets
include the fragmented packets of which packet, the packet location, and other information). Some
operating systems contain overlapping offset that will crash, reboot, and so on when receiving
fragmented packets.
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Smurf Attack
Smurf attacks consist of two types: basic attack and advanced attack. A basic Smurf attack is used to
attack a network by setting the destination address of ICMP ECHO packets to the broadcast address of
the attacked network. In such a condition all the hosts within the network will send their own response
to the ICMP request, leading to network congestion. An advanced Smurf attack is mainly used to attack
a target host by setting the source address of ICMP ECHO packets to the address of the attacked host,
eventually leading to host crash. Theoretically, the more hosts in a network, the better the attacking
effect will be.

Fraggle Attack
A fraggle attack is basically the same with a smurf attack. The only difference is the attacking vector of
fraggle is UDP packets.

Land Attack
During a Land attack, an attacker will carefully craft a packet and set its source and destination address
to the address of the server that will be attacked. In such a condition the attacked server will send a
message to its own address, and this address will also return a response and establish a Null connection.
Each of such connections will be maintained until timeout. Many servers will crash under Land attacks.

IP Fragment Attack
An attacker sends the victim an IP datagram with an offset smaller than 5 but greater than 0, which
causes the victim to malfunction or crash.

IP Option Attack
An attacker sends IP datagrams in which the IP options are abnormal. This attack intends to probe the
network topology. The target system will break down if it is incapable of processing error packets.

Huge ICMP Packet Attack
An attacker sends large ICMP packets to crash the victim. Large ICMP packets can cause memory
allocation error and crash the protocol stack.

TCP Flag Attack
An attacker sends packets with defective TCP flags to probe the operating system of the target host.
Different operating systems process unconventional TCP flags differently. The target system will break
down if it processes this type of packets incorrectly.
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DNS Query Flood Attack
The DNS server processes and replies to all DNS queries that it receives. A DNS flood attacker sends a
large number of forged DNS queries. This attack consumes the bandwidth and resources of the DNS
server, which prevents the server from processing and replying legal DNS queries.

TCP Split Handshake Attack
When a client establishes TCP connection with a malicious TCP server, the TCP server will respond to a
fake SYN packet and use this fake one to initialize the TCP connection with the client. After establishing
the TCP connection, the malicious TCP server switches its role and becomes the client side of the TCP
connection. Thus, the malicious traffic might enter into the intranet.

Configuring Attack Defense
To configure the Attack Defense based on security zones, take the following steps:
1.

Create a zone. For more information, refer to "Security Zone".

2.

In the Zone Configuration dialog box, select Threat Protection tab.

3.

To enable the Attack Defense functions, select the Enable check box, and click
Configure.
In the Attack Defense dialog box, enter the Attack Defense configurations.
Option

Description
IP address or IP range in the whitelist is exempt from attack
defense check.
click Configure, in the Whitelist Configuration dialog box, enter
the configurations:


Type - Specifies the address type, source or
destination.



IP/Netmask - Specifies the IP address and
netmask and click Add to add to the whitelist.



Address entry - Specifies the address entry and
click Add to add to the whitelist.

Whitelist

Select All
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Enable all: Select this check box to enable all the Attack Defense
functions for the security zone.
Action: Specifies an action for all the Attack Defense functions,
i.e., the defense measure system will be taken if any attack has
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Option

Description
been detected.




Drop - Drops packets. This is the default action.
Alarm - Gives an alarm but still permits packets
to pass through.
--- - Do not specify global actions.

Click the
button to expand the information of all flood attack defenses.
Select the Flood Attack Defense check box to enable all flood
attack defenses.
ICMP Flood: Select this check box to enable ICMP flood
defense for the security zone.


Threshold - Specifies a threshold for inbound
ICMP packets. If the number of inbound ICMP packets
matched to one single IP address per second exceeds the
threshold, system will identify the traffic as an ICMP
flood and take the specified action. The value range is 1
to 50000. The default value is 1500.



Action - Specifies an action for ICMP flood
attacks. If the default action Drop is selected, system will
only permit the specified number (threshold) of IMCP
packets to pass through during the current and the next
second, and also give an alarm. All the excessive packets
of the same type will be dropped during this period.

Flood Attack
Defense

UDP Flood: Select this check box to enable UDP flood defense
for the security zone.
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Src threshold - Specifies a threshold for
outbound UDP packets. If the number of outbound
UDP packets originating from one single source IP
address per second exceeds the threshold, system will
identify the traffic as a UDP flood and take the specified
action. The value range is 1 to 50000. The default value is
1500.



Dst threshold - Specifies a threshold for inbound
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Option

Description
UDP packets. If the number of inbound UDP packets
destined to one single port of one single destination IP
address per second exceeds the threshold, system will
identify the traffic as a UDP flood and take the specified
action. The value range is 1 to 50000. The default value is
1500.


Action - Specifies an action for UDP flood
attacks. If the default action Drop is selected, system will
only permit the specified number (threshold) of UDP
packets to pass through during the current and the next
second, and also give an alarm. All the excessive packets
of the same type will be dropped during this period.



Session State Check - Select this check box to
enable the function of session state check. After the
function is enabled, system will not check whether there
is UDP Flood attack in the backward traffic of UDP
packet of the identified sessions.

DNS Query Flood: Select this check box to enable DNS query
flood defense for the security zone.
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Src threshold - Specifies a threshold for
outbound DNS query packets. If the number of
outbound DNS query packets originating from one single
IP address per second exceeds the threshold, FSOS will
identify the traffic as a DNS query flood and take the
specified action.



Dst threshold - Specifies a threshold for inbound
DNS query packets. If the number of inbound DNS
query packets matched to one single IP address per
second exceeds the threshold, FSOS will identify the
traffic as a DNS query flood and take the specified
action.



Action - Specifies an action for DNS query flood
attacks. If the default action Drop is selected, FSOS will
only permit the specified number (threshold) of DNS
query packets to pass through during the current and
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Option

Description
next second, and also give an alarm. All the excessive
packets of the same type will be dropped during this
period; if Alarm is selected, FSOS will give an alarm but
still permit the DNS query packets to pass through.
Recursive DNS Query Flood: Select this check box to enable
recursive DNS query flood defense for the security zone.


Src threshold - Specifies a threshold for
outbound recursive DNS query packets packets. If the
number of outbound DNS query packets originating
from one single IP address per second exceeds the
threshold, FSOS will identify the traffic as a DNS query
flood and take the specified action.



Dst threshold - Specifies a threshold for inbound
recursive DNS query packets packets. If the number of
inbound DNS query packets destined to one single IP
address per second exceeds the threshold, FSOS will
identify the traffic as a DNS query flood and take the
specified action.



Action - Specifies an action for recursive DNS
query flood attacks. If the default action Drop is selected,
FSOS will only permit the specified number (threshold)
of recursive DNS query packets to pass through during
the current and next second, and also give an alarm. All
the excessive packets of the same type will be dropped
during this period; if Alarm is selected, FSOS will give an
alarm but still permit the recursive DNS query packets to
pass through.

SYN Flood: Select this check box to enable SYN flood defense
for the security zone.
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Src threshold - Specifies a threshold for
outbound SYN packets (ignoring the destination IP
address and port number). If the number of outbound
SYN packets originating from one single source IP
address per second exceeds the threshold, FSOS will
identify the traffic as a SYN flood. The value range is 0
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Option

Description
to 50000. The default value is 1500. The value of 0
indicates the Src threshold is void.
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Dst threshold - Specifies a threshold for inbound
SYN packets destined to one single destination IP
address per second.


IP-based - Click IP-based and then type a
threshold value into the box behind. If the
number of inbound SYN packets matched to one
single destination IP address per second exceeds
the threshold, FSOS will identify the traffic as a
SYN flood. The value range is 0 to 50000. The
default value is 1500. The value of 0 indicates the
Dst threshold is void.



Port-based - Click Port-based and then
type a threshold value into the box behind. If the
number of inbound SYN packets matched to one
single destination port of the destination IP
address per second exceeds the threshold, FSOS
will identify the traffic as a SYN flood. The value
range is 0 to 50000. The default value is 1500.
The value of 0 indicates the Dst threshold is void.
After clicking Port-based, you also need to type
an address into or select an IP Address or
Address entry from the Dst address combo box
to enable port-based SYN flood defense for the
specified segment. The SYN flood attack defense
for other segments will be IP based. The value
range for the mask of the Dst address is 24 to 32.

Action - Specifies an action for SYN flood
attacks. If the default action Drop is selected, FSOS will
only permit the specified number (threshold) of SYN
packets to pass through during the current and the next
second, and also give an alarm. All the excessive packets
of the same type will be dropped during this period.
Besides if Src threshold and Dst threshold are also
configured, FSOS will first detect if the traffic is a
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Option

Description
destination SYN flood attack: if so, FSOS will drop the
packets and give an alarm, if not, FSOS will continue to
detect if the traffic is a source SYN attack.

ARP Spoofing Click the
button to expand the information of the ARP spoofing. Select
the ARP Spoofing check box to enable all ARP spoofing
defenses.
Max IP number per MAC: Select this check box to check the
max IP number per MAC.
Specifies whether system will check the IP number per MAC in
the ARP table. If the parameter is set to 0, system will not check
the IP number; if it is set to a value other than 0, system will
check the IP number, and if the IP number per MAC is larger
than the parameter value, system will take the specified action.
The value range is 0 to 1024.
ARP Send Rate: Select this check box to check the ARP send
rate.
Specifies if FSOS will send gratuitous ARP packet(s). If the
parameter is set to 0 (the default value), FSOS will not send any
gratuitous ARP packet; if it is set to a value other than 0, FSOS
will send gratuitous ARP packet(s), and the number sent per
second is the specified parameter value. The value range is 0 to
10.
Reverse Query: Select this check box to enable Reverse query.
Select this check box to enable Reverse query. When FSOS
receives an ARP request, it will log the IP address and reply with
another ARP request; and then FSOS will check if any packet
with a different MAC address will be returned, or if the MAC
address of the returned packet is the same as that of the ARP
request packet.
MS-Windows
Defense

Click the
button to expand the information of MS-Windows defense.
Select the MS-Windows Defense check box to enable MSWindows defense.
Win Nuke Attack: Select this check box to enable WinNuke
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Option

Description
attack defense for the security zone. If any WinNuke attack has
been detected, system will drop the packets and give an alarm.

Scan/Spoof
Defense

Click the
button to expand the information of Scan/Spoof Defense.
Select the Scan/Spoof Defense check box to enable all
scan/spoof defenses.
IP Address Spoof: Select this check box to enable IP address
spoof defense for the security zone. If any IP address spoof
attack has been detected, FSOS will drop the packets and give an
alarm.
IP Address Sweep: Select this check box to enable IP address
sweep defense for the security zone.


Threshold - Specifies a time threshold for IP
address sweep. If over 10 TCP SYN packets are sent to
different ports within the period specified by the
threshold, FSOS will identify them as a port scan attack.
The value range is 1 to 5000 milliseconds. The default
value is 1.



Action - Specifies an action for IP address sweep
attacks. If the default action Drop is selected, FSOS will
only permit 10 TCP SYN packets destined to different
ports to pass through and drops the other packets of the
same type during the specified period (threshold), and
also gives an alarm.

Port Scan: Select this check box to enable port scan defense for
the security zone.
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Threshold - Specifies a time threshold for port
scan. If over 10 TCP SYN packets are sent to different
ports within the period specified by the threshold, FSOS
will identify them as a port scan attack. The value range is
1 to 5000 milliseconds. The default value is 1.



Action - Specifies an action for port scan attacks.
If the default action Drop is selected, FSOS will only
permit 10 TCP SYN packets destined to different ports
to pass through and drops the other packets of the same
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Option

Description
type during the specified period , and also gives an alarm.

Denial of
Service
Defense

Click the
button to expand the information of denial of service defense.
Select the Denial of Service Defense check box to enable all
denial of service defenses.
Ping of Death Attack: Select this check box to enable Ping of
Death attack defense for the security zone. If any Ping of Death
attack has been attacked, FSOS will drop the attacking packets,
and also give an alarm.
Teardrop Attack: Select this check box to enable Teardrop attack
defense for the security zone. If any Teardrop attack has been
attacked, FSOS will drop the attacking packets, and also give an
alarm.
IP Fragment: Select this check box to enable IP fragment
defense for the security zone.


Action - Specifies an action for IP fragment
attacks. The default action is Drop.

IP Option: Select this check box to enable IP option attack
defense for the security zone. FSOS will defend against the
following types of IP options: Security, Loose Source Route,
Record Route, Stream ID, Strict Source Route and Timestamp.


Action - Specifies an action for IP option
attacks. The default action is Drop.

Smurf or Fragile Attack: Select this check box to enable Smurf or
fragile attack defense for the security zone.


Action - Specifies an action for Smurf or fragile
attacks. The default action is Drop.

Land Attack: Select this check box to enable Land attack defense
for the security zone.


Action - Specifies an action for Land attacks.
The default action is Drop.

Large ICMP Packet: Select this check box to enable large ICMP
packet defense for the security zone.

www.fs.com
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Option

Proxy

Description


Threshold - Specifies a size threshold for ICMP
packets. If the size of any inbound ICMP packet is larger
than the threshold, FSOS will identify it as a large ICMP
packet and take the specified action. The value range is 1
to 50000 bytes. The default value is 1024.



Action - Specifies an action for large ICMP
packet attacks. The default action is Drop.

Click the
button to expand the information of proxy defense. Select the
Proxy check box to enable all proxy defenses.
SYN Proxy: Select this check box to enable SYN proxy for the
security zone. SYN proxy is designed to defend against SYN
flood attacks in combination with SYN flood defense. When
both SYN flood defense and SYN proxy are enabled, SYN proxy
will act on the packets that have already passed detections for
SYN flood attacks.
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Proxy trigger rate - Specifies a min number for
SYN packets that will trigger SYN proxy or SYN-Cookie
(if the Cookie check box is selected). If the number of
inbound SYN packets matched to one single port of one
single destination IP address per second exceeds the
specified value, FSOS will trigger SYN proxy or SYNCookie. The value range is 1 to 50000. The default value
is 1000.



Cookie - Select this check box to enable SYNCookie. SYN-Cookie is a stateless SYN proxy
mechanism that enables FSOS to enhance its capacity of
processing multiple SYN packets. Therefore, you are
advised to expand the range between "Proxy trigger rate"
and "Max SYN packet rate" appropriately.



Max SYN packet rate - Specifies a max number
for SYN packets that are permitted to pass through per
second by SYN proxy or SYN-Cookie (if the Cookie
check box is selected). If the number of inbound SYN
packets destined to one single port of one single
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Option

Description
destination IP address per second exceeds the specified
value, FSOS will only permit the specified number of
SYN packets to pass through during the current and the
next second. All the excessive packets of the same type
will be dropped during this period. The value range is 1
to 1500000. The default value is 3000.


Protocol
Anomaly
Report

Timeout - Specifies a timeout for half-open
connections. The half-open connections will be dropped
after timeout. The value range is 1 to 180 seconds. The
default value is 30.

Click the
button to expand the information of protocol anomaly report.
Select the Protocol Anomaly Report check box to enable the
function of all protocol anomaly reports.
TCP Anomalies: Select this check box to enable TCP option
anomaly defense for the security zone.


Action - Specifies an action for TCP option
anomaly attacks. The default action is Drop.

TCP Split Handshake: Select this check box to enable TCP split
handshake defense for the security zone.


Action - Specifies an action for TCP split
handshake attacks. The default action is Drop.

4.

To restore the system default settings, click Restore Default.

5.

Click OK.

Perimeter Traffic Filtering
Perimeter Traffic Filtering can filter the perimeter traffic based on known risk IP list, and take
logging/block action on the malicious traffic that hits the risk IP list.
The risk IP list includes the following three types:


IP Reputation list: Retrieve the risk IP (such as Botnet, Spam, Tor nodes, Compromised,
Brute-forcer, and so on.) list from the Perimeter Traffic Filtering signature database.
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User-defined black/white list : According to the actual needs of users, the specified IP
address is added to a user-definedblack/white list.

Notes:


You need to update the IP reputation database before enabling the IP Reputation
function for the first time. By default, system will update the database at the certain time
everyday, and you can modify the updating settings according to your own requirements, see
"Upgrading System".



Perimeter Traffic Filtering is controlled by license. To use Threat protection, apply and
install the PTF license.

Enabling Perimeter Traffic Filtering
To realize the zone-based Perimeter Traffic Filtering, take the following steps:
1.

Create a zone. For more information , refer to "Security Zone";

2.

In the Zone Configuration dialog box, select Threat Protection tab.

3.

Select the Enable check box after the Perimeter Traffic Filtering.

4.

Specifies an action for the malicious traffic that hits the blacklist. Select the User-defined ,
Pre-defined or IP Reputation check box , and select the action from drop-down list:


Log Only: Only generates logs if the malicious traffic hits the blacklist. This is the
default option.



Drop: Drop packets if the malicious traffic hits the blacklist.

Configuring User-defined Black/White List
To configure the user-defined black/white list , take the following steps:
1.

Select Object > Perimeter Traffic Filtering.

2.

Click New.
In Perimeter Traffic Filtering Configuration dialog box, enter the user-defined black/white list
configuration.
Option

www.fs.com

Description

IP

Specify the IP address for the user-defined black/white list.

mask

Specify the netmask of the IP address.
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Option
Black/White
List
3.

Description
Select the radio button to add the IP address to the blacklist or
whitelist .

Click OK.

Searching Black/White List
To search the black/white list, take the following steps:

www.fs.com

1.

Select Object > Perimeter Traffic Filtering.

2.

Click Search.

3.

Enter the IP address and click Search. The results will be displayed in this dialog box.
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Chapter 12 Monitor
The monitor section includes the following functions:


Monitor: The Monitor function statistically analyzes the devices and displays the statistics
in a bar chart, line chart, tables, and so on, which helps the users have information about the
devices.



WAP traffic distribution: Displays the history result (In the past 24 hours and the last 30
days) of WAP traffic distribution, including requests and responses.



Report: Through gathering and analyzing the device traffic data, traffic management data,
threat data, monitor data and device resource utilization data, the function provides the allaround and multi-demensional statistics.



Log: Records various system logs, including system logs, threat logs, session logs, NAT
logs, NBC logs and configuration logs.

Monitor
System can monitor the following objects.


User Monitor: Displays the application statistics within the specified period (Realtime,
latest 1 hour, latest 1 day, latest 1 month ) The statistics include the application traffic and
applications' concurrent sessions.



Application Monitor: Displays the statistics of applications, application categories,
application subcategories, application risk levels, application technologies, application
characteristics within the specified period (Realtime, latest 1 hour, latest 1 day, latest 1 month ).
The statistics include the application traffic and applications' concurrent sessions.



Cloud Application Monitor: Displays statistics of cloud based applications, including
their traffic, new sessions and concurrent sessions.



Share Access Monitor: Displays the access terminal statistics of specified filter
condition(Virtual router, IP, host number), including operation system , online time, login time
and last online time of users.



Device Monitor: Displays the device statistics within the specified period (Realtime, latest
1 hour, latest 1 day, latest 1 month ), including the total traffic, interface traffic, zone traffic,
CPU/memory status, sessions, Online IP and hardware status.



URL Hit: If system is configured with "URL Filtering", the predefined stat-set of URL
Hit can gather statistics on user/IPs, URLs and URL categories.

www.fs.com
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Link Status Monitor:Displays the traffic statistics of the interfaces that have been bound
within the specified period .



Application Block: If system is configured with "Security Policy" the application block
can gather statistics on the applications and user/IPs.



Keyword Block: If system is configured with"Web Content", "Email Filter", "Web
Posting", the predefined stat-set of Keyword Block can gather statistics on the Web keyword,
Web keywords, email keywords, posting keywords and users/IPs.



Authenticated User: If system is configured with"Web Authentication", "Single SignOn" , "SSL VPN" , "L2TP VPN" the auth user can gather statistics on the authenticated users.



Monitor Configuration: Enable or disable some monitor items as needed.



User Defined Monitor: Provides a more flexible approach to view the statistics.

Notes: If IPv6 is enabled, system will count the total traffic/sessions/AD/URLs/applications of
IPv4 and IPv6 address. Only User Monitor/Application Monitor/Cloud Application
Monitor/Device Monitor/URL Hit/Application Block/User-defined Monitor support IPv6 address.

User Monitor
This feature may vary slightly on different platforms . If there is a conflict between this guide and the
actual page, the latter shall prevail.
User monitor displays the application statistics within the specified period (Realtime, latest 1 hour, latest
1 day, latest 1 month ). The statistics include the application traffic and applications' concurrent
sessions.
If IPv6 is enabled, system will support to monitor both IPv4 and IPv6 address.
Notes: Non-root VSYS also supports user monitor, but does not support address book statistics.

Summary
Summary displays the user traffic/concurrent sessions ranking during a specified period or of specified
interfaces/zones. Click Monitor > User Monitor > Summary.
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Select a different Statistical_Period to view the statistical information in that period of
time.



Click

to refresh the monitoring data in this page.



Hover your mouse over a bar to view the user 's average upstream traffic, downstream
traffic, total trafficor concurrent sessions .



When displaying the user traffic statistics, the Upstream and Downstream legends are
used to select the statistical objects in the bar chart.

User Details
Click Monitor > User Monitor> User Details.



Click



To view the detailed information of a certain user , select the user entry in the list.


Application(real-time): Select the Application (real-time)tab and display the
detailed information of the category, subcategory, risk level, technology, upstream traffic,
downstream traffic, total traffic. Click Details in the list to view the line chart.



Cloud Application: Select the Cloud Application tab to display the cloud
application information of selected user.





to select the condition in the drop-down list to search the desired users.

Traffic: Select the Traffic tab to display the traffic trends of selected user .
Concurrent Sessions: Select the Concurrent Sessions tab to display the
concurrent sessions trends of selected user .
Frame a region's trends with the mouse. You can enlarge the scope of the displayed time

period. Click
www.fs.com

to restore the default size of the trend.
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Within the user entry list, hover your cursor over a user entry, and there is a
its right. Click this button and select Add to Black List.

button to

Address Book Details
Click Monitor>User Monitor>Address Book Details.



Click

to select the condition in the drop-down list to search the desired address

entry.


To view the detailed information of a address entry, select the address entry in the list.


Application (real-time): Select the Application (real-time) tab to displays the
detailed information of the upstream traffic, downstream traffic, and total traffic. Click
Detailsin the list to view the line chart.



Cloud Application: Select the Cloud Application tab to display the cloud
application information of selected address book.




Traffic: Select the Traffic tab to display the traffic trends of selected address entry.
Concurrent Sessions: Select the Concurrent Sessions tab to display the
concurrent sessions trends of selected address entry.

The monitor address is a database that stores the users' address which is used for the statistics.

Monitor Address Book
The monitor address is a database that stores the user 's address which is used for statistics.
Click Monitor > User Monitor> Select Address Book, and Click
corner.
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In this dialog box, you can perform the following actions:


Select the address entry check box, and click Add to add a new address entry entry to the
Selected list.



In the Selected list, select the address entry and click Remove for the address entry not
be counted.



Below the list shows the details of the selected address entry.

Statistical Period
System supports the predefined time cycle and the custom time cycle. Click the time button on the top
right corner of each tab to set the time cycle.


Real-time: Displays the current statistical information.



Last Hour: Displays the statistical information within the latest 1 hour.



Last Day: Displays the statistical information within the latest 1 day.



Last Month: Displays the statistical information within the latest 1 month.

Application Monitor
This feature may vary slightly on different platforms. If there is a conflict between this guide and the
actual page, the latter shall prevail.
Application monitor displays the statistics of applications, application categories, application
subcategories, application risk levels, application technologies, and application characteristics within the
specified period (Realtime, latest 1 hour, latest 1 day, latest 1 month ) .The statistics include the
application traffic and applications' concurrent sessions.
If IPv6 is enabled, system will support to monitor both IPv4 and IPv6 address.
Notes: Non-root VSYS also supports application monitor, but does not support to monitor
application group.
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Summary
The summary displays the following contents during a specified period:


The concurrent sessions of top 10 hot and high-risk applications.



The traffic/concurrent sessions of top 10 applications.



The traffic/concurrent sessions of top 10 application categories.



The traffic/concurrent sessions of top 10 application subcategories.



The traffic/concurrent sessions organized by application risk levels.



The traffic/concurrent sessions organized by application technologies.



The traffic/concurrent sessions organized by application characteristics.

Click Monitor>Application Monitor>Summary.



Select different Statistical_Period to view the statistical information in different periods
of time.



www.fs.com

From the drop-down menu, specify the type of statistics: Traffic or Concurrent Sessions.
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Click

to refresh the monitoring data in this page.

Hover your mouse over a bar or a pie graph to view the concrete statistical values of total
trafficor concurrent sessions .

Application Details
Click Monitor > Application Monitor > Application Details.



Click the Time drop-down menu to select different Statistical_Period to view the
statistical information in that periods of time.



Click
button and select Application in the drop-down menu. You can search
the desired application by entering the keyword of the application's name in the text field.



To view the detailed information of a certain application, select the application entry in
the list.


Users(real-time): Select the Users (real-time)tab to displays the detailed
information of users who are using the selected application. Click
in details column to
see the trends of upstream traffic, downstream traffic, total traffic .
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Traffic: Select the Traffic tab to display the traffic trends of selected application.



Concurrent Sessions: Select the Concurrent Sessions tab to display the
concurrent sessions trends of the selected application.



Description: Select the Description tab to displays the detailed information of the
selected application.
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Group Details
Click Monitor>Application Monitor>Group Details.



Click Time drop-down menu to select a different Statistical_Period to view the statistical
information in that periods of time.



Click
button and select Application Group in the drop-down menu. You can
search the desired application group by entering the keyword of the application group name in
the text field.



To view the detailed information of a certain application group, select the application
group entry in the list.


User(real-time): Select the Users(real-time)tab to display the detailed information
of users who are using the selected application group.Click
in details column, you can
see the trends of the upstream traffic, downstream traffic, total traffic .



Application(real-time): Select the Application(real-time) tab to display the detailed
information of applications in use which belongs to the selected application group.
Click
in details column to see the trends of the upstream traffic, downstream traffic,
total traffic of the selected application.



Traffic: Select the Traffic tab to display the traffic trends of selected application
group.
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Concurrent Sessions: Select the Concurrent Sessions tab to display the
concurrent sessions trends of the selected application group.



Description: Select the Description tab to display the detailed description of the
selected application.
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Select Application Group
Click Monitor>Application Monitor>Select Application Group.Click
on the
top left corner to configure the application groups required to be counted in the Select Application
Group dialog box. There are global application groups in the left column.

In this dialog box, you can perform the following actions:


Select the application groups check box, and click Add to add a new application groups
entry to the Selected list.



In the Selected list, select the application group entries and click Remove for the
application group entries not to be counted.

Statistical Period
System supports the predefined time cycle and the custom time cycle. Click Real-time on the top right
corner of each tab to set the time cycle.


Real-time: Displays the current statistical information.



Last 60 Minutes: Displays the statistical information within the latest 1 hour.



Last 24 Hours: Displays the statistical information within the latest 1 day.



Last 30 Days: Displays the statistical information within the latest 1 month.

Cloud Application Monitor
This feature may vary slightly on different platforms and not be available in VSYS on a part of platforms.
If there is a conflict between this guide and the actual page, the latter shall prevail.
A cloud application is an application program that functions in the cloud. It resides entirely on a remote
server and is delivered to users through the Internet.
Cloud application monitor page displays the statistics of cloud applications and users within a specified
period (realtime, latest 1 hour, latest 1 day, latest 1 month ), including application traffic, user number,
and usage trend.
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If IPv6 is enabled, system will support to monitor both IPv4 and IPv6 address.

Summary
The summary displays the following contents during a specified period:


Top 10 cloud application rank by traffic/concurrent session number with in a specified
period ( realtime, latest 1 hour, latest 1 day, latest 1 month ).



Top 10 cloud application user rank.

Click Monitor > Cloud Application Monitor> Summary.



By selecting different filters, you can view the statistics of different time period.
By selecting the drop-down menu of trafficor concurrent sessions, you can view your
intended statistics.



Click the update


icon to update the displayed data.

Hover your cursor over bar or pie chart to view exact data. Click the Details link
on hover box, and you will jump to the Cloud Application Details page.

Cloud Application Details
Click Monitor > Cloud Application Monitor>Cloud Application Details.


Click the Time drop-down menu to select different time period to view the statistics in
that period.



Click the Filter button, and select Application. In the new text box, enter the name of
your intended application.



To view the detailed information of a certain application group, select the application
group entry in the list.


User(real-time): Select the Users(real-time)tab to display the detailed information
of users who are using the selected application group. Click
in details column to see
the trends of the upstream traffic, downstream traffic, total traffic .



Application(real-time): Select the Application(real-time) tab to display the detailed
information of applications in use which belongs to the selected application . Click
in
details column to see the trends of the upstream traffic, downstream traffic, total traffic
of the selected application.
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Concurrent Sessions: Select the Concurrent Sessions tab to display the
concurrent sessions trends of the selected application.



Description: Select the Description tab to display the detailed description of the
selected application.

Statistical Period
System supports the predefined time cycle and the custom time cycle. Click Real-time on the top right
corner of each tab to set the time cycle.


Real-time: Displays the current statistical information.



Last 60 Minutes: Displays the statistical information within the latest 1 hour.



Last 24 Hours: Displays the statistical information within the latest 1 day.



Last 30 Days: Displays the statistical information within the latest 1 month.

Share Access Monitor
To detect the users' private behavior of shared access to the Internet, system supports to analyze the
User-agent filed of HTTP packet, a share access detect method which is based on the application
characteristic. The share access detect page can display the share access information with specified filter
condition.
Click Monitor> Share Access.



Click
for the share access.

, and click

to select the condition in the drop-down list to search



Source IP: Displays the endpoints statistics of the specified source IP.



Rule Name: Displays the endpoints statistics of the specified share access rule.



Source Zone: Displays the endpoints statistics of the specified source zone.



Endpoint Number: Displays the endpoints statistics of the specified endpoint number.



Status: Displays the endpoints statistics of the specified status.
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Move the mouse to Endpoint Number list, click
of Endpoint info and First Detection Time.

button, and then click Details, you will view the list

iQoS Monitor
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
When the iQoS policy is configured and the function of iQoS is enabled, you can view the real-time
traffic details or traffic trends of pipes and sub-pipes in Level-1 Control or Level-2 Control.
Notes: The iQoS monitor function is controlled by license, To use the function, install the iQoS
license. For more information on license, please refer to the License .

iQoS Details
Click Monitor >iQoS Monitor and enter the iQOS page. The pipe name and total traffic will be
displayed in the list.



Select the
selected level.
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In the
drop-down list, select Last 60 Minutes, Last 24 Hours, Last
7 Days or Last 30 Days to display the pipe traffic of the selected period. The maximum period is
30 days.



Click to expand sub-pipes.



Click Edit to edit the selected pipe.



Hover your mouse over the colorful lines of Traffic to view the forward traffic and
backward traffic.

The traffic details of the selected pipe will be displayed at the bottom of the page, including application,
user, traffic, sub-pipe stack (forward) and sub-pipe stack (backward).


Traffic： Displays the trends of forward traffic, backward traffic and total traffic of
pipes. Hover you mouse over the lines to view the forward traffic, backward traffic and total
traffic in real time. When you click Forward Traffic, Backward Traffic or Total Traffic in the top
right corner of trend chart, it will turn grey and the corresponded line will be hidden; when you
click it again, it will turn black and the line will appear.



Sub-pipe Stack (Forward)： Displays the trends of forward traffic of sub-pipes. Hover
you mouse over the lines to view the top 5 traffic and other forward traffic of sub-pipes in real
time. When you click the name of the specified sub-pipe in the top right corner of trend chart, it
will turn grey and the corresponded line will be hidden; when you click it again, it will turn black
and the line will appear.



Sub-pipe Stack (Backward)： Displays the trends of backward traffic of sub-pipes.
Hover you mouse over the lines to view the top 5 backward traffic and other backward traffic of
sub-pipes in real time. When you click the name of the specified sub-pipe in the top right corner
of trend chart, it will turn grey and the corresponded line will be hidden; when you click it again,
it will turn black and the line will appear.

Device Monitor
This feature may vary slightly on different platforms. If there is a conflict between this guide and the
actual page, the latter shall prevail.
The Device page displays the device statistics within the specified period, including the total traffic,
interface traffic, zone traffic, CPU/memory status, sessions, hardware status and online IP.

Summary
The summary displays the device statistics within last 24 hours. Click Monitor>Device
Monitor>Summary.
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Total traffic: Displays the total traffic within the specified statistical period.


Hover your mouse over the chart to view the total traffic statistics at a specific
point in time.



Select a different Statistical Period to view the statistical information in that
period of time.






If IPv6 is enabled, the device traffic will show the total traffic of IPv4 and IPv6.

Interface traffic: Displays the upstream traffic, downstream traffic, total traffic and
concurrent sessions of interface within the specified statistical period by rank.


Click Traffic In, Traffic Out, Traffic, or Concurrent Sessions. System displays the
interface traffic according to the value(from large to small) of the specified object. By
default, the interface traffic is displayed according to the total traffic value of interface.



Select a different Statistical Period to view the statistical information in that
period of time.



Click the interface name to view the Detailed Information.



If IPv6 is enabled, the interface traffic will show the traffic of IPv4 and IPv6.

Zone traffic: Displays the upstream traffic, downstream traffic, total traffic and
concurrent sessions of zone within the specified statistical period by rank.
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zone traffic according to the value(from large to small) of the specified object. By default,
the zone traffic is displayed according to the total traffic value of zone.
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Select a different Statistical Period to view the statistical information in that
period of time.




Click the zone name to view the Detailed Information.

Hardware status: Displays the real-time hardware status, including storage, chassis
temperature and fan status.



Storage: Displays the percentage of disk space utilization.
Internal Storage: Displays the percentage of hard disk utilization. Only partial
platforms support this function.







Hover your mouse over the utilization to view the current utilization, the
used storage size and the total storage size.
Chassis temperature: Displays the current CPU/chassis temperature.

Fan status: Displays the operation status of the fan. Green indicates normal, and
red indicates error or a power supply module is not used.
Sessions: Displays the current sessions utilization.

CPU/memory status: Displays current CPU utilization, memory utilization and CPU
temperature statistics.


Click legends of CPU Utilization, Memory Utilization or CPU Temperature to
specify the histogram statistical objects. By default, it displays statistics of all objects.

Statistical Period
System supports the predefined time cycle. Select statistical period from the drop-down menu
at the top right corner of some statistics page to set the time cycle.


Real-time: Displays the current statistical information.



Last 60 Minutes: Displays the statistical information within the latest 1 hour.



Last 24 Hours: Displays the statistical information within the latest 1 day.



Last 30 Days: Displays the statistical information within the latest 1 month.

Detailed Information
The detailed information page displays detailed statistics of certain monitored objects. In addition, in the
detailed information page, hover your mouse over the chart that represents a certain object to view the
statistics of history trend and other information.
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For example, click ethernet0/0 in the Interface Traffic , and the detailed information of ethernet0/0
appears.



Icon
and
are used to switch the line chart and stacked chart, which display the
history trend of sessions and concurrent sessions.



In traffic trend section, click legends of Traffic In or Traffic Out to specify the statistical
objects. By default, it displays all statistical objects.



In the User or Application section, click Username/IP or Application to display the realtime trend of the specified user or application. For example, the user traffic trend is shown as
below.
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480

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE



Select line chart or stacked chart from the pop-up menu
top right corner .



at the

Hover your mouse over the chart to view the session statistics at a specific point
in time.

Online IP
Click Monitor>Device>Online IP to view the historical trend of the number of online users. You can
select the statistical period as last 60 minutes, last 24 hours or last 30 days.



Hover your mouse over the line to view online users information.

URL Hit
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
If the "URL Filtering" function is enabled in the security policy rule, the predefined stat-set of URL
filter can gather statistics on user/IPs, URLs and URL categories.
If IPv6 is enabled, system will support to monitor both IPv4 and IPv6 address.

Summary
Click Monitor> URL Hit>Summary.


Select a different Statistical_Period to view the statistical information in that period of
time.



Hover your mouse over a bar, to view the hit count of user/IP, URL or URL Category .



Click
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Click

to switch between the bar chart and the pie chart.

User/IP
Click Monitor> URL Hit>User/IP.






The user/IPs and detailed hit count are displayed in the list below.
Click a user/IP in the list to display the corresponding URL hit statistics in the curve
chart below.


Statistics: Displays the hit statistics of the selected User/IP, including the realtime statistics and statistics for the latest 1 hour, 24 hours 30 days .



URL(real-time): Displays the URLs' real-time hit count of selected User/IP. Click
URL link ,you can view the corresponding URLs detailed statistics page. Click Detail link,
you can view the URL hit trend of the selected User/IP in the URL Filter Detailsdialog .



URL category(real-time): Displays the URL categories' read-time hit count of
selected user/IP. Click URL category link , you can view the corresponding URL
categories' detailed statistics page. Click Detail link, you can view the URL category hit
trend of the selected user/IP in the pop-up dialog .

Click
at top-right corner and then click the Filter button at top-left corner.
Select User/IP and you can search the user/IP hit count information by entering the keyword of
the username or IP.

URL
Click Monitor > URL Hit > URL.
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Click a URL in the list to view its detailed statistics.


Statistics: Displays the hit statistics of the selected URL, including the real-time
statistics and statistics for the latest 1 hour, 24 hours 30 days .



User/IP(real-time): Displays the User/IP's real-time hit count of selected URL.
Click the User/IP link and you can view the corresponding user/IPs detailed statistics
page. Click the Detail link and you can view the URL hit trend of the selected user/IP in
the URL Filter Details dialog box.

Click
at the top-right corner and then click the Filter button at the top-left
corner. Select URLand you can search the URL hit count information by entering the keyword
of the URL.



Click

to refresh the real-time data in the list.

URL Category
Click Monitor> URL Hit > URL Category.



The URL category, count, traffic are displayed in the list.
Click a URL category in the list to view its detailed statistics displayed in the Statistics,
URL(real-time), User/IP(real-tiime) tabs.





Statistics: Displays the trend of the URL category visits, including the real-time
trend and the trend in the last 60 minutes, 24 hours , 30 days.



URL(real-time): Displays the visit information of the URLs, contained in the
URL category, that are being visited.



User/IP(real-time): Displays the visit information of the users or IPs that are
visiting the URL category.
Click

to refresh the real-time data in the list.

Statistical Period
System supports the predefined time cycle and the custom time cycle. Click the time button on the top
right corner of each tab to set the time cycle.


Real-time: Displays the current statistical information.



Last 60 Minutes: Displays the statistical information within the latest 1 hour.



Last 24 Hours: Displays the statistical information within the latest 1 day.
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Last 30 Days: Displays the statistical information within the latest 1 month.

Link Status Monitor
Link status monitoring can calculate the sampling traffic information of the specific interface in the link,
including latency, packet loss rate, and jitter, to monitor and display the overall status of the link.
Link state monitor page displays the traffic statistics of the interfaces that have been bound within a
specified period (Realtime, latest 1 hour, latest 1 day, latest 1 month) . System also supports for link
detection to calculate the traffic information of the specific destination IP address in the link, including
latency, and jitter.

Link User Experience
The link user experience page displays the traffic statistics of the interfaces that have been bound within
a specified period (Realtime, latest 1 hour, latest 1 day, latest 1 month) .
Click Monitor > Link Status Monitor. For more information about configuration of binding interfaces,
refer to Link Configuration.


Select a different Statistical_Period to view the statistical information in that periods of
time.



Select the binding interface Binding Interface drop-down list, Click the Binding Interface
drop-down menu and select the interface name to view the link status monitoring statistics for
this interface. You can select multiple interfaces.



Click
button and select Application in the drop-down menu. You can select the
TOP 10 or Application / Application group name to view the link status monitoring statistics
according to the specified application.

Notes:



"Time" and "Binding Interface" are required in the filter condition.
If the application switch of the specified interface is not enabled in the link configuration,
the Application filter condition cannot be added.

Statistical Period
System supports the predefined time cycle and the custom time cycle. Click Last 60 Minutes on the top
right corner of each tab to set the time cycle.


Real-time: Displays the current statistical information.



Last 60 Minutes: Displays the statistical information within the latest 1 hour.
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484

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE



Last 24 Hours: Displays the statistical information within the latest 1 day.



Last 30 Days: Displays the statistical information within the latest 1 month.

Link Detection
The link detection page displays real-time traffic statistics of specified detection destination IP to link or
link to detection destination IP, include latency, and jitter.
To configure the link detection, take the following steps:
1.

Click Monitor > Link Status Monitor > Link Detection.

2.

Select the interface name to view the link status monitoring statistics for this interface,
you can select up to 8 interfaces. Click New to add interfaces, you can add up to 16 interfaces.
For more information about configuration of binding interfaces, refer to Link Configuration.

3.

Select the IP address to view the link status monitoring statistics for this destination
address, you can select up to 8 addresses. Click New to add destination address, you can add
up to 32 addresses. For more information about configuration of destination addresses, refer
to Detection Destination.

4.

Click Start Detection, and view the statistics of the real-time link detection at the bottom
of the page. Select Detection Destination IP->Link or Link->Detection Destination IP tab to
view the trend chart of latency and jitter. Click Trend Chart and Table to switch between the
trend chart and table.

5.

Click End Detection to end the real-time link detection.

Link Configuration
In the link configuration page, you can configure the binding interface to monitor the link state and can
enable the application switch and link user experience.
To configure the link, take the following steps:

www.fs.com

1.

Click Monitor > Link Status Monitor > Link Configuration.

2.

Click New.
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In the Link Configuration dialog box, configure these values

3.

Option

Description

Binding Interface

Select the interface in the drop down menu.

Application

Select Application check box. After enabling, you can see
details of the specific application in this interface.

Monitor

Select Monitor check box. After enabling, you can see
traffic statistics in this interface.

Click OK.

Detection Destination
In the detection destination page, you can configure the destination IP address to monitor the link state.
To configure the detection destination, take the following steps:
1.

Click Monitor > Link Status Monitor > Detection Destination

2.

Click New.

In the Detection Destination Configuration dialog box, configure these values
Option

Description

IP Type

Selects the IP address type, include IPv4 or IPv6.

Detection Destination Specifies the IP address of the detection destination.
IP

3.

Protocol

Specifies the protocol of the detection destination,
include TCP or ICMP.

Port

Specifies the port number of the detection destination.

Interval

Specifies the interval time of the detection packet. The
value range is 1 to 5 seconds, the default value is 1.

Description

Types the description for the detection destination

Click OK.

Application Block
This feature may not be available on all platforms. Please check your system's actual page to see if your
device delivers this feature.
If system is configured with "Security Policy" the application block can gather statistics on the
applications and user/IPs.
www.fs.com

486

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

If IPv6 is enabled, system will support to monitor both IPv4 and IPv6 address.

Summary
The summary displays the application block's statistics on the top 10 applications and top 10 user/IPs.
Click Monitor>Application Block> Summary.


Select a different Statistical_Period to view the statistical information in that period of
time.



Hover your mouse over a bar to view the block count on the applications and user/IPs.



Click

at the top-right corner of every table and enter the corresponding details page.



Click

to switch between the bar chart and the pie chart.

Application
Click Monitor>Application Block> Application.



The applications and detailed block count are displayed in the list below.
To view the corresponding information of application block on the applications and
user/IPs, select the application entry in the list.


Statistics: Displays the block count statistics of the selected application, including
the real-time statistics and statistics for the latest 1 hour, 24 hours and 30 days.



User/IP: Displays the user/IPs that are blocked from the selected application.
Click a user/IP in the list to display the corresponding block count statistics in the curve
chart below. Click



to jump to the corresponding user / IPs page.

Click
, and then click
to select the condition in the drop-down list.
You can search the application block information by entering the keyword of the application
name.



Click

to refresh the real-time data in the list.

User/IP
Click Monitor>Application Block> User/IP.


The user/IP and detailed block count are displayed in the list below.



Click a user/IP in the list to display the corresponding block count statistics in the curve
chart below. Click
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Click
, and then click
You can search the users/IPs information.

to select the condition in the drop-down list.

Statistical Period
System supports the predefined time cycle and the custom time cycle. Click (
the top right corner of each tab to set the time cycle.


Realtime: Displays the statistical information within the realtime.



Last Hour: Displays the statistical information within the latest 1 hour.



Last Day: Displays the statistical information within the latest 1 day.



Last Month: Displays the statistical information within the latest 1 month.

) on

Keyword Block
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
If system is configured with "Web Content" , "Email Filter" on, or "Web Posting", the predefined statset of the Keyword Block can gather statistics on the Web keyword, Web keywords, email keywords,
posting keywords and users/IPs.

Summary
The summary displays the predefined stat-set of the Keyword Block that can gather statistics on the top
10 hit Web keywords, the top 10 hit email keywords, the top 10 posting keywords, and the top 10
users/IPs. Click Monitor > Keyword Block > Summary.
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Select a different Statistical_Period to view the statistical information in that period of
time.



Hover your mouse over a bar to view the block count on the keywords .



Click

at the top-right corner of every table and enter the corresponding details page.



Click

to switch between the bar chart and the pie chart.

Web Content
Click Monitor>Keyword Block> Web Content.




The Web content and detailed block count are displayed in the list below.
To view the corresponding information of keyword block on the Web content, select the
keyword entry in the list.


Statistics: Displays the statistics of the selected keyword, including the real-time
statistics and statistics for the latest 1 hour, 24 hours and 30 days.



User/IP: Displays the user/IPs that are blocked by the selected keyword. Click a
user/IP in the list to display the corresponding block count statistics in the curve chart
below. Click



to jump to the corresponding user / IPs page.

Click
, and then click
to select the condition in the drop-down list.
You can search the keyword block information by entering the keyword .



Click

to refresh the real-time data in the list.

Email Content
Click Monitor>Keyword Block> Email Content.
www.fs.com
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For a page description, see Web_Content.

Web Posting
Click Monitor>Keyword Block>Web Posting.
For a page description, see Web_Content.

User/IP
Click Monitor>Keyword Block>User/IP.



The user/IP and detailed block count are displayed in the list below.



Click a user/IP in the list to display the corresponding statistics , Web content, Email
Content, Web Posting in the curve chart below. Click
page.



Click
, and then click
You can search the users/IPs information .

to jump to the corresponding detail

to select the condition in the drop-down list.

Statistical Period
System supports the predefined time cycle and the custom time cycle. Click (
the top right corner of each tab to set the time cycle.


Real-time: Displays the current statistical information.



Last Hour: Displays the statistical information within the latest 1 hour.



Last Day: Displays the statistical information within the latest 1 day.



Last Month: Displays the statistical information within the latest 1 month.
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Authentication User
If system is configured with"Web Authentication", "Single Sign-On" , "SSL VPN", "L2TP VPN" the
authentication user can gather statistics on the authenticated users.
Click Monitor>Authenticated User.


Click
the users.

, and click

to select the condition in the drop-down list to filter



Click Kick Out under the Operation column to kick the user out.



Click

to refresh the real-time data in the list.

Monitor Configuration
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
You can enable or disable some monitor items as needed. The monitor items for Auth user are enabled
automatically.
To enable/disable a monitor item, take the following steps:
1.

Click Monitor > Monitor Configuration.

2.

Select or clear the monitor item(s) you want to enable or disable.

3.

Click OK .

Notes: After a monitor item is enabled or disabled in the root VSYS, the item of all VSYSs will be
enabled or disabled(except that the non-root VSYS does not support this monitor item). You can not
enable or disable monitor item in non-root VSYSs.
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User-defined Monitor
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
A user-defined stat-set provides a more flexible approach to view the statistics. You can view the
statistics as needed. The statistical data may vary in the data types you have selected.
If IPv6 is enabled, system will support to monitor both IPv4 and IPv6 address.
The IP type-based statistical information table.
Data type
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Data type
Directi
on
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Statistics
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security
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on the
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Data type
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Data type
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Data type
Directi
on

Conditi
on

Traffic
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and
e
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d traffic
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a specific
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The interface, zone, user, application, URL, URL category, VSYS type-based statistical information table.
Data type
Group
by

Zone
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Data type
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Data type
Group
by

User
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Data type
Group
by

Directi
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Traffic
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count

categor
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VSYS
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d
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N/A

You can configure a filtering condition for the stat-set to gather statistics on the specified condition,
such as statistics on the session number of the specified security zone, or the traffic of the specified IP.
The filtering conditions supported table.
Type

Description

filter zone

Data is filtered by security zone.

filter zone zone-name ingress

Data is filtered by ingress security zone.

filter zone zone-name egress

Data is filtered by egress security zone.

filter interface

Data is filtered by interface.

filter interface if-name ingress

Data is filtered by ingress interface.

filter interface if-name egress

Data is filtered by egress interface.

filter application

Data is filtered by application.

filter ip

Data is filtered by address entry.

filter ip add-entry source

Data is filtered by source address
(address entry).

filter ip add-entry destination

Data is filtered by destination address
(address entry).

filter ip A.B.C.D/M

Data is filtered by IP.

www.fs.com
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Type

Description

filter ip A.B.C.D/M source

Data is filtered by source IP.

filter ip A.B.C.D/M destination

Data is filtered by destination IP.

filter user

Data is filtered by user.

filter user-group

Data is filtered by user group.

filter severity

Data is filtered by signature severity.

Click Monitor>User-defined Monitor.




Click New. For more information, see Creating_a_User-defined_Stat-set
Click the user-defined stat-set name link. For more information, see Viewing_Userdefined_Stat-set_Statistics.

Creating a User-defined Stat-set
To create a user-defined stat-set, take the following steps:
1.

Click Monitor>User Defined Monitor.

2.

Click New.

In the User-defined Monitor Configuration dialog box, modify according to your needs.
Option

Description

Name

Type the name for the stat-set into the Name box.

Data Type

Select an appropriate data type from the Data type list.

Group by

Select an appropriate grouping method from the Group by list.

Root vsys only If you only want to perform the data statistics for the root VSYS,
select the Root vsys only checkbox. This checkbox will take
effect when the data type is Traffic, Session, Ramp-up rate, or
URL hit. If the data grouping method is configured to VSYS, this
checkbox will be unavailable.
Options
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To configure a filtering condition, click Option. In the Advanced
dialog box, select a filter condition from the Filter drop-down
list. For more details about this option,see
The_filtering_conditions_supported_table.

500

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

3.

Click OK to save your settings . The configured stat-set will be displayed .

Notes: You need to pay attention to the following when configure a stat-set.



The URL hit statistics are only available to users who have a URL license.
If the Data type is Traffic, Session, Ramp-up rate, Virus attack count, Intrusion count or
URL hit count, then the Filter should not be Attack log.



If the Data type is URL hit count, then the Filter should not be Service.



System will hide unavailable options automatically.

Viewing User-defined Monitor Statistics
Click the user-defined stat-set name link, and then select the stat-set you want to view.



Displays the top 10 statistical result from multiple aspects in forms of bar chart.



View specified historic statistics by selecting a period from the statistic period drop-down
list.



Click All Data to view all the statistical result from multiple aspects in forms of list, trend.
Click TOP 10 returns bar chart.

Reporting
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
The reporting feature gathers and analyzes data for the following report categories, providing all-around
and multi-dimensional statistics to you.
Report
Categories
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Report
Categories

Description

Threat Report Helps users quickly understand the overall risk situation of the
servers and users.
Traffic Report Analysis and display of the user, application, interface, zone's
traffic and concurrency.
URL Content
Report

Detailed description of the URL hit, including the hit times,
trends, categories.

You can configure report task in "User-defined Task" and "Predefined Task", and view generated report
files in "Report File".

Report File
Go to Monitor > Reports > Report File and the report file page shows all of the generated report files.
The report file pages may vary slightly on different platforms, which are shown below.



Sort report files by different conditions: Select Group by Time, Group by Task or Group
by Status from the drop-down list, and then select a time, task or status from the selective table,
and the related report files will be shown in the report file table.



Click Delete to delete the selected report files.



Click Export to download the selected report files.



Click Mark as Read to modify the status of the selected report files.



Click
, and click
to select the condition in the drop-down list. In the
text box, enter the keyword to search for the report files.



In the File Type column, click the icon of the report file to preview the report file. Not
all platforms support this function. The content of the security report varies slightly on different
platforms.



Hover your mouse over the Send Object column, and the system will prompt the Email
addresses or FTP information about sending.

www.fs.com
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Notes: If your browser has enabled "Blocking pop-up windows", you will not see the generated file.
Make sure to set your browser "Always allow pop-up windows", or you can go to your blocked
window history to find the report file.

User-defined Task
A user-defined task is a customized report task which can be tailored to meet your requirements.

Creating a User-defined Task
To create a user-defined task, take the following steps:
1.

Select Monitor > Reports > User-defined Task.

2.

Click New.
In the Report Task Configuration dialog box, configure these values.
Option

Description

Basic
Name

Specifies the name of the report task.

Description

Specifies the description of the report task.

Report Items
Report Items

Specifies the content for the report file.
To add report items to the report task, take the following steps:
1.

Expand the categories from the left list.

2.
Select the category item you want, and click Add
to add it to the right column.
Schedule
The schedule specifies the running time of the report task. The report task can be
run periodically or run immediately.
Periodic: Generates report files as planned.


Schedule: Specifies the statistical period.



At: Specifies the running time.

Generate Now: Generates report files immediately.
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Option

Description

Output
File Format

The output format of the report file is a PDF.

Recipient

Sends report file via email. To add recipients, enter the email
addresses in to the recipient text box (use ";" to separate multiple
email addresses).

Send via FTP

Check the Send via FTP check box to send the report file to a
specified FTP server.

Server Name/IP: Specifies the FTP server name
or the IP address.

Virtual Router: Specifies the virtual router of the
FTP server.

Username: Specifies the username used to log on
to the FTP server.

Password: Enter the password of the FTP
username.

Anonymous: Check the check box to log on to
the FTP server anonymously.

Path: Specifies the location where the report file
will be saved.

3.

Click OK to complete task configuration.

Enabling/Disabling the User-defined Task
To enable or disable the user-defined task, take the following steps:
1.
2.

Select Monitor > Reports > User-defined Task.
Select the task you want, and click the Enable or Disable button on the top.
By default, the user-defined task is enabled.

Viewing Report Files
To view the generated report files, select Monitor > Reports > Report File.
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504

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

Predefined Task
The predefined tasks are the system report task template. Each report task is named according to the
name of the report item, the configured date and time.
The predefined tasks include the following types:


Threat Report



Traffic Report



URL Content Report

Generating Report Tasks

1.

Select Monitor > Reports > Predefined Task.

2.

In the Action column, click the

icon.

In the Report Task Configuration dialog box, configure these values.
Option

Description

Basic
Name

Specifies the name of the report task.

Description

Specifies the description of the report task. You can modify
according to your requirements.

Schedule
The schedule specifies the running time of report task. The report task can be run
periodically or run immediately.
Periodic: Generates report files as planned.


Schedule: Specifies the statistical period.



At: Specifies the running time.

Generate Now: Generates report file immediately.


Type: Generates report files based on the data in the specified
statistical period.

Output
File Format
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Option

Description

Recipient

Sends report file via email. To add recipients, enter the email
addresses in to the recipient text box (use ";" to separate multiple
email addresses).

Send via FTP

Check the Send via FTP check box to send the report file to a
specified FTP server.

Server Name/IP: Specifies the FTP server name
or the IP address.

Virtual Router: Specifies the virtual router of the
FTP server.

Username: Specifies the username used to log on
to the FTP server.

Password: Enter the password of the FTP
username.

Anonymous: Check the check box to log on to
the FTP server anonymously.

Path: Specifies the location where the report file
will be saved.

3.

Click OK to complete task configuration.

Viewing Report Files
To view the generated report files, select Monitor > Reports > Report File.

Logging
Logging is a feature that records various kinds of system logs, including device log, threat log, session log,
NAT log, Content filter log,File filter log, Network Behavior Record logshare access logs, and URL logs.


Device log
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error, critical, alert, emergency.
Network - logs about network services, like PPPoE and DDNS.
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Configuration - logs about configuration on command line interface, e.g.
interface IP address setting.
Share Access Logs - logs about share access rule.



Threat - logs related to behaviors threatening the protected system, e.g. attack defense
and application security.



Session - Session logs, e.g. session protocols, source and destination IP addresses and
ports.



NAT - NAT logs, including NAT type, source and destination IP addresses and ports.



File Filter - logs related with file filter function.



Content filter logs – logs related with content filter function, e.g. Web content filter,
Web posting, Email filter and HTTP/FTP control.



Network behavior record logs – Logs related with network behavior record function,
e.g. IM behavior ,etc.



URL - logs about network surfing, e.g. Internet visiting time, web pages visiting history,
an URL filtering logs.



PBR - logs about policy-based route.

The system logs the running status of the device, thus providing information for analysis and evidence.

Log Severity
Event logs are categorized into eight severity levels.
Severity

Level

Description

Log
Definition

Emergencies

0

Identifies illegitimate system events.

LOG_EMER
G

Alerts

1

Identifies problems which need
LOG_ALER
immediate attention such as device is T
being attacked.

Critical

2

Identifies urgent problems, such as
hardware failure.

Errors

3

Generates messages for system errors. LOG_ERR

Warnings

4

Generates messages for warning.

www.fs.com
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Severity

Level

Description

Log
Definition

Notifications

5

Generates messages for notice and
special attention.

LOG_NOTI
CE

Informational 6

Generates informational messages.

LOG_INFO

Debugging

Generates all debugging messages,
including daily operation messages.

LOG_DEBU
G

7

Destination of Exported Logs
Log messages can be sent to the following destinations:


Console - The default output destination. You can close this destination via CLI.



Remote - Includes Telnet and SSH.



Buffer - Memory buffer.



File - By default, the logs are sent to the specified USB destination in form of a file.



Syslog Server - Sends logs to UNIX or Windows Syslog Server.



Email - Sends logs to a specified email account.



Local database - Sends logs to the local database of the device.

Log Format
To facilitate the access and analysis of the system logs, FSOS logs follow a fixed pattern of information
layout, i.e. date/time, severity level@module: descriptions.See the example below:
2000-02-05 01:51:21, WARNING@LOGIN: Admin user "admin" logged in through console from
localhost.

Event Logs
This feature may vary slightly on different platforms. Please see the actual page of the feature that your
device delivers.
To view event logs, select Monitor > Log > Event Log.
In this page, you can perform the following actions:


Configure: Click to jump to the configuration page.



Clear: Click to clear the selected logs.

www.fs.com
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Export: Click to export the displayed logs as a TXT or CSV file.



Filter: Click Filter to add conditions to show logs that march your filter.

Network Logs
This feature may vary slightly on different platforms. Please see the actual page of the feature that your
device delivers.
To view network logs, select Monitor > Log > Network Log.
In this page, you can perform the following actions:


Configure: Click to jump to the configuration page.



Clear: Click to clear the selected logs.



Export: Click to export the displayed logs as a TXT or CSV file.



Filter: Click
your filter.

, and then click

to add conditions to show logs that march

Configuration Logs
This feature may vary slightly on different platforms. Please see the actual page of the feature that your
device delivers.
To view configuration logs, select Monitor > Log > Configuration Log.
In this page, you can perform the following actions:


Configuration: Click to jump to the configuration page.



Clear: Click to clear the selected logs.



Export: Click to export the displayed logs as a TXT or CSV file.



Filter: Click
your filter.

, and then click

to add conditions to show logs that march

Share Access Logs
To view share access logs, select Monitor > Log > Share Access Log.
In this page, you can perform the following actions:
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Clear: Click to clear the selected logs.



Export: Click to export the displayed logs as a TXT file.



Add to My Log: Click to add the current filtered results to MyLog list.



Filter: Click
your filter.

, and then click

to add conditions to show logs that march

Threat Logs
This feature may vary slightly on different platforms. Please see the actual page of the feature that your
device delivers.
Threat logs can be generated under the conditions that:



Threat logging in the Logging feature is enabled. Refer to "Log Configuration".
You have enabled one or more of the following features: "Anti Virus" , " Intrusion
Prevention System", "Attack-Defense" or "Perimeter Traffic Filtering" .

To view threat logs, select Monitor > Log > Threat Log.
In this page, you can perform the following actions:


Configure: Click to jump to the configuration page.



Clear: Click to clear the selected logs.



Export: Click to export the displayed logs as a TXT or CSV file.



Filter: Click
, and then click
to add conditions to show logs that march
your filter.You can enter the IPv4 or IPv6 address if the filter condition is selected as source or
destination IP.



View the details of selected log in the Log Details tab. In the Log Details tab, you can
click "View Pcap" "Download" "Add Whitelist" "Disable Signatures" to quickly link to the
relevant page.

Session Logs
Session logs can be generated under the conditions that:



Session logging in the Logging feature is enabled. Refer to "Log Configuration" .
You have enabled one or more of the following features: ."Web Content"、"Web
Posting" 、"Email Filter" and "Data Security" functions.

www.fs.com
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To view session logs, select Monitor > Log > Session log.

Notes:


For ICMP session logs, the system will only record the ICMP type value and its code
value. As ICMP 3, 4, 5, 11 and 12 are generated by other communications, not a complete
ICMP session, system will not record such kind of packets.



For TCP and UDP session logs, system will check the packet length first. If the packet
length is 20 bytes (i.e., with IP header, but no loads), it will be defined as a malformed packet
and be dropped; if a packet is over 20 bytes, but it has errors, system will drop it either. So,
such abnormal TCP and UDP packets will not be recorded.

PBR Logs
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
PBR logs can be generated under the conditions that:


PBR logging in the Logging feature is enabled. Refer to "Log Configuration".



You have enabled logging function in PBR rules. Refer to "Creating a Policy-based Route
Rule" .

To view PBR logs, select Monitor > Log > PBR Log.

NAT Logs
NAT logs are generated under the conditions that:

www.fs.com
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NAT logging in the Logging feature is enabled. Refer to "Log Configuration".



NAT logging of the NAT rule configuration is enabled. Refer to"Configuring SNAT"
and "Configuring SNAT" "Configuring DNAT".

To view NAT logs, select Monitor > Log > NAT Log.


Filter: Click Filter to add conditions to show logs that march your filter



Configure: Click to jump to the configuration page



Clear: Click to delete all the displayed logs.



Export: Click to export the displayed logs as a TXT or CSV file.

URL Logs
This feature may not be available on all platforms. Please check your system's actual page to see if your
device delivers this feature.
URL logs can be generated under the conditions that:


URL logging in the Logging feature is enabled. Refer to "Log Configuration".



You have enabled logging function in URL rules. Refer to "URL Filtering"

To view URL logs, select Monitor > Log > URL Log.

File Filter Logs
This feature may not be available on all platforms. Please check your system's actual page to see if your
device delivers this feature.
File Filter logs can be generated under the conditions that:

www.fs.com
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File Filter logging in the Logging feature is enabled. Refer to "Log Configuration".



You have enabled the function of "File Filter".

To view File Filter logs, select Monitor > Log > File Filter.


Filter: Click Filter to add conditions to show logs that march your filter



Configure: Click to jump to the configuration page



Clear: Click to delete all the displayed logs.



Export: Click to export the displayed logs as a TXT or CSV file.

Content Filter Logs
This feature may not be available on all platforms. Please check your system's actual page to see if your
device delivers this feature.
Content Filter logs can be generated under the conditions that:



Content Filter logging in the Logging feature is enabled. Refer to "Log Configuration".
You have enabled one or more of the following features: "Web Content", "Web
Posting" , "Email Filter" and"HTTP/FTP Control" function.

To view Content Filter logs, select Monitor > Log > Content Filter.


Filter: Click Filter to add conditions to show logs that march your filter



Configure: Click to jump to the configuration page



Clear: Click to delete all the displayed logs.



Export: Click to export the displayed logs as a TXT or CSV file.

Network Behavior Record Logs
This feature may not be available on all platforms. Please check your system's actual page to see if your
device delivers this feature.
Network Behavior Record logs can be generated under the conditions that:


Network Behavior Record logging in the Logging feature is enabled. Refer to "Log
Configuration".
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You have enabled the function of"Network Behavior Record".

To view Network Behavior Record logs, select Monitor > Log > Network Behavior Record.


Filter: Click Filter to add conditions to show logs that march your filter



Configure: Click to jump to the configuration page



Clear: Click to delete all the displayed logs.



Export: Click to export the displayed logs as a TXT or CSV file.

Managing Logs
You can configure system to enable the logging function, including enabling various logs.

Configuring Logs
To configure parameters of various log types, take the following steps:
1.
2.

Select Monitor > Log > Log Management.
Click on the tab of the log type you want, and you will enter the corresponding log
settings.

3.

Click OK.

Option Descriptions of Various Log Types
This section describes the options when you set the properties of each log types.
Event Log
Option

Description

Enable

Select the check box to enable the event logging function.

Console

Select the check box to send a syslog to the Console.


Terminal
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Lowest Severity - Specifies the lowest
severity level. Logs below the severity level selected
here will not be exported.

Select the check box to send a syslog to the terminal.


Lowest Severity - Specifies the lowest
severity level. Logs below the severity level selected
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Option

Description
here will not be exported.

Cache

File

Log Server

Email Address

www.fs.com

Select the check box to send a syslog to the cache.


Lowest Severity - Specifies the lowest
severity level. Logs below the severity level selected
here will not be exported.



Max Buffer Size - The maximum size of the
cached logs. The default value may vary for
different hardware platforms.

Select the check box to send a syslog to a file.


Max File Size - Specifies the maximum size
of the syslog file. The value range is 4096 to
1048576 bytes. The default value is 1048576 bytes.



Save logs to USB - Select the check box and
select a USB drive (USB0 or USB1) from the dropdown list. Type a name for the syslog file into the
File Name box.

Select the check box to export event logs to the syslog
server.


View Log Server - Click to see all existing
syslog servers or to add new server.



Lowest Severity - Specifies the lowest
severity level. Logs below the severity level selected
here will not be exported.

Select the check box to send event logs to the email.


View Email Address: Click to see all existing
email addresses or add a new address.



Lowest Severity - Specifies the lowest
severity level. Logs below the severity level selected
here will not be exported.
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Network Log
Option

Description

Enable

Select the check box to enable the network logging function.

Cache

Select the check box to export network logs to the cache.


File

Log Server

Max Buffer Size - The maximum size of the
cached network logs. The value range is 4096 to 524288
bytes. The default value may vary for different hardware
platforms.

Select the check box to send a syslog to a file.


Max File Size - Specifies the maximum size of
the syslog file. The value range is 4096 to 1048576 bytes.
The default value is 1048576 bytes.



Save logs to USB - Select the check box and
select a USB drive (USB0 or USB1) from the drop-down
list. Type a name for the syslog file into the File Name
box.

Select the check box to export network logs to the syslog server.


View Log Server - Click to see all existing syslog
servers or to add a new server.

Configuration Log
Option

Description

Enable

Select the check box to enable the configuration logging function.

Cache

Select the check box to export configuration logs to the cache.


Log Server
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Max Buffer Size - The maximum size of the
cached configuration logs. The value range is 4096 to
524288 bytes. The default value may vary for different
hardware platforms.

Select the check box to export network logs to the syslog server.


View Log Server - Click to see all existing syslog
servers or to add new server.
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Option

Description

Log Speed
Limit

Select the check box to define the maximum efficiency of
generating logs.


Maximum Speed - Specified the speed (messages
per second).

Session Log
Option
Enable

Cache

Log Server

Description
Select the check box to enable the session logging function.


Record User Name: Select to show the user's
name in the session log messages.



Record Host Name: Select to show the host's
name in the session log messages.

Select the check box to export session logs to cache.


Max Buffer Size - The maximum size of the
cached session logs. The value range is 4096 to 2097152
bytes. The default value may vary for different hardware
platforms.

Select the check box to export session logs to the syslog server.


View Log Server - Click to see all existing syslog
servers or to add a new server.



Syslog Distribution Methods - The distributed
logs can be in the format of binary or text. If you select
the check box, you will send log messages to different log
servers, which will relieve the pressure of a single log
server. The algorithm can be Round Robin or Src IP
Hash.

PBR Log
Option
Enable
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Description
Select the check box to enable a PBR logging function.
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Option

Cache

Log Server

Description


Record User Name: Select to show the user's
name in the PBR log messages.



Record Host Name: Select to show the host's
name in the PBR log messages.

Select the check box to export PBR logs to the cache.


Max Buffer Size - The maximum size of the
cached PBR logs. The value range is 4096 to 2097152
bytes. The default value may vary for different hardware
platforms.

Select the check box to export PBR logs to the syslog server.


View Log Server - Click to see all existing syslog
servers or to add a new server.



Syslog Distribution Methods - The distributed
logs can be in the format of plain text. If you select the
check box, you will send log messages to different log
servers, which will relieve the pressure of a single log
server. The algorithm can be Round Robin or Src IP
Hash.

NAT Log
Option
Enable

Description
Select the check box to enable the NAT logging function.


Cache

Log Server
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Record Host Name: Select to show the host's
name in the NAT log messages.

Select the check box to export NAT logs to cache.


Max Buffer Size - The maximum size of the
cached NAT logs. The default value may vary for
different hardware platforms.

Select the check box to export NAT logs to log servers.
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Option

Description


View Log Server - Click to see all existing syslog
servers or to add a new server.



Syslog Distribution Methods - The distributed
logs can be in the format of binary or text. If you select
the check box, you will send log messages to different log
servers, which will relieve the pressure of a single log
server. The algorithm can be Round Robin or Src IP
Hash.

URL Log
Option
Enable

Description
Select the check box to enable the URL logging function.


Cache

Log Server

Record Host Name: Select to show the host's
name in the URL log messages.

Select the check box to export URL logs to the cache.


Max Buffer Size - The maximum size of the
cached URL logs. The default value may vary for
different hardware platforms.

Select the check box to export URL logs to a log server.


View Log Server - Click to see all existing syslog
servers or to add a new server.



Syslog Distribution Methods - The distributed
logs can be in the format of binary or text. If you select
the check box, you will send log messages to different log
servers, which will relieve the pressure of a single log
server. The algorithm can be Round Robin or Src IP
Hash.

File Filter Log
Option
Enable

www.fs.com

Description
Select this check box to enable the File Filter logging function.
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Option
Cache

Description
Select the check box to export File Filter logs to cache.


Log Server

Max Buffer Size - The maximum size of the
cached File Filter logs. The default value may vary for
different hardware platforms.

Select the check box to export File Filter logs to log server.


View Log Server - Click to see all existing syslog
servers or to add a new server.



Syslog Distribution Methods - The distributed
logs can be in the format of binary or text. If you select
the check box, you will send log messages to different log
servers, which will relieve the pressure of a single log
server. The algorithm can be Round Robin or Src IP
Hash.

Content Filtering Log
Option

Description

Enable

Select this check box to enable the Content Filter logging
function.

Cache

Select the check box to export Content Filter logs to cache.


Log Server
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Max Buffer Size - The maximum size of the
cached Content Filter logs. The default value may vary
for different hardware platforms.

Select the check box to export Content Filter logs to log server.


View Log Server - Click to see all existing syslog
servers or to add a new server.



Syslog Distribution Methods - The distributed
logs can be in the format of binary or text. If you select
the check box, you will send log messages to different log
servers, which will relieve the pressure of a single log
server. The algorithm can be Round Robin or Src IP
Hash.
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Network Behavior Record Log
Option

Description

Enable

Select this check box to enable the Network Behavior Record
logging function.

Cache

Select the check box to export Network Behavior Record logs to
cache.


Log Server

Max Buffer Size - The maximum size of the
cached Network Behavior Record logs. The default value
may vary from different hardware platforms.

Select the check box to export Network Behavior Record logs to
log server.


View Log Server - Click to see all existing syslog
servers or to add a new server.



Syslog Distribution Methods - The distributed
logs can be in the format of binary or text. If you select
the check box, you will send log messages to different log
servers, which will relieve the pressure of a single log
server. The algorithm can be Round Robin or Src IP
Hash.

Threat Log
Option

Description

Enable

Select this check box to enable the threat logging function.

Cache

Select the check box to export threat logs to the cache.

File



Max buffer size - The maximum size of the
cached threat logs. The default value may vary from
different hardware platforms.



Lowest Severity - Specifies the lowest severity
level. Logs below the severity level selected here will not
be exported.

Select to export threat logs as a file to USB.
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Lowest Severity - Specifies the lowest severity
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Option

Description
level. Logs below the severity level selected here will not
be exported.



Max File Size - Exported log file maximum size.
Save logs to USB - Select a USB device and enter
a name as the log file name.

Terminal

Select to send logs to terminals.

Log Server

Select the check box to export threat logs to log server.

Email address



View Log Server - Click to see all existing syslog
servers or to add a new server.



Syslog Distribution Methods - the distributed logs
can be in the format of binary or text. If you select the
check box, you will send log messages to different log
servers, which will relieve the pressure of a single log
server. The algorithm can be Round Robin or Src IP
Hash.

Select the check box to export logs to the specified email
address.


Viewing Email Address: Click to see or add email
address.

Database
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Select the checkbox to save logs in the local device. Only several
platforms support this parameters.


Disk Space - Enter a number as the percentage
of a storage the logs will take. For example, if you enter
30, the threat logs will take at most 30% of the total disk
size.



Disk Space Limit - If Auto Overwrite is selected,
the logs which exceed the disk space will overwrite the
old logs automatically. If Stop Storing is selected, system
will stop storing new logs when the logs exceed the disk
space.
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Share Access Log
Option

Description

Enable

Select this check box to enable the Share Access logging
function.

Console

Select to export Share Access logs to the console.

Cache

Select the check box to export Share Access logs to the cache.


Log Server

Max buffer size - The maximum size of the
cached Share Access logs.

Select the check box to export Share Access logs to log server.


View Log Server - Click to see all existing syslog
servers or to add a new server.

Log Configuration
You can create log server, set up log email address, and add UNIX servers.

Creating a Log Server
To create a log server, take the following steps:
1.

Select Monitor > Log > Log Configuration.

2.

Click Log Server Configuration tab.

3.

Click New.
In the Log Server Configuration dialog box, configure these values.
Option

Description

Hostname

Enter the name or IP of the log server.

Binding
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Specifies the source IP address to receive logs.


Virtual Router: Select Virtual Router and then
select a virtual router form the drop-down list. If a virtual
router is selected, the device will determine the source IP
address by searching the reachable routes in the virtual
router.



Source Interface: Select Source Interface and then
select a source interface from the drop-down list. The
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Option

Description
device will use the IP address of the interface as the
source IP to send logs to the syslog server. If
management IP address is configured on the interface,
the management IP address will be preferred.

4.

Protocol

Specifies the protocol type of the syslog server. If "Secure-TCP"
is selected, you can select Do not validate the server certificate
option, and system can transfer logs normally and do not need
any certifications.

Port

Specifies the port number of the syslog server.

Log Type

Specifies the log types the syslog server will receive.

Click OK to save the settings.

Notes: You can add at most 3 log servers.

Configuring Log Encoding
The default encoding format for the log information that is output to the log server is utf-8, and the user
can start GBK encoding as needed. After the GBK encoding format is opened, the log encoding format
that is output to the log server will be GBK encoding. To enable the GBK encoding :
1.

Select Monitor > Log > Log Configuration.

2.

Click Log Server Configuration tab.

3.

Click the Log Encoding Configuration button in the upper right corner to open the Log
Encoding Config dialog box.

4.

Select the check box to enable the GBK encoding.

5.

.Click OK to save the settings.

Adding Email Address to Receive Logs
An email in the log management setting is an email address for receiving log messages.
To add an email address, take the following steps:
1.
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Select Monitor > Log > Log Configuration.
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2.

Click Web Mail Configuration tab.

3.

Enter an email address and click Add.

4.

If you want to delete an existing email, click Delete.

Notes: You can add at most 3 email addresses.

Specifying a Unix Server
To specify a Unix server to receive logs, take the following steps:
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1.

Select Monitor > Log > Log Configuration.

2.

Click the Facility Configuration tab.

3.

Select the device you want and the logs will be exported to that Unix server.

4.

Click OK.
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Chapter 13 Diagnostic Tool
This feature may not be available on all platforms. Please check your system's actual page if your device
delivers this feature.
System supports the following diagnostic methods:


Test Tools: DNS Query, Ping and Traceroute can be used when troubleshooting the
network.

Test Tools
DNS Query, Ping and Traceroute can be used when troubleshooting the network.

DNS Query
To check the DNS working status of the device, take the following steps:
1.

Select System > Diagnostic Tool > Test Tools.

2.

Type a domain name into the DNS Query box.

3.

Click Test, and the testing result will be displayed in the list below.

Ping
To check the network connecting status, take the following steps:
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1.

Select System > Diagnostic Tool > Test Tools.

2.

Type an IP address into the Ping box.

3.

Click Test, and the testing result will be displayed in the list below.

4.

The testing result contains two parts:


The Ping packet response. If there is no response from the target after timeout, it
will print Destination Host Not Response, etc. Otherwise, the response contains
sequence of packet, TTL and the response time.



Overall statistics, including number of packet sent, number of packet received,
percentage of no response, the minimum, average and maximum response time.
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Traceroute
Traceroute is used to test and record gateways the packet has traversed from the originating host to the
destination. It is mainly used to check whether the network connection is reachable, and analyze the
broken point of the network. The common Traceroute function is performed as follows: first, send a
packet with TTL 1, so the first hop sends back an ICMP error message to indicate that this packet can
not be sent (because of the TTL timeout); then this packet is re-sent, with TTL 2, TTL timeout is sent
back again; repeat this process till the packet reaches the destination. In this way, each ICMP TTL
timeout source address is recorded. As the result, the path from the originating host to the destination is
identified.
To test and record gateways the packet has traversed by Traceroute, take the following steps:
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1.

Select System > Diagnostic Tool > Test Tools.

2.

Type an IP address into the Traceroute box.

3.

Click Test, and the testing result will be displayed in the list below.
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Chapter 14 High Availability
HA, the abbreviation for High Availability, provides a fail-over solution for communications lines or
device failure to ensure the smooth communication and effectively improve the reliability of the network.
To implement the HA function, you need to configure the two devices as HA clusters, using the
identical hardware platform and firmware version, both enabling Virtual Router and AV functions, with
anti-virus license installed. When one device is not available or can not handle the request from the client
properly, the request will be promptly directed to the other device that works normally, thus ensuring
uninterrupted network communication and greatly improving the reliability of communications.
System supports three HA modes: Active-Passive (A/P), Active-Active (A/A), and Peer.


Active-Passive (A/P) mode: In the HA cluster, configure two devices to form an HA
group, with one device acting as a primary device and the other acting as its backup device. The
primary device is active, forwarding packets, and meanwhile synchronizes all of its network and
configuration information and current session information to the backup device. When the
primary device fails, the backup device will be promoted to primary and takes over its work to
forward packets. This A/P mode is redundant, and features a simple network structure for you
to maintain and manage.



Active-Active (A/A) mode: When the security device is in NAT mode, routing mode or
a combination of both, you can configure two FS devices in the HA cluster as active, so that the
two devices are running their own tasks simultaneously, and monitoring the operation status of
each other. When one device fails, the other will take over the work of the failure device and also
run its own tasks simultaneously to ensure uninterrupted work. This mode is known as the
Active-Active mode. The A/A mode has the advantage of high-performance, as well as loadbalancing.



Peer mode: the Peer mode is a special HA Active-Active mode. In the Peer mode, two
devices are both active, perform their own tasks simultaneously, and monitor the operation
status of each other. When one device fails, the other will take over the work of the failure device
and also run its own tasks simultaneously. In the Peer mode, only the device at the active status
can send/receive packets. The device at the disabled status can make two devices have the same
configuration information but its interfaces do not send/receive any packets. The Peer mode is
more flexible and is suitable for the deployment in the asymmetric routing environment.

HA Active-Active (A/A) and Peer mode may not be available on all platforms. Please check your
system's actual page to see if your device delivers this feature.
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Basic Concepts
HA Cluster
For the external network devices, an HA cluster is a single device which handles network traffic and
provides security services. The HA cluster is identified by its cluster ID. After specifying an HA cluster
ID for the device, the device will be in the HA state to implement HA function.

HA Group
System will select the primary and backup device of the same HA group ID in an HA cluster according
to the HCMP protocol and the HA configuration. The primary device is in the active state and processes
network traffic. When the primary device fails, the backup device will take over its work.
When assigning a cluster ID to the device, the HA group with ID 0 will be automatically created. In
Active-Passive (A/P) mode, the device only has HA group 0. In Active-Active (A/A) mode, the latest
FS version supports two HA groups, i.e., Group 0 and Group 1.

HA Node
To distinguish the HA devices in an HA group, you can use the value of HA Node to mark the devices.
FSOS support the values of 0 and 1.
In the HA Peer mode, the system can decide which device is the master according to the HA Node
value. In the HA group 0, the device whose HA Node value is 0 will be active and the device whose HA
Node value is 1 is at the disabled status. In the HA group 1, this does not make sense because both
times is HA Node value of 0

Virtual Forward Interface and MAC
In the HA environment, each HA group has an interface to forward traffic, which is known as the
Virtual Forward Interface. The primary device of each HA group manages a virtual MAC (VMAC)
address which is corresponding with its interface, and the traffic is forwarded on the interface. Different
HA groups in an HA cluster cannot forward data among each other. VMAC address is defined by HA
base MAC, HA cluster ID, HA group ID and the physical interface index.

HA Selection
In an HA cluster, if the group ID of the HA devices is the same, the one with higher priority will be
selected as the primary device.

HA Synchronization
To ensure the backup device can take over the work of the primary device when it fails, the primary
device will synchronize its information with the backup device. There are three types of information that
www.fs.com
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can be synchronized: configuration information, files and RDO (Runtime Dynamic Object). The specific
content of RDO includes:


Session information (The following types of session information will not be
synchronized: the session to the device itself, tunnel session, deny session, ICMP session, and
the tentative session)



IPsec VPN information



SCVPN information



DNS cache mappings



ARP table



PKI information



DHCP information



MAC table



WebAuth information

System supports two methods to synchronize: real-time synchronization and batch synchronization.
When the primary device has just been selected successfully, the batch synchronization will be used to
synchronize all information of the primary device to the backup device. When the configurations change,
the real-time synchronization will be used to synchronize the changed information to the backup device.
Except for the HA related configurations and local configurations (for example, the host name), all the
other configurations will be synchronized.

Configuring HA
To configure the HA function, take the following steps:
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1.

Configure an HA Virtual Forward Interface. For more information on configuring the
interface, see "Configuring an Interface".

2.

Configure an HA link interface which is used for the device synchronization and HA
packets transmission.

3.

Configure an HA cluster. Specify the ID of HA cluster to enable the HA function.

4.

Configure an HA group. Specify the priority for devices and HA messages parameters.
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You need to configure the HA data link interface when configuring the HA function, and make sure the
HA group interface 0 and interface 1 can be configured as an HA control link interface, but not an HA
data link interface.
To configure HA, take the following steps:
1.

Go to System > HA.
Option

Description

Control link interface Specifies the name of the HA control link interface. The
1
control link interface is used to synchronize all data
between two devices.
Control link interface Specifies the name of HA control link interface (Backup
2
device).
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Data link interface

Specifies the name of the HA data link interface. The data
link interface is used to synchronize the data packet
information. After specifying this data link, the session
information will be synchronized over this data link. You
can configure the physical interface or aggregate interface
as the interface of the data link and you can specify at most
1 HA data link interface.

IP address

Specifies the IP address and netmask of the HA link
interface.

HA cluster ID

Specifies an ID for HA cluster. When the length of prefix
is set to 7 hexadecimal, the ID ranges from 1~128. When
the length of prefix is set to 8 or by default, the ID ranges
from 1~8. None indicates to disable the HA function.

Node ID

After enabling the HA function, specify the Node ID
(HA Node) for the device. The IDs for two devices must
be different. The range is 0 to 1. If you do not specify this
value, the devices will obtain the Node ID by automatic
negotiation.

Peer-mode

Selects the Enable checkbox to enable the HA Peer mode
and specifies the role of this device in the HA cluster. The
range is 0 to 1. By default, the group 0 in the device whose
HA Node ID is 0 will be active and the group 0 in the
device whose HA Node ID is will be in the disabled status.

Symmetric-routing

Select Symmetric-routing to make the device work in the
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Option

Description
symmetrical routing environment.
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HA Synchronize
Configuration

In some exceptional circumstances, the master and backup
configurations may not be synchronized. In such a case
you need to manually synchronize the configuration
information of the master and backup device. Click HA
Synchronize Configuration to synchronize the
configuration information of the master and backup
device.

HA Synchronize
Session

By default the system will synchronize sessions between
HA devices automatically. Session synchronization will
generate some traffic, and will possibly impact device
performance when the device is overloaded. You can
enable automatic HA session synchronization according to
the device workload to assure stability. Click HA
Synchronize Session to enable automatic HA session
synchronization.

New

After specifying the HA cluster ID, the system will create
the HA group 0 automatically. Click New to create the HA
group 1.

Delete

Click Delete to remove HA group 1 if needed.

Priority

Specifies the priority for the device. The device with
higher priority (smaller number) will be selected as the
primary device.

Preempt

Configure the preempt mode. When the preempt mode is
enabled, once the backup device finds that its own priority
is higher than the primary device, it will upgrade itself to
become the primary device and the original primary device
will become the backup device. The value of 0 indicates to
disable the preempt mode. When the preempt mode is
disabled, even if the device's priority is higher than the
primary device, it will not take over the primary device
unless the primary device fails.

Hello interval

Specifies the Hello interval value. The Hello interval refers
to the interval for the HA device to send heartbeats (Hello
packets) to other devices in the HA group. The Hello
interval in the same HA group must be identical.
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2.
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Option

Description

Hello threshold

Specifies the threshold value of the Hello message. If the
device does not receive the specified number of Hello
messages from the other device, it will suppose the other
device's heartbeat stops.

Gratuitous ARP
packet number

Specifies the number of gratuitous ARP packets. When the
backup device is selected as the primary device, it will send
an ARP request packet to the network to inform the
relevant network devices to update its ARP table.

Track object

Specifies the track object you have configured. The track
object is used to monitor the working status of the device.
Once finding the device stop working normally, system will
take the corresponding action.

Description

Type the descriptions of HA group into the box.

Click OK.
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Chapter 15 System Management
The device's maintenance and management include:


"System Information"



"Device Management"



"Configuration File Management"



"SNMP"



"Upgrading System"



"License"



"Mail Server"



"Test Tools"



"VSYS (Virtual System)"

System Information
Users can view the general information of the system in the System Information page, including Serial
Number, Hostname, Platform, System Time, System Uptime, Firmware, Signature Database and so on.

Viewing System Information
To view system information, select System > System Information.
Option

Description

Serial Number Show the serial number of device.
Hostname

Show the name of device.

Platform

Show the platform model of device.

System Time

Show the system date and time of device.

System Uptime Show the system uptime of device.
HA State

Show the HA status of device.
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Standalone: Non-HA mode that represents HA is
disabled.



Init: Initial state.



Hello: Negotiation state that represents the
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Option

Description
device is consulting the relationship between the master
and backup.


Master: Master state that represents the current
device is the master.



Backup: Backup state that represents the current
device is the backup.



Failed: Fault state that represents the device has
failed.

Firmware

Show the current firmware version of the device.

Boot File

Show the current boot file version of the device.

AntiVirus
Signature

Show the current version of the antivirus signature database and
the date of the last update.

IPS Signature

Show the current version of the IPS signature database and the
date of the last update.

URL Category Show the current version of the URL signature database and the
Signature
date of the last update.
Application
Identification
Signature

Show the current version of the application signature database
and the date of the last update.

Notes: The signature is all license controlled, so you need to make sure that your system has installed
that license. Refer to "License" .

Device Management
Introduces how to configure the Administrator, Trust Host, MGT Interface, System Time, NTP Key
and system options.

Administrators
Device administrators of different roles have different privileges. The system supports pre-defined
administrator roles and customized administrator roles. By default, the system supports the following
administrators, which cannot be deleted or edited:

www.fs.com
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admin: Permission for reading, executing and writing. This role has the authority over all
features. You can view the current or historical configuration information.



admin-read-only: Permission for reading and executing. You can view the current or
historical configuration information.



operator: Permission for reading, executing and writing. You have the authority over all
features except modify the Administrator's configuration, view the current or historical
configuration information , but no permission to check the log information.



auditor: You can only operate on the log information, including view, export and clear.

The following table shows the permissions to different types of administrators.
Operation

Administratior

Auditor

Operator

Administratior(re
ad-only)
Configure (including √
saving
configuration)

χ

χ

√

Configure
administrator

√

χ

χ

χ

Restore factory
default

√

χ

χ

χ

Delete configuration √
file

χ

χ

√

Roll back
configuration

√

χ

χ

√

Reboot

√

χ

χ

χ

View configuration √
information

√

χ

√

View log
information

√

√

√

χ

Modify current
admin password

√

√

χ

√

ping/traceroute

√

√

χ

√

Notes:
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The device ships with a default administrator named admin. You can modify the setting
of admin. However, this account cannot be deleted.



Other administrator roles (except default administrator) cannot configure the admin
settings, except modifying its own password.



The system auditor can manage one or more logs, but only the system administrator can
manage the log types.

VSYS Administrator
Administrators in different VSYSs are independent from each other. Administrators in the root VSYS
are known as root administrators and administrators in the non-root VSYS are known as non-root
administrators. The system supports four types of administrator, including Administrators,
Administrator(read-only), Operator, and Auditor.
When creating VSYS administrators, you must follow the rules listed below:


Backslash (\) cannot be used in administrator names.



The non-root administrators are created by root administrators or root operators after
logging into the non-root VSYS.



After logging into the root VSYS, the root administrators can switch to the non-root
VSYS and configure it.



Non-root administrators can enter the corresponding non-root VSYS after a successful
login, but the non-root administrators cannot switch to the root VSYS.



Each administrator name should be unique in the VSYS it belongs to, while
administrator names can be the same in different VSYSs. In such a case, when logging in, you
must specify the VSYS the administrator belongs to in form of vsys_name\admin_name. If no
VSYS is specified, you will enter the root VSYS.

The following table shows the permissions to different types of VSYS administrators.
Operation Root
Root
Root Root Non-root Non-root Non- NonVSYS
VSYS
VSY VSYS VSYS
VSYS
root
root
Administr Administr S
Opera Administr Administr VSYS VSY
atior
atior(read Audit tor
atior
atior(read Operato S
-only)
or
-only)
r
Audi
tor
Configure √
(including
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χ

√

√

χ

√

χ
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Operation Root
Root
Root Root Non-root Non-root Non- NonVSYS
VSYS
VSY VSYS VSYS
VSYS
root
root
Administr Administr S
Opera Administr Administr VSYS VSY
atior
atior(read Audit tor
atior
atior(read Operato S
-only)
or
-only)
r
Audi
tor
saving
configurat
ion)
Configure √
administra
tor

χ

χ

χ

√

χ

χ

χ

Restore
factory
default

√

χ

χ

χ

χ

χ

χ

χ

Delete
√
configurat
ion file

χ

χ

√

√

χ

√

χ

Roll back √
configurat
ion

χ

χ

√

√

χ

√

χ

Reboot

χ

χ

χ

χ

χ

χ

χ

View
√
configurat
ion
informatio
n

√

χ

√

View
informati
on in
current
VSYS

View
informati
on in
current
VSYS

View χ
informa
tion in
current
VSYS

View log √
informatio
n

√

√

χ

√

√

χ

√

Modify
√
current
admin
password

√

√

√

√

√

√

√

ping/trace √
route

√

χ

√

√

√

√

χ
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Creating an Administrator Account
To create an administrator account, take the following steps:
1.

Select System > Device Management > Administrators.

2.

Click New.

3.

In the Configuration dialog box, configure the following.
Configure the following options.
Option

Description

Name

Type a name for the system administrator account.

Role

From the Role drop-down list, select a role for the administrator
account. Different roles have different privileges.

Administrator: Permission for reading, executing
and writing. This role has the authority over all features.

Operator: YThis role has the authority over all
features except modifying the Administrator's
configurations, and has no permission to check the log
information

Auditor: You can only operate on the log
information, including the view, export and clear.

Administrator-read-only: Permission for reading
and executing. You can view the current or historical
configuration information.

Password
Confirm
Password

4.
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Type a login password for the admin into the Password box. The
password should meet the requirements of Password Strategy.
Re-type the password into the Confirm Password box.

Login Type

Select the access method(s) for the admin, including Console,
Telnet, SSH, HTTP and HTTPS. If you need all access methods,
select Select All.

Description

Enter descriptions for the administrator account.

Click OK.
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Admin Roles
Device administrators of different roles have different privileges. The system supports pre-defined
administrator roles and customized administrator roles. The pre-defined administrator role cannot be
deleted or edited. You can customize administrator roles according to your requirements:
To create a new administrator role, take the following steps:
1.

Select System > Device Management > Admin Roles.

2.

Click New.

3.

In the Configuration dialog box, configure the following:
Option
Role
CLI
WebUI

Description
Enter the role name.
Specify the administrator role's privileges of CLI.
Click module name to set the administrator role's privilege.
represents the administrator role does not have privilege of the
specified module, and cannot read and edit the configurations of
the specified module.
represents the administrator role has the read privilege of the
specified module, and cannot edit the configurations.
represents the administrator role can read and edit the
configurations of the specified module.

Description
4.

Specify the description for this administrator role.

Click OK to save the settings.

Trusted Host
The device only allows the trusted host to manage the system to enhance the security. Administrator can
specify an IP range, and hosts in the specified IP range are trusted hosts. Only trusted hosts could access
the management interface to manage the device.
Notes: If the system cannot be managed remotely, check the trusted host configuration.

Creating a Trusted Host
To create a trust host, take the following steps:
1.
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Select System > Device Management > Trusted Host.
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2.

Click New.

3.

In the Trusted Host Configuration dialog box, configure these values.
Configure the following options.
Option

Description

Type

Specifies the type of host. You can select IP/Netmask or IP
Range.

Login Type

4.



IP/Netmask: Type the IP address and netmask
into the IP box respectively.



IP Range: Type the start IP and end IP into the
IP box respectively.

Select the access methods for the trust host, including Telnet,
SSH, HTTP and HTTPS.

Click OK.

Management Interface
The device supports the following access methods: Console, Telnet, SSH and WebUI. You can
configure the timeout value, port number, PKI trust domain of HTTPS,and PKI trust domain of
certificate authentication. When accessing the device through Telnet, SSH, HTTP or HTTPS, if login
fails three times in one minute, the IP address that attempts the login will be blocked for 2 minutes
during which the IP address cannot connect to the device.
To configure the access methods:
1.

Select System > Device Management > Management Interface.

2.

In the Management Interface tab, configure these values.
Configure the following options.
Option

Description

Console

Configure the Console access method parameters.
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Timeout: Type the Console timeout value into the
Timeout box. The value range is 0 to 60. The default
value is 10. The value of 0 indicates never timeout. If
there is no activity until the timeout, system will drop the
console connection.
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Option

Description

Telnet

Configure the Telnet access method parameters.

SSH

Web

www.fs.com



Timeout: Specifies the Telnet timeout value. The
value range is 1 to 60. The default value is 10.



Port: Specifies the Telnet port number. The value
range is 1 to 65535. The default value is 23.

Configure the SSH access method parameters.


Timeout: Specifies the SSH timeout value. The
value range is 1 to 60. The default value is 10.



Port: Specifies the SSH port number. The value
range is 1 to 65535. The default value is 22.

Configure the WebUI access method parameters.


Multiple Login with Same Account: Select the
check box and users are allowed to log in to devices with
the same account simultaneously. By default, the function
is disabled. In the default situation, when a same account
is used to log in again, the previous login account will be
kicked out.



Timeout: Specifies the WebUI timeout value. The
value range is 1 to 1440. The default value is 10.



HTTP Port: Specifies the HTTP port number.
The value range is 1 to 65535. The default value is 80.



HTTPS Port: Specifies the HTTPS port number.
The value range is 1 to 65535. The default value is 443.



HTTPS Trust Domain: Select the trust domain
existing in the system from the drop-down list. When
HTTPS starts, HTTPS server will use the certificate with
the specified trusted domain. By default, the trust domain
trust_domain_default will be used.



Certificate Authentication: With this checkbox
selected, system will start the certificat authentication.
The certificate includes the digital certificate of users and
secondary CA certificate signed by the root
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Option

Description
CA.Certificate authentication is one of two-factor
authentication. The two-factor authentication does not
only need the user's name and password authentication,
but also needs other authentication methods, like a
certificate or fingerprint.

3.



Certificate Trust Domain: After enabling the
certificate authentication and logging into the device over
HTTPS, HTTPS server will use the certificate with the
specified trusted domain.Make sure that root CA
certificate is imported into it.



CN Check：After the CN check is enabled, the
name of the root CA certificate is checked and verified
when the user logs in. Only the certificate and the user
can be consistent, and the login succeeds.

Click OK.

Notes: When changing HTTP port, HTTPS port or HTTPS Trust Domain, the web server will
restart. You may need to log in again if you are using the Web interface.

System Time
You can configure the current system time manually, or synchronize the system time with the NTP
server time via NTP protocol.

Configuring the System Time Manually
To configure the system time manually, take the following steps:
1.

Select System > Device Management > System Time.

2.

Under System Time Configuration in the System Time tab, configure the following.
Option

Description

Sync with
Local PC

Specifies the method of synchronize with local PC. You can
select Sync Time or Sync Zone&Time.



www.fs.com

Sync Time: Synchronize the system time with
local PC.
Sync Zone&Time: Synchronize the system
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Option

Description
zone&time with local PC.

Specified the
system time.

3.

Configure parameter of system time.


Time Zone: Select the time zone from the dropdown list.



Date: Specifies the date.



Time: Specifies the time.

Click OK.

Configuring NTP
The system time may affect the establishment time of VPN tunnel and the schedule, so the accuracy of
the system time is very important. To ensure the system is able to maintain an accurate time, the device
allows you to synchronize the system time with a NTP server on the network via NTP protocol.
To configure NTP:
1.

Select System > Device Management > System Time.

2.

Under NTP Configuration in the System Time tab, configure the following.
Option

Description

Enable

Select the Enable check box to enable the NTP function. By
default, the NTP function is disabled.

Authentication

Select the Authentication check box to enable the NTP
Authentication function.

Server

Specifies the NTP server that device need to synchronize
with. You can specify at most 3 servers.



Key: Select a key from the Key drop-down
list. If you enable the NTP Authentication function,
you must specify a key.



Virtual Router: Select the Virtual Router of
interface for NTP communication from the dropdown list.
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IP: Type IP address of the server .

Source interface: Select an interface for
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Option

Description
sending and receiving NTP packets.


3.

Specify as a preferred server: Click Specify as
a preferred server to set the server as the first
preferred server. The system will synchronizate with
the first preferred server.

Sync Interval

Type the interval value. The device will synchronize the
system time with the NTP server at the interval you
specified to ensure the system time is accurate.

Time Offset

Type the time value. If the time difference between the
system time and the NTP server's time is within the max
adjustment value you specified, the synchronization will
succeed, otherwise it will fail.

Click OK.

NTP Key
After enabling NTP Authentication function, you need to configure MD5 key ID and keys. The device
will only synchronize with the authorized servers.

Creating a NTP Key
To create an NTP key:
1.

Select System > Device Management > NTP Key.

2.

Click NEW.

3.

In the NTP Key Configuration dialog box, configure these values.
Configure the following options.

4.
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Option

Description

Key ID

Type the ID number into the Key ID box. The value range is 1
to 65535.

Password

Type a MD5 key into the Password box. The value range is 1 to
31.

Confirm
Password

Re-type the same MD5 key you have entered into the Confirm
box.

Click OK.
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Option
Specifies system options, including system language, administrator authentication server, host name,
password strategy, reboot and exporting the system debugging information.
To change system option, take the following steps:
1.

Select System > Device Management > Option

2.

Configure the following.
Option

Description

System
Maintenance

Configure the system language and administrator
authentication server.

Host
Configuration



System Language: You can select Chinese or
English according to your own requirements.



Administrator Authentication Server: Select a
server to authenticate the administrator from the
drop-down list.

In some situation, more than one devices are installed within
a network. To distinguish among these devices, different
names should be assigned to different devices. The default
host name is assigned according to the model.


Hostname: Type a host name you want to
change into the Hostname box.



Domain: Type a domain name you want to
specify into the Domain box.

Password Strategy Configure password complexity for admin user.


Minimum Password Length: Specifies the
minimum length of password. The value range is 4 to
16 characters. The default value is 4.



Password Complexity: Unlimited means no
restriction on the selection of password
characters.You can select Set Password Complexity to
enable password complexity checking and configure
password complexity.


www.fs.com

Capital letters length：The default
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Option

Description
value is 2 and the range is 0 to 16.

3.



Small letters length：The default
value is 2 and the range is 0 to 16.



Number letters length：The default
value is 2 and the range is 0 to 16.



Special letters Length：The default
value is 2 and the range is 0 to 16.



Validity Period：The unit is day.The
range is 0 to 365.The default value is 0, which
indicates that there is no restriction on validity
period of the password.

Click OK.

Rebooting the System
Some operations like license installation or image upgrading will require the system to reboot before it
can take effect.
To reboot a system, take the following steps:
1.

Go to System > Device Management > Option .

2.

Click Reboot, and select Yes in the prompt.

3.

The system will reboot. You need to wait a while before it can start again.

System Debug
System debug is supported for you to check and analyze the problems.

Failure Feedback
To enable the failure feedback function, take the following steps:
1.
2.

www.fs.com

Select System > Device Management> Option.
In the System Tools dialog box, select the Enable check box for Failure feedback, and
then system will automatically send the technical support file to the manufacturer.

547

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

System Debug Information
System debugging helps you to diagnose and identify system errors by the exported file.
To export the system debugging information, take the following steps:
1.
2.

Select System > Device Management> Option.
Click Export, system will pack the file in /etc/local/core and prompt to save techsupport file. After selecting the saved location and click OK, you can export the file
successfully.

Configuration File Management
System configuration information is stored in the configuration file, and it is stored and displayed in the
format of command line. The information that is used to initialize the FS device in the configuration file
is known as the initial configuration information. If the initial configuration information is not found,
the FS device will use the default parameters for the initialization. The information being taking effect is
known as the current configuration information.
System initial configuration information includes current initial configuration information (used when
the system starts) and backup initial configuration information. System records the latest ten saved
configuration information, and the most recently saved configuration information for the system will be
recorded as the current initial configuration information. The current configuration information is
marked as Startup; the previous nine configuration information is marked with number from 0 to 8, in
the order of save time.
You can not only export or delete the saved configuration files, but also export the current system
configurations.

Managing Configuration File
This feature may vary slightly on different platforms. If there is a conflict between this guide and the
actual page, the latter shall prevail.
To manage the system configuration files, take the following steps:

www.fs.com

1.

Select System > Configuration File Management > Configuration File List.

2.

In the Configuration File List page, configure the following.


Export: Select the configuration file you want to export, and click Export.



Delete: Select the configuration file you want to delete, and click Delete.
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Backup Restore: You can restore the system configurations to the saved
configuration file or factory default, or you can backup the current configurations.

Option

Description

Back up Current
Configurations

Type descriptions for the configuration file into
Description box. Click Start to backup.

Restore Configuration

Roll back to Saved Configurations:


Select Backup System Configuration File:
Click this button, then select Backup
Configuration File from the list. Click OK.



Upload Configuration File: Click this
button. In the Importing Configuration File
dialog box, click Browse and choose a local
configuration file you need in your PC. If you
need to make the configuration file take effect,
select the check box. Click OK.

Restore to Factory Defaults:


Click Restore, in the Restore to Factory
Defaults dialog box, click OK.

Notes: Device will be restored to factory defaults. Meanwhile, all the system
configurations will be cleared, including backup system configuration files.

www.fs.com



Export All Vsys Configuration: Click Export All Vsys Configuration to export
the current configuration file of VSYS.



Import All Vsys Configuration: Click Import All Vsys Configuration to import
the saved configuration file of VSYS.
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Option

Description

File Name

Click Browse to select the configuration file needed to be
imported. The file type can be GZ and ZIP.

Reboot to make the
configuration file
take effect

After importing the configuration file, you need to reboot
the device to make the configuration file take effect. Select
the Reboot to make the configuration file take effect
checkbox and click OK to reboot the device immediately.

Viewing the Current Configuration
To view the current configuration file:
1.

Select System > Configuration File Management > Current Configurations.

2.

Click Export to export the current configuration file.

SNMP
The device is designed with a SNMP Agent, which can receive the operation request from the Network
Management System and give the corresponding information of the network and the device.
The device supports SNMPv1 protocol, SNMPv2 protocol and SNMPv3 protocol. SNMPv1 protocol
and SNMPv2 protocol use community-based authentication to limit the Network Management System
to get device information. SNMPv3 protocol introduces an user-based security module for information
security and a view-based access control module for access control.
The device supports all relevant Management Information Base II (MIB II) groups defined in RFC-1213
and the Interfaces Group MIB (IF-MIB) using SMIv2 defined in RFC-2233. Besides, the system offers a
private MIB, which contains the system information, IPSec VPN information and statistics information
of the device. You can use the private MIB by loading it into an SNMP MIB browser on the
management host.

www.fs.com

550

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

SNMP Agent
The device is designed with a SNMP Agent, which provides network management and monitors the
running status of the network and devices by viewing statistics and receiving notification of important
system events.
To configure an SNMP Agent, take the following steps:
1.

Select System > SNMP > SNMP Agent.

2.

In the SNMP Agent page, configure these values.
Option

Description

SNMP Agent

Select the Enable check box for Service to enable the SNMP
Agent function.

ObjectID

The Object ID displays the SNMP object ID of the system. The
object ID is specific to an individual system and cannot be
modified.

System
Contact

Type the SNMP system contact information of the device into
the System Contact box. System contact is a management
variable of the group system in MIB II and it contains the ID and
contact of relevant administrator of the managed device. By
configuring this parameter, you can save the important
information to the device for the possible use in case of
emergency.

Location

Type the location of the device into the Location box.

Host Port

Type the port number of the managed device into the Host Port
box.

Virtual Router Select the VRouter from the Virtual Router drop-down list.
Local
EnginelID
3.

Type the SNMP engine ID into the Local EngineID box.

Click Apply.

Notes: SNMP Engine ID identifies an engine uniquely. SNMP Engine is an important component of
the SNMP entity (Network Management System or managed network device) which implements the
functions like the reception/sending and verification of SNMP messages, PDU abstraction,
encapsulation, and communications with SNMP applications.

www.fs.com
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SNMP Host
To create an SNMP host, take the following steps:
1.

Select System > SNMP > SNMP Host.

2.

Click New.

3.

In the SNMP Agent dialog box, configure these values.
Option

Description

Type

Select the SNMP host type from the Type drop-down list. You
can select IP Address, IP Range or IP/Netmask.

IP Address: Type the IP address for SNMP host
into Hostname box.

IP Range: Type the start IP and end IP into the
Hostname box respectively.

IP/Netmask: Type the start IP address and
Netmask for SNMP host into the Hostname box
respectively.

SNMP Version Select the SNMP version from the SNMP Version drop-down
list.
Community

Type the community for the SNMP host into the Community
box. Community is a password sent in clear text between the
manager and the agent. This option is only effective if the SNMP
version is V1 or V2C.

Permission

Select the read and write permission for the community from
the Permission drop-down list. This option is only effective if
the SNMP version is V1 or V2C.

RO: Stand for read-only, the read-only
community is only allowed to read the MIB information.

RW: Stand for read-write, the read-write
community is allowed to read and modify the MIB
information.

4.
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Click OK.
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Trap Host
To create a Trap host, take the following steps:
1.

Select System > SNMP > Trap Host.

2.

Click New.

3.

In the Trap Host Configuration dialog box, configure these values.
Option

Description

Host

Type the domain name or IP address of the Trap host into the
Host box.

Trap Host Port Type the port number for the Trap host into the Trap Host Port
box.
SNMP Agent

4.

Select the SNMP version from the SNMP Agent drop-down list.


V1 or V2C: Type the community for the Trap
host into the Community box.



V3: Select the V3 user from the V3 User dropdown list. Type the Engine ID for the trap host into the
Engine ID box.

Click OK.

V3 User Group
SNMPv3 protocol introduces a user-based security module. You need to create an SNMP V3 user group
for the SNMP host if the SNMP version is V3.
To create a V3 user group:
1.

Select System > SNMP > V3 User Group.

2.

Click New.

3.

In the V3 Group Configuration dialog box, enter values.
Option

Description

Name

Type the SNMP V3 user group name into the Name box.

Security Model The Security model option displays the security model for the
SNMP V3 user group.
Security Level
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Select the security level for the user group from the Security
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Option

Description
Level drop-down list.
Security level determines the security mechanism used in
processing an SNMP packet. Security levels for V3 user groups
include No Authentication (no authentication and encryption),
Authentication (authentication algorithm based on MD5 or SHA)
and Authentication and Encryption (authentication algorithm
based on MD5 or SHA and message encryption based on AES
and DES).

4.

Read View

Select the read-only MIB view name for the user group from the
Read View drop-down list. If this parameter is not specified, all
MIB views will be none.

Write View

Select the write MIB view name for the user group from the
Write View drop-down list. If this parameter is not specified, all
MIB views will be none.

Click OK.

V3 User
If the selected SNMP version is V3, you need to create an SNMP V3 user group for the SNMP host and
then add users to the user group.
To create a user for an existing V3 user group, take the following steps:
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1.

Select System > SNMP > V3 User.

2.

Click New.

3.

In the V3 User Configuration dialog box, configure these values.
Option

Description

Name

Type the SNMP V3 user name into the Name box.

V3 User Group

Select an existing user group for the user from the Group
drop-down list.

Security Model

The Security model option displays the security model for
the SNMP V3 user.

Remote IP

Type the IP address of the remote management host into
the Remote IP box.

Authentication

Select the authentication protocol from the Authentication
drop-down list. By default, this parameter is None, i.e., no
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Option

Description
authentication.

Authentication
Password

Type the authentication password into the Authentication
password box.

Confirm Password Re-type the authentication password into the Confirm
Password box to confirm.
Encryption

Select the encryption protocol from the Encryption dropdown list.

Encryption
Password

Type the encryption password into the Encryption
Password box.

Confirm Password Re-type the encryption password into the Confirm Password
box to confirm.
4.

Click OK.

SNMP Server
You can configure the SNMP server to get the ARP information through the SNMP protocol.

Creating an SNMP Server
To create an SNMP server, take the following steps:
1.

Select System > SNMP server.

2.

Click New.

In the SNMP Server Configuration dialog box, configure these values
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Option

Description

Server IP

Type the SNMP server IP address into the Server IP
box.

Port

Type the port number for the SNMP server into the
Port box. The value range is 1 to 65535, the default
value is 161.

Community

Type the community for the SNMP server into the
Community box. This option is only effective if the
SNMP version is V1 or V2C.

Virtual Router

Select the VRouter from the drop-down list.
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3.

Option

Description

Source Interface

Select the source interface from the drop-down list for
receiving ARP information on the SNMP server.

Interval Time

Type the the interval into the Interval Time box for
receiving ARP information on the SNMP server. The
value range is 5 to 1800 seconds, the default value is 60
seconds.

Click OK.

Upgrading System
The firmware upgrade wizard helps you:


Upgrade system to a new version or roll back system to a previous version.



Update the Signature Database.

Upgrading Firmware
To upgrade firmware, take the following steps:
1.

Select System > Upgrade Management > Upgrade Firmware.

2.

In the Upgrade Firmware tab box, configure the following.
Upgrade Firmware
Backup
Make sure you have backed up the configuration file before
Configuration File upgrading. Click Backup Configuration File to backup the
current firmware file and the system will automatically redirect
the Configuration File Management page after the backup.
Current Version

The current firmware version.

Upload Firmware Click Browse to select a firmware file from your local disk.
Backup Image

The backup firmware version.

Reboot

Select the Reboot now to make the new firmware take effect
check box and click Apply to reboot system and make the
firmware take effect. If you click Apply without selecting the
check box, the firmware will take effect after the next startup.

Choose a Firmware for the next startup
Select the
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Select the firmware that will take effect for the next startup.
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Upgrade Firmware
firmware that will
take effect for the
next startup.
Reboot

Select the Reboot now to make the new firmware take effect
check box and click Apply to reboot system and make the
firmware take effect. If you click Apply without selecting the
check box, the firmware will take effect after the next startup.

Updating Signature Database
To update signature database, take the following steps:
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1.

Select System > Upgrade Management > Signature Database Update.

2.

In the Signature Database Update tab box, configure the following.
Option

Description

Current
Version

Show the current version number.

Remote
Update

Application signature database, URL signature database, Share
Access Signature Database Update, Antivirus signature database,
IPS signature database .


Update Now: Click Update to update the
signature database right now.



Auto Update: Select Enable Auto Update and
specify the auto update time. Click Save to save your
changes.



Configure Update Server: By default the system
updates the signature database everyday automatically.
You can change the update configuration as needed. FS
devices provide two default update servers:
https://Update1.fw1.fs.com and
https://Update2.fw2.fs.com. You can customize the
servers according to your need. In the pop-up Auto
Update Settings dialog box, specify the server IP or
domain name and Virtual Router.
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Option

Description


Local Update

Configure Proxy Server: When the device
accesses the Internet through a HTTP proxy server, you
need to specify the IP address and the port number of the
HTTP proxy server. With the HTTP proxy server
specified, various signature database can update normally.
Click Configure Proxy Server, then enter the IP addresses
and ports of the main proxy server and the backup proxy
server.

Click Browse and select the signature file in your local PC, and
then click Upload.

License
Licenses are used to authorize the users' features, authorize the users' services, or extend the
performance. If you do not buy and install the corresponding license, the features, services, and
performance which is based on the license will not be used or cannot be achieved.
License classes and rules.
Platform
License

Description

Valid Time

Platform Trial

Platform license is the basis of the
other licenses operation. If the platform
license is invalid, the other licenses are
not effective. The device have been preinstalled platform trial license for 15
days in the factory.

You cannot modify the
existing configuration
when License expires.
The system will restore
to factory defaults
when the device reboot.

Platform Base

You can install the platform base
System cannot upgrade
license after the device formal sale. The the OS version when
license provide basic firewall and VPN the license expires, but
function.
the system could still
work normally.

Function
License

Description

Valid Time

VSYS

Authorizing the available number of
VSYS.

Permanent

www.fs.com
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SSL VPN

Authorizing the maximum number of Permanent
SSL VPN access. Through installing
multiple SSL VPN licenses, you can add
the maximum number of SSL VPN
access.

QoS

Enable iQoS function.

System cannot upgrade
the iQoS function and
cannot provide the
maintenance service
when License expired.

Service License Description

Valid Time

AntiVirus

Providing antivirus function and
antivirus signature database update.

System cannot update
the antiviru signature
database when the
license expires, but the
antivirus function could
still be used normally.

URL

Providing URL database and URL
signature database update.

System cannot provide
the search URL
database online
function when the
license expires, but the
user-defined URL and
URL filtering function
can be used normally.

IPS

Providing IPS function and IPS
signature database update.

System cannot update
the IPS signature
database when the
license expires, but the
IPS function could still
be used normally.

APP signature

APP signature license is issued with
>System cannot
platform license, you do not need to
update the APP
apply alone. The valid time of license is signature database
same as platform license.
when the license
expires, but the
included functions and
rules could still be used

www.fs.com
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normally.

Viewing License List
Select System > License to enter the License List page. All licenses the system supports will be displayed
in this page, including the authorized licenses and unauthorized licenses.
If there is license that is about to expire (the remaining valid period is within 30 days) or has expired:


When you log into the device, the License Expiration Information dialog box will pop up,
which prompts for licenses that are about to expire or have expired. Check the Don't remind me
again checkbox so that the dialog box will never prompt again when you login. Click the Update
Now button to jump to the License List page.



The notification icon with the number of notifications is displayed in the upper-right
corner. Hover your mouse over the icon, and click Details after the License Expiration
Information, the License Expiration Information dialog will pop up.

Applying for a License
Before you apply for a license, you have to generate a license request first.
1.

Under License Request, input user information. All fields are required.

2.

Click Generate, and then appears a bunch of code.

3.

Send the code to your sales contact. The sales person will issue the license and send the
code back to you.

Installing a License
After obtaining the license, you must install it to the device.
To install a license, take the following steps:
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1.

Select System > License .

2.

Under License installation in the License page, configure options below.
Option

Description

Upload

Select Upload License File. Click Browse to select the license file,
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Option

Description

License File

using the TXT format, and then click OK to upload it.

Manual Input

Select Manual Input. Type the license string into the box.

3.

Click OK.

4.

Go to System > Device Management, and click the Option tab.

5.

Click Reboot, and select Yes in the prompt.

6.

System will reboot. When it starts again, installed license(s) will take effect.

Mail Server
By configuring the SMTP server in the Mail Server page, the system can send the log messages to the
specified email address.

Creating a Mail Server
To create a mail server, take the following steps:
1.

Select System > Mail Server.

2.

In the SMTP Server Configuration page, configure these values.
Option

Description

Name

Type a name for the SMTP server into the box.

Server

Type Domain name or IP address for the SMTP server into the
box.

Virtual Router From the Virtual Router drop-down list, select the Virtual
Router for the SMTP server.

3.

Verification

Select the Enable check box for SMTP verification to enable it if
needed. Type the username and its password into the
corresponding boxes.

Email

Type the email address that sends log messages.

Click Apply.

VSYS (Virtual System)
This feature may vary slightly on different platforms. If there is a conflict between this guide and the
actual page, the latter shall prevail.
www.fs.com

561

NSG SERIES FIREWALLS WEBUI CONFIGURATION GUIDE

VSYS (Virtual System) is logically divides the physical firewall into several virtual firewalls. Each virtual
firewall can work independently as a physical device with its own system resources, and it provides most
firewall features. A VSYS is separated from other VSYS, and by default, they cannot directly
communicate with each other.
VSYS has the following characteristics:


Each VSYS has its own administrator;



Each VSYS has an its own virtual router, zone, address book and service book;



Each VSYS can have its own physical or logical interfaces;



Each VSYS has its own security policies.

Notes: The maximum VSYS number is determined by the platform capacity and license. You can
expand VSYS maximum number by purchasing addition licenses.

VSYS Objects
This section describes VSYS objects, including root VSYS, non-root VSYS, administrator, VRouter,
VSwitch, zone, and interface.

Root VSYS and Non-root VSYS
System contains only one root VSYS which cannot be deleted. You can create or delete non-root VSYSs
after installing a VSYS license and rebooting the device. When creating or deleting non-root VSYSs, you
must follow the rules listed below:


When creating or deleting non-root VSYSs through CLI, you must be under the root
VSYS configuration mode.



Only the root VSYS administrators and root VSYS operators can create or delete nonroot VSYS. For more information about administrator permissions, see "Device Management" .



When creating a non-root VSYS, the following corresponding objects will be created
simultaneously:


A non-root VSYS administrator named admin. The password is vsys_nameadmin.



A VRouter named vsys_name-vr.



A L3 zone named vsys_name-trust.

For example, when creating the non-root VSYS named vsys1, the following objects will be
created:
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The RXW administrator named admin with the password vsys1-admin.



The default VRouter named vsys1-vr.



The L3 zone named vsys1-trust and it is bound to vsys1-vr automatically.



When deleting a non-root VSYS, all the objects and logs in the VSYS will be deleted
simultaneously.



The root VSYS contains a default VSwitch named VSwitch1, but there is no default
VSwitch in a newly created non-root VSYS. Therefore, before creating l2 zones in a non-root
VSYS, a VSwitch must be created. The first VSwitch created in a non-root VSYS will be
considered as the default VSwitch, and the l2 zone created in the non-root VSYS will be bound
to the default VSwitch automatically.

VRouter, VSwitch, Zone and Interface
VRouter, VSwitch, zone, and interface in VSYS have two properties which are shared and dedicated.
Objects with dedicated property are dedicated objects, while doing specific operations to the object with
the shared property will make it a shared object. The dedicated object and shared object have the
following characters:


Dedicated object: A dedicated object belongs to a certain VSYS, and cannot be
referenced by other VSYSs. Both root VSYS and non-root VSYS can contain dedicated objects.



Shared object: A shared object can be shared by multiple VSYSs. A shared object can
only belong to the root VSYS and can only be configured in the root VSYS. A non-root VSYS
can reference the shared object, but cannot configure them. The name of the shared object must
be unique in the whole system.

The figure below shows the reference relationship among dedicated and shared VRouter, VSwitch, zone,
and interface.

As shown in the figure above, there are three VSYSs in FSOS: Root VSYS, VSYS-A, and VSYS B.
Root VSYS contains shared objects (including Shared VRouter, Shared VSwitch, Shared L3-zone,
Shared L2-zone, Shared IF1, and Shared IF2) and dedicated objects.
VSYS-A and VSYS-B only contain dedicated objects. The dedicated objects VSYS-A and VSYS-B can
reference the shared objects in Root VSYS. For example, A-zone2 in VSYS-A is bound to the shared
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object Shared VRouter in Root VSYS, and B-IF3 in VSYS-B is bound to the shared object Shared L2zone in Root VSYS.

Shared VRouter
A shared VRouter contains the shared and dedicated L3 zones of the root VSYS. Bind a L3 zone to a
shared VRouter and configure this L3 zone to have the shared property. Then this zone becomes a
shared zone.

Shared VSwitch
A shared VSwitch contains the shared and dedicated L2 zones of the root VSYS. Bind a L2 zone to a
shared VSwitch and configure this L2 zone to have the shared property. Then this zone becomes a
shared zone.

Shared Zone
The shared zones consist of L2 shared zones and L3 shared zones. After binding the L2 zone with the
shared property to a shared VSwitch, it becomes a shared L2 zone; after binding the L3 zone with shared
property to a shared VRouter, it becomes a shared L3 zone. A shared zone can contain interfaces in
both root VSYS and non-root VSYS. All function zones cannot be shared.

Shared Interface
After binding an interface in the root VSYS to a shared zone, it becomes a shared interface automatically.

Interface Configuration
Only RXW administrator in the root VSYS can create or delete interfaces. Configurations to an interface
and its sub-interfaces must be performed in the same VSYS.
Notes: Only adminitrator has the authority ot delete or create interfaces. If you are about to delete an
interface and its-subinterfaces, you have to do it under the same VSYS.

Creating Non-root VSYS
To create a new non-root VSYS, take the following steps:
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1.

Select System > VSYS > VSYS.

2.

Click New to add a non-root VSYS.

3.

In the prompt, configure these values.
Option

Description

Name

Enter a name for the non-root VSYS.
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Option

Description

Interface
Binding

Select a physical or a logical interface. In VSYS, a physical
interface can have its sub-interfaces, but logical interfaces cannot.

Physically Import: Select the interface you want,
and click Physically Import to add it to the right pane.

Logically Allocate: Select the interface you want,
and click Logically Allocate to add it to the right pane.

Release: Select the added interface(s), and click
Release to delete it.

Quota
4.

Select an existing quota.

Click OK to save configuration. The new VSYS will be seen in the VSYS list.

Configuring Dedicated and Shared Objects for Non-root VSYS
VRouter, VSwitch, zone, and interface in VSYS have two properties which are shared and dedicated.
Objects with dedicated property are dedicated objects, while doing specific operations to the object with
the shared property will make it a shared object. The dedicated object and shared object have the
following characters:


Dedicated object: A dedicated object belongs to a certain VSYS, and cannot be
referenced by other VSYSs. Both root VSYS and non-root VSYS can contain dedicated objects.



Shared object: A shared object can be shared by multiple VSYSs. A shared object can
only belong to the root VSYS and can only be configured in the root VSYS. A non-root VSYS
can reference the shared object, but cannot configure them. The name of the shared object must
be unique in the whole system.

To configure VSYS shared object, take the following steps:

www.fs.com

1.

Select System > VSYS > VSYS.

2.

Click Share Resource.

3.

In the prompt, configure these values for VSwitch, VRouter and Zone.
Option

Description

VSwitch

In the VSwtich tab, select a Vswitch and click Share to set it as a
shared object; to make a VSwitch as a dedicated object, click Do
Not Share.
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4.

Option

Description

Virtual Router

In the Virtual Router tab, select a Vswitch and click Share to set
it as a shared object; to make a Virtual Router as a dedicated
object, click Do Not Share.

Zone

In the Zone tab, select a Zone and click Share to set it as a
shared object; to make a Zone as a dedicated object, click Do
Not Share.

Click Close to exit.

Configuring VSYS Quota
VSYSs work independently in functions but share system resources including concurrent sessions, zone
number, policy rule number, SNAT rule number, DNAT rule number, session limit rules number,
memory buffer, URL resources , IPS resources and SCVPN users’ number. You can specify the
reserved quota and maximum quota for each type of system resource in a VSYS by creating a VSYS
profile. Reserved quota refers to the resource number reserved for the VSYS; maximum quota refers to
the maximum resource number available to the VSYS. The root administrator have the permission to
create VSYS quota. The total for each resource of all VSYSs cannot exceed the system capacity.
To define a quota for VSYS, take the following steps:
1.

Select System > VSYS > Quota.

2.

Click New .

3.

In the prompt, configure these values.
Option

Description

Basic Configuration
Name

Enter a name for the new quota.

CPU

Specify values for parameters of CPU.

Limit: Specifies the maximum performance limit
for processing 1 Mbps packets.

Reserve: A dedicated reservered value for CPU in
this VSYS. The value range is 0 to 20000.

Alarm Threshold: Specifies a percentage value for
alarms. When the CPU usage reaches this value, the
system will generate alarm logs.
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Option

Description

Basic Configuration
System Resources
System
Resources

Specify the maximum quota and reserved quota of system
resources.

Sessions: Specifies the maximum and reserved
number for sessions in the VSYS.

Zone: Specifies the maximum and reserved
number for zones in the VSYS.

Policy rules: Specifies the maximum and reserved
number for policy rules in the VSYS.

Policy Groups: Specifies the maximum and
reserved number for policy groups in the VSYS.

SNAT rules: Specifies the maximum and
reserved number for SNAT rules in the VSYS.

DNAT rules: Specifies the maximum and
reserved number for SNAT rules in the VSYS.

Stat-set (session): Specifies the maximum and
reserved number for sessions of a staticstic set in the
VSYS.

Stat-set (others): Specifies the maximum and
reserved number for other items than sessions of a
staticstic set in the VSYS.

IPSec: Specifies the maximum and reserved
number for IPSec tunnels in the VSYS.

SCVPN users: Specifies the maximum and
reserved number for SCVPN users.

Session Limit Rules: Specifies the maximum and
reserved number for session limit rules in the VSYS.

Keyword Categories: Specifies the maximum and
reserved number for keyword categories in the VSYS.
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URL Regex Keywords: Specifies the maximum
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Option

Description

Basic Configuration
and reserved number for regular expression keywords in
a URL category in the VSYS.

Keyword: Specifies the maximum and reserved
number for simple keywords in a URL category in the
VSYS.

IQoS: Select the Enable check box to enable the
QoS function and specifies the maximum and reserved
number for root-pipe in the VSYS.
Protection
URL Resources Specify the maximum quota and reserved quota of URL
resources.

URL: Select the Enable check box to enable the
URL filter function.

URL Profiles: Specifies the maximum and
reserved number for URL filter profiles in a VSYS.

URL Categories: Specifies the maximum and
reserved number for user-defined URL categories in a
VSYS.

URL: Specifies the maximum and reserved
number for URLs in a VSYS.
IPS Resources

Specify the maximum quota and reserved quota of IPS
resources.

IPS: Select the Enable check box to enable the
IPS function.

IPS Profiles: Specifies the maximum and reserved
number for IPS profiles in a VSYS. You can create one
IPS Profile at most in non-root VSYS, i.e., the range of
maximum quota varies from 0 to 1. The default value of
maximum quota and reserved quota is 0, which means
only predefined IPS Profiles can be used in non-root
VSYS.
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Option

Description

Basic Configuration
Log Configuration
Log
Specify the maximum quota and reserved quota of memory
Configuration buffer for each type of log in a VSYS. The reserved quota should
not exceed the maximum quota. If the logs' capacity in a VSYS
exceeds its maximum quota, the new logs will override the
earliest logs in the buffer.

Config Logs: Specify the maximum and reserved
value of buffer for configuration logs in a VSYS.

Event Logs: Specify the maximum and reserved
value of buffer for event logs in a VSYS.

Network Logs: Specify the maximum and
reserved value of buffer for network logs in a VSYS.

Threat Logs: Specify the maximum and reserved
value of buffer for threat logs in a VSYS.

Session Logs: Specify the maximum and reserved
value of buffer for session logs in a VSYS.

NAT Logs: Specify the maximum and reserved
value of buffer for NAT logs in a VSYS.

Web Surfing: Specify the maximum and reserved
value of buffer for websurf logs in a VSYS.

PBR: Surfing: Specify the maximum and reserved
value of buffer for PBR logs in a VSYS.
4.

Click OK to save settings. The new VSYS quota will be shown in the list.



Up to 128 VSYS quotas are supported.

Notes:
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The default VSYS profile of the root VSYS named root-vsys-profile and the default
VSYS profile of non-root VSYS named default-vsys-profile cannot be edited or deleted.
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Before deleting a VSYS profile, you must delete all the VSYSs referencing the VSYS
profile.



The maximum quota varies from one platform to another. The reserved quota cannot
exceed maximum quota.

Entering the VSYS
After typing the management IP in a browser, you should type the username and password in the login
page. For example, the management IP of root VSYS is 10.90.89.1, after typing the username (admin)
and password (admin), you can enter the root VSYS. After creating the non-root VSYS (vsys1), you
should type the name management IP 10.90.89.1, type the non-root administrator username
(vsys1\admin) and password (vsys1-admin), and then you can enter the non-root VSYS directly. For the
detailed information of administrator configuration, see "Device Management" .
Besides, the root VSYS administrator can enter the non-root VSYS from root VSYS. The administrator
in the root VSYS can configure the functions of the non-root VSYS after entering it. To enter a nonroot VSYS, take the following steps:
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1.

Select System > VSYS > VSYS to enter the VSYS page.

2.

In the VSYS list, click the name of non-root VSYS, and enter the non-root VSYS.

3.

Return to the root VSYS, click
in the right top corner of the page, and click Return
root Vsys in the pop-up dialog box.
Note: If you enter the non-root VSYS directly, you cannot back to the root VSYS.
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